Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Lorenzo2016-04-27 11:24:25 -0400
committerGerrit Code Review @ Eclipse.org2016-05-02 08:01:15 -0400
commitbf80a8cb11fd449f9d57094e6330491fd2456988 (patch)
tree27f53469564f21402f59a3191e8e31f2c9e98783 /plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF
parentdbfc46bf0d3bfcc3a8a4a7eb09093ad0bc223996 (diff)
downloadorg.eclipse.papyrus-bf80a8cb11fd449f9d57094e6330491fd2456988.tar.gz
org.eclipse.papyrus-bf80a8cb11fd449f9d57094e6330491fd2456988.tar.xz
org.eclipse.papyrus-bf80a8cb11fd449f9d57094e6330491fd2456988.zip
Bug 469382 - [Rich Text] Nebula rich text editor integration
- Nebula rich text editor has replaced the old EPF rich text editor - Add buttons to new editor: insert reference, update references and spell check button - Reference displayed as its name in editor - Extension framework for HTML renderer (in uml.diagram.common) - Rename org.eclipse.papyrus.infra.widgets.epf.richtext.extension to org.eclipse.papyrus.infra.widgets.richtext.extesion (folder, project, package) - Releng work: rename widgets.epf.richtext.extension to widgets.richtext.extension and update feature.xml and pom.xml files Bug 458020: [Table] The table must include the Papyrus richtext editor https://bugs.eclipse.org/bugs/show_bug.cgi?id=458020 Change-Id: Ia3d8db3600f1b23cc419e09c43dfa6cd09565deb Signed-off-by: Shuai Li <shuai.li@cea.fr> Signed-off-by: Vincent Lorenzo <vincent.lorenzo@cea.fr>
Diffstat (limited to 'plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF')
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
index 92ff6a939c5..25d71a48a6d 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
@@ -80,7 +80,8 @@ Require-Bundle: org.eclipse.papyrus.extensionpoints.editors;bundle-version="[1.2
org.eclipse.e4.ui.css.core;bundle-version="[0.11.0,1.0.0)",
org.eclipse.papyrus.infra.gmfdiag.canonical;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
org.eclipse.papyrus.uml.appearance;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.hyperlink;bundle-version="[2.0.0,3.0.0)"
+ org.eclipse.papyrus.infra.hyperlink;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.nebula.widgets.richtext;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-Version: 2.0.0.qualifier
Eclipse-BuddyPolicy: dependent

Back to the top