Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2014-07-25 14:26:30 -0400
committerChristian W. Damus2014-07-29 09:30:44 -0400
commit50edf3efe0cd5f9a20a0ffb58ef4c302b7113933 (patch)
tree09e98f523689c39f17898e852f71e629c220bd44 /plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF
parent7b9fa63b694baf79bb2d9d6f5d7d2c5c24dde46d (diff)
downloadorg.eclipse.papyrus-50edf3efe0cd5f9a20a0ffb58ef4c302b7113933.tar.gz
org.eclipse.papyrus-50edf3efe0cd5f9a20a0ffb58ef4c302b7113933.tar.xz
org.eclipse.papyrus-50edf3efe0cd5f9a20a0ffb58ef4c302b7113933.zip
440197: The "Apply" action in "Repair Stereotypes" dialog doesn't work for the first click when more than 2 (incl. 2) profiles involved.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=440197 Fix display of repairable applied stereotypes in diagrams. This includes updating the responsible edit-part to schedule deletion of the stereotype visuals (or refreshing to pick up repair results) after the completion of the repair user interaction. This deferral until repair is completed was actually broken: deferred actions would be run prematurely in cases where repair loads additional UML resources that weren't previously loaded. So, that is fixed in order to let the diagram properly defer treatment of broken stereotype visuals. Change-Id: I5510ce304ef7c13d4ca4449073e274298608f013
Diffstat (limited to 'plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF')
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
index d2f10f18925..82f01440b95 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
@@ -98,7 +98,8 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="1.0.0",
org.eclipse.papyrus.infra.core.pluginexplorer;bundle-version="1.0.0",
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="1.0.0",
org.eclipse.papyrus.uml.diagram.paletteconfiguration;bundle-version="1.0.0",
- org.eclipse.papyrus.infra.tools;bundle-version="1.0.0"
+ org.eclipse.papyrus.infra.tools;bundle-version="1.0.0",
+ org.eclipse.papyrus.uml.modelrepair;bundle-version="1.0.0"
Bundle-Vendor: %providerName
Ant-Version: Apache Ant 1.7.0
Bundle-Version: 1.0.0.qualifier

Back to the top