Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2018-04-19 09:02:16 -0400
committerQuentin Le Menez2018-04-20 11:27:59 -0400
commit0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9 (patch)
tree06a5ffe07d36d156da570028a5b59cba288d2930 /plugins/toolsmiths
parent85563b6891ef31d88c9df1a916a51dbcbc537494 (diff)
downloadorg.eclipse.papyrus-0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9.tar.gz
org.eclipse.papyrus-0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9.tar.xz
org.eclipse.papyrus-0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9.zip
Bug 533804 - [Diagram] Update batik dependencies for 1.9.1
- Update tests and dependencies to the new architecture and version - Update the targetplatforms to set the required dependency to 1.9.1 from the latest M6 Orbit repository Change-Id: I07824370934a51062038d382597330833e5ee801 Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
Diffstat (limited to 'plugins/toolsmiths')
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
index 431d632fa29..cd9e7425b64 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
+++ b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
@@ -34,7 +34,7 @@ public class VersionRules {
private final VersionRule rule = VersionRule.composeAll(
new CurrentVersionRule(), // The default behaviour
- new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.6.0,1.7.0)"), //$NON-NLS-1$//$NON-NLS-2$
+ new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.9.1, 2.0.0)"), //$NON-NLS-1$//$NON-NLS-2$
new SkipRule("com.ibm.icu"), //$NON-NLS-1$
new FixedRangeRule("com.google.guava", "21.0.0") //$NON-NLS-1$
);

Back to the top