Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Maggi2017-03-30 07:34:38 -0400
committerGerrit Code Review @ Eclipse.org2017-04-06 06:11:56 -0400
commit5e003e0b53e1ad9e4cfb10acc96a407324026816 (patch)
tree08a8fcd218cb3ced3a4ae24abb38eb2fc4f79fe4 /plugins/facet
parent52394556389df5daa214a659ecae3d12060117c5 (diff)
downloadorg.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.gz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.tar.xz
org.eclipse.papyrus-5e003e0b53e1ad9e4cfb10acc96a407324026816.zip
Bug 514332 - Papyrus should never reexport non-singleton plugins
- remove Required-Bundle Guava (and their re-export) - use package import for Guava dependencies Change-Id: Ie1e383b6b8ed1d57747345c2788c0c63de1f08bb Signed-off-by: Benoit Maggi <benoit.maggi@cea.fr> Signed-off-by: Florian Noyrit <florian.noyrit@cea.fr>
Diffstat (limited to 'plugins/facet')
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF26
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF32
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF76
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF2
4 files changed, 68 insertions, 68 deletions
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF b/plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF
index b2f898fc140..42cb64a130b 100644
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF
+++ b/plugins/facet/org.eclipse.papyrus.emf.facet.util.jface.ui/META-INF/MANIFEST.MF
@@ -1,13 +1,13 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.emf.facet.util.jface.ui.imageprovider
-Require-Bundle: org.eclipse.jface;bundle-version="[3.12.0,4.0.0)";visibility:=reexport,
- org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.emf.facet.util.swt;bundle-version="[1.2.0,2.0.0)"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-Activator: org.eclipse.papyrus.emf.facet.util.jface.ui.internal.Activator
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.jface.ui
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.emf.facet.util.jface.ui.imageprovider
+Require-Bundle: org.eclipse.jface;bundle-version="[3.12.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.util.swt;bundle-version="[1.2.0,2.0.0)"
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 2.0.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-Activator: org.eclipse.papyrus.emf.facet.util.jface.ui.internal.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.jface.ui;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF b/plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF
index 8728226e8c3..049ff8efb74 100644
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF
+++ b/plugins/facet/org.eclipse.papyrus.emf.facet.util.pde.core/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.emf.facet.util.pde.core.internal.exported,
- org.eclipse.papyrus.emf.facet.util.pde.core.internal.exported.exception
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.pde.core;bundle-version="[3.11.0,4.0.0)";visibility:=reexport,
- org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
- org.eclipse.jdt.core;bundle-version="[3.12.0,4.0.0)",
- com.ibm.icu;bundle-version="54.0.0"
-Bundle-Vendor: Eclipse Modeling Project
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: Papyrus EMF Facet PDE Core Utils
-Bundle-Activator: org.eclipse.papyrus.emf.facet.util.pde.core.internal.Activator
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.pde.core
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.emf.facet.util.pde.core.internal.exported,
+ org.eclipse.papyrus.emf.facet.util.pde.core.internal.exported.exception
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.pde.core;bundle-version="[3.11.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)";visibility:=reexport,
+ org.eclipse.jdt.core;bundle-version="[3.12.0,4.0.0)",
+ com.ibm.icu;bundle-version="54.0.0"
+Bundle-Vendor: Eclipse Modeling Project
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: Papyrus EMF Facet PDE Core Utils
+Bundle-Activator: org.eclipse.papyrus.emf.facet.util.pde.core.internal.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.pde.core;singleton:=true
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF b/plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF
index ef718fac531..be97a97961d 100644
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF
+++ b/plugins/facet/org.eclipse.papyrus.emf.facet.util.ui/META-INF/MANIFEST.MF
@@ -1,38 +1,38 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.emf.facet.util.ui.internal.exported.composite,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.dialog,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.displaysync,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.handler,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.tree.menu,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.composite,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.dialog,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.handler,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree.item,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree.menu,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.command,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.getorcreate,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties.bounds,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties.name,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.query,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.wizard,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.widget,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.widget.getorcreate,
- org.eclipse.papyrus.emf.facet.util.ui.internal.exported.wizard,
- org.eclipse.papyrus.emf.facet.util.ui.utils
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
- org.eclipse.jface;bundle-version="[3.12.0,4.0.0)";visibility:=reexport,
- org.eclipse.emf.edit;bundle-version="[2.12.0,3.0.0)"
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-Activator: org.eclipse.papyrus.emf.facet.util.ui.internal.Activator
-Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.ui
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.emf.facet.util.ui.internal.exported.composite,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.dialog,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.displaysync,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.handler,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.tree.menu,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.composite,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.dialog,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.handler,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree.item,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.tree.menu,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.command,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.getorcreate,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties.bounds,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.component.properties.name,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.widget.query,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.util.wizard,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.widget,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.widget.getorcreate,
+ org.eclipse.papyrus.emf.facet.util.ui.internal.exported.wizard,
+ org.eclipse.papyrus.emf.facet.util.ui.utils
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.papyrus.emf.facet.util.core;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
+ org.eclipse.jface;bundle-version="[3.12.0,4.0.0)";visibility:=reexport,
+ org.eclipse.emf.edit;bundle-version="[2.12.0,3.0.0)"
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 2.0.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-Activator: org.eclipse.papyrus.emf.facet.util.ui.internal.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.util.ui;singleton:=true
+Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF b/plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF
index 3718eda0610..86dc1e40c1d 100644
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF
+++ b/plugins/facet/org.eclipse.papyrus.emf.facet.widgets/META-INF/MANIFEST.MF
@@ -11,5 +11,5 @@ Bundle-Version: 1.2.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.emf.facet.widgets.internal.Activator
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.widgets
+Bundle-SymbolicName: org.eclipse.papyrus.emf.facet.widgets;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5

Back to the top