Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Noyrit2017-03-28 13:42:34 -0400
committerFlorian Noyrit2017-03-30 13:42:47 -0400
commita82ba33c9533d3bfb931b7725cff7ac0478511d3 (patch)
treefcd6301bc9325e2b08e33a60930c70868d1bb35d /plugins/developer
parent6177ae6f0aa8abd35d40a30281a11839097be211 (diff)
downloadorg.eclipse.papyrus-a82ba33c9533d3bfb931b7725cff7ac0478511d3.tar.gz
org.eclipse.papyrus-a82ba33c9533d3bfb931b7725cff7ac0478511d3.tar.xz
org.eclipse.papyrus-a82ba33c9533d3bfb931b7725cff7ac0478511d3.zip
[releng] Update plugins and feature version numbers for Oxygen with
Neon.3 as baseline Change-Id: Icb3b699de6846ce60370a1fedc169e1df741ace2
Diffstat (limited to 'plugins/developer')
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF32
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF46
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml2
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.types/META-INF/MANIFEST.MF40
-rw-r--r--plugins/developer/org.eclipse.papyrus.dev.ui/META-INF/MANIFEST.MF34
-rw-r--r--plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF32
6 files changed, 93 insertions, 93 deletions
diff --git a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
index 731b44ce2ae..870724bbca3 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
-Manifest-Version: 1.0
-Require-Bundle: com.google.inject;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.emf;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.assistants.codegen.internal.Activator
-Bundle-Description: %description
-Bundle-SymbolicName: org.eclipse.papyrus.dev.assistants.codegen;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.7
+Manifest-Version: 1.0
+Require-Bundle: com.google.inject;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.papyrus.uml.profile.assistants.generator;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.assistants.codegen.internal.Activator
+Bundle-Description: %description
+Bundle-SymbolicName: org.eclipse.papyrus.dev.assistants.codegen;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
index f73e9f47371..7c2e9d44b38 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/META-INF/MANIFEST.MF
@@ -1,23 +1,23 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)";visibility:=reexport,
- org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.tools;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)";visibility:=reexport
-Bundle-Vendor: %Bundle-Vendor
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %Bundle-Name
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.project.management.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.dev.project.management;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.papyrus.dev.project.management,
- org.eclipse.papyrus.dev.project.management.dialog,
- org.eclipse.papyrus.dev.project.management.handlers,
- org.eclipse.papyrus.dev.project.management.handlers.features,
- org.eclipse.papyrus.dev.project.management.handlers.plugins,
- org.eclipse.papyrus.dev.project.management.internal.operations;x-internal:=true,
- org.eclipse.papyrus.dev.project.management.utils
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.eclipse.project.editors;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.pde.ui;bundle-version="[3.9.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)";visibility:=reexport
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.project.management.Activator
+Bundle-SymbolicName: org.eclipse.papyrus.dev.project.management;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Export-Package: org.eclipse.papyrus.dev.project.management,
+ org.eclipse.papyrus.dev.project.management.dialog,
+ org.eclipse.papyrus.dev.project.management.handlers,
+ org.eclipse.papyrus.dev.project.management.handlers.features,
+ org.eclipse.papyrus.dev.project.management.handlers.plugins,
+ org.eclipse.papyrus.dev.project.management.internal.operations;x-internal:=true,
+ org.eclipse.papyrus.dev.project.management.utils
diff --git a/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml b/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
index 9b29839bb59..9c23d1c7c68 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
+++ b/plugins/developer/org.eclipse.papyrus.dev.project.management/plugin.xml
@@ -61,7 +61,7 @@
point="org.eclipse.ui.menus">
<menuContribution
allPopups="false"
- locationURI="menu:org.eclipse.papyrus.developer.ui.menu?after=org.eclipse.papyrus.developer.ui.menu.separator">
+ locationURI="menu:org.eclipse.ui.main.menu?after=edit">
<menu
icon="icons/papyrus.png"
label="Project management">
diff --git a/plugins/developer/org.eclipse.papyrus.dev.types/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.types/META-INF/MANIFEST.MF
index aa3527abd1c..b42762d5f64 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.types/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.types/META-INF/MANIFEST.MF
@@ -1,20 +1,20 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.services.edit;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)",
- org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
- org.eclipse.m2m.qvt.oml;bundle-version="[3.6.0,4.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="1.0.0"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.types.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.dev.types;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.7
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.2.0,6.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.services.edit;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.gmf.codegen;bundle-version="[2.11.0,3.0.0)",
+ org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.m2m.qvt.oml;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[1.0.0,2.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 3.0.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.types.Activator
+Bundle-SymbolicName: org.eclipse.papyrus.dev.types;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/plugins/developer/org.eclipse.papyrus.dev.ui/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.dev.ui/META-INF/MANIFEST.MF
index 75aeb050fa8..8284af37788 100644
--- a/plugins/developer/org.eclipse.papyrus.dev.ui/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.dev.ui/META-INF/MANIFEST.MF
@@ -1,17 +1,17 @@
-Manifest-Version: 1.0
-Export-Package: org.eclipse.papyrus.dev.ui
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[2.0.0,3.0.0)"
-Bundle-Vendor: %providerName
-Bundle-Version: 0.0.1.qualifier
-Eclipse-BuddyPolicy: dependent
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.dev.ui.Activator
-Bundle-Description: Plugin dedicated to manage generic menus and actions,
- linked to Papyrus Developer.
-Bundle-SymbolicName: org.eclipse.papyrus.dev.ui;singleton:=true
+Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.dev.ui
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)"
+Bundle-Vendor: %providerName
+Bundle-Version: 0.0.1.qualifier
+Eclipse-BuddyPolicy: dependent
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.dev.ui.Activator
+Bundle-Description: Plugin dedicated to manage generic menus and actions,
+ linked to Papyrus Developer.
+Bundle-SymbolicName: org.eclipse.papyrus.dev.ui;singleton:=true
diff --git a/plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF
index 8b535c34395..71760cd203e 100644
--- a/plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.infra.emf.commandstack/META-INF/MANIFEST.MF
@@ -1,16 +1,16 @@
-Manifest-Version: 1.0
-Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.gmf.runtime.emf.commands.core;bundle-version="[1.7.0,2.0.0)",
- org.eclipse.papyrus.emf.facet.common.ui;bundle-version="[1.2.0,2.0.0)"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: %pluginName
-Bundle-Localization: plugin
-Bundle-ManifestVersion: 2
-Bundle-Activator: org.eclipse.papyrus.infra.emf.commandstack.Activator
-Bundle-Description: This plugin allows to show the command owned by the emf command stack
-Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.commandstack;singleton:=true
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.ui;bundle-version="[3.107.0,4.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.gmf.runtime.emf.commands.core;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.papyrus.emf.facet.common.ui;bundle-version="[1.2.0,2.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %pluginName
+Bundle-Localization: plugin
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.infra.emf.commandstack.Activator
+Bundle-Description: This plugin allows to show the command owned by the emf command stack
+Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.commandstack;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8

Back to the top