Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2015-02-10 10:34:02 -0500
committerChristian W. Damus2015-02-11 09:31:33 -0500
commit0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4 (patch)
treed3196c2cd734d2bf4e683a1b3bc3a756c81114a2 /plugins/developer/org.eclipse.papyrus.gmfgenextension
parent47a579d759aa402fc63cde46060488164a4b5a44 (diff)
downloadorg.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.tar.gz
org.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.tar.xz
org.eclipse.papyrus-0b8eef8e59cb91fb3b0348e3f82a474bf06e4ad4.zip
Bug 459566: [Releng] Consider letting Tycho use JDT's project settings for compilation
https://bugs.eclipse.org/bugs/show_bug.cgi?id=459566 Add Tycho compiler's <useProjectSettings> to the plug-in management in the main top POM to ensure that each project's build preferences are respected. This does require removing a few {@link}/@see references to restricted API in doc comments to work around a bug in Tycho (459554). A great many plug-in projects using 1.6 source constructs (mostly @Override of abstract methods) failed to declare 1.6 requirement either in the BREE, or the classpath/compiler settings, or both. Change-Id: Ia73b592fff8d46eaf0bc628b6e21d1e758ff0c64
Diffstat (limited to 'plugins/developer/org.eclipse.papyrus.gmfgenextension')
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmfgenextension/.classpath14
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmfgenextension/.settings/org.eclipse.jdt.core.prefs3
-rw-r--r--plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF2
3 files changed, 11 insertions, 8 deletions
diff --git a/plugins/developer/org.eclipse.papyrus.gmfgenextension/.classpath b/plugins/developer/org.eclipse.papyrus.gmfgenextension/.classpath
index 45f024e850e..ad32c83a788 100644
--- a/plugins/developer/org.eclipse.papyrus.gmfgenextension/.classpath
+++ b/plugins/developer/org.eclipse.papyrus.gmfgenextension/.classpath
@@ -1,7 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
- <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
- <classpathentry kind="output" path="bin"/>
-</classpath>
+<?xml version="1.0" encoding="UTF-8"?>
+<classpath>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
+ <classpathentry kind="output" path="bin"/>
+</classpath>
diff --git a/plugins/developer/org.eclipse.papyrus.gmfgenextension/.settings/org.eclipse.jdt.core.prefs b/plugins/developer/org.eclipse.papyrus.gmfgenextension/.settings/org.eclipse.jdt.core.prefs
index 4d72ad12656..94d61f00da6 100644
--- a/plugins/developer/org.eclipse.papyrus.gmfgenextension/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/developer/org.eclipse.papyrus.gmfgenextension/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,10 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.6
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=16
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF b/plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF
index 669489a7f60..47f05d16ccd 100644
--- a/plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF
+++ b/plugins/developer/org.eclipse.papyrus.gmfgenextension/META-INF/MANIFEST.MF
@@ -20,5 +20,5 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.gmfgenextension;singleton:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6

Back to the top