Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Lorenzo2016-11-14 10:34:10 -0500
committerGerrit Code Review @ Eclipse.org2016-11-15 09:13:53 -0500
commit00b96bc6d26533e8bfed7df488cfb82c94f22fea (patch)
tree157ed8d0159bfae1a9a5dea06b770e432c0bfc48 /papyrusrequirements
parent4496cf7257f6ccb68f74b02b7c530bee00f36f67 (diff)
downloadorg.eclipse.papyrus-00b96bc6d26533e8bfed7df488cfb82c94f22fea.tar.gz
org.eclipse.papyrus-00b96bc6d26533e8bfed7df488cfb82c94f22fea.tar.xz
org.eclipse.papyrus-00b96bc6d26533e8bfed7df488cfb82c94f22fea.zip
Bug 496903 : add a diagram requirements
Signed-off-by: Vincent Lorenzo <vincent.lorenzo@cea.fr>
Diffstat (limited to 'papyrusrequirements')
-rw-r--r--papyrusrequirements/PapyrusRequirements.uml2
1 files changed, 2 insertions, 0 deletions
diff --git a/papyrusrequirements/PapyrusRequirements.uml b/papyrusrequirements/PapyrusRequirements.uml
index 8155dffb000..04688bbb6f8 100644
--- a/papyrusrequirements/PapyrusRequirements.uml
+++ b/papyrusrequirements/PapyrusRequirements.uml
@@ -74,6 +74,7 @@
<packagedElement xmi:type="uml:Abstraction" xmi:id="_FIVKcDelEeaoIeKDbY2kpA" name="Derived_from_Diagram.REQ_008" client="_YpHAsDSrEeaZ0_eSx8_2aA" supplier="_jx4RQDRxEeaZ0_eSx8_2aA"/>
<packagedElement xmi:type="uml:Class" xmi:id="_xwwMkDe2EeaPnYE3F_KdYw" name="Diagram.REQT_004"/>
<packagedElement xmi:type="uml:Abstraction" xmi:id="_V7hgMDe4EeaPnYE3F_KdYw" name="Derived_from_Diagram.REQ_018" client="_xwwMkDe2EeaPnYE3F_KdYw" supplier="_z-gBEDe3EeaPnYE3F_KdYw"/>
+ <packagedElement xmi:type="uml:Class" xmi:id="_T1twoKp_Eea736WDa-fj3g" name="Diagram.REQT_005"/>
</packagedElement>
<packagedElement xmi:type="uml:Package" xmi:id="_jo1n0DRiEeaZ0_eSx8_2aA" name="UML Diagram Requirements">
<packagedElement xmi:type="uml:Package" xmi:id="_op3zwDSZEeaZ0_eSx8_2aA" name="Class Diagram"/>
@@ -246,4 +247,5 @@
<Requirements:Requirement xmi:id="_xw5WgDe2EeaPnYE3F_KdYw" text="Each diagram must have a version number.&#xD;&#xA;in the notation there is a name style name=&quot;diagram_compatibility_version&quot; stringValue=&quot;1.2.0&quot;" id="Diagram.REQT_004" base_Class="_xwwMkDe2EeaPnYE3F_KdYw"/>
<Requirements:Requirement xmi:id="_z-oj8De3EeaPnYE3F_KdYw" text="Papyrus shall provide facilities to migrate diagram from a version to upper version" id="Diagram.REQ_018" base_Class="_z-gBEDe3EeaPnYE3F_KdYw"/>
<Requirements:DeriveReqt xmi:id="_V7qqIDe4EeaPnYE3F_KdYw" base_Abstraction="_V7hgMDe4EeaPnYE3F_KdYw"/>
+ <Requirements:Requirement xmi:id="_T1wz8Kp_Eea736WDa-fj3g" text="The extension point used to defines palette oep.uml.diagram.common.paletteDefinition must allow to define several palettes in the same time (cardinality 1..*] " id="Diagram.REQT_003" base_Class="_T1twoKp_Eea736WDa-fj3g"/>
</xmi:XMI>

Back to the top