Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2016-07-10 17:43:06 -0400
committerChristian W. Damus2016-07-10 17:46:32 -0400
commit200cbb5748916344ac2dcd9163a39f6d6a4b01d5 (patch)
tree4606d41325cbe202efe0b9d8fc5edeccc525ec1c
parent9704bd2eadac0e6346d637f844d84e712b5b108c (diff)
downloadorg.eclipse.papyrus-200cbb5748916344ac2dcd9163a39f6d6a4b01d5.tar.gz
org.eclipse.papyrus-200cbb5748916344ac2dcd9163a39f6d6a4b01d5.tar.xz
org.eclipse.papyrus-200cbb5748916344ac2dcd9163a39f6d6a4b01d5.zip
Bug 496307: [Profile Migration] Restrictive package pattern matching
https://bugs.eclipse.org/bugs/show_bug.cgi?id=496307 Mark the new internal 'uripattern' package as internal in the manifest (it is not API). Change-Id: Ia91a540767b38feb0c4585462fe3054ffa34a93f
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.palette/.settings/.api_filters19
-rw-r--r--plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.settings/.api_filters11
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.settings/.api_filters26
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.settings/.api_filters11
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.settings/.api_filters12
-rw-r--r--plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.settings/.api_filters11
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.settings/.api_filters11
-rw-r--r--plugins/infra/filters/org.eclipse.papyrus.infra.filters/.settings/.api_filters11
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/.settings/.api_filters11
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/.settings/.api_filters49
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/.settings/.api_filters11
-rw-r--r--plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/.settings/.api_filters11
-rw-r--r--plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/.settings/.api_filters11
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters19
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/.settings/.api_filters11
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/.settings/.api_filters11
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/.settings/.api_filters11
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/.settings/.api_filters11
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.documentation.profile/.settings/.api_filters11
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.extensionpoints/.settings/.api_filters23
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF2
21 files changed, 1 insertions, 303 deletions
diff --git a/plugins/customization/org.eclipse.papyrus.customization.palette/.settings/.api_filters b/plugins/customization/org.eclipse.papyrus.customization.palette/.settings/.api_filters
deleted file mode 100644
index a223824fdda..00000000000
--- a/plugins/customization/org.eclipse.papyrus.customization.palette/.settings/.api_filters
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.customization.palette" version="2">
- <resource path="src/org/eclipse/papyrus/customization/palette/dialog/PaletteLocalSeparatorProxy.java" type="org.eclipse.papyrus.customization.palette.dialog.PaletteLocalSeparatorProxy">
- <filter comment="Nobody would have modified this" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.customization.palette.dialog.PaletteLocalSeparatorProxy"/>
- <message_argument value="SEPARATOR_ICON"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="src/org/eclipse/papyrus/customization/palette/dialog/PaletteLocalStackProxy.java" type="org.eclipse.papyrus.customization.palette.dialog.PaletteLocalStackProxy">
- <filter comment="Nobody would have modified this" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.customization.palette.dialog.PaletteLocalStackProxy"/>
- <message_argument value="STACK_ICON"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.settings/.api_filters b/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.settings/.api_filters
deleted file mode 100644
index a96f3d8704f..00000000000
--- a/plugins/customization/org.eclipse.papyrus.infra.gmfdiag.expansion.edit/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.gmfdiag.expansion.edit" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.common"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.settings/.api_filters b/plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.settings/.api_filters
deleted file mode 100644
index 03840fb6de9..00000000000
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.custom.metamodel/.settings/.api_filters
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.emf.facet.custom.metamodel" version="2">
- <resource path="src/org/eclipse/papyrus/emf/facet/custom/metamodel/v0_2_0/custom/CustomPackage.java" type="org.eclipse.papyrus.emf.facet.custom.metamodel.v0_2_0.custom.CustomPackage">
- <filter comment="EMF package interfaces are not intended to be implemented or extended by clients" id="388194388">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.emf.facet.custom.metamodel.v0_2_0.custom.CustomPackage"/>
- <message_argument value="ECLASS_CUSTOMIZATION_FEATURE_COUNT"/>
- <message_argument value="14"/>
- </message_arguments>
- </filter>
- <filter comment="EMF package interfaces are not intended to be implemented or extended by clients" id="388194388">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.emf.facet.custom.metamodel.v0_2_0.custom.CustomPackage"/>
- <message_argument value="FACET_CUSTOMIZATION_FEATURE_COUNT"/>
- <message_argument value="15"/>
- </message_arguments>
- </filter>
- <filter comment="EMF package interfaces are not intended to be implemented or extended by clients" id="388194388">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.emf.facet.custom.metamodel.v0_2_0.custom.CustomPackage"/>
- <message_argument value="FACET_CUSTOMIZATION__CUSTOMIZED_FACET"/>
- <message_argument value="14"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.settings/.api_filters b/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.settings/.api_filters
deleted file mode 100644
index 08f00933360..00000000000
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel.edit/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.emf.facet.efacet.metamodel.edit" version="2">
- <resource path="src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/provider/FacetItemProvider.java" type="org.eclipse.papyrus.emf.facet.efacet.metamodel.v0_2_0.efacet.provider.FacetItemProvider">
- <filter id="338792546">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.emf.facet.efacet.metamodel.v0_2_0.efacet.provider.FacetItemProvider"/>
- <message_argument value="addInstanceClassPropertyDescriptor(Object)"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.settings/.api_filters b/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.settings/.api_filters
deleted file mode 100644
index a748dcaf92d..00000000000
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.efacet.metamodel/.settings/.api_filters
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.emf.facet.efacet.metamodel" version="2">
- <resource path="src/org/eclipse/papyrus/emf/facet/efacet/metamodel/v0_2_0/efacet/EFacetPackage.java" type="org.eclipse.papyrus.emf.facet.efacet.metamodel.v0_2_0.efacet.EFacetPackage">
- <filter comment="EMF package interfaces are not intended to be implemented or extended by clients" id="388194388">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.emf.facet.efacet.metamodel.v0_2_0.efacet.EFacetPackage"/>
- <message_argument value="FACET_FEATURE_COUNT"/>
- <message_argument value="14"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.settings/.api_filters b/plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.settings/.api_filters
deleted file mode 100644
index c1f1ee7ae15..00000000000
--- a/plugins/facet/org.eclipse.papyrus.emf.facet.query.ocl.metamodel/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.emf.facet.query.ocl.metamodel" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Re-exported Ecore bundle version previously was unbounded" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.settings/.api_filters b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.settings/.api_filters
deleted file mode 100644
index ec19a254b99..00000000000
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.appearance/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.emf.appearance" version="2">
- <resource path="src/org/eclipse/papyrus/infra/emf/appearance/helper/AppearanceHelper.java" type="org.eclipse.papyrus.infra.emf.appearance.helper.AppearanceHelper">
- <filter comment="No developer would reasonably have modified this field" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.emf.appearance.helper.AppearanceHelper"/>
- <message_argument value="EXTENSION_ID"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/filters/org.eclipse.papyrus.infra.filters/.settings/.api_filters b/plugins/infra/filters/org.eclipse.papyrus.infra.filters/.settings/.api_filters
deleted file mode 100644
index 93e4f961d9b..00000000000
--- a/plugins/infra/filters/org.eclipse.papyrus.infra.filters/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.filters" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.uml2.common"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/.settings/.api_filters b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/.settings/.api_filters
deleted file mode 100644
index a036c140df1..00000000000
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.editor/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.gmfdiag.assistant.editor" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependencies had implicit upper bounds in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.core.resources"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/.settings/.api_filters b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/.settings/.api_filters
deleted file mode 100644
index 1b17faa8112..00000000000
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/.settings/.api_filters
+++ /dev/null
@@ -1,49 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.gmfdiag.css" version="2">
- <resource path="src/org/eclipse/papyrus/infra/gmfdiag/css/engine/BaseCSSEngine.java" type="org.eclipse.papyrus.infra.gmfdiag.css.engine.BaseCSSEngine">
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.engine.BaseCSSEngine"/>
- <message_argument value="EXTENSION_ID"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="src/org/eclipse/papyrus/infra/gmfdiag/css/engine/ProjectCSSEngine.java" type="org.eclipse.papyrus.infra.gmfdiag.css.engine.ProjectCSSEngine">
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.engine.ProjectCSSEngine"/>
- <message_argument value="PROJECT_STYLESHEETS"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="src/org/eclipse/papyrus/infra/gmfdiag/css/engine/WorkspaceCSSEngine.java" type="org.eclipse.papyrus.infra.gmfdiag.css.engine.WorkspaceCSSEngine">
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.engine.WorkspaceCSSEngine"/>
- <message_argument value="instance"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="src/org/eclipse/papyrus/infra/gmfdiag/css/theme/ThemeManager.java" type="org.eclipse.papyrus.infra.gmfdiag.css.theme.ThemeManager">
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.theme.ThemeManager"/>
- <message_argument value="EXTENSION_ID"/>
- </message_arguments>
- </filter>
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.theme.ThemeManager"/>
- <message_argument value="instance"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="src/org/eclipse/papyrus/infra/gmfdiag/css/theme/ThemeManager.java" type="org.eclipse.papyrus.infra.gmfdiag.css.theme.ThemeManager$EmptyTheme">
- <filter comment="Could never have been modified without breaking the system" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.infra.gmfdiag.css.theme.ThemeManager.EmptyTheme"/>
- <message_argument value="instance"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/.settings/.api_filters b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/.settings/.api_filters
deleted file mode 100644
index b4660023894..00000000000
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.css.model/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.gmfdiag.css.model" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependencies had implicit upper bounds in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/.settings/.api_filters b/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/.settings/.api_filters
deleted file mode 100644
index f7154d592a4..00000000000
--- a/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.iso42010.edit/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.viewpoints.iso42010.edit" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="All external dependencies were implicitly upper-bounded in Mars." id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.edit"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/.settings/.api_filters b/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/.settings/.api_filters
deleted file mode 100644
index 8851cb89a65..00000000000
--- a/plugins/infra/viewpoints/org.eclipse.papyrus.infra.viewpoints.policy/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.infra.viewpoints.policy" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="All external dependencies were implicitly upper-bounded in Mars." id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore.xmi"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters b/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters
deleted file mode 100644
index ddb0af66b5f..00000000000
--- a/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.alf.common" version="2">
- <resource path="META-INF/MANIFEST.MF" type="org.eclipse.xtext.generator.FileSystemSupportBasedFileSystemAccess">
- <filter comment="The xtext.generator dependency is optional and so could not reasonably have been re-exported or relied on by clients" id="305422471">
- <message_arguments>
- <message_argument value="org.eclipse.xtext.generator.FileSystemSupportBasedFileSystemAccess"/>
- <message_argument value="org.eclipse.papyrus.uml.alf.common_1.1.2"/>
- </message_arguments>
- </filter>
- </resource>
- <resource path="META-INF/MANIFEST.MF" type="org.eclipse.xtext.generator.IDerivedResourceMarkers">
- <filter comment="The xtext.generator dependency is optional and so could not reasonably have been re-exported or relied on by clients" id="305422471">
- <message_arguments>
- <message_argument value="org.eclipse.xtext.generator.IDerivedResourceMarkers"/>
- <message_argument value="org.eclipse.papyrus.uml.alf.common_1.1.2"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/.settings/.api_filters b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/.settings/.api_filters
deleted file mode 100644
index 1eabbc87b41..00000000000
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.decoratormodel.controlmode" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.uml2.types"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/.settings/.api_filters b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/.settings/.api_filters
deleted file mode 100644
index 65cbe64d8bb..00000000000
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.decoratormodel.ui" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/.settings/.api_filters b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/.settings/.api_filters
deleted file mode 100644
index f95edcf03b7..00000000000
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.diagram.paletteconfiguration.edit" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.edit"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/.settings/.api_filters b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/.settings/.api_filters
deleted file mode 100644
index a0e37d51527..00000000000
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.paletteconfiguration/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.diagram.paletteconfiguration" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.documentation.profile/.settings/.api_filters b/plugins/uml/org.eclipse.papyrus.uml.documentation.profile/.settings/.api_filters
deleted file mode 100644
index 7b8681aa8a2..00000000000
--- a/plugins/uml/org.eclipse.papyrus.uml.documentation.profile/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.documentation.profile" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bounds were implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.emf.ecore"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.extensionpoints/.settings/.api_filters b/plugins/uml/org.eclipse.papyrus.uml.extensionpoints/.settings/.api_filters
deleted file mode 100644
index f4ae5227a91..00000000000
--- a/plugins/uml/org.eclipse.papyrus.uml.extensionpoints/.settings/.api_filters
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.papyrus.uml.extensionpoints" version="2">
- <resource path="src/org/eclipse/papyrus/uml/extensionpoints/standard/ExtensionIds.java" type="org.eclipse.papyrus.uml.extensionpoints.standard.ExtensionIds">
- <filter comment="Attempts to modify these would have broken the system in Mars" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.uml.extensionpoints.standard.ExtensionIds"/>
- <message_argument value="LIBRARY_EXTENSION_ID"/>
- </message_arguments>
- </filter>
- <filter comment="Attempts to modify these would have broken the system in Mars" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.uml.extensionpoints.standard.ExtensionIds"/>
- <message_argument value="METAMODEL_EXTENSION_ID"/>
- </message_arguments>
- </filter>
- <filter comment="Attempts to modify these would have broken the system in Mars" id="388100214">
- <message_arguments>
- <message_argument value="org.eclipse.papyrus.uml.extensionpoints.standard.ExtensionIds"/>
- <message_argument value="PROFILE_EXTENSION_ID"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
index 6f0c03bb259..015198ad9be 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Export-Package: org.eclipse.papyrus.uml.modelrepair,
org.eclipse.papyrus.uml.modelrepair.handler,
org.eclipse.papyrus.uml.modelrepair.internal.participants;x-internal:=true,
org.eclipse.papyrus.uml.modelrepair.internal.stereotypes;x-friends:="org.eclipse.papyrus.migration.rsa",
- org.eclipse.papyrus.uml.modelrepair.internal.uripattern,
+ org.eclipse.papyrus.uml.modelrepair.internal.uripattern;x-internal:=true,
org.eclipse.papyrus.uml.modelrepair.internal.validation;x-internal:=true,
org.eclipse.papyrus.uml.modelrepair.service,
org.eclipse.papyrus.uml.modelrepair.ui,

Back to the top