Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Lorenzo2018-10-08 10:21:25 -0400
committervincent lorenzo2018-11-29 07:49:43 -0500
commit87b76bb26c9389fc79c6971cbcf92fb1109840f2 (patch)
tree2b21b333f836444198ab4609dad345da7cec0698
parent5bf47e1b9c6d58b68dbed5407cf12669cceee874 (diff)
downloadorg.eclipse.papyrus-87b76bb26c9389fc79c6971cbcf92fb1109840f2.tar.gz
org.eclipse.papyrus-87b76bb26c9389fc79c6971cbcf92fb1109840f2.tar.xz
org.eclipse.papyrus-87b76bb26c9389fc79c6971cbcf92fb1109840f2.zip
Bug 539926: [CDO] Papyrus standart version must execute its tests with the CDO'ified version of metamodel too
Change-Id: I6e9c894ceb2b5e17600db2b42bd59fe123ec91a7 Signed-off-by: Vincent Lorenzo <vincent.lorenzo@cea.fr>
-rwxr-xr-xreleng/Papyrus - Main tests with cdo.launch20
-rwxr-xr-xreleng/main-tests-with-cdo/README7
-rwxr-xr-xreleng/main-tests-with-cdo/pom.xml196
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target138
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/eclipse/pom.xml15
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/pom.xml41
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target138
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.tpd36
-rwxr-xr-xreleng/main-tests-with-cdo/targetPlatform/portable/pom.xml15
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.classpath11
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.project28
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.settings/org.eclipse.jdt.core.prefs7
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/META-INF/MANIFEST.MF12
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/OSGI-INF/l10n/bundle.properties3
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/README5
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/about.html28
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/build.properties18
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/pom.xml16
-rwxr-xr-xtests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/src/org/eclipse/papyrus/compatibility/cdo/tests/CDOInstallationTest.java58
-rwxr-xr-xtests/compatibility/cdo/pom.xml23
20 files changed, 815 insertions, 0 deletions
diff --git a/releng/Papyrus - Main tests with cdo.launch b/releng/Papyrus - Main tests with cdo.launch
new file mode 100755
index 00000000000..f82f5b5606a
--- /dev/null
+++ b/releng/Papyrus - Main tests with cdo.launch
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<launchConfiguration type="org.eclipse.m2e.Maven2LaunchConfigurationType">
+<booleanAttribute key="M2_DEBUG_OUTPUT" value="false"/>
+<stringAttribute key="M2_GOALS" value="clean verify"/>
+<booleanAttribute key="M2_NON_RECURSIVE" value="false"/>
+<booleanAttribute key="M2_OFFLINE" value="false"/>
+<stringAttribute key="M2_PROFILES" value="defaultProfile"/>
+<listAttribute key="M2_PROPERTIES">
+<listEntry value="papyrus.repo.main=file:/${project_loc:releng}/main/site/target/repository"/>
+<listEntry value="papyrus.repo.toolsmiths=file:/${project_loc:releng}/toolsmiths/site/target/repository"/>
+<listEntry value="target.platform=org.eclipse.papyrus.main.tests.cdo.portable.target"/>
+</listAttribute>
+<stringAttribute key="M2_RUNTIME" value="EMBEDDED"/>
+<booleanAttribute key="M2_SKIP_TESTS" value="false"/>
+<intAttribute key="M2_THREADS" value="1"/>
+<booleanAttribute key="M2_UPDATE_SNAPSHOTS" value="false"/>
+<stringAttribute key="M2_USER_SETTINGS" value=""/>
+<booleanAttribute key="M2_WORKSPACE_RESOLUTION" value="false"/>
+<stringAttribute key="org.eclipse.jdt.launching.WORKING_DIRECTORY" value="${project_loc:releng}/main-tests-with-cdo"/>
+</launchConfiguration>
diff --git a/releng/main-tests-with-cdo/README b/releng/main-tests-with-cdo/README
new file mode 100755
index 00000000000..2578c664062
--- /dev/null
+++ b/releng/main-tests-with-cdo/README
@@ -0,0 +1,7 @@
+In order to run the Papyrus Tests, with CDO installed, we need to define the target platform in the Eclipse launch config:
+<listEntry value="target.platform=org.eclipse.papyrus.main.tests.cdo.portable.target"/>
+
+On Hudson, we must configure the job with the same information.
+
+We are not able to run the job with the expected target platform due to the current Papyrus pom architecture. Without this information, maven uses the 'normal' target platform defined for the Papyrus tests.
+ \ No newline at end of file
diff --git a/releng/main-tests-with-cdo/pom.xml b/releng/main-tests-with-cdo/pom.xml
new file mode 100755
index 00000000000..4c4bf351d21
--- /dev/null
+++ b/releng/main-tests-with-cdo/pom.xml
@@ -0,0 +1,196 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus</groupId>
+ <artifactId>org.eclipse.papyrus.all.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus</groupId>
+ <artifactId>org.eclipse.papyrus.tests.cdo.releng</artifactId>
+ <packaging>pom</packaging>
+
+ <properties>
+ <testConfig>CI_TESTS_CONFIG</testConfig> <!-- See org.eclipse.papyrus.junit.framework.classification.ClassificationConfig -->
+ <testSuiteClass>org.eclipse.papyrus.tests.AllTests</testSuiteClass>
+ <jacoco.version>0.7.9</jacoco.version>
+ <!-- Separate property for test argLine seems to be required when running
+ Jacoco + Surefire -->
+ <test.argLine>-Xms512m -Xmx2048m -XX:SoftRefLRUPolicyMSPerMB=100</test.argLine>
+ <target.platform>org.eclipse.papyrus.main.tests.cdo.${target.suffix}.target</target.platform>
+ </properties>
+
+ <modules>
+ <!-- Features -->
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.infra.core.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.infra.emf.expressions.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.infra.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.infra.nattable.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.infra.services.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.assistants.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.decoratormodel.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.diagram.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.expressions.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.nattable.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.uml.tools.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.views.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.uml.textedit.tests.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.uml.alf.tests.feature</module>
+ <module>../../features/papyrus-tests-features/org.eclipse.papyrus.tests.toolsmiths.feature</module>
+
+ <!-- Plugins -->
+ <module>../../tests/junit/plugins</module>
+ <module>../../tests/compatibility/cdo</module>
+ <module>targetPlatform</module>
+ </modules>
+
+<build>
+ <pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.jacoco</groupId>
+ <artifactId>jacoco-maven-plugin</artifactId>
+ <version>${jacoco-version}</version>
+ </plugin>
+ </plugins>
+ </pluginManagement>
+
+ <plugins>
+ <plugin>
+ <groupId>org.apache.maven.plugins</groupId>
+ <artifactId>maven-resources-plugin</artifactId>
+ </plugin>
+
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-compiler-plugin</artifactId>
+ </plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-maven-plugin</artifactId>
+ </plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>target-platform-configuration</artifactId>
+ </plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-p2-repository-plugin</artifactId>
+ </plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-surefire-plugin</artifactId>
+ <version>${tycho-version}</version>
+ <configuration>
+ <failIfNoTests>false</failIfNoTests>
+ <useUIHarness>true</useUIHarness>
+ <useUIThread>true</useUIThread>
+ <testFailureIgnore>true</testFailureIgnore>
+ <!-- ${tycho.testArgLine} is populated by JaCoCo and is required to
+ enable code coverage -->
+ <argLine>${tycho.testArgLine} ${test.argLine}</argLine>
+ <appArgLine>-testConfig=${testConfig}</appArgLine>
+ <product>org.eclipse.sdk.ide</product>
+ <skipTests>${skipInnerTests}</skipTests>
+ </configuration>
+ </plugin>
+
+ <plugin>
+ <groupId>org.jacoco</groupId>
+ <artifactId>jacoco-maven-plugin</artifactId>
+ <version>${jacoco.version}</version>
+ <configuration>
+ <excludes>
+ <exclude>org.eclipse.uml2</exclude>
+ </excludes>
+ <includes>
+ <include>org.eclipse.papyrus.*</include>
+ </includes>
+ </configuration>
+ <executions>
+ <execution>
+ <id>default-prepare-agent</id>
+ <goals>
+ <goal>prepare-agent</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>default-report</id>
+ <goals>
+ <goal>report</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+
+ <profiles>
+ <profile>
+ <id>defaultProfile</id>
+ <activation>
+ <activeByDefault>true</activeByDefault>
+ </activation>
+ <repositories>
+ <repository>
+ <id>papyrus-main</id>
+ <layout>p2</layout>
+ <url>${papyrus.repo.main}</url>
+ </repository>
+ <repository>
+ <id>papyrus-toolsmiths</id>
+ <layout>p2</layout>
+ <url>${papyrus.repo.toolsmiths}</url>
+ </repository>
+ </repositories>
+ </profile>
+
+ <profile>
+ <id>mac-tests</id>
+ <activation>
+ <os>
+ <family>mac</family>
+ </os>
+ </activation>
+ <properties>
+ <test.argLine>-Xms512m -Xmx2048m -XX:SoftRefLRUPolicyMSPerMB=100
+ -XstartOnFirstThread</test.argLine>
+ </properties>
+ </profile>
+
+ <profile>
+ <id>buildAll</id>
+ <activation>
+ <property>
+ <name>buildAll</name>
+ <value>true</value>
+ </property>
+ </activation>
+ <!-- Papyrus Update sites not included (They are included in the same
+ build) -->
+
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-p2-plugin</artifactId>
+ <version>${tycho-version}</version>
+ <executions>
+ <execution>
+ <id>attach-p2-metadata</id>
+ <phase>package</phase>
+ <goals>
+ <goal>p2-metadata</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+ </profile>
+ </profiles>
+</project>
diff --git a/releng/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target b/releng/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target
new file mode 100755
index 00000000000..c9190ec1987
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target
@@ -0,0 +1,138 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde?>
+<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
+<target name="Papyrus CDO Tests" sequenceNumber="1543484200">
+ <locations>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
+ <unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201703081533"/>
+ <repository id="nebula" location="file:/home/data/httpd/download.eclipse.org/nebula/releases/1.2.0/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.1.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.1.0.201703192131"/>
+ <repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
+ <unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
+ <unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
+ <unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
+ <unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
+ <unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/S20181120221132/repository"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.1.v20181127-0601"/>
+ <repository id="qvto" location="file:/home/data/httpd/download.eclipse.org/mmt/qvto/updates/milestones/3.9.1/S201811270601"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
+ <unit id="org.eclipse.xtend.feature.group" version="2.2.0.v201605260315"/>
+ <repository id="xpand" location="file:/home/data/httpd/download.eclipse.org/modeling/m2t/xpand/updates/releases/R201605260315/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.5.0.v20181126-1312"/>
+ <repository id="uml" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/uml2/updates/5.5milestones"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.sdk.feature.group" version="4.10.0.v20181121-1800"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.10milestones/S-4.10M3-201811211800/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.7.0.v20181126-1148"/>
+ <unit id="org.eclipse.ocl.examples.feature.group" version="6.6.0.v20181126-1148"/>
+ <repository id="ocl" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.6.0/S201811261148"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
+ <repository id="xwt" location="file:/home/data/httpd/download.eclipse.org/xwt/updates"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xtext.sdk.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtend.sdk.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.redist.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.runtime.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.ui.feature.group" version="2.16.0.v20181126-0210"/>
+ <repository id="xtext" location="file:/home/data/httpd/download.eclipse.org/modeling/tmf/xtext/updates/milestones/head/S201811260210"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.mwe2.language.sdk.feature.group" version="2.9.1.201705291011"/>
+ <repository id="mwe" location="file:/home/data/httpd/download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="0.0.0"/>
+ <repository id="webtools" location="https://download.eclipse.org/webtools/downloads/drops/R3.12.0/S-3.12.0.M3-20181124033837/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
+ <repository id="gmfRuntime" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-runtime/updates/milestones/S201806010809"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
+ <repository id="gmfNotation" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-notation/updates/milestones/S201805221301"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.16.0.v20181116-0557"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201811200213"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
+ <repository id="emfQuery" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/query/updates/milestones/S201805030653"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
+ <repository id="emfValidation" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/validation/updates/milestones/S201805030717"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
+ <repository id="emfTransaction" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/transaction/updates/milestones/S201805140824/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gef.feature.group" version="3.11.0.201606061308"/>
+ <repository id="gef" location="file:/home/data/httpd/download.eclipse.org/tools/gef/updates/legacy/releases/4.0.0_gef-master_1952"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.codegen" version="2.11.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.ui" version="1.3.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.xtend" version="1.0.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.xtend.ui" version="1.0.0.201509291144"/>
+ <repository id="gmfTooling" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201806221350/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="0.0.0"/>
+ <repository id="PapyrusMain" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="0.0.0"/>
+ <repository id="Sysml" location="https://hudson.eclipse.org/papyrus/job/papyrus-sysml-master/4/artifact/releng/org.eclipse.papyrus.sysml14.p2/target/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.cdo.feature.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.papyrus.cdo.models.feature.feature.group" version="0.0.0"/>
+ <repository id="papyrusCdo" location="https://hudson.eclipse.org/papyrus/job/Papyrus-CDO/lastSuccessfulBuild/artifact/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.cdo.explorer" version="4.5.200.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.dawn" version="2.0.600.v20180530-1201"/>
+ <unit id="org.eclipse.emf.cdo.dawn.gmf" version="2.1.500.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.admin" version="4.1.600.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.explorer.ui" version="4.4.300.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.ui.admin" version="4.1.500.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.server.ocl" version="4.2.300.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.ecore" version="0.0.0"/>
+ <unit id="org.eclipse.emf.cdo.gmf.notation" version="0.0.0"/>
+ <repository id="cdo" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/cdo/drops/I20181123-0100"/>
+ </location>
+ </locations>
+</target>
diff --git a/releng/main-tests-with-cdo/targetPlatform/eclipse/pom.xml b/releng/main-tests-with-cdo/targetPlatform/eclipse/pom.xml
new file mode 100755
index 00000000000..1f5e66ff641
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/eclipse/pom.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+
+ <parent>
+ <artifactId>org.eclipse.papyrus.main.tests.cdo.target.parent</artifactId>
+ <groupId>org.eclipse.papyrus</groupId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+
+ <artifactId>org.eclipse.papyrus.main.tests.cdo.eclipse.target</artifactId>
+ <packaging>eclipse-target-definition</packaging>
+</project>
diff --git a/releng/main-tests-with-cdo/targetPlatform/pom.xml b/releng/main-tests-with-cdo/targetPlatform/pom.xml
new file mode 100755
index 00000000000..ba9eeaf9fea
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/pom.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+
+ <parent>
+ <artifactId>org.eclipse.papyrus.tests.cdo.releng</artifactId>
+ <groupId>org.eclipse.papyrus</groupId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+
+ <artifactId>org.eclipse.papyrus.main.tests.cdo.target.parent</artifactId>
+ <packaging>pom</packaging>
+
+ <profiles>
+ <profile>
+ <id>portable</id>
+ <activation>
+ <activeByDefault>true</activeByDefault>
+ </activation>
+ <modules>
+ <module>portable</module>
+ </modules>
+ </profile>
+ <profile>
+ <id>eclipse</id>
+ <activation>
+ <property>
+ <name>target.suffix</name>
+ <value>eclipse</value>
+ </property>
+ </activation>
+ <modules>
+ <module>eclipse</module>
+ </modules>
+ </profile>
+ </profiles>
+
+</project>
+
diff --git a/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target b/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target
new file mode 100755
index 00000000000..7c4468efc42
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target
@@ -0,0 +1,138 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde?>
+<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
+<target name="Papyrus CDO Tests" sequenceNumber="1543484200">
+ <locations>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
+ <unit id="org.eclipse.nebula.cwt.feature.feature.group" version="1.0.0.201703081533"/>
+ <repository id="nebula" location="http://download.eclipse.org/nebula/releases/1.2.0/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.nebula.widgets.nattable.core.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.core.source.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.glazedlists.source.feature.feature.group" version="1.5.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.feature.feature.group" version="1.1.0.201703192131"/>
+ <unit id="org.eclipse.nebula.widgets.nattable.extension.nebula.source.feature.feature.group" version="1.1.0.201703192131"/>
+ <repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
+ <unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
+ <unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
+ <unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
+ <unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
+ <unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/S20181120221132/repository"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.1.v20181127-0601"/>
+ <repository id="qvto" location="http://download.eclipse.org/mmt/qvto/updates/milestones/3.9.1/S201811270601"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
+ <unit id="org.eclipse.xtend.feature.group" version="2.2.0.v201605260315"/>
+ <repository id="xpand" location="http://download.eclipse.org/modeling/m2t/xpand/updates/releases/R201605260315/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.5.0.v20181126-1312"/>
+ <repository id="uml" location="http://download.eclipse.org/modeling/mdt/uml2/updates/5.5milestones"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.sdk.feature.group" version="4.10.0.v20181121-1800"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.10milestones/S-4.10M3-201811211800/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.7.0.v20181126-1148"/>
+ <unit id="org.eclipse.ocl.examples.feature.group" version="6.6.0.v20181126-1148"/>
+ <repository id="ocl" location="http://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.6.0/S201811261148"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
+ <repository id="xwt" location="http://download.eclipse.org/xwt/updates"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.xtext.sdk.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtend.sdk.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.redist.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.runtime.feature.group" version="2.16.0.v20181126-0210"/>
+ <unit id="org.eclipse.xtext.ui.feature.group" version="2.16.0.v20181126-0210"/>
+ <repository id="xtext" location="http://download.eclipse.org/modeling/tmf/xtext/updates/milestones/head/S201811260210"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.mwe2.language.sdk.feature.group" version="2.9.1.201705291011"/>
+ <repository id="mwe" location="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="0.0.0"/>
+ <repository id="webtools" location="https://download.eclipse.org/webtools/downloads/drops/R3.12.0/S-3.12.0.M3-20181124033837/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
+ <repository id="gmfRuntime" location="http://download.eclipse.org/modeling/gmp/gmf-runtime/updates/milestones/S201806010809"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
+ <repository id="gmfNotation" location="http://download.eclipse.org/modeling/gmp/gmf-notation/updates/milestones/S201805221301"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.16.0.v20181116-0557"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201811200213"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
+ <repository id="emfQuery" location="http://download.eclipse.org/modeling/emf/query/updates/milestones/S201805030653"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
+ <repository id="emfValidation" location="http://download.eclipse.org/modeling/emf/validation/updates/milestones/S201805030717"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
+ <repository id="emfTransaction" location="http://download.eclipse.org/modeling/emf/transaction/updates/milestones/S201805140824/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gef.feature.group" version="3.11.0.201606061308"/>
+ <repository id="gef" location="http://download.eclipse.org/tools/gef/updates/legacy/releases/4.0.0_gef-master_1952"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.gmf.codegen" version="2.11.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.ui" version="1.3.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.xtend" version="1.0.0.201509291144"/>
+ <unit id="org.eclipse.gmf.codegen.xtend.ui" version="1.0.0.201509291144"/>
+ <repository id="gmfTooling" location="http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201806221350/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="0.0.0"/>
+ <repository id="PapyrusMain" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="0.0.0"/>
+ <repository id="Sysml" location="https://hudson.eclipse.org/papyrus/job/papyrus-sysml-master/4/artifact/releng/org.eclipse.papyrus.sysml14.p2/target/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.cdo.feature.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.papyrus.cdo.models.feature.feature.group" version="0.0.0"/>
+ <repository id="papyrusCdo" location="https://hudson.eclipse.org/papyrus/job/Papyrus-CDO/lastSuccessfulBuild/artifact/repository/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.cdo.explorer" version="4.5.200.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.dawn" version="2.0.600.v20180530-1201"/>
+ <unit id="org.eclipse.emf.cdo.dawn.gmf" version="2.1.500.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.admin" version="4.1.600.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.explorer.ui" version="4.4.300.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.ui.admin" version="4.1.500.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.server.ocl" version="4.2.300.v20180529-1130"/>
+ <unit id="org.eclipse.emf.cdo.ecore" version="0.0.0"/>
+ <unit id="org.eclipse.emf.cdo.gmf.notation" version="0.0.0"/>
+ <repository id="cdo" location="http://download.eclipse.org/modeling/emf/cdo/drops/I20181123-0100"/>
+ </location>
+ </locations>
+</target>
diff --git a/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.tpd b/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.tpd
new file mode 100755
index 00000000000..6eea54c3da6
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.tpd
@@ -0,0 +1,36 @@
+target "Papyrus CDO Tests" with source requirements
+
+include
+"../../../main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd"
+
+//manualUpdate
+
+location PapyrusMain "http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"{
+ org.eclipse.papyrus.sdk.feature.feature.group lazy
+}
+
+//location PapyrusToolsmithis
+
+location Sysml "https://hudson.eclipse.org/papyrus/job/papyrus-sysml-master/4/artifact/releng/org.eclipse.papyrus.sysml14.p2/target/repository/" {
+ org.eclipse.papyrus.sysml14.feature.feature.group lazy
+}
+
+location papyrusCdo "https://hudson.eclipse.org/papyrus/job/Papyrus-CDO/lastSuccessfulBuild/artifact/repository/" {
+ org.eclipse.papyrus.cdo.feature.feature.group lazy
+ org.eclipse.papyrus.cdo.models.feature.feature.group lazy
+
+}
+
+
+//manual update
+location cdo "http://download.eclipse.org/modeling/emf/cdo/drops/I20181123-0100" {
+ org.eclipse.emf.cdo.explorer
+ org.eclipse.emf.cdo.dawn
+ org.eclipse.emf.cdo.dawn.gmf
+ org.eclipse.emf.cdo.admin
+ org.eclipse.emf.cdo.explorer.ui
+ org.eclipse.emf.cdo.ui.admin
+ org.eclipse.emf.cdo.server.ocl
+ org.eclipse.emf.cdo.ecore lazy
+ org.eclipse.emf.cdo.gmf.notation lazy
+}
diff --git a/releng/main-tests-with-cdo/targetPlatform/portable/pom.xml b/releng/main-tests-with-cdo/targetPlatform/portable/pom.xml
new file mode 100755
index 00000000000..d34c0f06cee
--- /dev/null
+++ b/releng/main-tests-with-cdo/targetPlatform/portable/pom.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+
+ <parent>
+ <groupId>org.eclipse.papyrus</groupId>
+ <artifactId>org.eclipse.papyrus.main.tests.cdo.target.parent</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+
+ <artifactId>org.eclipse.papyrus.main.tests.cdo.portable.target</artifactId>
+ <packaging>eclipse-target-definition</packaging>
+</project>
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.classpath b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.classpath
new file mode 100755
index 00000000000..3e5654f17eb
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.classpath
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<classpath>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
+ <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src">
+ <attributes>
+ <attribute name="test" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="output" path="bin"/>
+</classpath>
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.project b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.project
new file mode 100755
index 00000000000..07d9580f439
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.project
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.compatibility.cdo.tests</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ </natures>
+</projectDescription>
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.settings/org.eclipse.jdt.core.prefs b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.settings/org.eclipse.jdt.core.prefs
new file mode 100755
index 00000000000..0c68a61dca8
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/META-INF/MANIFEST.MF b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/META-INF/MANIFEST.MF
new file mode 100755
index 00000000000..be8d2c57b53
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/META-INF/MANIFEST.MF
@@ -0,0 +1,12 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %Bundle-Name
+Bundle-SymbolicName: org.eclipse.papyrus.compatibility.cdo.tests
+Bundle-Version: 1.0.0.qualifier
+Bundle-Vendor: %Bundle-Vendor
+Automatic-Module-Name: org.eclipse.papyrus.compatibility.cdo.tests
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
+Require-Bundle: org.junit;bundle-version="[4.12.0,5.0.0)",
+ org.eclipse.gmf.runtime.notation;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.uml2.uml;bundle-version="[5.4.0,6.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.style;bundle-version="[2.0.0,3.0.0)"
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/OSGI-INF/l10n/bundle.properties b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/OSGI-INF/l10n/bundle.properties
new file mode 100755
index 00000000000..f5bbfe4314b
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/OSGI-INF/l10n/bundle.properties
@@ -0,0 +1,3 @@
+#Properties file for org.eclipse.papyrus.compatibility.cdo.tests
+Bundle-Vendor = Eclipse Modeling Project
+Bundle-Name = Papyrus Compatibility CDO Tests \ No newline at end of file
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/README b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/README
new file mode 100755
index 00000000000..61ee03229e9
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/README
@@ -0,0 +1,5 @@
+This plugin is here, to check that the CDO version of metamodels used in Papyrus are in the tested installation.
+So we run, in a dedicated job, the Papyrus JUnit tests, using the metamodels provided by CDO. (UML, Notation, and others).
+So this plugin doesn't execute CDO JUnit tests, it just check the CDO installation.
+So the tests result must be the same than without CDO installed of course.
+
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/about.html b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/about.html
new file mode 100755
index 00000000000..997c5a2284d
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/about.html
@@ -0,0 +1,28 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
+<title>About</title>
+</head>
+<body lang="EN-US">
+<h2>About This Content</h2>
+
+<p>November 30, 2017</p>
+<h3>License</h3>
+
+<p>The Eclipse Foundation makes available all content in this plug-in (&quot;Content&quot;). Unless otherwise
+indicated below, the Content is provided to you under the terms and conditions of the
+Eclipse Public License Version 2.0 (&quot;EPL&quot;). A copy of the EPL is available
+at <a href="https://www.eclipse.org/legal/epl-2.0/">https://www.eclipse.org/legal/epl-2.0/</a>.
+For purposes of the EPL, &quot;Program&quot; will mean the Content.</p>
+
+<p>If you did not receive this Content directly from the Eclipse Foundation, the Content is
+being redistributed by another party (&quot;Redistributor&quot;) and different terms and conditions may
+apply to your use of any object code in the Content. Check the Redistributor's license that was
+provided with the Content. If no such license exists, contact the Redistributor. Unless otherwise
+indicated below, the terms and conditions of the EPL still apply to any source code in the Content
+and such source code may be obtained at <a href="http://www.eclipse.org/">http://www.eclipse.org</a>.</p>
+
+</body>
+</html>
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/build.properties b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/build.properties
new file mode 100755
index 00000000000..e218575bc18
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/build.properties
@@ -0,0 +1,18 @@
+#
+# Copyright (c) 2016 Christian W. Damus and others
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Eclipse Public License 2.0
+# which accompanies this distribution, and is available at
+# https://www.eclipse.org/legal/epl-2.0/
+#
+# SPDX-License-Identifier: EPL-2.0
+#
+# Contributors:
+# Vincent LORENZO (CEA-LIST) - Initial API and implementation
+#
+source.. = src/
+output.. = bin/
+bin.includes = META-INF/,\
+ .,\
+ OSGI-INF/
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/pom.xml b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/pom.xml
new file mode 100755
index 00000000000..e4bf4a86234
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/pom.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
+ xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus.compatibility.tests-cdo</groupId>
+ <artifactId>org.eclipse.papyrus.plugins.tests.cdo</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ </parent>
+ <groupId>org.eclipse.papyrus.tests</groupId>
+ <artifactId>org.eclipse.papyrus.compatibility.cdo.tests</artifactId>
+ <version>1.0.0-SNAPSHOT</version>
+ <packaging>eclipse-test-plugin</packaging>
+</project>
diff --git a/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/src/org/eclipse/papyrus/compatibility/cdo/tests/CDOInstallationTest.java b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/src/org/eclipse/papyrus/compatibility/cdo/tests/CDOInstallationTest.java
new file mode 100755
index 00000000000..1c753791983
--- /dev/null
+++ b/tests/compatibility/cdo/org.eclipse.papyrus.compatibility.cdo.tests/src/org/eclipse/papyrus/compatibility/cdo/tests/CDOInstallationTest.java
@@ -0,0 +1,58 @@
+/*****************************************************************************
+ * Copyright (c) 2018 CEA LIST.
+ *
+ *
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License 2.0
+ * which accompanies this distribution, and is available at
+ * https://www.eclipse.org/legal/epl-2.0/
+ *
+ * SPDX-License-Identifier: EPL-2.0
+ *
+ * Contributors:
+ * Vincent Lorenzo (CEA LIST) - Initial API and implementation
+ *
+ *****************************************************************************/
+
+package org.eclipse.papyrus.compatibility.cdo.tests;
+
+import org.eclipse.gmf.runtime.notation.NotationFactory;
+import org.eclipse.papyrus.infra.gmfdiag.style.StyleFactory;
+import org.eclipse.uml2.uml.UMLFactory;
+import org.junit.Assert;
+import org.junit.Test;
+
+/**
+ *
+ * This test classes allows to check that the CDO version of metamodel is used by the Eclipse Instance
+ */
+@SuppressWarnings("nls")
+public class CDOInstallationTest {
+
+ private static final String PAPYRUS_NOTATION_CDO_FACTORY_CLASS_NAME = "org.eclipse.papyrus.infra.gmfdiag.css.cdo.factory.CSSNotationFactory";
+
+ private static final String PAPYRUS_DIAGRAM_STYLE_CDO_FACTORY_CLASS_NAME = "org.eclipse.papyrus.infra.gmfdiag.style.cdo.impl.StyleFactoryImpl";
+
+ private static final String PAPYRUS_UML_CDO_FACTORY_CLASS_NAME = "org.eclipse.uml2.uml.cdo.internal.impl.UMLFactoryImpl";
+
+ @Test
+ public void checkNotationFactory() {
+ final NotationFactory notationFactory = NotationFactory.eINSTANCE;
+ final String name = notationFactory.getClass().getName();
+ Assert.assertEquals("The tests result is wrong, because the CDO version of GMF Notation is not installed (or used?!).", PAPYRUS_NOTATION_CDO_FACTORY_CLASS_NAME, name);
+ }
+
+ @Test
+ public void checkStyleFactory() {
+ final StyleFactory notationFactory = StyleFactory.eINSTANCE;
+ final String name = notationFactory.getClass().getName();
+ Assert.assertEquals("The tests result is wrong, because the CDO version of the Diagram Style is not installed (or used?!).", PAPYRUS_DIAGRAM_STYLE_CDO_FACTORY_CLASS_NAME, name);
+ }
+
+ @Test
+ public void checkUMLFactory() {
+ final UMLFactory umlFactory = UMLFactory.eINSTANCE;
+ final String name = umlFactory.getClass().getName();
+ Assert.assertEquals("The tests result is wrong, because the CDO version of the UML Metamodel is not installed (or used?!).", PAPYRUS_UML_CDO_FACTORY_CLASS_NAME, name);
+ }
+}
diff --git a/tests/compatibility/cdo/pom.xml b/tests/compatibility/cdo/pom.xml
new file mode 100755
index 00000000000..fc73b37210f
--- /dev/null
+++ b/tests/compatibility/cdo/pom.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
+ xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.papyrus</groupId>
+ <artifactId>org.eclipse.papyrus.tests.cdo.releng</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
+ <relativePath>../../../releng/main-tests-with-cdo/pom.xml</relativePath>
+ </parent>
+ <groupId>org.eclipse.papyrus.compatibility.tests-cdo</groupId>
+ <artifactId>org.eclipse.papyrus.plugins.tests.cdo</artifactId>
+ <packaging>pom</packaging>
+ <description>The top container of plug-in projects compatibility tests for the main Papyrus distribution.</description>
+
+ <modules>
+ <!-- children -->
+ <module>org.eclipse.papyrus.compatibility.cdo.tests</module>
+ </modules>
+
+</project> \ No newline at end of file

Back to the top