Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian W. Damus2016-06-23 07:35:23 -0400
committerChristian W. Damus2016-06-24 16:44:24 -0400
commit7ad46f5da4cfe33aa1e80aa62625658bc1b5b954 (patch)
tree5f6e9d6ded64c0166988bf401cd0eae1e6f229fd
parent8e99c528755691c777013d4b4f07a82318967ca3 (diff)
downloadorg.eclipse.papyrus-7ad46f5da4cfe33aa1e80aa62625658bc1b5b954.tar.gz
org.eclipse.papyrus-7ad46f5da4cfe33aa1e80aa62625658bc1b5b954.tar.xz
org.eclipse.papyrus-7ad46f5da4cfe33aa1e80aa62625658bc1b5b954.zip
Bug 496439: [RSA Import] Give mapping traces to extension transformations
https://bugs.eclipse.org/bugs/show_bug.cgi?id=496439 Update bundle versions for RSA Import fix. Change-Id: I11953254402fbfa52141851fc70e1c245a2649a0 (cherry picked from commit 0661aeadd449f2351285b55d57dcc7141d605447)
-rw-r--r--extraplugins/migration/org.eclipse.papyrus.m2m.qvto/META-INF/MANIFEST.MF4
-rw-r--r--extraplugins/migration/org.eclipse.papyrus.m2m.qvto/pom.xml2
-rw-r--r--extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF4
-rw-r--r--extraplugins/migration/org.eclipse.papyrus.migration.rsa/pom.xml2
-rw-r--r--plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters8
-rw-r--r--tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/pom.xml2
7 files changed, 9 insertions, 17 deletions
diff --git a/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/META-INF/MANIFEST.MF b/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/META-INF/MANIFEST.MF
index 30141c6b9c1..05d9f251430 100644
--- a/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/META-INF/MANIFEST.MF
+++ b/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/META-INF/MANIFEST.MF
@@ -7,8 +7,8 @@ Require-Bundle: org.eclipse.ui,
Export-Package: org.eclipse.papyrus.m2m.qvto
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
-Bundle-Name: Qvto Library
+Bundle-Version: 1.2.1.qualifier
+Bundle-Name: Papyrus QVTo Library
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.m2m.qvto.Activator
Bundle-SymbolicName: org.eclipse.papyrus.m2m.qvto;singleton:=true
diff --git a/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/pom.xml b/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/pom.xml
index fa4877a253d..00c7e3f5773 100644
--- a/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/pom.xml
+++ b/extraplugins/migration/org.eclipse.papyrus.m2m.qvto/pom.xml
@@ -9,6 +9,6 @@
</parent>
<artifactId>org.eclipse.papyrus.m2m.qvto</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.2.1-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
index eeebcb6057c..83e5e1c8ee0 100644
--- a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
+++ b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.ecore.xmi;bundle-version="2.10.1",
org.eclipse.uml2.types;visibility:=reexport,
org.eclipse.uml2.uml.resources;bundle-version="5.0.0",
- org.eclipse.papyrus.m2m.qvto;bundle-version="1.2.0",
+ org.eclipse.papyrus.m2m.qvto;bundle-version="[1.2.1,2.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="1.7.0",
org.eclipse.papyrus.uml.extensionpoints;bundle-version="1.2.0",
org.eclipse.papyrus.dsml.validation;bundle-version="1.2.0",
@@ -55,7 +55,7 @@ Export-Package: org.eclipse.papyrus.migration.rsa,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.2.1.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.migration.rsa.Activator
diff --git a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/pom.xml b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/pom.xml
index 70154f484e4..520dff7e67b 100644
--- a/extraplugins/migration/org.eclipse.papyrus.migration.rsa/pom.xml
+++ b/extraplugins/migration/org.eclipse.papyrus.migration.rsa/pom.xml
@@ -9,6 +9,6 @@
</parent>
<artifactId>org.eclipse.papyrus.migration.rsa</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.2.1-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project> \ No newline at end of file
diff --git a/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters b/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters
index 591bac6158a..ddb0af66b5f 100644
--- a/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters
+++ b/plugins/uml/alf/org.eclipse.papyrus.uml.alf.common/.settings/.api_filters
@@ -1,13 +1,5 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<component id="org.eclipse.papyrus.uml.alf.common" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Dependency upper bound was implicit in Mars" id="927989779">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="org.eclipse.xtext"/>
- </message_arguments>
- </filter>
- </resource>
<resource path="META-INF/MANIFEST.MF" type="org.eclipse.xtext.generator.FileSystemSupportBasedFileSystemAccess">
<filter comment="The xtext.generator dependency is optional and so could not reasonably have been re-exported or relied on by clients" id="305422471">
<message_arguments>
diff --git a/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/META-INF/MANIFEST.MF b/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/META-INF/MANIFEST.MF
index c8ff1195bdf..394343b26bc 100644
--- a/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.m2m.qvt.oml;bundle-version="3.4.0",
org.eclipse.papyrus.infra.core.log;bundle-version="1.2.0",
org.eclipse.papyrus.infra.gmfdiag.css;bundle-version="1.2.0",
- org.eclipse.papyrus.migration.rsa;bundle-version="1.2.0",
+ org.eclipse.papyrus.migration.rsa;bundle-version="1.2.1",
org.eclipse.ui;bundle-version="3.106.0",
org.junit;bundle-version="4.11.0",
org.eclipse.papyrus.m2m.qvto;bundle-version="1.2.0",
@@ -37,7 +37,7 @@ Export-Package: org.eclipse.papyrus.migration.rsa.tests,
org.eclipse.papyrus.migration.rsa.tests.qvt
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.2.1.qualifier
Bundle-Name: Model import migration Tests (Incubation)
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.migration.rsa.tests.Activator
diff --git a/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/pom.xml b/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/pom.xml
index 40b262852b1..436bee6d82d 100644
--- a/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/pom.xml
+++ b/tests/junit/extraplugins/migration/org.eclipse.papyrus.migration.rsa.tests/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.papyrus</groupId>
<artifactId>org.eclipse.papyrus.migration.rsa.tests</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.2.1-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
</project>

Back to the top