Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2019-06-12 08:23:01 -0400
committerQuentin Le Menez2019-06-12 12:12:55 -0400
commit8d9e61b2b52ba51d774875bc4fca0f7403fc10f4 (patch)
treebb33921d8e480fd6c35e0d11bbebdf07c8250440
parent7950d625faf2be8f90e494085475630ffaf2ec63 (diff)
downloadorg.eclipse.papyrus-4.4.0_RC2.tar.gz
org.eclipse.papyrus-4.4.0_RC2.tar.xz
org.eclipse.papyrus-4.4.0_RC2.zip
Bug 545631 - [Releng] Update the targets for 2019-06 RC24.4.0_RC2
- Add a strong dependency to guava 21 to avoid compiling against 27.1.0 in orbit - Rewire xwt dependency to the new milestone Change-Id: I54f2f76414b34acd186c2adfe6ce529b44f5c231 Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
-rw-r--r--features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/pom.xml32
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF6
-rwxr-xr-xplugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF2
-rw-r--r--plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF2
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF4
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF2
-rw-r--r--plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF8
-rwxr-xr-xplugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF6
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF2
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF2
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF8
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF4
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF2
-rw-r--r--plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF4
-rw-r--r--releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target26
-rw-r--r--releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target26
-rwxr-xr-xreleng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd23
-rw-r--r--releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target34
-rw-r--r--releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target34
-rw-r--r--releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd6
-rw-r--r--releng/tests/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target30
-rw-r--r--releng/tests/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target30
-rw-r--r--releng/tests/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target30
-rw-r--r--releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target30
-rw-r--r--releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd2
-rw-r--r--releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target32
-rw-r--r--releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target32
-rw-r--r--releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd4
-rw-r--r--tests/junit/framework/org.eclipse.papyrus.junit.framework/META-INF/MANIFEST.MF6
-rw-r--r--tests/junit/framework/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF10
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF6
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF6
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF4
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF4
97 files changed, 355 insertions, 326 deletions
diff --git a/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/pom.xml b/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/pom.xml
index 4444588cc0a..4f23d780d84 100644
--- a/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/pom.xml
+++ b/features/papyrus-main-features/org.eclipse.papyrus.sdk.feature/pom.xml
@@ -2,11 +2,37 @@
<project>
<modelVersion>4.0.0</modelVersion>
<parent>
- <groupId>org.eclipse.papyrus</groupId>
- <artifactId>org.eclipse.papyrus.features</artifactId>
- <version>0.0.1-SNAPSHOT</version>
+ <groupId>org.eclipse.papyrus</groupId>
+ <artifactId>org.eclipse.papyrus.features</artifactId>
+ <version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.sdk.feature</artifactId>
<version>4.4.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
+
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.eclipse.tycho.extras</groupId>
+ <artifactId>tycho-source-feature-plugin</artifactId>
+ <executions>
+ <execution>
+ <id>source-feature</id>
+ <phase>package</phase>
+ <goals>
+ <goal>source-feature</goal>
+ </goals>
+ <configuration>
+ <excludes>
+ <plugin id="com.google.guava" />
+ <plugin id="com.google.gson" />
+ </excludes>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+
+ </plugins>
+ </build>
+
</project>
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF b/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
index 947684bb410..a0914659456 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
@@ -38,8 +38,8 @@ Bundle-Activator: org.eclipse.papyrus.infra.core.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.core;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.io;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.io;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.core
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF b/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
index 8256a2425d2..4df02fe471d 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
@@ -20,7 +20,7 @@ Bundle-Activator: org.eclipse.papyrus.infra.tools.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.tools
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
index 26b93e6de2c..f079016b828 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
@@ -16,5 +16,5 @@ Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.gmf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.gmf
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
index f85786ee368..16162a78c8b 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
@@ -18,6 +18,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.emf.readonly.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.readonly;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.readonly
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
index f5234b3ea0b..fcbf4342bf1 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
@@ -24,7 +24,7 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
index ec02f4ab450..d4da534db54 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
@@ -27,6 +27,6 @@ Bundle-Activator: org.eclipse.papyrus.infra.ui.internal.emf.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.emf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.emf
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
index 2ca4de6202f..f852ab6935c 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
@@ -15,5 +15,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.assistant.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.assistant.ui
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
index fa8dec782ac..561726a6ce7 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
@@ -26,6 +26,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.assistant;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.assistant
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
index 01299547039..14b1b7f8c3b 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
@@ -15,6 +15,6 @@ Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.css.properties.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.css.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.css.properties
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
index 48a910526be..39921d8f4e9 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
@@ -40,5 +40,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.css.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.css;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.css
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
index 3198845e42b..29371745026 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.canonical;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.canonical
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
index bca832b3af2..17d427a1bc3 100755
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
@@ -87,9 +87,9 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.common;singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0",
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)",
org.osgi.service.component.annotations;version="1.3.0";resolution:=optional
Service-Component: OSGI-INF/org.eclipse.papyrus.infra.gmfdiag.common.internal.service.EditPolicyProviderServiceImpl.xml,
OSGI-INF/org.eclipse.papyrus.infra.gmfdiag.common.internal.service.ViewProviderServiceImpl.xml
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
index a5340465750..7401c577c04 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
@@ -14,5 +14,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.menu;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.menu
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
index 50c8d1c28c7..6c713a4a0a1 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
@@ -22,5 +22,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.properties
diff --git a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
index 7b602f55ade..053680d6727 100644
--- a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
@@ -37,5 +37,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="1.7.0",
org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
Bundle-ActivationPolicy: lazy
-Import-Package: com.google.common.base
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
index bbb178b2f23..6de33a66c95 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
@@ -11,5 +11,5 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.internationalization;bundle-version="[1.0.0,2.0.0)"
Bundle-ActivationPolicy: lazy
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.internationalization.readonly
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
index 9cfe66105c9..38fe6e18ec3 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
@@ -27,6 +27,6 @@ Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.12.0,3.0.0)";visibility
org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.infra.internationalization.Activator
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.internationalization
diff --git a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
index aa668a1584e..c9f6aaaba33 100755
--- a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
+++ b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
@@ -14,8 +14,8 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.sync.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.sync;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.reflect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.reflect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.sync
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
index fff1a80d826..9a4d29f9c94 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
@@ -32,5 +32,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.nattable.common.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.common;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable.common
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
index 3276236bba4..dbec808e7ae 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
@@ -15,6 +15,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable.controlmode
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
index 70bf8e3d37e..b52a7306dd3 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
@@ -82,5 +82,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
index 5d4227b6163..13ade560a0b 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
@@ -32,7 +32,7 @@ Bundle-Activator: org.eclipse.papyrus.infra.services.controlmode.ControlModePlug
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.controlmode
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
index b98fa9093cc..1a57467c5cb 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
@@ -21,5 +21,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.services.edit.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.edit;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.edit
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
index 7dea144bbdb..d731db4896c 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
@@ -13,5 +13,5 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.services.localizer.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.localizer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.localizer
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
index 0cabf8d626e..0a98516f398 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
@@ -19,5 +19,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.services.validation.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.validation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.validation
diff --git a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
index bbd16d7b676..ad305634352 100644
--- a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
+++ b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
@@ -23,5 +23,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.types.core.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.types.core;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.types.core
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
index cbb8cbf7edb..6c82345ef7a 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
@@ -12,5 +12,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.ui.resources.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.resources;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.resources
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
index e669489c1e8..f87b6b7df27 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
@@ -44,8 +44,8 @@ Bundle-Activator: org.eclipse.papyrus.infra.ui.Activator
Bundle-Description: Plugin dedicated to manage generic menus and actions,
linked to EMF but not to UML nor GMF technologies.
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui;singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.cache;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.cache;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
index cb4a465a4ff..33a14829ee4 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
@@ -39,5 +39,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.widgets.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.widgets;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.widgets
diff --git a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
index 1d606047651..e56e5de8293 100644
--- a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
@@ -20,5 +20,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.profile.types.generator.ui.internal.Ac
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile.types.generator.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.util.concurrent
+Import-Package: com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile.types.generator.ui
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
index e64e143201c..fe994750228 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
@@ -18,6 +18,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.releng.tools.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.releng.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base,
- com.google.common.collect
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.releng.tools
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
index 6a91807017e..9d1a4a689b6 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)
org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.compare;bundle-version="[3.3.0,4.0.0)",
- com.google.guava;bundle-version="21.0.0",
+ com.google.guava;bundle-version="[21.0.0, 22.0.0)",
org.eclipse.gmf.runtime.notation.edit;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.infra.constraints;bundle-version="[2.0.0,3.0.0)"
Bundle-Activator: org.eclipse.papyrus.uml.m2m.qvto.tests.tools.Activator
diff --git a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
index 3822e547046..487b0a4de72 100644
--- a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.profilemigration;singleton:=
Bundle-Version: 0.7.200.qualifier
Bundle-ClassPath: .
Require-Bundle: org.eclipse.ui,
- com.google.guava;bundle-version="21.0.0",
+ com.google.guava;bundle-version="[21.0.0, 22.0.0)",
org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.emf.compare;bundle-version="[3.3.0,4.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
index 92042a9d24b..90d7e2500af 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
@@ -22,6 +22,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.controlmode
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
index d412780b06e..cff02b96aeb 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
@@ -18,7 +18,7 @@ Bundle-Activator: org.eclipse.papyrus.uml.decoratormodel.properties.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.properties
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
index 1e43f44b1e4..8ab73c19322 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
@@ -27,8 +27,8 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.eventbus;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.eventbus;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.ui
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
index 42af6e8547c..ff0b20fb13b 100755
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
@@ -34,7 +34,7 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
index f7095836617..ad1bbf34883 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
@@ -93,6 +93,6 @@ Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.activity.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.activity; singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.activity
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
index e279eaf7e0e..43515848f25 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
@@ -84,6 +84,6 @@ Bundle-Activator: org.eclipse.papyrus.uml.diagram.clazz.part.UMLDiagramEditorPlu
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.clazz; singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.clazz
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
index 12268bce6a0..e159e26e080 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
@@ -97,6 +97,6 @@ Eclipse-BuddyPolicy: dependent
Bundle-Activator: org.eclipse.papyrus.uml.diagram.common.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.common;singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.common
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
index 8e16d051a5c..c920867fff0 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
@@ -76,5 +76,5 @@ Bundle-Version: 4.0.100.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.communication.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.communication; singleton:=true
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.communication
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
index e5af63b80da..3bf35d011f6 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
@@ -82,5 +82,5 @@ Bundle-Version: 3.1.100.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.composite.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.composite; singleton:=true
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.composite
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
index 8c95e511a1e..0712840ac73 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
@@ -35,5 +35,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.diagram.interactionoverview.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.interactionoverview;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.interactionoverview
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
index 1c3b7b49ae4..056de662d8a 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
@@ -85,5 +85,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.diagram.profile.part.UMLDiagramEditorP
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.profile; singleton:=true
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.profile
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
index e08ff9493ce..99b1b46f00a 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
@@ -74,5 +74,5 @@ Bundle-Version: 5.2.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.sequence.part.UMLDiagramEditorPlugin
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.sequence; singleton:=true
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.sequence
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
index 1e145b3f745..b4203bca7e4 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
@@ -81,6 +81,6 @@ Bundle-Version: 3.1.100.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.statemachine.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.statemachine; singleton:=true
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.statemachine
diff --git a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
index 95e18242206..e71ab62f9a4 100644
--- a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
@@ -36,6 +36,6 @@ Export-Package: org.eclipse.papyrus.uml.m2m.qvto.common,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters.impl,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters.util
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.m2m.qvto.common
diff --git a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
index a191e706e31..ba7bcfc6469 100644
--- a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
@@ -23,5 +23,5 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.modelexplorer.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.modelexplorer
diff --git a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
index 047c04dc932..9aa053a5b66 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
@@ -15,6 +15,6 @@ Bundle-Activator: org.eclipse.papyrus.uml.controlmode.profile.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.controlmode.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.controlmode.profile
diff --git a/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
index 1ef85cb18a6..fd4d1f123c1 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
@@ -23,5 +23,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.filters;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.filters
diff --git a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
index 45909d5e152..6872f58a134 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
@@ -23,8 +23,8 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.modelrepair;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.eventbus;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.eventbus;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.modelrepair
diff --git a/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
index e6385b81b7b..98d5d9eff6d 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
@@ -26,5 +26,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.service.types.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.service.types;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.service.types
diff --git a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
index edbfdaef9ce..dbc1feaf84b 100644
--- a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
+++ b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
@@ -24,6 +24,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.profile.drafter.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile.drafter;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile.drafter
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
index a22873aca9c..823f4c167d8 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Bundle-Activator: org.eclipse.papyrus.uml.tools.utils.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.utils;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Bundle-Description: %Bundle-Description
Automatic-Module-Name: org.eclipse.papyrus.uml.tools.utils
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
index e7ce3964cf0..66e444f44ca 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
@@ -40,6 +40,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.tools
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
index 7502351c183..d1f508da60e 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
@@ -36,6 +36,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.modelexplorer
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
index 69838961274..bc84888daf2 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
@@ -19,5 +19,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.views.properties.toolsmiths;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.properties.toolsmiths
diff --git a/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF b/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
index ba0321c7c06..e63e9e6712b 100644
--- a/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
+++ b/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
@@ -11,6 +11,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.views.validation.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.views.validation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.validation
diff --git a/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target b/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
index 3ec6b8848e6..215a052291c 100644
--- a/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
+++ b/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Main" sequenceNumber="1559720283">
+<target name="Papyrus Main" sequenceNumber="1560352546">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
diff --git a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
index 16ce703d8a0..a8b117dc32d 100644
--- a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
+++ b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Main" sequenceNumber="1559720283">
+<target name="Papyrus Main" sequenceNumber="1560352546">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="http://download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
diff --git a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
index 3f172408c4c..31f5c58f1b4 100755
--- a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
+++ b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
@@ -23,7 +23,7 @@ location nattable "http://download.eclipse.org/nattable/releases/1.5.0/repositor
//manualUpdate (Needed by infra.tools, API Evolution Report generation and other plugins)
-location orbit "https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository" {
+location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository" {
com.google.guava 21.0.0
com.google.guava.source 21.0.0
com.google.gson [2.7.0,2.8.0)
@@ -37,11 +37,20 @@ location orbit "https://download.eclipse.org/tools/orbit/downloads/drops/R201902
}
+/*** temporary manual ***/
+
+//manualUpdate (until the result of this job has been published)
+
+location xwt "https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/" {
+ org.eclipse.xwt.feature.feature.group lazy
+}
+
+
/*** Updates from the Simrel repository ***/
//updateFrom("QVT Operational for 2019-06",0)
-location qvto "https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849" {
+location qvto "https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948" {
org.eclipse.m2m.qvt.oml.sdk.feature.group
}
@@ -60,7 +69,7 @@ location uml "http://download.eclipse.org/modeling/mdt/uml2/updates/5.5" {
//updateFrom("Eclipse",0)
-location platform "http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/" {
+location platform "http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/" {
org.eclipse.sdk.feature.group
}
@@ -71,12 +80,6 @@ location ocl "https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6
org.eclipse.ocl.examples.feature.group
}
-//manualUpdate
-
-location xwt "https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/" {
- org.eclipse.xwt.feature.feature.group lazy
-}
-
//updateFrom("Xtext, Xtend",0)
location xtext "https://download.eclipse.org/modeling/tmf/xtext/updates/milestones/head/S201905280716" {
@@ -113,7 +116,7 @@ location gmfNotation "http://download.eclipse.org/modeling/gmp/gmf-notation/upda
//updateFrom("EMF (Core)",0)
-location emf "http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646" {
+location emf "http://download.eclipse.org/modeling/emf/emf/builds/release/2.18" {
org.eclipse.emf.sdk.feature.group
}
diff --git a/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target b/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
index 6b8ab666ca4..fca1351cc05 100644
--- a/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
+++ b/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus RCP" sequenceNumber="1559720283">
+<target name="Papyrus RCP" sequenceNumber="1560352546">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -47,10 +51,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -96,10 +96,10 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.12.0.v20190505-1221"/>
- <unit id="org.eclipse.rcp.configuration.feature.group" version="1.1.500.v20190531-0245"/>
+ <unit id="org.eclipse.rcp.configuration.feature.group" version="1.1.500.v20190605-1800"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="3.8.400.v20190515-0925"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.mylyn.ide_feature.feature.group" version="3.24.2.v20180905-0014"/>
@@ -111,14 +111,14 @@
<repository id="mylyn" location="file:/home/data/httpd/download.eclipse.org/mylyn/drops/3.24.2/v20180905-2014"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xsd.sdk.feature.group" version="2.18.0.v20190323-1100"/>
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.cdo.epp.feature.group" version="4.7.0.v20180530-1201"/>
diff --git a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
index 5b16e0a6ccb..02f6f0bac35 100644
--- a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
+++ b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus RCP" sequenceNumber="1559720283">
+<target name="Papyrus RCP" sequenceNumber="1560352546">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -47,10 +51,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -96,10 +96,10 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.e4.core.tools.feature.feature.group" version="4.12.0.v20190505-1221"/>
- <unit id="org.eclipse.rcp.configuration.feature.group" version="1.1.500.v20190531-0245"/>
+ <unit id="org.eclipse.rcp.configuration.feature.group" version="1.1.500.v20190605-1800"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="3.8.400.v20190515-0925"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.mylyn.ide_feature.feature.group" version="3.24.2.v20180905-0014"/>
@@ -111,14 +111,14 @@
<repository id="mylyn" location="http://download.eclipse.org/mylyn/drops/3.24.2/v20180905-2014"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xsd.sdk.feature.group" version="2.18.0.v20190323-1100"/>
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.cdo.epp.feature.group" version="4.7.0.v20180530-1201"/>
diff --git a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
index 03220e628a9..325eaaeb247 100644
--- a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
+++ b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
@@ -13,7 +13,7 @@ location egit "http://download.eclipse.org/egit/staging/v5.4.0.201905221418-m3"
//updateFrom("Eclipse",0)
-location platform "http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/" {
+location platform "http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/" {
org.eclipse.e4.core.tools.feature.feature.group
org.eclipse.rcp.configuration.feature.group
org.eclipse.equinox.executable.feature.group
@@ -32,14 +32,14 @@ location mylyn "http://download.eclipse.org/mylyn/drops/3.24.2/v20180905-2014" {
//updateFrom("EMF COMPARE",0)
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/" {
+location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/" {
org.eclipse.emf.compare.source.feature.group
org.eclipse.emf.compare.ide.ui.source.feature.group
}
//updateFrom("EMF (Core)",0)
-location emf "http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646" {
+location emf "http://download.eclipse.org/modeling/emf/emf/builds/release/2.18" {
org.eclipse.xsd.sdk.feature.group
}
diff --git a/releng/tests/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target b/releng/tests/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target
index 149cd61c230..54b13b7c95d 100644
--- a/releng/tests/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target
+++ b/releng/tests/main-tests-with-cdo/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.cdo.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus CDO Tests" sequenceNumber="1559720284">
+<target name="Papyrus CDO Tests" sequenceNumber="1560352547">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -106,8 +106,8 @@
<repository id="gmfTooling" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.cdo.admin" version="0.0.0"/>
diff --git a/releng/tests/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target b/releng/tests/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target
index 6904b207dbc..6acf03c4600 100644
--- a/releng/tests/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target
+++ b/releng/tests/main-tests-with-cdo/targetPlatform/portable/org.eclipse.papyrus.main.tests.cdo.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus CDO Tests" sequenceNumber="1559720284">
+<target name="Papyrus CDO Tests" sequenceNumber="1560352547">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="http://download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -106,8 +106,8 @@
<repository id="gmfTooling" location="http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.cdo.admin" version="0.0.0"/>
diff --git a/releng/tests/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target b/releng/tests/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
index 25dc6391f1a..d9323aad8c7 100644
--- a/releng/tests/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
+++ b/releng/tests/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Tests" sequenceNumber="1559720284">
+<target name="Papyrus Tests" sequenceNumber="1560352547">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -106,8 +106,8 @@
<repository id="gmfTooling" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
</locations>
</target>
diff --git a/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target b/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
index 3f5fb3524ef..9b4f2d3c956 100644
--- a/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
+++ b/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Tests" sequenceNumber="1559720284">
+<target name="Papyrus Tests" sequenceNumber="1560352547">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="http://download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -106,8 +106,8 @@
<repository id="gmfTooling" location="http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
</locations>
</target>
diff --git a/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd b/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
index c89442dd6ea..7229a823e3a 100644
--- a/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
+++ b/releng/tests/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
@@ -13,6 +13,6 @@ location gmfTooling "http://download.eclipse.org/modeling/gmp/gmf-tooling/update
//updateFrom("EMF COMPARE",0)
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/" {
+location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/" {
org.eclipse.emf.compare.source.feature.group
} \ No newline at end of file
diff --git a/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target b/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
index dd59d13b094..1d4056b0fbc 100644
--- a/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
+++ b/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Toolsmiths" sequenceNumber="1559720291">
+<target name="Papyrus Toolsmiths" sequenceNumber="1560352553">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="file:/home/data/httpd/download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="file:/home/data/httpd/download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="file:/home/data/httpd/download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -132,7 +132,7 @@
<unit id="org.eclipse.oomph.p2.feature.group" version="1.12.0.v20190527-1611"/>
<unit id="org.eclipse.oomph.setup.feature.group" version="1.13.0.v20190531-1228"/>
<unit id="org.eclipse.oomph.preferences.feature.group" version="1.11.0.v20190323-1134"/>
- <repository id="oomph" location="https://download.eclipse.org/oomph/drops/milestone/S20190531-082923-1.13.0-M4"/>
+ <repository id="oomph" location="https://download.eclipse.org/oomph/drops/release/1.13.0"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<repository id="egit" location="file:/home/data/httpd/download.eclipse.org/egit/staging/v5.4.0.201905221418-m3"/>
@@ -145,8 +145,8 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
</locations>
</target>
diff --git a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
index d0a7e8e42da..17ebb868318 100644
--- a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
+++ b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Papyrus Toolsmiths" sequenceNumber="1559720291">
+<target name="Papyrus Toolsmiths" sequenceNumber="1560352553">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.nebula.widgets.richtext.feature.feature.group" version="1.2.0.201703081533"/>
@@ -18,19 +18,23 @@
<repository id="nattable" location="http://download.eclipse.org/nattable/releases/1.5.0/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
+ <unit id="com.google.guava" version="27.1.0.v20190517-1946"/>
+ <unit id="com.google.guava.source" version="27.1.0.v20190517-1946"/>
<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
<unit id="org.objectweb.asm" version="5.0.1.v201404251740"/>
<unit id="org.objectweb.asm.source" version="5.0.1.v201404251740"/>
- <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20190602212107/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190519-0849"/>
- <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201905190849"/>
+ <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
+ <repository id="xwt" location="https://download.eclipse.org/xwt/milestones-1.4.0/1.4.0-RC2/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.3.v20190610-0948"/>
+ <repository id="qvto" location="https://download.eclipse.org/mmt/qvto/updates/milestones/3.9.3/S201906100948"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xpand.sdk.feature.group" version="2.2.0.v201605260315"/>
@@ -42,8 +46,8 @@
<repository id="uml" location="http://download.eclipse.org/modeling/mdt/uml2/updates/5.5"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190531-0648"/>
- <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC1a-201905310245/"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.12.0.v20190605-1801"/>
+ <repository id="platform" location="http://download.eclipse.org/eclipse/updates/4.12milestones/S-4.12RC2-201906051800/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.ocl.examples.classic.feature.group" version="5.9.0.v20190603-1146"/>
@@ -51,10 +55,6 @@
<repository id="ocl" location="https://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.8.0/S201906031146"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="0.0.0"/>
- <repository id="xwt" location="https://ci.eclipse.org/shared/job/xwt/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xtext.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtend.sdk.feature.group" version="2.18.0.v20190528-0716"/>
<unit id="org.eclipse.xtext.redist.feature.group" version="2.18.0.v20190528-0716"/>
@@ -80,7 +80,7 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="2.18.0.v20190528-0845"/>
- <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/milestone/S201905280646"/>
+ <repository id="emf" location="http://download.eclipse.org/modeling/emf/emf/builds/release/2.18"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.query.sdk.feature.group" version="1.12.0.201805030653"/>
@@ -132,7 +132,7 @@
<unit id="org.eclipse.oomph.p2.feature.group" version="1.12.0.v20190527-1611"/>
<unit id="org.eclipse.oomph.setup.feature.group" version="1.13.0.v20190531-1228"/>
<unit id="org.eclipse.oomph.preferences.feature.group" version="1.11.0.v20190323-1134"/>
- <repository id="oomph" location="https://download.eclipse.org/oomph/drops/milestone/S20190531-082923-1.13.0-M4"/>
+ <repository id="oomph" location="https://download.eclipse.org/oomph/drops/release/1.13.0"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<repository id="egit" location="http://download.eclipse.org/egit/staging/v5.4.0.201905221418-m3"/>
@@ -145,8 +145,8 @@
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905231313"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.7.201905300200"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/"/>
</location>
</locations>
</target>
diff --git a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
index 87c431a5b86..fadef92bc50 100644
--- a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
+++ b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
@@ -33,7 +33,7 @@ location gmfTooling "http://download.eclipse.org/modeling/gmp/gmf-tooling/update
//updateFrom("oomph",0)
-location oomph "https://download.eclipse.org/oomph/drops/milestone/S20190531-082923-1.13.0-M4" {
+location oomph "https://download.eclipse.org/oomph/drops/release/1.13.0" {
org.eclipse.oomph.version.feature.group
org.eclipse.oomph.setup.workingsets.feature.group
org.eclipse.oomph.projectconfig.feature.group
@@ -66,7 +66,7 @@ location mylyn "http://download.eclipse.org/mylyn/drops/3.24.2/v20180905-2014" /
//updateFrom("EMF COMPARE",0)
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905231313/" {
+location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201905300200/" {
org.eclipse.emf.compare.ide.ui.feature.group lazy
org.eclipse.emf.compare.source.feature.group
} \ No newline at end of file
diff --git a/tests/junit/framework/org.eclipse.papyrus.junit.framework/META-INF/MANIFEST.MF b/tests/junit/framework/org.eclipse.papyrus.junit.framework/META-INF/MANIFEST.MF
index e04a916905a..a90a34ae8f3 100644
--- a/tests/junit/framework/org.eclipse.papyrus.junit.framework/META-INF/MANIFEST.MF
+++ b/tests/junit/framework/org.eclipse.papyrus.junit.framework/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Bundle-Name: Conditional Junit Annotations
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.junit.framework;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.cache;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.cache;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.junit.framework
diff --git a/tests/junit/framework/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF b/tests/junit/framework/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
index c66ddbe748d..e29db928538 100644
--- a/tests/junit/framework/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
+++ b/tests/junit/framework/org.eclipse.papyrus.junit.utils/META-INF/MANIFEST.MF
@@ -25,9 +25,9 @@ Bundle-Activator: org.eclipse.papyrus.junit.utils.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.junit.utils;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.cache;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.io;version="21.0.0",
- com.google.common.primitives;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.cache;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.io;version="[21.0.0, 22.0.0)",
+ com.google.common.primitives;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.junit.utils
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
index 2d294234757..e34bb59358c 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.eclipse.project.editors.tests/META-INF/MANIFEST.MF
@@ -9,5 +9,5 @@ Bundle-Name: Papyrus Project Editor Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.eclipse.project.editors.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.eclipse.project.editors.tests
diff --git a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
index 93c14e6ddc0..edcee478d2a 100644
--- a/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/editor/org.eclipse.papyrus.editor.integration.tests/META-INF/MANIFEST.MF
@@ -45,6 +45,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.editor.integration.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.editor.integration.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.editor.integration.tests
diff --git a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
index b8cf4ea9bfd..6c0f2f0c4ee 100644
--- a/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/core/org.eclipse.papyrus.infra.core.tests/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.core.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.core.tests
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
index 0a281656e0c..e35ebcf278d 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly.tests/META-INF/MANIFEST.MF
@@ -16,6 +16,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.readonly.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.readonly.tests
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
index 4d5f1319dec..bc381fe0995 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.emf.tests/META-INF/MANIFEST.MF
@@ -19,8 +19,8 @@ Bundle-Localization: fragment
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.io;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.io;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.tests
diff --git a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
index 46a37651093..5c76a3479a4 100644
--- a/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf.tests/META-INF/MANIFEST.MF
@@ -17,6 +17,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.emf.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.emf.tests
diff --git a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
index 9cf6a958f8a..105a86c2fcd 100644
--- a/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.tests/META-INF/MANIFEST.MF
@@ -31,6 +31,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.assistant.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.assistant.tests
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
index 2a0b81f7a7e..0dbf993d637 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical.tests/META-INF/MANIFEST.MF
@@ -30,7 +30,7 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.canonical.tests.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.canonical.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.canonical.tests
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
index 14eed331522..f34d1ca3530 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.commands.tests/META-INF/MANIFEST.MF
@@ -14,6 +14,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.commands.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.commands.tests
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
index de7acd710a6..a5f9f374da1 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common.tests/META-INF/MANIFEST.MF
@@ -23,5 +23,5 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.common.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.common.tests
diff --git a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
index 40db5ef8090..01050b67b05 100644
--- a/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests/META-INF/MANIFEST.MF
@@ -21,6 +21,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.tests
diff --git a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
index 862dd1d24ce..344869b1966 100644
--- a/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/org.eclipse.papyrus.infra.tools.tests/META-INF/MANIFEST.MF
@@ -16,5 +16,5 @@ Bundle-Name: Papyrus Infrastructure Tools Tests
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.tools.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.tools.tests
diff --git a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
index cadaafc15d0..f911f8f826f 100644
--- a/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode.tests/META-INF/MANIFEST.MF
@@ -27,5 +27,5 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.services.controlmode.tests.control.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.controlmode.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.controlmode.tests
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
index 68f2227aef4..38792fe1c13 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode.tests/META-INF/MANIFEST.MF
@@ -28,5 +28,5 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.controlmode.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.controlmode.tests
diff --git a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
index bcfd58a736e..747159e8112 100644
--- a/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.tests/META-INF/MANIFEST.MF
@@ -30,8 +30,8 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0",
- com.google.common.io;version="21.0.0",
- com.google.common.util.concurrent;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)",
+ com.google.common.io;version="[21.0.0, 22.0.0)",
+ com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.tests
diff --git a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
index ad6176e801e..dcd832f35eb 100644
--- a/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.wizards.tests/META-INF/MANIFEST.MF
@@ -21,6 +21,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.wizards.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.wizards.tests
diff --git a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
index 5883b26d10e..8f152462e73 100644
--- a/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/internationalization/org.eclipse.papyrus.uml.internationalization.controlmode.tests/META-INF/MANIFEST.MF
@@ -24,5 +24,5 @@ Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.uml.internationalization.controlmode.tests.Activator
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.internationalization.controlmode.tests
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
index 8949e43b997..df2268b2837 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.modelrepair.tests/META-INF/MANIFEST.MF
@@ -15,6 +15,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.modelrepair.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.modelrepair.tests
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
index bf63ae305b0..b9870a48a31 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.properties.tests/META-INF/MANIFEST.MF
@@ -14,5 +14,5 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.properties.tests
diff --git a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
index e99f0bb14ce..217a3d80ac6 100644
--- a/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/org.eclipse.papyrus.uml.service.types.tests/META-INF/MANIFEST.MF
@@ -21,5 +21,5 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.service.types.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.service.types.tests
diff --git a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
index ea891ac21ef..014eb49d130 100644
--- a/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter.tests/META-INF/MANIFEST.MF
@@ -26,5 +26,5 @@ Export-Package: org.eclipse.papyrus.uml.profile.drafter.tests,
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
-Import-Package: com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile.drafter.tests
diff --git a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
index 2f396010ead..21246d22f78 100644
--- a/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
+++ b/tests/junit/plugins/uml/tools/org.eclipse.papyrus.uml.tools.tests/META-INF/MANIFEST.MF
@@ -28,6 +28,6 @@ Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.tools.tests.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.tests;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="21.0.0",
- com.google.common.collect;version="21.0.0"
+Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
+ com.google.common.collect;version="[21.0.0, 22.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.tools.tests

Back to the top