Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Ortmayr2019-01-16 07:53:30 -0500
committerTobias Ortmayr2019-01-17 08:29:22 -0500
commit8a79f97a540987ee337e56a0e516cd3a74c038e0 (patch)
tree0ca3c9d5ae842dc9da346f4e9b5a2a69203ce9a4
parent86a0da1435722698da2cd4cf10f46ce5089633f7 (diff)
downloadorg.eclipse.papyrus-collaborativemodeling-8a79f97a540987ee337e56a0e516cd3a74c038e0.tar.gz
org.eclipse.papyrus-collaborativemodeling-8a79f97a540987ee337e56a0e516cd3a74c038e0.tar.xz
org.eclipse.papyrus-collaborativemodeling-8a79f97a540987ee337e56a0e516cd3a74c038e0.zip
Update target definitions to eclipse 2018-12
- Update nightly target to 2018-12 - Update release target to 2018-12 - Remove oxygen target - Create previous-release target (2018-09) - Update maven configuration - Remove EMF Compare from p2 repository Change-Id: Iecd0f3bd7b40ebe80637048431afa60461eec209 Signed-off-by: Tobias Ortmayr <tortmayr@eclipsesource.com>
-rw-r--r--compare/org.eclipse.papyrus.compare.p2/category.xml4
-rw-r--r--compare/org.eclipse.papyrus.compare.p2/pom.xml5
-rwxr-xr-xcompare/pom.xml20
-rw-r--r--compare/targetplatforms/compare-nightly.target15
-rwxr-xr-xcompare/targetplatforms/compare-nightly.tpd15
-rw-r--r--compare/targetplatforms/compare-previous-release.target (renamed from compare/targetplatforms/compare-oxygen.target)78
-rwxr-xr-xcompare/targetplatforms/compare-previous-release.tpd (renamed from compare/targetplatforms/compare-oxygen.tpd)14
-rw-r--r--compare/targetplatforms/compare-release.target56
-rwxr-xr-xcompare/targetplatforms/compare-release.tpd22
-rw-r--r--compare/targetplatforms/compare.tests-nightly.target15
-rwxr-xr-xcompare/targetplatforms/compare.tests-nightly.tpd4
-rwxr-xr-xcompare/targetplatforms/compare.tests-oxygen.tpd18
-rw-r--r--compare/targetplatforms/compare.tests-previous-release.target (renamed from compare/targetplatforms/compare.tests-oxygen.target)81
-rwxr-xr-xcompare/targetplatforms/compare.tests-previous-release.tpd12
-rw-r--r--compare/targetplatforms/compare.tests-release.target60
-rwxr-xr-xcompare/targetplatforms/compare.tests-release.tpd2
16 files changed, 190 insertions, 231 deletions
diff --git a/compare/org.eclipse.papyrus.compare.p2/category.xml b/compare/org.eclipse.papyrus.compare.p2/category.xml
index 5f0d935..ec617b5 100644
--- a/compare/org.eclipse.papyrus.compare.p2/category.xml
+++ b/compare/org.eclipse.papyrus.compare.p2/category.xml
@@ -11,8 +11,4 @@
Papyrus Compare Category
</description>
</category-def>
- <!-- This is currently ignored by Tycho, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=453708 -->
- <!-- We add those sites in the root pom.xml now instead as a workaround -->
- <repository-reference location="http://download.eclipse.org/egit/updates" enabled="true" />
- <repository-reference location="http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/integration/" enabled="true" />
</site>
diff --git a/compare/org.eclipse.papyrus.compare.p2/pom.xml b/compare/org.eclipse.papyrus.compare.p2/pom.xml
index 9700e20..24ffd87 100644
--- a/compare/org.eclipse.papyrus.compare.p2/pom.xml
+++ b/compare/org.eclipse.papyrus.compare.p2/pom.xml
@@ -63,11 +63,6 @@
<update.site.version>${update.site.version}</update.site.version>
<target.eclipse.version>${target.eclipse.version}</target.eclipse.version>
</symbols>
-
- <associateSites>
- <associateSite>${emf-compare.p2.repo}</associateSite>
- <associateSite>${egit.p2.repo}</associateSite>
- </associateSites>
</configuration>
</execution>
</executions>
diff --git a/compare/pom.xml b/compare/pom.xml
index a15777e..40c3afc 100755
--- a/compare/pom.xml
+++ b/compare/pom.xml
@@ -15,8 +15,8 @@
<properties>
<!-- plugins versions -->
<!-- use 'mvn versions:display-plugin-updates' to check for the latest -->
- <tycho-version>1.0.0</tycho-version>
- <tychoExtrasVersion>1.0.0</tychoExtrasVersion>
+ <tycho-version>1.3.0</tycho-version>
+ <tychoExtrasVersion>1.3.0</tychoExtrasVersion>
<maven-checkstyle-version>2.12.1</maven-checkstyle-version>
<maven-findbugs-version>3.0.0</maven-findbugs-version>
<maven-pmd-version>3.1</maven-pmd-version>
@@ -32,9 +32,6 @@
<target.file>${target.folder}/compare-${target.stream}</target.file>
<!-- Platform properties -->
<env.ui.test>-Xms256m -Xmx1024m</env.ui.test>
- <!-- P2 Repo References -->
- <egit.p2.repo>http://download.eclipse.org/egit/updates</egit.p2.repo>
- <emf-compare.p2.repo>http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/integration/</emf-compare.p2.repo>
</properties>
<pluginRepositories>
<pluginRepository>
@@ -208,11 +205,6 @@
<environment>
<os>win32</os>
<ws>win32</ws>
- <arch>x86</arch>
- </environment>
- <environment>
- <os>win32</os>
- <ws>win32</ws>
<arch>x86_64</arch>
</environment>
<environment>
@@ -374,17 +366,15 @@
</activation>
<properties>
<target.stream>nightly</target.stream>
- <egit.p2.repo>http://download.eclipse.org/egit/updates</egit.p2.repo>
- <emf-compare.p2.repo>http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/integration/</emf-compare.p2.repo>
</properties>
</profile>
<profile>
- <id>oxygen</id>
+ <id>previous-release</id>
<activation>
<activeByDefault>false</activeByDefault>
</activation>
<properties>
- <target.stream>oxygen</target.stream>
+ <target.stream>previous-release</target.stream>
</properties>
</profile>
</profiles>
@@ -393,4 +383,4 @@
<module>tests</module>
<module>org.eclipse.papyrus.compare.p2</module>
</modules>
-</project> \ No newline at end of file
+</project>
diff --git a/compare/targetplatforms/compare-nightly.target b/compare/targetplatforms/compare-nightly.target
index 753d8ae..74654d4 100644
--- a/compare/targetplatforms/compare-nightly.target
+++ b/compare/targetplatforms/compare-nightly.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
-<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Compare Target Platform - Nightly" sequenceNumber="1540989876">
+<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
+<target name="Compare Target Platform - Nightly" sequenceNumber="1547731187">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.draw2d" version="0.0.0"/>
@@ -11,16 +11,13 @@
<unit id="org.eclipse.ocl.examples.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.sdk.feature.group" version="0.0.0"/>
<unit id="org.eclipse.xsd.sdk.feature.group" version="0.0.0"/>
- <repository id="eclipse-photon" location="http://download.eclipse.org/staging/photon/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
<unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
<unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
<unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
- <repository location="http://download.eclipse.org/eclipse/updates/4.9/"/>
+ <repository id="eclipse-2018-12" location="http://download.eclipse.org/staging/2018-12/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
@@ -30,7 +27,7 @@
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="0.0.0"/>
- <repository id="papyrusNightly" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
+ <repository location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
@@ -43,7 +40,7 @@
<unit id="org.eclipse.emf.compare.egit.source.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="0.0.0"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest/"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/nightly/latest"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.apache.commons.io" version="0.0.0"/>
@@ -61,7 +58,7 @@
<unit id="org.hamcrest.integration" version="0.0.0"/>
<unit id="org.hamcrest.text" version="0.0.0"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
+ <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare-nightly.tpd b/compare/targetplatforms/compare-nightly.tpd
index 7763242..99fa188 100755
--- a/compare/targetplatforms/compare-nightly.tpd
+++ b/compare/targetplatforms/compare-nightly.tpd
@@ -1,6 +1,6 @@
target "Compare Target Platform - Nightly" with source requirements
-location "http://download.eclipse.org/staging/photon/" eclipse-photon {
+location "http://download.eclipse.org/staging/2018-12/" eclipse-2018-12 {
org.eclipse.draw2d lazy
org.eclipse.gef lazy
org.eclipse.ocl.core.sdk.feature.group lazy
@@ -8,13 +8,6 @@ location "http://download.eclipse.org/staging/photon/" eclipse-photon {
org.eclipse.ocl.examples.feature.group lazy
org.eclipse.emf.sdk.feature.group lazy
org.eclipse.xsd.sdk.feature.group lazy
-}
-
-/*
- * Once Photon.1 is released this should be removed as the necessary feature versions
- * will also be available in http://download.eclipse.org/staging/photon/
- */
-location "http://download.eclipse.org/eclipse/updates/4.9/" {
org.eclipse.sdk.feature.group lazy
org.eclipse.platform.feature.group lazy
org.eclipse.rcp.feature.group lazy
@@ -32,7 +25,7 @@ location "http://download.eclipse.org/egit/updates" EGit {
org.eclipse.jgit.feature.group lazy
}
-location papyrusNightly "http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master" {
+location "http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master" {
org.eclipse.papyrus.sdk.feature.feature.group lazy
org.eclipse.papyrus.views.properties.toolsmiths lazy
}
@@ -45,7 +38,7 @@ location xwt "http://download.eclipse.org/xwt/updates" {
* If changed, this should also be changed in Papyrus Compare's root pom.xml, in the nightly profile
* Search all references to emf-compare.p2.repo
*/
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest/" {
+location "https://download.eclipse.org/modeling/emf/compare/updates/nightly/latest" emfCompare {
org.eclipse.emf.compare.source.feature.group lazy
org.eclipse.emf.compare.diagram.gmf.source.feature.group lazy
org.eclipse.emf.compare.uml2.source.feature.group lazy
@@ -54,7 +47,7 @@ location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/lo
org.eclipse.emf.compare.rcp.ui.source.feature.group lazy
}
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/" {
+location "https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/" orbit{
org.apache.commons.io lazy
org.apache.commons.io.source lazy
com.google.inject lazy
diff --git a/compare/targetplatforms/compare-oxygen.target b/compare/targetplatforms/compare-previous-release.target
index 23a965e..9b7964b 100644
--- a/compare/targetplatforms/compare-oxygen.target
+++ b/compare/targetplatforms/compare-previous-release.target
@@ -1,66 +1,66 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Oxygen" sequenceNumber="1538035456">
+<target name="Compare Target Platform - Previous Release" sequenceNumber="1547565818">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="4.7.3.v20180330-0640"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.7.3.v20180330-0919"/>
- <unit id="org.eclipse.rcp.feature.group" version="4.7.3.v20180330-0640"/>
- <unit id="org.eclipse.jdt.feature.group" version="3.13.4.v20180330-0919"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.1.1.v20170906-1259"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="3.7.2.v20171108-1834"/>
+ <unit id="org.eclipse.platform.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.rcp.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.jdt.feature.group" version="3.15.0.v20180906-0745"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.100.v20180822-1357"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.100.v20180827-1352"/>
<unit id="org.eclipse.draw2d" version="3.10.100.201606061308"/>
<unit id="org.eclipse.gef" version="3.11.0.201606061308"/>
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.7.0.v20170604-1316"/>
- <unit id="org.eclipse.emf.sdk.feature.group" version="2.13.0.v20170609-0928"/>
- <unit id="org.eclipse.xsd.sdk.feature.group" version="2.13.0.v20170609-0928"/>
- <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.11.0.201706061352"/>
- <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.11.0.201706061339"/>
- <unit id="org.eclipse.emf.workspace.feature.group" version="1.11.0.201706061339"/>
- <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.11.0.201706061354"/>
- <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.11.0.201706061437"/>
- <unit id="org.eclipse.uml2.sdk.feature.group" version="5.3.0.v20170605-1616"/>
- <repository id="eclipse-oxygen" location="http://download.eclipse.org/releases/oxygen/"/>
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.0.v20180911-0720"/>
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.15.0.v20180905-1732"/>
+ <unit id="org.eclipse.xsd.sdk.feature.group" version="2.15.0.v20180722-1116"/>
+ <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
+ <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
+ <unit id="org.eclipse.emf.workspace.feature.group" version="1.12.0.201805140824"/>
+ <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
+ <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.4.1.v20180903-1400"/>
+ <repository id="eclipse-2018-09" location="http://download.eclipse.org/releases/2018-09/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
- <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.1.0.201809111528-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.1.0.201809111528-r"/>
+ <repository id="egit" location="https://download.eclipse.org/egit/updates-5.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
<unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
<unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="1.2.3.201805161152"/>
+ <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="3.3.4.201806221350"/>
<unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
<unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/releases/3.3/R201806221350/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.apache.commons.io" version="2.2.0.v201405211200"/>
- <unit id="org.apache.commons.io.source" version="2.2.0.v201405211200"/>
- <unit id="com.google.inject" version="3.0.0.v201605172100"/>
+ <unit id="org.apache.commons.io" version="0.0.0"/>
+ <unit id="org.apache.commons.io.source" version="0.0.0"/>
+ <unit id="com.google.inject" version="0.0.0"/>
<unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
<unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
- <unit id="javaewah" version="1.1.6.v20160919-1400"/>
- <unit id="org.apache.commons.compress" version="1.6.0.v201310281400"/>
- <unit id="org.apache.commons.lang" version="2.6.0.v201404270220"/>
- <unit id="org.kohsuke.args4j" version="2.33.0.v20160323-2218"/>
+ <unit id="javaewah" version="0.0.0"/>
+ <unit id="org.apache.commons.compress" version="0.0.0"/>
+ <unit id="org.apache.commons.lang" version="0.0.0"/>
+ <unit id="org.kohsuke.args4j" version="0.0.0"/>
<unit id="org.mockito" version="1.9.5.v201605172210"/>
- <unit id="org.hamcrest" version="1.1.0.v20090501071000"/>
- <unit id="org.hamcrest.library" version="1.3.0.v201505072020"/>
- <unit id="org.hamcrest.integration" version="1.3.0.v201305210900"/>
- <unit id="org.hamcrest.text" version="1.1.0.v20090501071000"/>
+ <unit id="org.hamcrest" version="0.0.0"/>
+ <unit id="org.hamcrest.library" version="0.0.0"/>
+ <unit id="org.hamcrest.integration" version="0.0.0"/>
+ <unit id="org.hamcrest.text" version="0.0.0"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="3.4.0.201805210649"/>
- <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201805210649"/>
- <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201805210649"/>
- <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201805210649"/>
- <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/oxygen"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.1.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201809121107"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-09"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare-oxygen.tpd b/compare/targetplatforms/compare-previous-release.tpd
index 7ae1140..573d083 100755
--- a/compare/targetplatforms/compare-oxygen.tpd
+++ b/compare/targetplatforms/compare-previous-release.tpd
@@ -1,6 +1,6 @@
-target "Compare Target Platform - Oxygen" with source requirements
+target "Compare Target Platform - Previous Release" with source requirements
-location "http://download.eclipse.org/releases/oxygen/" eclipse-oxygen {
+location "http://download.eclipse.org/releases/2018-09/" eclipse-2018-09 {
org.eclipse.platform.feature.group
org.eclipse.sdk.feature.group
org.eclipse.rcp.feature.group
@@ -20,22 +20,22 @@ location "http://download.eclipse.org/releases/oxygen/" eclipse-oxygen {
org.eclipse.uml2.sdk.feature.group
}
-location "http://download.eclipse.org/egit/updates-5.0.3" egit {
+location "https://download.eclipse.org/egit/updates-5.1/" egit {
org.eclipse.egit.feature.group
org.eclipse.jgit.feature.group
}
-location "http://download.eclipse.org/modeling/emf/compare/updates/releases/" emfCompare {
+location "https://download.eclipse.org/modeling/emf/compare/updates/releases/3.3/R201806221350/" emfCompare {
org.eclipse.emf.compare.source.feature.group [3.3.3,4.0.0)
org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.3,4.0.0)
org.eclipse.emf.compare.uml2.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.egit.source.feature.group [1.2.3,2.0.0)
+ org.eclipse.emf.compare.egit.source.feature.group [3.3.4,4.0.0)
org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.3,4.0.0)
org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.3,4.0.0)
}
//manualUpdate
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository" {
+location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/" {
org.apache.commons.io
org.apache.commons.io.source
com.google.inject
@@ -54,7 +54,7 @@ location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R2017030
org.objenesis [1.0.0,2.0.0)
}
-location papyrus "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/oxygen" {
+location papyrus "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-09" {
org.eclipse.papyrus.sdk.feature.feature.group
org.eclipse.papyrus.infra.gmfdiag.feature.feature.group
org.eclipse.papyrus.infra.services.feature.feature.group
diff --git a/compare/targetplatforms/compare-release.target b/compare/targetplatforms/compare-release.target
index 59f2499..965a203 100644
--- a/compare/targetplatforms/compare-release.target
+++ b/compare/targetplatforms/compare-release.target
@@ -1,41 +1,41 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Release" sequenceNumber="1537800868">
+<target name="Compare Target Platform - Release" sequenceNumber="1547653155">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.8.0.v20180611-0826"/>
- <unit id="org.eclipse.rcp.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.jdt.feature.group" version="3.14.0.v20180611-0500"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.0.v20180512-1128"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.0.v20180518-2029"/>
+ <unit id="org.eclipse.platform.feature.group" version="4.10.0.v20181206-0815"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.10.0.v20181206-1038"/>
+ <unit id="org.eclipse.rcp.feature.group" version="4.10.0.v20181206-0815"/>
+ <unit id="org.eclipse.jdt.feature.group" version="3.16.0.v20181206-1038"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.100.v20180822-1357"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.200.v20180922-1751"/>
<unit id="org.eclipse.draw2d" version="3.10.100.201606061308"/>
<unit id="org.eclipse.gef" version="3.11.0.201606061308"/>
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180612-0940"/>
- <unit id="org.eclipse.emf.sdk.feature.group" version="2.14.0.v20180529-1157"/>
- <unit id="org.eclipse.xsd.sdk.feature.group" version="2.14.0.v20180131-0817"/>
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.1.v20181210-1559"/>
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.16.0.v20181206-1055"/>
+ <unit id="org.eclipse.xsd.sdk.feature.group" version="2.16.0.v20181127-0852"/>
<unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
<unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
<unit id="org.eclipse.emf.workspace.feature.group" version="1.12.0.201805140824"/>
<unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
- <unit id="org.eclipse.uml2.sdk.feature.group" version="5.4.0.v20180604-1153"/>
- <repository id="eclipse-photon" location="http://download.eclipse.org/releases/photon/"/>
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.5.0.v20181203-1331"/>
+ <repository id="eclipse-2018-12" location="http://download.eclipse.org/releases/2018-12/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
- <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.1.0.201809111528-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.1.0.201809111528-r"/>
+ <repository id="egit" location="http://download.eclipse.org/egit/updates-5.1"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="1.2.3.201805161152"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.5.201812111422"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/releases/latest/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.apache.commons.io" version="0.0.0"/>
@@ -53,14 +53,14 @@
<unit id="org.hamcrest.integration" version="0.0.0"/>
<unit id="org.hamcrest.text" version="0.0.0"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
+ <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201806131019"/>
- <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/photon"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.2.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201812121049"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-12"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare-release.tpd b/compare/targetplatforms/compare-release.tpd
index ac4330c..51a65ff 100755
--- a/compare/targetplatforms/compare-release.tpd
+++ b/compare/targetplatforms/compare-release.tpd
@@ -1,6 +1,6 @@
target "Compare Target Platform - Release" with source requirements
-location "http://download.eclipse.org/releases/photon/" eclipse-photon {
+location "http://download.eclipse.org/releases/2018-12/" eclipse-2018-12 {
org.eclipse.platform.feature.group
org.eclipse.sdk.feature.group
org.eclipse.rcp.feature.group
@@ -20,22 +20,22 @@ location "http://download.eclipse.org/releases/photon/" eclipse-photon {
org.eclipse.uml2.sdk.feature.group
}
-location "http://download.eclipse.org/egit/updates-5.0.3" egit {
+location "http://download.eclipse.org/egit/updates-5.1" egit {
org.eclipse.egit.feature.group
org.eclipse.jgit.feature.group
}
-location "http://download.eclipse.org/modeling/emf/compare/updates/releases/" emfCompare {
- org.eclipse.emf.compare.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.uml2.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.egit.source.feature.group [1.2.3,2.0.0)
- org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.3,4.0.0)
+location "https://download.eclipse.org/modeling/emf/compare/updates/releases/latest/" emfCompare {
+ org.eclipse.emf.compare.source.feature.group [3.3.5,4.0.0)
+ org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.5,4.0.0)
+ org.eclipse.emf.compare.uml2.source.feature.group [3.3.5,4.0.0)
+ org.eclipse.emf.compare.egit.source.feature.group [3.3.5,4.0.0)
+ org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.5,4.0.0)
+ org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.5,4.0.0)
}
//manualUpdate
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/" {
+location orbit "https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/" {
org.apache.commons.io
org.apache.commons.io.source
com.google.inject
@@ -54,7 +54,7 @@ location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R2018060
org.objenesis [1.0.0,2.0.0)
}
-location papyrus "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/photon" {
+location papyrus "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-12" {
org.eclipse.papyrus.sdk.feature.feature.group
org.eclipse.papyrus.infra.gmfdiag.feature.feature.group
org.eclipse.papyrus.infra.services.feature.feature.group
diff --git a/compare/targetplatforms/compare.tests-nightly.target b/compare/targetplatforms/compare.tests-nightly.target
index 9738bd4..6612001 100644
--- a/compare/targetplatforms/compare.tests-nightly.target
+++ b/compare/targetplatforms/compare.tests-nightly.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
-<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1540989888">
+<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
+<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1547731247">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.draw2d" version="0.0.0"/>
@@ -11,16 +11,13 @@
<unit id="org.eclipse.ocl.examples.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.sdk.feature.group" version="0.0.0"/>
<unit id="org.eclipse.xsd.sdk.feature.group" version="0.0.0"/>
- <repository id="eclipse-photon" location="http://download.eclipse.org/staging/photon/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
<unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
<unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
<unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
- <repository location="http://download.eclipse.org/eclipse/updates/4.9/"/>
+ <repository id="eclipse-2018-12" location="http://download.eclipse.org/staging/2018-12/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
@@ -30,7 +27,7 @@
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="0.0.0"/>
- <repository id="papyrusNightly" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
+ <repository location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
@@ -52,7 +49,7 @@
<unit id="org.hamcrest.integration" version="0.0.0"/>
<unit id="org.hamcrest.text" version="0.0.0"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
+ <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="0.0.0"/>
@@ -66,7 +63,7 @@
<unit id="org.eclipse.emf.compare.egit.source.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="0.0.0"/>
<unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="0.0.0"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest/"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/nightly/latest"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare.tests-nightly.tpd b/compare/targetplatforms/compare.tests-nightly.tpd
index 1cf730a..cb81151 100755
--- a/compare/targetplatforms/compare.tests-nightly.tpd
+++ b/compare/targetplatforms/compare.tests-nightly.tpd
@@ -2,8 +2,6 @@ target "Compare Target Platform - Nightly, Tests" with source requirements
include "compare-nightly.tpd"
-
-
// Required for Compare test ProfileMigrationTest and Architecture Framework support tests
// Required for Compare test ProfileMigrationTest and Architecture Framework support tests
// NOTE that this is a volatile Hudson build archive. It should be replaced by a stable
@@ -13,6 +11,6 @@ location sysml "https://hudson.eclipse.org/papyrus/job/papyrus-sysml-master/last
org.eclipse.papyrus.sysml14.feature.feature.group lazy
}
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest/" {
+location "https://download.eclipse.org/modeling/emf/compare/updates/nightly/latest" emfCompare {
org.eclipse.emf.compare.tests.source.feature.group lazy
} \ No newline at end of file
diff --git a/compare/targetplatforms/compare.tests-oxygen.tpd b/compare/targetplatforms/compare.tests-oxygen.tpd
deleted file mode 100755
index 7390861..0000000
--- a/compare/targetplatforms/compare.tests-oxygen.tpd
+++ /dev/null
@@ -1,18 +0,0 @@
-target "Compare Target Platform - Oxygen, Tests" with source requirements
-
-include "compare-oxygen.tpd"
-
-
-//Transitive dependency for Papyrus Nightly (Will be released in Oxygen.2 but is not yet present in Oxygen.1)
-location xwt "http://download.eclipse.org/xwt/updates" {
- org.eclipse.xwt.feature.feature.group [1.3.1,2.0.0)
-}
-
-
-location sysml "http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14" {
- org.eclipse.papyrus.sysml14.feature.feature.group [1.2.0,1.3.0)
-}
-
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/releases/" {
- org.eclipse.emf.compare.tests.source.feature.group [3.5.1,4.0.0)
-} \ No newline at end of file
diff --git a/compare/targetplatforms/compare.tests-oxygen.target b/compare/targetplatforms/compare.tests-previous-release.target
index 57b70b9..d6b8a16 100644
--- a/compare/targetplatforms/compare.tests-oxygen.target
+++ b/compare/targetplatforms/compare.tests-previous-release.target
@@ -1,32 +1,41 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Oxygen, Tests" sequenceNumber="1538469395">
+<target name="Compare Target Platform - Previous Release, Tests" sequenceNumber="1547647938">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="4.7.3.v20180330-0640"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.7.3.v20180330-0919"/>
- <unit id="org.eclipse.rcp.feature.group" version="4.7.3.v20180330-0640"/>
- <unit id="org.eclipse.jdt.feature.group" version="3.13.4.v20180330-0919"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.1.1.v20170906-1259"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="3.7.2.v20171108-1834"/>
+ <unit id="org.eclipse.platform.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.rcp.feature.group" version="4.9.0.v20180906-1121"/>
+ <unit id="org.eclipse.jdt.feature.group" version="3.15.0.v20180906-0745"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.100.v20180822-1357"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.100.v20180827-1352"/>
<unit id="org.eclipse.draw2d" version="3.10.100.201606061308"/>
<unit id="org.eclipse.gef" version="3.11.0.201606061308"/>
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.7.0.v20170604-1316"/>
- <unit id="org.eclipse.emf.sdk.feature.group" version="2.13.0.v20170609-0928"/>
- <unit id="org.eclipse.xsd.sdk.feature.group" version="2.13.0.v20170609-0928"/>
- <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.11.0.201706061352"/>
- <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.11.0.201706061339"/>
- <unit id="org.eclipse.emf.workspace.feature.group" version="1.11.0.201706061339"/>
- <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.11.0.201706061354"/>
- <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.11.0.201706061437"/>
- <unit id="org.eclipse.uml2.sdk.feature.group" version="5.3.0.v20170605-1616"/>
- <repository id="eclipse-oxygen" location="http://download.eclipse.org/releases/oxygen/"/>
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.0.v20180911-0720"/>
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.15.0.v20180905-1732"/>
+ <unit id="org.eclipse.xsd.sdk.feature.group" version="2.15.0.v20180722-1116"/>
+ <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
+ <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
+ <unit id="org.eclipse.emf.workspace.feature.group" version="1.12.0.201805140824"/>
+ <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
+ <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.4.1.v20180903-1400"/>
+ <repository id="eclipse-2018-09" location="http://download.eclipse.org/releases/2018-09/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
- <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.1.0.201809111528-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.1.0.201809111528-r"/>
+ <repository id="egit" location="https://download.eclipse.org/egit/updates-5.1/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
+ <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
+ <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
+ <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="3.3.4.201806221350"/>
+ <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
+ <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/releases/3.3/R201806221350/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.apache.commons.io" version="2.2.0.v201405211200"/>
@@ -35,41 +44,31 @@
<unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
<unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
<unit id="javaewah" version="1.1.6.v20160919-1400"/>
- <unit id="org.apache.commons.compress" version="1.6.0.v201310281400"/>
+ <unit id="org.apache.commons.compress" version="1.15.0.v20180119-1613"/>
<unit id="org.apache.commons.lang" version="2.6.0.v201404270220"/>
<unit id="org.kohsuke.args4j" version="2.33.0.v20160323-2218"/>
<unit id="org.mockito" version="1.9.5.v201605172210"/>
<unit id="org.hamcrest" version="1.1.0.v20090501071000"/>
- <unit id="org.hamcrest.library" version="1.3.0.v201505072020"/>
+ <unit id="org.hamcrest.library" version="1.3.0.v20180524-2246"/>
<unit id="org.hamcrest.integration" version="1.3.0.v201305210900"/>
<unit id="org.hamcrest.text" version="1.1.0.v20090501071000"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="3.4.0.201805210649"/>
- <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201805210649"/>
- <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201805210649"/>
- <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201805210649"/>
- <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/oxygen"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.1.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201809120950"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201809121107"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-09"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
- <repository id="xwt" location="http://download.eclipse.org/xwt/updates"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="1.2.0"/>
- <repository id="sysml" location="http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14"/>
+ <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="1.3.1"/>
+ <repository id="sysml" location="http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.tests.source.feature.group" version="3.5.2.201806221350"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="1.2.3.201805161152"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/"/>
+ <repository location="https://download.eclipse.org/modeling/emf/compare/updates/releases/3.3/R201806221350//"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare.tests-previous-release.tpd b/compare/targetplatforms/compare.tests-previous-release.tpd
new file mode 100755
index 0000000..59417b6
--- /dev/null
+++ b/compare/targetplatforms/compare.tests-previous-release.tpd
@@ -0,0 +1,12 @@
+target "Compare Target Platform - Previous Release, Tests" with source requirements
+
+include "compare-previous-release.tpd"
+
+
+location sysml "http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14/" {
+ org.eclipse.papyrus.sysml14.feature.feature.group [1.3.1,2.0.0)
+}
+
+location "https://download.eclipse.org/modeling/emf/compare/updates/releases/3.3/R201806221350//" {
+ org.eclipse.emf.compare.tests.source.feature.group [3.5.1,4.0.0)
+}
diff --git a/compare/targetplatforms/compare.tests-release.target b/compare/targetplatforms/compare.tests-release.target
index 5172a94..d58cdcd 100644
--- a/compare/targetplatforms/compare.tests-release.target
+++ b/compare/targetplatforms/compare.tests-release.target
@@ -1,32 +1,32 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Release, Tests" sequenceNumber="1537801502">
+<target name="Compare Target Platform - Release, Tests" sequenceNumber="1547653155">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.8.0.v20180611-0826"/>
- <unit id="org.eclipse.rcp.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.jdt.feature.group" version="3.14.0.v20180611-0500"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.0.v20180512-1128"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.0.v20180518-2029"/>
+ <unit id="org.eclipse.platform.feature.group" version="4.10.0.v20181206-0815"/>
+ <unit id="org.eclipse.sdk.feature.group" version="4.10.0.v20181206-1038"/>
+ <unit id="org.eclipse.rcp.feature.group" version="4.10.0.v20181206-0815"/>
+ <unit id="org.eclipse.jdt.feature.group" version="3.16.0.v20181206-1038"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.100.v20180822-1357"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.200.v20180922-1751"/>
<unit id="org.eclipse.draw2d" version="3.10.100.201606061308"/>
<unit id="org.eclipse.gef" version="3.11.0.201606061308"/>
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180612-0940"/>
- <unit id="org.eclipse.emf.sdk.feature.group" version="2.14.0.v20180529-1157"/>
- <unit id="org.eclipse.xsd.sdk.feature.group" version="2.14.0.v20180131-0817"/>
+ <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.9.1.v20181210-1559"/>
+ <unit id="org.eclipse.emf.sdk.feature.group" version="2.16.0.v20181206-1055"/>
+ <unit id="org.eclipse.xsd.sdk.feature.group" version="2.16.0.v20181127-0852"/>
<unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
<unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
<unit id="org.eclipse.emf.workspace.feature.group" version="1.12.0.201805140824"/>
<unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
- <unit id="org.eclipse.uml2.sdk.feature.group" version="5.4.0.v20180604-1153"/>
- <repository id="eclipse-photon" location="http://download.eclipse.org/releases/photon/"/>
+ <unit id="org.eclipse.uml2.sdk.feature.group" version="5.5.0.v20181203-1331"/>
+ <repository id="eclipse-2018-12" location="http://download.eclipse.org/releases/2018-12/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
- <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.1.0.201809111528-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.1.0.201809111528-r"/>
+ <repository id="egit" location="http://download.eclipse.org/egit/updates-5.1"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.apache.commons.io" version="0.0.0"/>
@@ -44,28 +44,28 @@
<unit id="org.hamcrest.integration" version="0.0.0"/>
<unit id="org.hamcrest.text" version="0.0.0"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
+ <repository id="orbit" location="https://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201806130934"/>
- <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201806131019"/>
- <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/photon"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.2.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201812120922"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201812121049"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2018-12"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="1.3.0"/>
+ <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="1.3.1"/>
<repository id="sysml" location="http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.tests.source.feature.group" version="3.5.2.201806221350"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="1.2.3.201805161152"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/"/>
+ <unit id="org.eclipse.emf.compare.tests.source.feature.group" version="3.5.2.201812111422"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.5.201812111422"/>
+ <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.5.201812111422"/>
+ <repository id="emfCompare" location="https://download.eclipse.org/modeling/emf/compare/updates/releases/latest/"/>
</location>
</locations>
</target>
diff --git a/compare/targetplatforms/compare.tests-release.tpd b/compare/targetplatforms/compare.tests-release.tpd
index 054af6e..8021f7c 100755
--- a/compare/targetplatforms/compare.tests-release.tpd
+++ b/compare/targetplatforms/compare.tests-release.tpd
@@ -7,6 +7,6 @@ location sysml "http://download.eclipse.org/modeling/mdt/papyrus/components/sysm
org.eclipse.papyrus.sysml14.feature.feature.group [1.3.0,2.0.0)
}
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/releases/" {
+location "https://download.eclipse.org/modeling/emf/compare/updates/releases/latest/" emfCompare {
org.eclipse.emf.compare.tests.source.feature.group [3.5.1,4.0.0)
}

Back to the top