Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Langer2018-09-26 05:31:01 -0400
committerGerrit Code Review @ Eclipse.org2018-09-26 05:31:01 -0400
commit5863f8191580f8937e27bc288181ec0ca07ea874 (patch)
treef078fdb93e7ee4fee11cdb7fa80d4ab5c6766f12
parent41e98668ef2ec7b5d22fc77235a5eec6f9369ed5 (diff)
parent7d381a9ffc7abb51828f757f6d113523b1d9818a (diff)
downloadorg.eclipse.papyrus-collaborativemodeling-5863f8191580f8937e27bc288181ec0ca07ea874.tar.gz
org.eclipse.papyrus-collaborativemodeling-5863f8191580f8937e27bc288181ec0ca07ea874.tar.xz
org.eclipse.papyrus-collaborativemodeling-5863f8191580f8937e27bc288181ec0ca07ea874.zip
Merge "Update targets to fix build of Papyrus Compare Nightly & Integration"
-rw-r--r--plugins/compare/targetplatforms/compare-nightly.target17
-rwxr-xr-xplugins/compare/targetplatforms/compare-nightly.tpd19
-rw-r--r--plugins/compare/targetplatforms/compare-release-base.target59
-rwxr-xr-xplugins/compare/targetplatforms/compare-release-base.tpd59
-rw-r--r--plugins/compare/targetplatforms/compare-release.target8
-rwxr-xr-xplugins/compare/targetplatforms/compare-release.tpd54
-rw-r--r--plugins/compare/targetplatforms/compare.tests-nightly.target17
-rw-r--r--plugins/compare/targetplatforms/compare.tests-release.target19
-rwxr-xr-xplugins/compare/targetplatforms/compare.tests-release.tpd10
9 files changed, 107 insertions, 155 deletions
diff --git a/plugins/compare/targetplatforms/compare-nightly.target b/plugins/compare/targetplatforms/compare-nightly.target
index e2673c9..764bd4e 100644
--- a/plugins/compare/targetplatforms/compare-nightly.target
+++ b/plugins/compare/targetplatforms/compare-nightly.target
@@ -1,15 +1,9 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Nightly" sequenceNumber="1537527352">
+<target name="Compare Target Platform - Nightly" sequenceNumber="1537951470">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
<unit id="org.eclipse.draw2d" version="0.0.0"/>
<unit id="org.eclipse.gef" version="0.0.0"/>
<unit id="org.eclipse.ocl.core.sdk.feature.group" version="0.0.0"/>
@@ -20,6 +14,15 @@
<repository id="eclipse-photon" location="http://download.eclipse.org/staging/photon/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
+ <repository location="http://download.eclipse.org/eclipse/updates/4.9-I-builds/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
<unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
<repository id="EGit" location="http://download.eclipse.org/egit/updates"/>
diff --git a/plugins/compare/targetplatforms/compare-nightly.tpd b/plugins/compare/targetplatforms/compare-nightly.tpd
index af677bb..c435a68 100755
--- a/plugins/compare/targetplatforms/compare-nightly.tpd
+++ b/plugins/compare/targetplatforms/compare-nightly.tpd
@@ -1,12 +1,6 @@
target "Compare Target Platform - Nightly" with source requirements
location "http://download.eclipse.org/staging/photon/" eclipse-photon {
- org.eclipse.platform.feature.group lazy
- org.eclipse.sdk.feature.group lazy
- org.eclipse.rcp.feature.group lazy
- org.eclipse.jdt.feature.group lazy
- org.eclipse.equinox.p2.discovery.feature.feature.group lazy
- org.eclipse.equinox.executable.feature.group lazy
org.eclipse.draw2d lazy
org.eclipse.gef lazy
org.eclipse.ocl.core.sdk.feature.group lazy
@@ -17,6 +11,19 @@ location "http://download.eclipse.org/staging/photon/" eclipse-photon {
}
/*
+ * Once Photon.1 is released this should be removed as the necessary feature versions
+ * will also be available in http://download.eclipse.org/staging/photon/
+ */
+location "http://download.eclipse.org/eclipse/updates/4.9-I-builds/" {
+ org.eclipse.sdk.feature.group lazy
+ org.eclipse.platform.feature.group lazy
+ org.eclipse.rcp.feature.group lazy
+ org.eclipse.jdt.feature.group lazy
+ org.eclipse.equinox.p2.discovery.feature.feature.group lazy
+ org.eclipse.equinox.executable.feature.group lazy
+}
+
+/*
* If changed, this should also be changed in Papyrus Compare's root pom.xml, in the nightly profile
* Search all references to egit.p2.repo
*/
diff --git a/plugins/compare/targetplatforms/compare-release-base.target b/plugins/compare/targetplatforms/compare-release-base.target
deleted file mode 100644
index 48b0cd6..0000000
--- a/plugins/compare/targetplatforms/compare-release-base.target
+++ /dev/null
@@ -1,59 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<?pde?>
-<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Base for Release" sequenceNumber="1537534626">
- <locations>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.sdk.feature.group" version="4.8.0.v20180611-0826"/>
- <unit id="org.eclipse.rcp.feature.group" version="4.8.0.v20180611-0656"/>
- <unit id="org.eclipse.jdt.feature.group" version="3.14.0.v20180611-0500"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="1.2.0.v20180512-1128"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="3.8.0.v20180518-2029"/>
- <unit id="org.eclipse.draw2d" version="3.10.100.201606061308"/>
- <unit id="org.eclipse.gef" version="3.11.0.201606061308"/>
- <unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180612-0940"/>
- <unit id="org.eclipse.emf.sdk.feature.group" version="2.14.0.v20180529-1157"/>
- <unit id="org.eclipse.xsd.sdk.feature.group" version="2.14.0.v20180131-0817"/>
- <unit id="org.eclipse.emf.validation.sdk.feature.group" version="1.12.0.201805030717"/>
- <unit id="org.eclipse.emf.transaction.sdk.feature.group" version="1.12.0.201805140824"/>
- <unit id="org.eclipse.emf.workspace.feature.group" version="1.12.0.201805140824"/>
- <unit id="org.eclipse.gmf.runtime.notation.sdk.feature.group" version="1.12.0.201805221301"/>
- <unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201806010809"/>
- <unit id="org.eclipse.uml2.sdk.feature.group" version="5.4.0.v20180604-1153"/>
- <repository id="eclipse-photon" location="http://download.eclipse.org/releases/photon/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.diagram.gmf.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.uml2.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.egit.source.feature.group" version="1.2.3.201805161152"/>
- <unit id="org.eclipse.emf.compare.ide.ui.source.feature.group" version="3.3.4.201806221350"/>
- <unit id="org.eclipse.emf.compare.rcp.ui.source.feature.group" version="3.3.4.201806221350"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.apache.commons.io" version="0.0.0"/>
- <unit id="org.apache.commons.io.source" version="0.0.0"/>
- <unit id="com.google.inject" version="0.0.0"/>
- <unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
- <unit id="com.google.guava.source" version="21.0.0.v20170206-1425"/>
- <unit id="javaewah" version="0.0.0"/>
- <unit id="org.apache.commons.compress" version="0.0.0"/>
- <unit id="org.apache.commons.lang" version="0.0.0"/>
- <unit id="org.kohsuke.args4j" version="0.0.0"/>
- <unit id="org.mockito" version="1.9.5.v201605172210"/>
- <unit id="org.hamcrest" version="0.0.0"/>
- <unit id="org.hamcrest.library" version="0.0.0"/>
- <unit id="org.hamcrest.integration" version="0.0.0"/>
- <unit id="org.hamcrest.text" version="0.0.0"/>
- <unit id="org.objenesis" version="1.0.0.v201505121915"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
- </location>
- </locations>
-</target>
diff --git a/plugins/compare/targetplatforms/compare-release-base.tpd b/plugins/compare/targetplatforms/compare-release-base.tpd
deleted file mode 100755
index 9a6c31d..0000000
--- a/plugins/compare/targetplatforms/compare-release-base.tpd
+++ /dev/null
@@ -1,59 +0,0 @@
-//This target platform is not used as-is, but we need it to get a mix of Nightlies and Release artifacts for Papyrus
-//Papyrus tests need the Nightlies, whereas we want to build against the Release. We can't mix both in a single TP.
-//So we need a generic base TP that excludes Papyrus, then Main and Tests will add the version of Papyrus they need
-
-target "Compare Target Platform - Base for Release" with source requirements
-
-location "http://download.eclipse.org/releases/photon/" eclipse-photon {
- org.eclipse.platform.feature.group
- org.eclipse.sdk.feature.group
- org.eclipse.rcp.feature.group
- org.eclipse.jdt.feature.group
- org.eclipse.equinox.p2.discovery.feature.feature.group
- org.eclipse.equinox.executable.feature.group
- org.eclipse.draw2d
- org.eclipse.gef
- org.eclipse.m2m.qvt.oml.sdk.feature.group
- org.eclipse.emf.sdk.feature.group
- org.eclipse.xsd.sdk.feature.group
- org.eclipse.emf.validation.sdk.feature.group
- org.eclipse.emf.transaction.sdk.feature.group
- org.eclipse.emf.workspace.feature.group
- org.eclipse.gmf.runtime.notation.sdk.feature.group
- org.eclipse.gmf.runtime.sdk.feature.group
- org.eclipse.uml2.sdk.feature.group
-}
-
-location "http://download.eclipse.org/egit/updates" egit {
- org.eclipse.egit.feature.group
- org.eclipse.jgit.feature.group
-}
-
-location "http://download.eclipse.org/modeling/emf/compare/updates/releases/" emfCompare {
- org.eclipse.emf.compare.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.uml2.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.egit.source.feature.group [1.2.3,2.0.0)
- org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.3,4.0.0)
-}
-
-//manualUpdate
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/" {
- org.apache.commons.io
- org.apache.commons.io.source
- com.google.inject
- com.google.guava [21.0.0,22.0.0)
- com.google.guava.source [21.0.0,22.0.0)
- /* Egit/Jgit */
- javaewah
- org.apache.commons.compress
- org.apache.commons.lang
- org.kohsuke.args4j
- org.mockito [1.9.0,2.0.0)
- org.hamcrest
- org.hamcrest.library
- org.hamcrest.integration
- org.hamcrest.text
- org.objenesis [1.0.0,2.0.0)
-}
diff --git a/plugins/compare/targetplatforms/compare-release.target b/plugins/compare/targetplatforms/compare-release.target
index a19ae42..59f2499 100644
--- a/plugins/compare/targetplatforms/compare-release.target
+++ b/plugins/compare/targetplatforms/compare-release.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Release" sequenceNumber="1537534626">
+<target name="Compare Target Platform - Release" sequenceNumber="1537800868">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.platform.feature.group" version="4.8.0.v20180611-0656"/>
@@ -24,9 +24,9 @@
<repository id="eclipse-photon" location="http://download.eclipse.org/releases/photon/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
+ <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.4.201806221350"/>
diff --git a/plugins/compare/targetplatforms/compare-release.tpd b/plugins/compare/targetplatforms/compare-release.tpd
index ae9b531..ac4330c 100755
--- a/plugins/compare/targetplatforms/compare-release.tpd
+++ b/plugins/compare/targetplatforms/compare-release.tpd
@@ -1,6 +1,58 @@
target "Compare Target Platform - Release" with source requirements
-include "compare-release-base.tpd"
+location "http://download.eclipse.org/releases/photon/" eclipse-photon {
+ org.eclipse.platform.feature.group
+ org.eclipse.sdk.feature.group
+ org.eclipse.rcp.feature.group
+ org.eclipse.jdt.feature.group
+ org.eclipse.equinox.p2.discovery.feature.feature.group
+ org.eclipse.equinox.executable.feature.group
+ org.eclipse.draw2d
+ org.eclipse.gef
+ org.eclipse.m2m.qvt.oml.sdk.feature.group
+ org.eclipse.emf.sdk.feature.group
+ org.eclipse.xsd.sdk.feature.group
+ org.eclipse.emf.validation.sdk.feature.group
+ org.eclipse.emf.transaction.sdk.feature.group
+ org.eclipse.emf.workspace.feature.group
+ org.eclipse.gmf.runtime.notation.sdk.feature.group
+ org.eclipse.gmf.runtime.sdk.feature.group
+ org.eclipse.uml2.sdk.feature.group
+}
+
+location "http://download.eclipse.org/egit/updates-5.0.3" egit {
+ org.eclipse.egit.feature.group
+ org.eclipse.jgit.feature.group
+}
+
+location "http://download.eclipse.org/modeling/emf/compare/updates/releases/" emfCompare {
+ org.eclipse.emf.compare.source.feature.group [3.3.3,4.0.0)
+ org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.3,4.0.0)
+ org.eclipse.emf.compare.uml2.source.feature.group [3.3.3,4.0.0)
+ org.eclipse.emf.compare.egit.source.feature.group [1.2.3,2.0.0)
+ org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.3,4.0.0)
+ org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.3,4.0.0)
+}
+
+//manualUpdate
+location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/" {
+ org.apache.commons.io
+ org.apache.commons.io.source
+ com.google.inject
+ com.google.guava [21.0.0,22.0.0)
+ com.google.guava.source [21.0.0,22.0.0)
+ /* Egit/Jgit */
+ javaewah
+ org.apache.commons.compress
+ org.apache.commons.lang
+ org.kohsuke.args4j
+ org.mockito [1.9.0,2.0.0)
+ org.hamcrest
+ org.hamcrest.library
+ org.hamcrest.integration
+ org.hamcrest.text
+ org.objenesis [1.0.0,2.0.0)
+}
location papyrus "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/photon" {
org.eclipse.papyrus.sdk.feature.feature.group
diff --git a/plugins/compare/targetplatforms/compare.tests-nightly.target b/plugins/compare/targetplatforms/compare.tests-nightly.target
index 442d586..57eb926 100644
--- a/plugins/compare/targetplatforms/compare.tests-nightly.target
+++ b/plugins/compare/targetplatforms/compare.tests-nightly.target
@@ -1,15 +1,9 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1537533988">
+<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1537951715">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
<unit id="org.eclipse.draw2d" version="0.0.0"/>
<unit id="org.eclipse.gef" version="0.0.0"/>
<unit id="org.eclipse.ocl.core.sdk.feature.group" version="0.0.0"/>
@@ -20,6 +14,15 @@
<repository id="eclipse-photon" location="http://download.eclipse.org/staging/photon/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.sdk.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.platform.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.rcp.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
+ <repository location="http://download.eclipse.org/eclipse/updates/4.9-I-builds/"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
<unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
<repository id="EGit" location="http://download.eclipse.org/egit/updates"/>
diff --git a/plugins/compare/targetplatforms/compare.tests-release.target b/plugins/compare/targetplatforms/compare.tests-release.target
index e8fdd37..5172a94 100644
--- a/plugins/compare/targetplatforms/compare.tests-release.target
+++ b/plugins/compare/targetplatforms/compare.tests-release.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Release, Tests" sequenceNumber="1537534626">
+<target name="Compare Target Platform - Release, Tests" sequenceNumber="1537801502">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.platform.feature.group" version="4.8.0.v20180611-0656"/>
@@ -24,9 +24,9 @@
<repository id="eclipse-photon" location="http://download.eclipse.org/releases/photon/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
- <repository id="egit" location="http://download.eclipse.org/egit/updates"/>
+ <unit id="org.eclipse.egit.feature.group" version="5.0.3.201809091024-r"/>
+ <unit id="org.eclipse.jgit.feature.group" version="5.0.3.201809091024-r"/>
+ <repository id="egit" location="http://download.eclipse.org/egit/updates-5.0.3"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.apache.commons.io" version="0.0.0"/>
@@ -47,8 +47,15 @@
<repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20180606145124/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="0.0.0"/>
- <repository id="sysml" location="https://hudson.eclipse.org/papyrus/job/papyrus-sysml-photon/lastStableBuild/artifact/releng/org.eclipse.papyrus.sysml14.p2/target/repository/"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="4.0.0.201806130934"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201806130934"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201806130934"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201806131019"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/photon"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.papyrus.sysml14.feature.feature.group" version="1.3.0"/>
+ <repository id="sysml" location="http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.tests.source.feature.group" version="3.5.2.201806221350"/>
diff --git a/plugins/compare/targetplatforms/compare.tests-release.tpd b/plugins/compare/targetplatforms/compare.tests-release.tpd
index 733541c..054af6e 100755
--- a/plugins/compare/targetplatforms/compare.tests-release.tpd
+++ b/plugins/compare/targetplatforms/compare.tests-release.tpd
@@ -1,12 +1,10 @@
target "Compare Target Platform - Release, Tests" with source requirements
-include "compare-release-base.tpd"
+include "compare-release.tpd"
-// Required for Compare test ProfileMigrationTest and Architecture Framework support tests
-// NOTE that this is a volatile Hudson build archive. It should be replaced by a release
-// build ASAP! This is only even remote feasible because it is a tests-only dependency.
-location sysml "https://hudson.eclipse.org/papyrus/job/papyrus-sysml-photon/lastStableBuild/artifact/releng/org.eclipse.papyrus.sysml14.p2/target/repository/" {
- org.eclipse.papyrus.sysml14.feature.feature.group lazy
+
+location sysml "http://download.eclipse.org/modeling/mdt/papyrus/components/sysml14/" {
+ org.eclipse.papyrus.sysml14.feature.feature.group [1.3.0,2.0.0)
}
location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/releases/" {

Back to the top