Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2018-08-20 03:17:02 -0400
committerGerrit Code Review @ Eclipse.org2018-08-20 03:17:02 -0400
commit286fb90eefe69a9e0e823769fdc65c1c0467926d (patch)
tree05f18dbdcecfc03ea82195eeb654ff0d1176eb5f
parentc14aeeb9d2697bdccc127b8f10b5c305d6f5e3a2 (diff)
parenta2f91843d8e64da30aec1941a56a57ab6684bbef (diff)
downloadorg.eclipse.papyrus-collaborativemodeling-286fb90eefe69a9e0e823769fdc65c1c0467926d.tar.gz
org.eclipse.papyrus-collaborativemodeling-286fb90eefe69a9e0e823769fdc65c1c0467926d.tar.xz
org.eclipse.papyrus-collaborativemodeling-286fb90eefe69a9e0e823769fdc65c1c0467926d.zip
Merge "[Releng] [Compare] Update Compare's feature dependencies in order to limit installation conflicts"
-rw-r--r--plugins/compare/bundles/org.eclipse.papyrus.compare.feature/feature.xml32
1 files changed, 9 insertions, 23 deletions
diff --git a/plugins/compare/bundles/org.eclipse.papyrus.compare.feature/feature.xml b/plugins/compare/bundles/org.eclipse.papyrus.compare.feature/feature.xml
index 303695d..d85b825 100644
--- a/plugins/compare/bundles/org.eclipse.papyrus.compare.feature/feature.xml
+++ b/plugins/compare/bundles/org.eclipse.papyrus.compare.feature/feature.xml
@@ -22,29 +22,15 @@ http://www.eclipse.org/legal/epl-v10.html
%license
</license>
- <includes
- id="org.eclipse.emf.compare"
- version="0.0.0"/>
-
- <includes
- id="org.eclipse.emf.compare.diagram.gmf"
- version="0.0.0"/>
-
- <includes
- id="org.eclipse.emf.compare.egit"
- version="0.0.0"/>
-
- <includes
- id="org.eclipse.emf.compare.ide.ui"
- version="0.0.0"/>
-
- <includes
- id="org.eclipse.emf.compare.rcp.ui"
- version="0.0.0"/>
-
- <includes
- id="org.eclipse.emf.compare.uml2"
- version="0.0.0"/>
+ <requires>
+ <import feature="org.eclipse.emf.compare.diagram.gmf" version="3.0.0" match="compatible" />
+
+ <import plugin="org.eclipse.emf.compare" version="3.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.compare.egit" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.compare.ide.ui" version="4.1.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.compare.rcp.ui" version="4.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.compare.uml2" version="2.5.0" match="compatible"/>
+ </requires>
<plugin
id="org.eclipse.papyrus.compare.uml2"

Back to the top