Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Ortmayr2018-10-02 04:08:47 -0400
committerTobias Ortmayr2018-10-02 04:40:39 -0400
commit1dab50a68d07223d93dcbd5770d7ebb47e8e6bb7 (patch)
treeea3ad9c62a32d31b917b96ac8442f5dc3e370013
parent900872109201ad7cca4f3c648c439896c0d15935 (diff)
downloadorg.eclipse.papyrus-collaborativemodeling-1dab50a68d07223d93dcbd5770d7ebb47e8e6bb7.tar.gz
org.eclipse.papyrus-collaborativemodeling-1dab50a68d07223d93dcbd5770d7ebb47e8e6bb7.tar.xz
org.eclipse.papyrus-collaborativemodeling-1dab50a68d07223d93dcbd5770d7ebb47e8e6bb7.zip
Update target to fix build of Papyrus Comapre Nightly & Oxygen
*Some nightly plugins depend on Eclipse 4.9 which is not yet in the staging Photon repository. Temporary swapped to an explicit 4.9 update site. Should be changed back after the release of Photon.1 *Removed unused repositories from the oxygen-test target Change-Id: Ieceee07733f4555ebfd5beb1d34f7cf003d1c165 Signed-off-by: Tobias Ortmayr <tortmayr@eclipsesource.com>
-rw-r--r--plugins/compare/targetplatforms/compare-nightly.target4
-rwxr-xr-xplugins/compare/targetplatforms/compare-nightly.tpd2
-rwxr-xr-xplugins/compare/targetplatforms/compare-release-current.tpd59
-rw-r--r--plugins/compare/targetplatforms/compare.tests-nightly.target4
-rw-r--r--plugins/compare/targetplatforms/compare.tests-oxygen.target15
-rwxr-xr-xplugins/compare/targetplatforms/compare.tests-oxygen.tpd15
6 files changed, 11 insertions, 88 deletions
diff --git a/plugins/compare/targetplatforms/compare-nightly.target b/plugins/compare/targetplatforms/compare-nightly.target
index 764bd4e..d6bf1bc 100644
--- a/plugins/compare/targetplatforms/compare-nightly.target
+++ b/plugins/compare/targetplatforms/compare-nightly.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Nightly" sequenceNumber="1537951470">
+<target name="Compare Target Platform - Nightly" sequenceNumber="1538467196">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.draw2d" version="0.0.0"/>
@@ -20,7 +20,7 @@
<unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
- <repository location="http://download.eclipse.org/eclipse/updates/4.9-I-builds/"/>
+ <repository location="http://download.eclipse.org/eclipse/updates/4.9/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
diff --git a/plugins/compare/targetplatforms/compare-nightly.tpd b/plugins/compare/targetplatforms/compare-nightly.tpd
index c435a68..328ae0d 100755
--- a/plugins/compare/targetplatforms/compare-nightly.tpd
+++ b/plugins/compare/targetplatforms/compare-nightly.tpd
@@ -14,7 +14,7 @@ location "http://download.eclipse.org/staging/photon/" eclipse-photon {
* Once Photon.1 is released this should be removed as the necessary feature versions
* will also be available in http://download.eclipse.org/staging/photon/
*/
-location "http://download.eclipse.org/eclipse/updates/4.9-I-builds/" {
+location "http://download.eclipse.org/eclipse/updates/4.9/" {
org.eclipse.sdk.feature.group lazy
org.eclipse.platform.feature.group lazy
org.eclipse.rcp.feature.group lazy
diff --git a/plugins/compare/targetplatforms/compare-release-current.tpd b/plugins/compare/targetplatforms/compare-release-current.tpd
deleted file mode 100755
index 3d646fa..0000000
--- a/plugins/compare/targetplatforms/compare-release-current.tpd
+++ /dev/null
@@ -1,59 +0,0 @@
-//This target platform is not used as-is, but we need it to get a mix of Nightlies and Release artifacts for Papyrus
-//Papyrus tests need the Nightlies, whereas we want to build against the Release. We can't mix both in a single TP.
-//So we need a generic base TP that excludes Papyrus, then Main and Tests will add the version of Papyrus they need
-
-target "Compare Target Platform - Base for Release" with source requirements
-
-location "http://download.eclipse.org/releases/photon/" eclipse-photon{
- org.eclipse.platform.feature.group
- org.eclipse.sdk.feature.group
- org.eclipse.rcp.feature.group
- org.eclipse.jdt.feature.group
- org.eclipse.equinox.p2.discovery.feature.feature.group
- org.eclipse.equinox.executable.feature.group
- org.eclipse.draw2d
- org.eclipse.gef
- org.eclipse.m2m.qvt.oml.sdk.feature.group
- org.eclipse.emf.sdk.feature.group
- org.eclipse.xsd.sdk.feature.group
- org.eclipse.emf.validation.sdk.feature.group
- org.eclipse.emf.transaction.sdk.feature.group
- org.eclipse.emf.workspace.feature.group
- org.eclipse.gmf.runtime.notation.sdk.feature.group
- org.eclipse.gmf.runtime.sdk.feature.group
- org.eclipse.uml2.sdk.feature.group
-}
-
-location "http://download.eclipse.org/egit/updates" egit {
- org.eclipse.egit.feature.group
- org.eclipse.jgit.feature.group
-}
-
-location "http://download.eclipse.org/modeling/emf/compare/updates/releases/" emfCompare {
- org.eclipse.emf.compare.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.diagram.gmf.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.uml2.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.egit.source.feature.group [1.2.3,2.0.0)
- org.eclipse.emf.compare.ide.ui.source.feature.group [3.3.3,4.0.0)
- org.eclipse.emf.compare.rcp.ui.source.feature.group [3.3.3,4.0.0)
-}
-
-//manualUpdate
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository" {
- org.apache.commons.io
- org.apache.commons.io.source
- com.google.inject
- com.google.guava [21.0.0,22.0.0)
- com.google.guava.source [21.0.0,22.0.0)
- /* Egit/Jgit */
- javaewah
- org.apache.commons.compress
- org.apache.commons.lang
- org.kohsuke.args4j
- org.mockito [1.9.0,2.0.0)
- org.hamcrest
- org.hamcrest.library
- org.hamcrest.integration
- org.hamcrest.text
- org.objenesis [1.0.0,2.0.0)
-}
diff --git a/plugins/compare/targetplatforms/compare.tests-nightly.target b/plugins/compare/targetplatforms/compare.tests-nightly.target
index 57eb926..20e0053 100644
--- a/plugins/compare/targetplatforms/compare.tests-nightly.target
+++ b/plugins/compare/targetplatforms/compare.tests-nightly.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1537951715">
+<target name="Compare Target Platform - Nightly, Tests" sequenceNumber="1538467236">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.draw2d" version="0.0.0"/>
@@ -20,7 +20,7 @@
<unit id="org.eclipse.jdt.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.p2.discovery.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.equinox.executable.feature.group" version="0.0.0"/>
- <repository location="http://download.eclipse.org/eclipse/updates/4.9-I-builds/"/>
+ <repository location="http://download.eclipse.org/eclipse/updates/4.9/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
diff --git a/plugins/compare/targetplatforms/compare.tests-oxygen.target b/plugins/compare/targetplatforms/compare.tests-oxygen.target
index 5d0b5db..57b70b9 100644
--- a/plugins/compare/targetplatforms/compare.tests-oxygen.target
+++ b/plugins/compare/targetplatforms/compare.tests-oxygen.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
-<target name="Compare Target Platform - Oxygen, Tests" sequenceNumber="1538034300">
+<target name="Compare Target Platform - Oxygen, Tests" sequenceNumber="1538469395">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.platform.feature.group" version="4.7.3.v20180330-0640"/>
@@ -47,14 +47,11 @@
<repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.junit.utils" version="0.0.0"/>
- <unit id="org.eclipse.papyrus.junit.framework" version="0.0.0"/>
- <repository location="https://hudson.eclipse.org/papyrus/job/Papyrus-Oxygen-Developer/lastSuccessfulBuild/artifact/repository/"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.papyrus.infra.nattable.feature.feature.group" version="0.0.0"/>
- <repository id="papyrusNightly" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/oxygen"/>
+ <unit id="org.eclipse.papyrus.sdk.feature.feature.group" version="3.4.0.201805210649"/>
+ <unit id="org.eclipse.papyrus.infra.gmfdiag.feature.feature.group" version="3.0.0.201805210649"/>
+ <unit id="org.eclipse.papyrus.infra.services.feature.feature.group" version="3.0.0.201805210649"/>
+ <unit id="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2.201805210649"/>
+ <repository id="papyrus" location="http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/oxygen"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.xwt.feature.feature.group" version="1.3.1.I20171018-2059"/>
diff --git a/plugins/compare/targetplatforms/compare.tests-oxygen.tpd b/plugins/compare/targetplatforms/compare.tests-oxygen.tpd
index 9c35634..7390861 100755
--- a/plugins/compare/targetplatforms/compare.tests-oxygen.tpd
+++ b/plugins/compare/targetplatforms/compare.tests-oxygen.tpd
@@ -2,21 +2,6 @@ target "Compare Target Platform - Oxygen, Tests" with source requirements
include "compare-oxygen.tpd"
-location "https://hudson.eclipse.org/papyrus/job/Papyrus-Oxygen-Developer/lastSuccessfulBuild/artifact/repository/" {
- org.eclipse.papyrus.junit.utils lazy
- org.eclipse.papyrus.junit.framework lazy
-}
-
-//For the tests, we need a nightly version of some Papyrus plugins, as breaking changes have been
-//introduced between Oxygen.1 (Release) and Oxygen.2 (Nightly)
-//Papyrus test framework is only available as a Nightly, and depends on these breaking changes
-location papyrusNightly "http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/oxygen" {
- //Override Papyrus units from compare-release.tpd, to make sure we pull the nightly
- org.eclipse.papyrus.sdk.feature.feature.group lazy
-
- //That's the feature we explicitly need, for the Papyrus junit.utils to work
- org.eclipse.papyrus.infra.nattable.feature.feature.group lazy
-}
//Transitive dependency for Papyrus Nightly (Will be released in Oxygen.2 but is not yet present in Oxygen.1)
location xwt "http://download.eclipse.org/xwt/updates" {

Back to the top