Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Merks2017-12-02 06:21:38 -0500
committerEd Merks2017-12-02 06:21:38 -0500
commitdf519cdcd88e6eedae85ce9d5018928a7b4f11ed (patch)
treef66513808c088f9376587f6109072e58b9fae6ab
parent63326835950c0b779f8a529079a654db5870182c (diff)
downloadorg.eclipse.oomph-df519cdcd88e6eedae85ce9d5018928a7b4f11ed.tar.gz
org.eclipse.oomph-df519cdcd88e6eedae85ce9d5018928a7b4f11ed.tar.xz
org.eclipse.oomph-df519cdcd88e6eedae85ce9d5018928a7b4f11ed.zip
[528055] Fix JDT's Unlikely type argument warnings
https://bugs.eclipse.org/bugs/show_bug.cgi?id=528055
-rw-r--r--features/org.eclipse.oomph.projectconfig-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.projectconfig-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.setup.launching-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.setup.launching-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.setup.mylyn-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.setup.mylyn-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.setup.projectset-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.setup.projectset-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.setup.workbench-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.setup.workbench-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.setup.workingsets-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.setup.workingsets-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.workingsets-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.workingsets-feature/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2.core/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.p2.core/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2.doc/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.p2.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2.tests/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.p2.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.p2.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.p2/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2/src/org/eclipse/oomph/p2/impl/RequirementImpl.java2
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.editor/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.projectconfig/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.projectconfig/src/org/eclipse/oomph/projectconfig/impl/PreferenceProfileImpl.java13
-rw-r--r--plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.core/src/org/eclipse/oomph/setup/internal/core/util/IndexManager.java4
-rw-r--r--plugins/org.eclipse.oomph.setup.doc/META-INF/MANIFEST.MF28
-rw-r--r--plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.git/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.jdt/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.launching.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.launching/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.maven/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.setup.p2.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.p2/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.oomph.setup.p2/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.pde/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.projects/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.projectset.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.projectset/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.projectset/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.targlets/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.tests/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.ui/src/org/eclipse/oomph/setup/ui/wizards/ProjectPage.java11
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.oomph.setup/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.setup/src/org/eclipse/oomph/setup/impl/VariableTaskImpl.java2
-rw-r--r--plugins/org.eclipse.oomph.targlets.core/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.targlets.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.targlets/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.workingsets.editor/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.workingsets.editor/src/org/eclipse/oomph/workingsets/presentation/WorkingSetManager.java2
93 files changed, 204 insertions, 196 deletions
diff --git a/features/org.eclipse.oomph.projectconfig-feature/feature.xml b/features/org.eclipse.oomph.projectconfig-feature/feature.xml
index 1603469cf..aae11d1ba 100644
--- a/features/org.eclipse.oomph.projectconfig-feature/feature.xml
+++ b/features/org.eclipse.oomph.projectconfig-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.projectconfig"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.projectconfig-feature/pom.xml b/features/org.eclipse.oomph.projectconfig-feature/pom.xml
index 69b237e16..990b9fcbc 100644
--- a/features/org.eclipse.oomph.projectconfig-feature/pom.xml
+++ b/features/org.eclipse.oomph.projectconfig-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.projectconfig</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.setup.launching-feature/feature.xml b/features/org.eclipse.oomph.setup.launching-feature/feature.xml
index dd18e65f3..b21aac60a 100644
--- a/features/org.eclipse.oomph.setup.launching-feature/feature.xml
+++ b/features/org.eclipse.oomph.setup.launching-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.setup.launching"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.setup.launching-feature/pom.xml b/features/org.eclipse.oomph.setup.launching-feature/pom.xml
index f0dc96523..04de943c3 100644
--- a/features/org.eclipse.oomph.setup.launching-feature/pom.xml
+++ b/features/org.eclipse.oomph.setup.launching-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.setup.launching</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.setup.mylyn-feature/feature.xml b/features/org.eclipse.oomph.setup.mylyn-feature/feature.xml
index cff6c20ce..50b4c7ada 100644
--- a/features/org.eclipse.oomph.setup.mylyn-feature/feature.xml
+++ b/features/org.eclipse.oomph.setup.mylyn-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.setup.mylyn"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.setup.mylyn-feature/pom.xml b/features/org.eclipse.oomph.setup.mylyn-feature/pom.xml
index e51d6b2ca..a4b338633 100644
--- a/features/org.eclipse.oomph.setup.mylyn-feature/pom.xml
+++ b/features/org.eclipse.oomph.setup.mylyn-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.setup.mylyn</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.setup.projectset-feature/feature.xml b/features/org.eclipse.oomph.setup.projectset-feature/feature.xml
index 9e64d36d8..19ade6e8f 100644
--- a/features/org.eclipse.oomph.setup.projectset-feature/feature.xml
+++ b/features/org.eclipse.oomph.setup.projectset-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.setup.projectset"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.setup.projectset-feature/pom.xml b/features/org.eclipse.oomph.setup.projectset-feature/pom.xml
index 92295a950..6443b60b1 100644
--- a/features/org.eclipse.oomph.setup.projectset-feature/pom.xml
+++ b/features/org.eclipse.oomph.setup.projectset-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.setup.projectset</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.setup.workbench-feature/feature.xml b/features/org.eclipse.oomph.setup.workbench-feature/feature.xml
index 5b9f6bb01..2b71fac7f 100644
--- a/features/org.eclipse.oomph.setup.workbench-feature/feature.xml
+++ b/features/org.eclipse.oomph.setup.workbench-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.setup.workbench"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.setup.workbench-feature/pom.xml b/features/org.eclipse.oomph.setup.workbench-feature/pom.xml
index 59d6be677..21d94e0d8 100644
--- a/features/org.eclipse.oomph.setup.workbench-feature/pom.xml
+++ b/features/org.eclipse.oomph.setup.workbench-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.setup.workbench</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.setup.workingsets-feature/feature.xml b/features/org.eclipse.oomph.setup.workingsets-feature/feature.xml
index 90f314aca..9257dd52c 100644
--- a/features/org.eclipse.oomph.setup.workingsets-feature/feature.xml
+++ b/features/org.eclipse.oomph.setup.workingsets-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.setup.workingsets"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.setup.workingsets-feature/pom.xml b/features/org.eclipse.oomph.setup.workingsets-feature/pom.xml
index d186e9ba2..907c73470 100644
--- a/features/org.eclipse.oomph.setup.workingsets-feature/pom.xml
+++ b/features/org.eclipse.oomph.setup.workingsets-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.setup.workingsets</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.workingsets-feature/feature.xml b/features/org.eclipse.oomph.workingsets-feature/feature.xml
index 912d1bac1..12c8d1441 100644
--- a/features/org.eclipse.oomph.workingsets-feature/feature.xml
+++ b/features/org.eclipse.oomph.workingsets-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.workingsets"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.workingsets-feature/pom.xml b/features/org.eclipse.oomph.workingsets-feature/pom.xml
index aab82cf3b..fb4facc36 100644
--- a/features/org.eclipse.oomph.workingsets-feature/pom.xml
+++ b/features/org.eclipse.oomph.workingsets-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.workingsets</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/plugins/org.eclipse.oomph.p2.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.core/META-INF/MANIFEST.MF
index 5bd656552..4f8634f7b 100644
--- a/plugins/org.eclipse.oomph.p2.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.core/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.p2.core;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.p2.internal.core.P2CorePlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.p2.core;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.p2.internal.core;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.p2.core;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.p2.internal.core;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.variables;bundle-version="[3.0.0,4.0.0)";resolution:=optional,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)",
@@ -25,7 +25,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.operations;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.touchpoint.natives;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.touchpoint.eclipse;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.oomph.p2;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.ecf;bundle-version="[3.1.0,4.0.0)",
org.eclipse.ecf.provider.filetransfer;bundle-version="[3.1.0,4.0.0)",
org.eclipse.ecf.filetransfer;bundle-version="[5.0.0,6.0.0)"
diff --git a/plugins/org.eclipse.oomph.p2.core/pom.xml b/plugins/org.eclipse.oomph.p2.core/pom.xml
index 5e1ae8c5d..122d1c6b1 100644
--- a/plugins/org.eclipse.oomph.p2.core/pom.xml
+++ b/plugins/org.eclipse.oomph.p2.core/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.p2.core</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.doc/META-INF/MANIFEST.MF
index 6fee78841..5ef2fa258 100644
--- a/plugins/org.eclipse.oomph.p2.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.doc/META-INF/MANIFEST.MF
@@ -9,10 +9,10 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .
Require-Bundle: org.eclipse.help;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
org.eclipse.oomph.util.doc;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.p2;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.p2.ui;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport
+ org.eclipse.oomph.p2;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport
Export-Package: org.eclipse.oomph.p2.doc;version="1.9.0";x-internal:=true,
org.eclipse.oomph.p2.doc.online;version="1.9.0";x-internal:=true,
org.eclipse.oomph.p2.doc.reference;version="1.9.0";x-internal:=true,
diff --git a/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
index ca8d4cb96..3d032b76f 100644
--- a/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.p2.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.p2.provider.P2EditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -12,5 +12,5 @@ Export-Package: org.eclipse.oomph.p2.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.p2.edit/pom.xml b/plugins/org.eclipse.oomph.p2.edit/pom.xml
index 412e20bff..bd4b8074c 100644
--- a/plugins/org.eclipse.oomph.p2.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.p2.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.p2.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.tests/META-INF/MANIFEST.MF
index 03017fb28..b95cec00d 100644
--- a/plugins/org.eclipse.oomph.p2.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.tests/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.p2.tests;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.p2.tests;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.p2.tests;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.equinox.p2.core;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.engine;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
@@ -18,7 +18,7 @@ Require-Bundle: org.eclipse.equinox.p2.core;bundle-version="[2.0.0,3.0.0)";visib
org.eclipse.equinox.p2.touchpoint.natives;bundle-version="[1.0.0,2.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.director;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.repository.tools;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.operations;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.transport.ecf;bundle-version="[1.0.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.tests;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
diff --git a/plugins/org.eclipse.oomph.p2.tests/pom.xml b/plugins/org.eclipse.oomph.p2.tests/pom.xml
index b25de567d..b3a599773 100644
--- a/plugins/org.eclipse.oomph.p2.tests/pom.xml
+++ b/plugins/org.eclipse.oomph.p2.tests/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.p2.tests</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
index 175cd5bfb..f435f613b 100644
--- a/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.p2.ui;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.p2.internal.ui.P2UIPlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.p2.internal.ui;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.p2.internal.ui;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.variables;bundle-version="[3.0.0,4.0.0)";resolution:=optional,
org.eclipse.equinox.p2.core;bundle-version="[2.0.0,3.0.0)",
@@ -18,8 +18,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.artifact.repository;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";resolution:=optional,
org.eclipse.ui.forms;bundle-version="[3.5.0,4.0.0)"
diff --git a/plugins/org.eclipse.oomph.p2.ui/pom.xml b/plugins/org.eclipse.oomph.p2.ui/pom.xml
index 60eca4d3e..b44df8374 100644
--- a/plugins/org.eclipse.oomph.p2.ui/pom.xml
+++ b/plugins/org.eclipse.oomph.p2.ui/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.p2.ui</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
index fa9139318..3db91cf88 100644
--- a/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.p2;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
@@ -14,6 +14,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
-Export-Package: org.eclipse.oomph.p2;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.p2.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.p2.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.p2;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.p2.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.p2.util;version="1.9.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.p2/pom.xml b/plugins/org.eclipse.oomph.p2/pom.xml
index 3020ef20f..215a707ff 100644
--- a/plugins/org.eclipse.oomph.p2/pom.xml
+++ b/plugins/org.eclipse.oomph.p2/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.p2</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2/src/org/eclipse/oomph/p2/impl/RequirementImpl.java b/plugins/org.eclipse.oomph.p2/src/org/eclipse/oomph/p2/impl/RequirementImpl.java
index 0419d6cf1..700290022 100644
--- a/plugins/org.eclipse.oomph.p2/src/org/eclipse/oomph/p2/impl/RequirementImpl.java
+++ b/plugins/org.eclipse.oomph.p2/src/org/eclipse/oomph/p2/impl/RequirementImpl.java
@@ -618,7 +618,7 @@ public class RequirementImpl extends ModelElementImpl implements Requirement
if (remove)
{
- details.remove(ANNOTATION_KEY);
+ details.removeKey(ANNOTATION_KEY);
if (annotation.getDetails().isEmpty())
{
getAnnotations().remove(annotation);
diff --git a/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
index c708726ee..17ff91314 100644
--- a/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.projectconfig.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.projectconfig.provider.ProjectConfigEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,7 +10,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.projectconfig.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.projectconfig;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.projectconfig;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.preferences.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
diff --git a/plugins/org.eclipse.oomph.projectconfig.edit/pom.xml b/plugins/org.eclipse.oomph.projectconfig.edit/pom.xml
index 409c559d9..22efec6fc 100644
--- a/plugins/org.eclipse.oomph.projectconfig.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.projectconfig.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.projectconfig.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
index 474fcab6b..5e40392ec 100644
--- a/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.projectconfig.editor;singleton:=true
-Bundle-Version: 1.7.0.qualifier
+Bundle-Version: 1.8.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.projectconfig.presentation.ProjectConfigEditorPlugin$Implementation
Bundle-Vendor: %providerName
@@ -13,7 +13,7 @@ Export-Package: org.eclipse.oomph.projectconfig.presentation;version="1.4.0";x-i
org.eclipse.oomph.projectconfig.presentation.sync;version="1.4.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.projectconfig.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.projectconfig.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
diff --git a/plugins/org.eclipse.oomph.projectconfig.editor/pom.xml b/plugins/org.eclipse.oomph.projectconfig.editor/pom.xml
index f5b68d399..ddc05d07a 100644
--- a/plugins/org.eclipse.oomph.projectconfig.editor/pom.xml
+++ b/plugins/org.eclipse.oomph.projectconfig.editor/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.projectconfig.editor</artifactId>
- <version>1.7.0-SNAPSHOT</version>
+ <version>1.8.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
index 4a35eec35..ca66696e8 100644
--- a/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.projectconfig;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.projectconfig.impl.ProjectConfigPlugin$Implementation
Bundle-Name: %pluginName
@@ -16,6 +16,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.projectconfig;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.projectconfig.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.projectconfig.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.projectconfig;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.projectconfig.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.projectconfig.util;version="1.9.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.projectconfig/pom.xml b/plugins/org.eclipse.oomph.projectconfig/pom.xml
index 084b5426e..6d78a36c9 100644
--- a/plugins/org.eclipse.oomph.projectconfig/pom.xml
+++ b/plugins/org.eclipse.oomph.projectconfig/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.projectconfig</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.projectconfig/src/org/eclipse/oomph/projectconfig/impl/PreferenceProfileImpl.java b/plugins/org.eclipse.oomph.projectconfig/src/org/eclipse/oomph/projectconfig/impl/PreferenceProfileImpl.java
index 2cd5c94cd..c6d6b5001 100644
--- a/plugins/org.eclipse.oomph.projectconfig/src/org/eclipse/oomph/projectconfig/impl/PreferenceProfileImpl.java
+++ b/plugins/org.eclipse.oomph.projectconfig/src/org/eclipse/oomph/projectconfig/impl/PreferenceProfileImpl.java
@@ -267,7 +267,8 @@ public class PreferenceProfileImpl extends ModelElementImpl implements Preferenc
return false;
}
- if (project.getName().equals(getProject().getPreferenceNode().getName()))
+ String projectName = project.getName();
+ if (projectName.equals(getProject().getPreferenceNode().getName()))
{
return true;
}
@@ -280,7 +281,15 @@ public class PreferenceProfileImpl extends ModelElementImpl implements Preferenc
}
}
- return getReferentProjects().contains(project);
+ for (Project referentProject : getReferentProjects())
+ {
+ if (projectName.equals(referentProject.getPreferenceNode().getName()))
+ {
+ return true;
+ }
+ }
+
+ return false;
}
/**
diff --git a/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
index 6e894872f..0fcd5e6c1 100644
--- a/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
@@ -32,9 +32,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.updatesite;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.security;bundle-version="[1.0.0,2.0.0)",
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.p2;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
org.eclipse.core.net;bundle-version="[1.2.0,2.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.oomph.setup.core/src/org/eclipse/oomph/setup/internal/core/util/IndexManager.java b/plugins/org.eclipse.oomph.setup.core/src/org/eclipse/oomph/setup/internal/core/util/IndexManager.java
index 55298a8e2..39c3b15a7 100644
--- a/plugins/org.eclipse.oomph.setup.core/src/org/eclipse/oomph/setup/internal/core/util/IndexManager.java
+++ b/plugins/org.eclipse.oomph.setup.core/src/org/eclipse/oomph/setup/internal/core/util/IndexManager.java
@@ -116,10 +116,10 @@ public class IndexManager
Annotation annotation = getAnnotation();
Annotation labelsAnnotation = annotation.getAnnotation("labels");
- annotation.getDetails().remove(indexLocation.toString());
+ annotation.getDetails().removeKey(indexLocation.toString());
if (labelsAnnotation != null)
{
- labelsAnnotation.getDetails().remove(indexLocation.toString());
+ labelsAnnotation.getDetails().removeKey(indexLocation.toString());
}
save(annotation);
diff --git a/plugins/org.eclipse.oomph.setup.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.doc/META-INF/MANIFEST.MF
index fdd127f24..55ef94db0 100644
--- a/plugins/org.eclipse.oomph.setup.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.doc/META-INF/MANIFEST.MF
@@ -9,37 +9,37 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .
Require-Bundle: org.eclipse.help;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
org.eclipse.oomph.util.doc;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.editor;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.git;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.git.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.installer;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.jdt;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.jdt.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.launching;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.launching.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.launching;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.launching.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.maven;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.maven.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.mylyn;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.mylyn.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.p2;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.p2.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.mylyn;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.mylyn.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.p2.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.pde;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.pde.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.projects;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.projects.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.projectset;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.projectset.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.projectset;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.projectset.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.targlets;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.targlets.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.ui;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.setup.ui.ide;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.workbench;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.workbench.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.workingsets;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.setup.workingsets.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport
+ org.eclipse.oomph.setup.workbench;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.workbench.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.workingsets;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.setup.workingsets.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport
Export-Package: org.eclipse.oomph.setup.doc;version="1.9.0";x-internal:=true,
org.eclipse.oomph.setup.doc.concepts;version="1.9.0";x-internal:=true,
org.eclipse.oomph.setup.doc.online;version="1.9.0";x-internal:=true,
diff --git a/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
index 2efe10ed2..0303bff19 100644
--- a/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.provider.SetupEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,7 +10,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.edit/pom.xml b/plugins/org.eclipse.oomph.setup.edit/pom.xml
index 0044ce156..a42ca0d6a 100644
--- a/plugins/org.eclipse.oomph.setup.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
index 461a7e678..a18175d5b 100644
--- a/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
@@ -19,17 +19,17 @@ Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.sync;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.workingsets.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.workingsets.editor;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.workingsets.editor;bundle-version="[1.9.0,2.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.p2.edit;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.p2.edit;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
index 77bb51bcc..76e834fdf 100644
--- a/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
@@ -13,5 +13,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.git;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.git/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.git/META-INF/MANIFEST.MF
index 05c620d8e..cd61a9310 100644
--- a/plugins/org.eclipse.oomph.setup.git/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.git/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Export-Package: org.eclipse.oomph.setup.git;version="1.9.0";x-internal:=true,
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.egit.core;bundle-version="[2.0.0,5.0.0)",
org.eclipse.jgit;bundle-version="[2.0.0,5.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
index 201af51aa..808e85033 100644
--- a/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
@@ -10,8 +10,8 @@ Bundle-Activator: org.eclipse.oomph.setup.internal.installer.SetupInstallerPlugi
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)",
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.equinox.p2.operations;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)",
@@ -23,8 +23,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.console;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.engine;bundle-version="[2.2.0,3.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.p2.ui;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup.p2;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.jreinfo.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.help;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
index 7b6467f1d..142f2de9f 100644
--- a/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
@@ -13,6 +13,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.jdt;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.jdt.launching;bundle-version="[3.6.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.jdt/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.jdt/META-INF/MANIFEST.MF
index 37f25b520..d739559cd 100644
--- a/plugins/org.eclipse.oomph.setup.jdt/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.jdt/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.jdt;version="1.9.0";x-internal:=true,
org.eclipse.oomph.setup.jdt.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.jdt.launching;bundle-version="[3.6.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
index 30f5c3ae6..bb46c8432 100644
--- a/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.launching.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.launching.provider.LaunchingEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,8 +10,8 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.launching.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.launching;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.launching;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.launching.edit/pom.xml b/plugins/org.eclipse.oomph.setup.launching.edit/pom.xml
index 0b976edb3..0c3aabfa2 100644
--- a/plugins/org.eclipse.oomph.setup.launching.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.launching.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.launching.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
index 93fd19d29..703c88ce5 100644
--- a/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.launching;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.launching;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.launching.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.launching.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.launching;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.launching.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.launching.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.debug.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.oomph.setup.launching.LaunchingPlugin$Implementation
diff --git a/plugins/org.eclipse.oomph.setup.launching/pom.xml b/plugins/org.eclipse.oomph.setup.launching/pom.xml
index 9b83b495e..93d10cb54 100644
--- a/plugins/org.eclipse.oomph.setup.launching/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.launching/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.launching</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
index de7e2674d..45cba108a 100644
--- a/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
@@ -15,5 +15,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.maven/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.maven/META-INF/MANIFEST.MF
index 51718e5c9..01ee17405 100644
--- a/plugins/org.eclipse.oomph.setup.maven/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.maven/META-INF/MANIFEST.MF
@@ -13,6 +13,6 @@ Export-Package: org.eclipse.oomph.setup.maven;version="1.9.0";x-internal:=true,
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.m2e.core;bundle-version="[1.3.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
index 93617c72d..d932a55f3 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.mylyn.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.mylyn.provider.MylynEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,8 +10,8 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.mylyn.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.mylyn;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.mylyn;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.mylyn.edit/pom.xml b/plugins/org.eclipse.oomph.setup.mylyn.edit/pom.xml
index eca8a51fc..2a920e964 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.mylyn.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.mylyn.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
index b31a93f5d..09edfaf32 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.mylyn;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.mylyn;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.mylyn.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.mylyn.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.mylyn;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.mylyn.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.mylyn.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.variables;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.mylyn.builds.core;bundle-version="[1.0.0,2.0.0)",
org.eclipse.mylyn.builds.ui;bundle-version="[1.0.0,2.0.0)",
org.eclipse.mylyn.commons.net;bundle-version="[3.0.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.mylyn/pom.xml b/plugins/org.eclipse.oomph.setup.mylyn/pom.xml
index 05c85f13c..d0169ba57 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.mylyn/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.mylyn</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
index 11bd66e34..006b6f9aa 100644
--- a/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.p2.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.p2.provider.SetupP2EditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,9 +10,9 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.p2.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.p2;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.p2.edit/pom.xml b/plugins/org.eclipse.oomph.setup.p2.edit/pom.xml
index 535b36034..e6f6ed228 100644
--- a/plugins/org.eclipse.oomph.setup.p2.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.p2.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.p2.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.p2/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.p2/META-INF/MANIFEST.MF
index 59ef86680..ecf8188b1 100644
--- a/plugins/org.eclipse.oomph.setup.p2/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.p2/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.p2;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.internal.p2.SetupP2Plugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.internal.p2;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.p2;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.p2.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.p2.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.internal.p2;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.p2;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.p2.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.p2.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.artifact.repository;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.console;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.core;bundle-version="[2.0.0,3.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.p2/pom.xml b/plugins/org.eclipse.oomph.setup.p2/pom.xml
index 6a97b97df..417d522c6 100644
--- a/plugins/org.eclipse.oomph.setup.p2/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.p2/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.p2</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
index be50d6565..8204681c6 100644
--- a/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
@@ -13,5 +13,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.pde;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.pde/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.pde/META-INF/MANIFEST.MF
index 8cf78b4b3..01c83bbc7 100644
--- a/plugins/org.eclipse.oomph.setup.pde/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.pde/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Export-Package: org.eclipse.oomph.setup.internal.pde;version="1.9.0";x-internal:
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.pde.api.tools;bundle-version="[1.0.0,2.0.0)",
org.eclipse.pde.core;bundle-version="[3.5.0,4.0.0)"
diff --git a/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
index 6856d98a0..3a69356ca 100644
--- a/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
@@ -15,5 +15,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.projects/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projects/META-INF/MANIFEST.MF
index b9dd104cf..41ef2b59b 100644
--- a/plugins/org.eclipse.oomph.setup.projects/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projects/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Export-Package: org.eclipse.oomph.setup.projects;version="1.9.0";x-internal:=tru
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.oomph.setup.projects.ProjectsPlugin$Implementation
diff --git a/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
index a616d7deb..2feefd1e8 100644
--- a/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.projectset.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.projectset.provider.ProjectSetEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,8 +10,8 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.projectset.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.projectset;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.projectset;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.projectset.edit/pom.xml b/plugins/org.eclipse.oomph.setup.projectset.edit/pom.xml
index 5598d961f..50c70e39e 100644
--- a/plugins/org.eclipse.oomph.setup.projectset.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.projectset.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.projectset.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.projectset/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projectset/META-INF/MANIFEST.MF
index f1be6e3fc..17d56f8cd 100644
--- a/plugins/org.eclipse.oomph.setup.projectset/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projectset/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.projectset;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.projectset;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.projectset.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.projectset.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.projectset;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.projectset.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.projectset.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.jface;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.workbench;bundle-version="[3.5.0,4.0.0)",
org.eclipse.team.ui;bundle-version="[3.5.0,4.0.0)"
diff --git a/plugins/org.eclipse.oomph.setup.projectset/pom.xml b/plugins/org.eclipse.oomph.setup.projectset/pom.xml
index 3b6649331..cc3200103 100644
--- a/plugins/org.eclipse.oomph.setup.projectset/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.projectset/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.projectset</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
index 5986fa33c..dec74b65f 100644
--- a/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)",
org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.userstorage;bundle-version="[1.1.0,2.0.0)";resolution:=optional;x-installation:=greedy,
org.apache.httpcomponents.httpclient;bundle-version="[4.0.0,5.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
index 6d8b1cb11..135e88127 100644
--- a/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
@@ -13,10 +13,10 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.targlets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.targlets/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.targlets/META-INF/MANIFEST.MF
index 2948d0995..87ba84968 100644
--- a/plugins/org.eclipse.oomph.setup.targlets/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.targlets/META-INF/MANIFEST.MF
@@ -14,9 +14,9 @@ Export-Package: org.eclipse.oomph.setup.internal.targlets;version="1.9.0";x-inte
org.eclipse.oomph.setup.targlets.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.tests/META-INF/MANIFEST.MF
index 2e0e77b43..1e7db87da 100644
--- a/plugins/org.eclipse.oomph.setup.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.tests/META-INF/MANIFEST.MF
@@ -13,16 +13,16 @@ Export-Package: org.eclipse.oomph.setup.tests;version="1.9.0";x-internal:=true,
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.equinox.p2.core;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.metadata.repository;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.repository;bundle-version="[2.0.0,3.0.0)",
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.setup.p2;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.tests;bundle-version="[1.8.0,2.0.0)",
org.eclipse.oomph.setup.jdt;bundle-version="[1.9.0,2.0.0)",
org.eclipse.jdt.launching;bundle-version="[3.6.0,4.0.0)"
diff --git a/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
index 6a3aa4a8d..68f54b81d 100644
--- a/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
@@ -18,8 +18,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)",
org.eclipse.emf.codegen.ecore;bundle-version="[2.10.0,3.0.0)",
org.eclipse.emf.codegen.ecore.ui;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.jdt.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
index 13e636eee..f91594709 100644
--- a/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
@@ -27,13 +27,13 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.p2.edit;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.p2.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.sync;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.p2.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.jreinfo.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.ui/src/org/eclipse/oomph/setup/ui/wizards/ProjectPage.java b/plugins/org.eclipse.oomph.setup.ui/src/org/eclipse/oomph/setup/ui/wizards/ProjectPage.java
index dc1d4a206..c29d9ad05 100644
--- a/plugins/org.eclipse.oomph.setup.ui/src/org/eclipse/oomph/setup/ui/wizards/ProjectPage.java
+++ b/plugins/org.eclipse.oomph.setup.ui/src/org/eclipse/oomph/setup/ui/wizards/ProjectPage.java
@@ -1236,14 +1236,13 @@ public class ProjectPage extends SetupWizardPage
Workspace workspace = getWizard().getSetupContext().getWorkspace();
if (workspace != null)
{
- List<Stream> streams = new ArrayList<Stream>(workspace.getStreams());
- streams.removeAll(existingStreams);
-
OS os = getPerformer().getOS();
-
- for (Stream stream : streams)
+ for (Stream stream : workspace.getStreams())
{
- SetupCoreUtil.sendStats(success, stream, os);
+ if (!existingStreams.contains(EcoreUtil.getURI(stream)))
+ {
+ SetupCoreUtil.sendStats(success, stream, os);
+ }
}
}
}
diff --git a/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
index 48a0f8ff3..ff15e86ea 100644
--- a/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.workbench.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.workbench.provider.WorkbenchEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,8 +10,8 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.workbench.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.workbench;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.workbench;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workbench.edit/pom.xml b/plugins/org.eclipse.oomph.setup.workbench.edit/pom.xml
index 1f01ca96c..445eb1d87 100644
--- a/plugins/org.eclipse.oomph.setup.workbench.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.workbench.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.workbench.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
index 6be32d3de..a3b0a8d0b 100644
--- a/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.workbench;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.workbench;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.workbench.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.workbench.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.workbench;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.workbench.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.workbench.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.ui.workbench;bundle-version="[3.0.0,4.0.0)",
org.eclipse.core.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.jface;bundle-version="[3.0.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.workbench/pom.xml b/plugins/org.eclipse.oomph.setup.workbench/pom.xml
index 3b3079b9a..16f9f6939 100644
--- a/plugins/org.eclipse.oomph.setup.workbench/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.workbench/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.workbench</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
index 0aa0b6bbc..8050cc146 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.workingsets.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.setup.workingsets.provider.SetupWorkingSetsEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,10 +10,10 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.workingsets.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.setup.workingsets;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.workingsets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.workingsets.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workingsets.edit/pom.xml b/plugins/org.eclipse.oomph.setup.workingsets.edit/pom.xml
index 086fc7eb3..518705664 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.workingsets.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.workingsets.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
index 80be81f75..f7579ec5f 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.setup.workingsets;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.setup.workingsets;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.workingsets.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.workingsets.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.setup.workingsets;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.workingsets.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.workingsets.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.setup;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.workingsets;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workingsets/pom.xml b/plugins/org.eclipse.oomph.setup.workingsets/pom.xml
index 05d07d282..443e9827e 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets/pom.xml
+++ b/plugins/org.eclipse.oomph.setup.workingsets/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup.workingsets</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
index d5d198d0e..5b43cc20b 100644
--- a/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.setup;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
@@ -16,9 +16,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
-Export-Package: org.eclipse.oomph.internal.setup;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.log;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.setup.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.internal.setup;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.log;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.setup.util;version="1.9.0";x-internal:=true
Bundle-Activator: org.eclipse.oomph.internal.setup.SetupPlugin$Implementation
diff --git a/plugins/org.eclipse.oomph.setup/pom.xml b/plugins/org.eclipse.oomph.setup/pom.xml
index c17dd6140..954b2e42a 100644
--- a/plugins/org.eclipse.oomph.setup/pom.xml
+++ b/plugins/org.eclipse.oomph.setup/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.setup</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.setup/src/org/eclipse/oomph/setup/impl/VariableTaskImpl.java b/plugins/org.eclipse.oomph.setup/src/org/eclipse/oomph/setup/impl/VariableTaskImpl.java
index 83321a6f7..cabf8e6ce 100644
--- a/plugins/org.eclipse.oomph.setup/src/org/eclipse/oomph/setup/impl/VariableTaskImpl.java
+++ b/plugins/org.eclipse.oomph.setup/src/org/eclipse/oomph/setup/impl/VariableTaskImpl.java
@@ -676,7 +676,7 @@ public class VariableTaskImpl extends SetupTaskImpl implements VariableTask
list.add(list.indexOf(this) + 1, stringSubstitutionTask);
}
- details.remove(ANNOTATION_KEY);
+ details.removeKey(ANNOTATION_KEY);
if (annotation.getDetails().isEmpty())
{
getAnnotations().remove(annotation);
diff --git a/plugins/org.eclipse.oomph.targlets.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.core/META-INF/MANIFEST.MF
index d0339d016..4915e83d3 100644
--- a/plugins/org.eclipse.oomph.targlets.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.core/META-INF/MANIFEST.MF
@@ -28,7 +28,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jdt.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.pde.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.equinox.frameworkadmin;bundle-version="[2.0.0,3.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
index 0a1075b02..107c49e3e 100644
--- a/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
index 503e3c1a5..bbbe2f1fe 100644
--- a/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
diff --git a/plugins/org.eclipse.oomph.targlets.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.tests/META-INF/MANIFEST.MF
index 321881053..404971be0 100644
--- a/plugins/org.eclipse.oomph.targlets.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.targlets.tests;version="1.9.0";x-internal:=true
-Require-Bundle: org.eclipse.oomph.p2.tests;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.oomph.p2.tests;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.pde.core;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
index a5195c8c1..f994e69ec 100644
--- a/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
@@ -31,7 +31,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.editor;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.p2.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.targlets/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets/META-INF/MANIFEST.MF
index 8e13944aa..1c56f4f74 100644
--- a/plugins/org.eclipse.oomph.targlets/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.publisher;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.updatesite;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.repository;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.oomph.p2.core;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
index af548c459..83bcca128 100644
--- a/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.workingsets.editor;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.workingsets.presentation.WorkingSetsEditorPlugin$Implementation
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.oomph.workingsets.editor/pom.xml b/plugins/org.eclipse.oomph.workingsets.editor/pom.xml
index 3313ff1d5..91cd1198a 100644
--- a/plugins/org.eclipse.oomph.workingsets.editor/pom.xml
+++ b/plugins/org.eclipse.oomph.workingsets.editor/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.workingsets.editor</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.workingsets.editor/src/org/eclipse/oomph/workingsets/presentation/WorkingSetManager.java b/plugins/org.eclipse.oomph.workingsets.editor/src/org/eclipse/oomph/workingsets/presentation/WorkingSetManager.java
index 3d75341ab..6a091a10f 100644
--- a/plugins/org.eclipse.oomph.workingsets.editor/src/org/eclipse/oomph/workingsets/presentation/WorkingSetManager.java
+++ b/plugins/org.eclipse.oomph.workingsets.editor/src/org/eclipse/oomph/workingsets/presentation/WorkingSetManager.java
@@ -487,7 +487,7 @@ public class WorkingSetManager
Set<IAdaptable> elements = workingSets.get(name);
if (elements != null)
{
- elements.remove(name);
+ elements.remove(project);
result = true;
}
}

Back to the top