Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Stepper2017-12-21 05:40:53 -0500
committerEike Stepper2017-12-21 05:40:53 -0500
commit64ae2f3f1e0ebe8cb3fee5b482875203149d8122 (patch)
treef62526f08e19ebd162916e1963aa51d3cbc38e1b
parent41d34f66c9dbb48d9e2a236d0681d2e6ffc58f60 (diff)
downloadorg.eclipse.oomph-64ae2f3f1e0ebe8cb3fee5b482875203149d8122.tar.gz
org.eclipse.oomph-64ae2f3f1e0ebe8cb3fee5b482875203149d8122.tar.xz
org.eclipse.oomph-64ae2f3f1e0ebe8cb3fee5b482875203149d8122.zip
[529065] Preserve TargetDefinitionGenerator.extraUnits even if they're implicit
https://bugs.eclipse.org/bugs/show_bug.cgi?id=529065
-rw-r--r--features/org.eclipse.oomph.manifests-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.manifests-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.preferences-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.preferences-feature/pom.xml2
-rw-r--r--features/org.eclipse.oomph.version-feature/feature.xml2
-rw-r--r--features/org.eclipse.oomph.version-feature/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.base.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.base.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.base/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.base/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.base/src/org/eclipse/oomph/base/util/BaseUtil.java16
-rw-r--r--plugins/org.eclipse.oomph.jreinfo.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.jreinfo.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.manifests/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.manifests/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.predicates.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.predicates.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.predicates/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.oomph.predicates/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.preferences.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.preferences.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.preferences.editor/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.preferences.editor/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.preferences/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.preferences/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.resources.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.resources/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.ui.questionnaire/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomArtifactUpdater.java4
-rw-r--r--plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomModulesUpdater.java4
-rw-r--r--plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/TargetDefinitionGenerator.java60
-rw-r--r--plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.ui/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.util.doc/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.oomph.version.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.oomph.version.ui/META-INF/MANIFEST.MF16
-rw-r--r--plugins/org.eclipse.oomph.version.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.workingsets.edit/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.workingsets.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.oomph.workingsets/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.oomph.workingsets/pom.xml2
-rw-r--r--releng/org.eclipse.oomph.releng/Build Clean.launch1
-rw-r--r--releng/org.eclipse.oomph.releng/Build Windows 32bit.launch1
-rw-r--r--releng/org.eclipse.oomph.releng/Build Windows 64bit (debug).launch1
-rw-r--r--releng/org.eclipse.oomph.releng/Build Windows 64bit.launch1
79 files changed, 201 insertions, 181 deletions
diff --git a/features/org.eclipse.oomph.manifests-feature/feature.xml b/features/org.eclipse.oomph.manifests-feature/feature.xml
index fc6185ad2..e3b9568d7 100644
--- a/features/org.eclipse.oomph.manifests-feature/feature.xml
+++ b/features/org.eclipse.oomph.manifests-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.manifests"
label="%featureName"
- version="1.7.0.qualifier"
+ version="1.8.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.manifests-feature/pom.xml b/features/org.eclipse.oomph.manifests-feature/pom.xml
index f8e27ee3c..a2298b80b 100644
--- a/features/org.eclipse.oomph.manifests-feature/pom.xml
+++ b/features/org.eclipse.oomph.manifests-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.manifests</artifactId>
- <version>1.7.0-SNAPSHOT</version>
+ <version>1.8.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.preferences-feature/feature.xml b/features/org.eclipse.oomph.preferences-feature/feature.xml
index 4b3256ef0..ac40406f7 100644
--- a/features/org.eclipse.oomph.preferences-feature/feature.xml
+++ b/features/org.eclipse.oomph.preferences-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.preferences"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.preferences-feature/pom.xml b/features/org.eclipse.oomph.preferences-feature/pom.xml
index f0d18e9d6..0956b0faa 100644
--- a/features/org.eclipse.oomph.preferences-feature/pom.xml
+++ b/features/org.eclipse.oomph.preferences-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.preferences</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/features/org.eclipse.oomph.version-feature/feature.xml b/features/org.eclipse.oomph.version-feature/feature.xml
index 74ef5c90b..7b518d8ba 100644
--- a/features/org.eclipse.oomph.version-feature/feature.xml
+++ b/features/org.eclipse.oomph.version-feature/feature.xml
@@ -12,7 +12,7 @@
<feature
id="org.eclipse.oomph.version"
label="%featureName"
- version="1.8.0.qualifier"
+ version="1.9.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.oomph.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.oomph.version-feature/pom.xml b/features/org.eclipse.oomph.version-feature/pom.xml
index 858dd1759..96e921b89 100644
--- a/features/org.eclipse.oomph.version-feature/pom.xml
+++ b/features/org.eclipse.oomph.version-feature/pom.xml
@@ -20,6 +20,6 @@
</parent>
<groupId>org.eclipse.oomph.features</groupId>
<artifactId>org.eclipse.oomph.version</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/plugins/org.eclipse.oomph.base.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.base.edit/META-INF/MANIFEST.MF
index 9afcb5ee3..c9362a94e 100644
--- a/plugins/org.eclipse.oomph.base.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.base.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.base.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.base.provider.BaseEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -12,5 +12,5 @@ Export-Package: org.eclipse.oomph.base.provider;version="1.5.0";x-internal:=true
org.eclipse.oomph.edit;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.base.edit/pom.xml b/plugins/org.eclipse.oomph.base.edit/pom.xml
index 60f01aecf..da9b2c349 100644
--- a/plugins/org.eclipse.oomph.base.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.base.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.base.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.base/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.base/META-INF/MANIFEST.MF
index 2e35d47ab..bdc4da8a7 100644
--- a/plugins/org.eclipse.oomph.base/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.base/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.base;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.internal.base.BasePlugin$Implementation
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.base;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.base.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.base.util;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.internal.base;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.base;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.base.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.base.util;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.internal.base;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
diff --git a/plugins/org.eclipse.oomph.base/pom.xml b/plugins/org.eclipse.oomph.base/pom.xml
index a4ee98992..1c590210b 100644
--- a/plugins/org.eclipse.oomph.base/pom.xml
+++ b/plugins/org.eclipse.oomph.base/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.base</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.base/src/org/eclipse/oomph/base/util/BaseUtil.java b/plugins/org.eclipse.oomph.base/src/org/eclipse/oomph/base/util/BaseUtil.java
index 430c51a6a..c0a564575 100644
--- a/plugins/org.eclipse.oomph.base/src/org/eclipse/oomph/base/util/BaseUtil.java
+++ b/plugins/org.eclipse.oomph.base/src/org/eclipse/oomph/base/util/BaseUtil.java
@@ -16,10 +16,12 @@ import org.eclipse.oomph.base.ModelElement;
import org.eclipse.oomph.internal.base.BasePlugin;
import org.eclipse.oomph.util.IORuntimeException;
import org.eclipse.oomph.util.IOUtil;
+import org.eclipse.oomph.util.ObjectUtil;
import org.eclipse.emf.common.notify.Adapter;
import org.eclipse.emf.common.notify.Notification;
import org.eclipse.emf.common.notify.Notifier;
+import org.eclipse.emf.common.util.BasicEList;
import org.eclipse.emf.common.util.EList;
import org.eclipse.emf.common.util.URI;
import org.eclipse.emf.ecore.EClass;
@@ -342,6 +344,20 @@ public final class BaseUtil
return false;
}
+ public static EList<Annotation> getAnnotations(ModelElement modelElement, String sourceURI)
+ {
+ EList<Annotation> annotations = new BasicEList<Annotation>();
+ for (Annotation annotation : modelElement.getAnnotations())
+ {
+ if (ObjectUtil.equals(annotation.getSource(), sourceURI))
+ {
+ annotations.add(annotation);
+ }
+ }
+
+ return annotations;
+ }
+
public static String getAnnotation(ModelElement modelElement, String sourceURI, String key)
{
Annotation annotation = modelElement.getAnnotation(sourceURI);
diff --git a/plugins/org.eclipse.oomph.jreinfo.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.jreinfo.ui/META-INF/MANIFEST.MF
index cad0dc3ca..b14dda9ed 100644
--- a/plugins/org.eclipse.oomph.jreinfo.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.jreinfo.ui/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.jreinfo.ui;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
@@ -9,6 +9,6 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Activator: org.eclipse.oomph.jreinfo.ui.JREInfoUIPlugin$Implementation
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.jreinfo;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
-Export-Package: org.eclipse.oomph.jreinfo.ui;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.jreinfo.ui;version="1.9.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.jreinfo.ui/pom.xml b/plugins/org.eclipse.oomph.jreinfo.ui/pom.xml
index 6557137b6..27245f07b 100644
--- a/plugins/org.eclipse.oomph.jreinfo.ui/pom.xml
+++ b/plugins/org.eclipse.oomph.jreinfo.ui/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.jreinfo.ui</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.manifests/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.manifests/META-INF/MANIFEST.MF
index 3b92c345c..4da86c9ae 100644
--- a/plugins/org.eclipse.oomph.manifests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.manifests/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.manifests;singleton:=true
-Bundle-Version: 1.7.0.qualifier
+Bundle-Version: 1.8.0.qualifier
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -15,6 +15,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jdt.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.pde.ui;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
-Export-Package: org.eclipse.oomph.manifests;version="1.7.0";x-internal:=true,
- org.eclipse.oomph.manifests.handlers;version="1.7.0";x-internal:=true
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
+Export-Package: org.eclipse.oomph.manifests;version="1.8.0";x-internal:=true,
+ org.eclipse.oomph.manifests.handlers;version="1.8.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.manifests/pom.xml b/plugins/org.eclipse.oomph.manifests/pom.xml
index fee04c87a..80d96b132 100644
--- a/plugins/org.eclipse.oomph.manifests/pom.xml
+++ b/plugins/org.eclipse.oomph.manifests/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.manifests</artifactId>
- <version>1.7.0-SNAPSHOT</version>
+ <version>1.8.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
index 3d032b76f..dd2aee8ca 100644
--- a/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.edit/META-INF/MANIFEST.MF
@@ -11,6 +11,6 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.p2.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
index f435f613b..4d9ea03ea 100644
--- a/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2.ui/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.repository;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.artifact.repository;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
index 3db91cf88..cfb902435 100644
--- a/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.p2/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.director;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.engine;bundle-version="[2.0.0,3.0.0)",
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.oomph.p2;version="1.9.0";x-internal:=true,
diff --git a/plugins/org.eclipse.oomph.predicates.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.predicates.edit/META-INF/MANIFEST.MF
index ea5b00787..9607c7aaf 100644
--- a/plugins/org.eclipse.oomph.predicates.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.predicates.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.predicates.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.predicates.provider.PredicatesEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,7 +10,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.predicates.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.predicates.edit/pom.xml b/plugins/org.eclipse.oomph.predicates.edit/pom.xml
index bee81f127..9e0dc93f5 100644
--- a/plugins/org.eclipse.oomph.predicates.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.predicates.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.predicates.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.predicates/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.predicates/META-INF/MANIFEST.MF
index f791cc2cd..2c0f6dc02 100644
--- a/plugins/org.eclipse.oomph.predicates/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.predicates/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.predicates;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.internal.predicates.PredicatesPlugin$Implementation
Bundle-Name: %pluginName
@@ -9,13 +9,13 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
org.eclipse.team.core;bundle-version="[3.6.0,4.0.0)";resolution:=optional,
org.eclipse.egit.core;bundle-version="[2.0.0,5.0.0)";resolution:=optional
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.internal.predicates;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.predicates;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.predicates.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.predicates.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.internal.predicates;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.predicates;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.predicates.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.predicates.util;version="1.9.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.predicates/pom.xml b/plugins/org.eclipse.oomph.predicates/pom.xml
index bd2700bb6..e473c14f3 100644
--- a/plugins/org.eclipse.oomph.predicates/pom.xml
+++ b/plugins/org.eclipse.oomph.predicates/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.predicates</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.preferences.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.preferences.edit/META-INF/MANIFEST.MF
index 12de6a855..2623bc517 100644
--- a/plugins/org.eclipse.oomph.preferences.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.preferences.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.preferences.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.preferences.provider.PreferencesEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,7 +10,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.preferences.provider;version="1.5.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.preferences.edit/pom.xml b/plugins/org.eclipse.oomph.preferences.edit/pom.xml
index 54e607b9d..da00dd44b 100644
--- a/plugins/org.eclipse.oomph.preferences.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.preferences.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.preferences.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.preferences.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.preferences.editor/META-INF/MANIFEST.MF
index c939a38e2..3b3050e02 100644
--- a/plugins/org.eclipse.oomph.preferences.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.preferences.editor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.preferences.editor;singleton:=true
-Bundle-Version: 1.7.0.qualifier
+Bundle-Version: 1.8.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.preferences.presentation.PreferencesEditorPlugin$Implementation
Bundle-Vendor: %providerName
@@ -13,12 +13,12 @@ Export-Package: org.eclipse.oomph.preferences.presentation;version="1.4.0";x-int
org.eclipse.oomph.preferences.presentation.handlers;version="1.4.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.core.filesystem;bundle-version="[1.3.0,2.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.preferences.editor/pom.xml b/plugins/org.eclipse.oomph.preferences.editor/pom.xml
index 4ba5328a5..b58fea759 100644
--- a/plugins/org.eclipse.oomph.preferences.editor/pom.xml
+++ b/plugins/org.eclipse.oomph.preferences.editor/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.preferences.editor</artifactId>
- <version>1.7.0-SNAPSHOT</version>
+ <version>1.8.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.preferences/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.preferences/META-INF/MANIFEST.MF
index 376338ede..f95925c8a 100644
--- a/plugins/org.eclipse.oomph.preferences/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.preferences/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.preferences;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
@@ -9,9 +9,9 @@ Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.security;bundle-version="[1.0.0,2.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.preferences;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.preferences.impl;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.preferences.util;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.preferences;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.preferences.impl;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.preferences.util;version="1.9.0";x-internal:=true
diff --git a/plugins/org.eclipse.oomph.preferences/pom.xml b/plugins/org.eclipse.oomph.preferences/pom.xml
index 25440789a..ab436538c 100644
--- a/plugins/org.eclipse.oomph.preferences/pom.xml
+++ b/plugins/org.eclipse.oomph.preferences/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.preferences</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
index 17ff91314..9c995c4a5 100644
--- a/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig.edit/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.oomph.projectconfig.provider;version="1.5.0";x-inter
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.projectconfig;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
index 5e40392ec..12b176bec 100644
--- a/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig.editor/META-INF/MANIFEST.MF
@@ -17,11 +17,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.preferences.editor;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.oomph.preferences.editor;bundle-version="[1.8.0,2.0.0)",
org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
index ca66696e8..ae38fdef0 100644
--- a/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.projectconfig/META-INF/MANIFEST.MF
@@ -9,8 +9,8 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.team.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)"
diff --git a/plugins/org.eclipse.oomph.resources.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.resources.edit/META-INF/MANIFEST.MF
index 29af1d94a..525d3c8b6 100644
--- a/plugins/org.eclipse.oomph.resources.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.resources.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.resources.provider;version="1.5.0";x-internal:
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.resources/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.resources/META-INF/MANIFEST.MF
index 99f34fcc5..959a56cd7 100644
--- a/plugins/org.eclipse.oomph.resources/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.resources/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibi
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.predicates;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.oomph.internal.resources;version="1.9.0";x-internal:=true,
diff --git a/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
index 0fcd5e6c1..cbd531a23 100644
--- a/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.core/META-INF/MANIFEST.MF
@@ -31,11 +31,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.touchpoint.natives;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.updatesite;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.security;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.core.net;bundle-version="[1.2.0,2.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
index 0303bff19..6d8b48fb3 100644
--- a/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.edit/META-INF/MANIFEST.MF
@@ -12,5 +12,5 @@ Export-Package: org.eclipse.oomph.setup.provider;version="1.5.0";x-internal:=tru
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
index a18175d5b..2a1d4e13d 100644
--- a/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.editor/META-INF/MANIFEST.MF
@@ -16,20 +16,20 @@ Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.sync;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.workingsets.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.workingsets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.workingsets.editor;bundle-version="[1.9.0,2.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.equinox.p2.metadata;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.p2.edit;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
index 76e834fdf..cc72950ef 100644
--- a/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.git.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.git.provider;version="1.5.0";x-internal:
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.git;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
index 808e85033..3b0b86c9e 100644
--- a/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.installer/META-INF/MANIFEST.MF
@@ -22,11 +22,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.equinox.p2.metadata.repository;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.console;bundle-version="[1.0.0,2.0.0)",
org.eclipse.equinox.p2.engine;bundle-version="[2.2.0,3.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.jreinfo.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.jreinfo.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.help;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.net;bundle-version="[1.0.0,2.0.0)",
org.eclipse.jsch.ui;bundle-version="[1.1.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
index 142f2de9f..d0db0421f 100644
--- a/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.jdt.edit/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Export-Package: org.eclipse.oomph.setup.jdt.provider;version="1.5.0";x-internal:
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.jdt;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.jdt.launching;bundle-version="[3.6.0,4.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
index bb46c8432..966a7dbfd 100644
--- a/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.launching.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.launching.provider;version="1.5.0";x-int
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.launching;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
index 703c88ce5..aef9ac31b 100644
--- a/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.launching/META-INF/MANIFEST.MF
@@ -14,6 +14,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.debug.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.oomph.setup.launching.LaunchingPlugin$Implementation
diff --git a/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
index 45cba108a..cb3b564f5 100644
--- a/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.maven.edit/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.oomph.setup.maven.provider;version="1.5.0";x-interna
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.maven;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
index d932a55f3..030ddb5e9 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.mylyn.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.mylyn.provider;version="1.5.0";x-interna
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.mylyn;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
index 09edfaf32..ff1311109 100644
--- a/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.mylyn/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.variables;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.mylyn.builds.core;bundle-version="[1.0.0,2.0.0)",
org.eclipse.mylyn.builds.ui;bundle-version="[1.0.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
index 006b6f9aa..7ed76f659 100644
--- a/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.p2.edit/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Export-Package: org.eclipse.oomph.setup.p2.provider;version="1.5.0";x-internal:=
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.p2;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
index 8204681c6..9c17b413c 100644
--- a/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.pde.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.pde.provider;version="1.5.0";x-internal:
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.pde;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
index 3a69356ca..2e9024fb2 100644
--- a/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projects.edit/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.oomph.setup.projects.provider;version="1.5.0";x-inte
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.projects;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
index 2feefd1e8..9cc3d98b7 100644
--- a/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.projectset.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.projectset.provider;version="1.5.0";x-in
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.projectset;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
index dec74b65f..26cdc6e07 100644
--- a/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.sync/META-INF/MANIFEST.MF
@@ -14,8 +14,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.userstorage;bundle-version="[1.1.0,2.0.0)";resolution:=optional;x-installation:=greedy,
diff --git a/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
index 135e88127..f59c1264d 100644
--- a/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.targlets.edit/META-INF/MANIFEST.MF
@@ -12,9 +12,9 @@ Export-Package: org.eclipse.oomph.setup.targlets.provider;version="1.5.0";x-inte
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
index 68f54b81d..d2a8df71f 100644
--- a/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.ui.ide/META-INF/MANIFEST.MF
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.codegen.ecore.ui;bundle-version="[2.10.0,3.0.0)",
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.jdt.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.core;bundle-version="[1.9.0,2.0.0)",
diff --git a/plugins/org.eclipse.oomph.setup.ui.questionnaire/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.ui.questionnaire/META-INF/MANIFEST.MF
index d6b782865..31643bc16 100644
--- a/plugins/org.eclipse.oomph.setup.ui.questionnaire/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.ui.questionnaire/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.setup.ui.questionnaire;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.ui;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
index f91594709..f489a2c0b 100644
--- a/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.ui/META-INF/MANIFEST.MF
@@ -30,10 +30,10 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.p2.edit;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.setup.sync;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.jreinfo.ui;bundle-version="[1.8.0,2.0.0)",
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.jreinfo.ui;bundle-version="[1.9.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
index ff15e86ea..40310bff7 100644
--- a/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workbench.edit/META-INF/MANIFEST.MF
@@ -12,6 +12,6 @@ Export-Package: org.eclipse.oomph.setup.workbench.provider;version="1.5.0";x-int
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.workbench;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
index a3b0a8d0b..0cbe13686 100644
--- a/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workbench/META-INF/MANIFEST.MF
@@ -16,5 +16,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.workbench;bundle-version="[3.0.0,4.0.0)",
org.eclipse.core.commands;bundle-version="[3.0.0,4.0.0)",
org.eclipse.jface;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
index 8050cc146..4843dba66 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workingsets.edit/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.oomph.setup.workingsets.provider;version="1.5.0";x-i
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.setup.workingsets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.workingsets.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.workingsets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
index f7579ec5f..4afd021c4 100644
--- a/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup.workingsets/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Export-Package: org.eclipse.oomph.setup.workingsets;version="1.9.0";x-internal:=
org.eclipse.oomph.setup.workingsets.util;version="1.9.0";x-internal:=true
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.setup;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.workingsets;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.workingsets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
index 5b43cc20b..60ed8a0be 100644
--- a/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.setup/META-INF/MANIFEST.MF
@@ -9,10 +9,10 @@ Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";resolution:=optional,
org.eclipse.core.variables;bundle-version="[3.0.0,4.0.0)";resolution:=optional,
- org.eclipse.oomph.preferences;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.preferences;bundle-version="[1.9.0,2.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.oomph.base;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomArtifactUpdater.java b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomArtifactUpdater.java
index d6cf91512..0aa28f2e8 100644
--- a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomArtifactUpdater.java
+++ b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomArtifactUpdater.java
@@ -11,6 +11,7 @@
package org.eclipse.oomph.targlets.internal.core.listeners;
import org.eclipse.oomph.base.Annotation;
+import org.eclipse.oomph.base.util.BaseUtil;
import org.eclipse.oomph.p2.P2Factory;
import org.eclipse.oomph.p2.Requirement;
import org.eclipse.oomph.p2.VersionSegment;
@@ -61,8 +62,7 @@ public class PomArtifactUpdater extends WorkspaceUpdateListener
ITargletContainer targletContainer = profileUpdateSucceededEvent.getSource();
for (Targlet targlet : targletContainer.getTarglets())
{
- Annotation annotation = targlet.getAnnotation(ANNOTATION);
- if (annotation != null)
+ for (Annotation annotation : BaseUtil.getAnnotations(targlet, ANNOTATION))
{
EMap<String, String> details = annotation.getDetails();
boolean skipArtifactIDs = "true".equalsIgnoreCase(details.get(ANNOTATION_SKIP_ARTIFACT_IDS));
diff --git a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomModulesUpdater.java b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomModulesUpdater.java
index 3859957b4..b44c28bbf 100644
--- a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomModulesUpdater.java
+++ b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/PomModulesUpdater.java
@@ -11,6 +11,7 @@
package org.eclipse.oomph.targlets.internal.core.listeners;
import org.eclipse.oomph.base.Annotation;
+import org.eclipse.oomph.base.util.BaseUtil;
import org.eclipse.oomph.targlets.Targlet;
import org.eclipse.oomph.targlets.core.ITargletContainer;
import org.eclipse.oomph.targlets.core.TargletContainerEvent.ProfileUpdateSucceededEvent;
@@ -59,8 +60,7 @@ public class PomModulesUpdater extends WorkspaceUpdateListener
for (Targlet targlet : targletContainer.getTarglets())
{
- Annotation annotation = targlet.getAnnotation(ANNOTATION);
- if (annotation != null)
+ for (Annotation annotation : BaseUtil.getAnnotations(targlet, ANNOTATION))
{
String location = annotation.getDetails().get(ANNOTATION_LOCATION);
if (!StringUtil.isEmpty(location))
diff --git a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/TargetDefinitionGenerator.java b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/TargetDefinitionGenerator.java
index 0dc9de9a0..2ee5ec331 100644
--- a/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/TargetDefinitionGenerator.java
+++ b/plugins/org.eclipse.oomph.targlets.core/src/org/eclipse/oomph/targlets/internal/core/listeners/TargetDefinitionGenerator.java
@@ -11,6 +11,7 @@
package org.eclipse.oomph.targlets.internal.core.listeners;
import org.eclipse.oomph.base.Annotation;
+import org.eclipse.oomph.base.util.BaseUtil;
import org.eclipse.oomph.p2.Repository;
import org.eclipse.oomph.p2.core.P2Util;
import org.eclipse.oomph.p2.core.Profile;
@@ -135,8 +136,7 @@ public class TargetDefinitionGenerator extends WorkspaceUpdateListener
ITargletContainer targletContainer = profileUpdateSucceededEvent.getSource();
for (Targlet targlet : targletContainer.getTarglets())
{
- Annotation annotation = targlet.getAnnotation(ANNOTATION);
- if (annotation != null)
+ for (Annotation annotation : BaseUtil.getAnnotations(targlet, ANNOTATION))
{
Profile profile = profileUpdateSucceededEvent.getProfile();
IInstallableUnit artificialRoot = profileUpdateSucceededEvent.getArtificialRoot();
@@ -739,16 +739,6 @@ public class TargetDefinitionGenerator extends WorkspaceUpdateListener
if (first)
{
- for (Iterator<IVersionedId> it = extraUnits.iterator(); it.hasNext();)
- {
- IVersionedId extraUnit = it.next();
- for (IInstallableUnit extraIU : P2Util.asIterable(queryable.query(QueryUtil.createIUQuery(extraUnit), null)))
- {
- ius.add(extraIU);
- break;
- }
- }
-
ius.addAll(resolvedIUs);
if (!generateImplicitUnits)
@@ -760,30 +750,22 @@ public class TargetDefinitionGenerator extends WorkspaceUpdateListener
RootAnalyzer.removeImplicitUnits(ius, queryable, monitor, true);
}
+ for (Iterator<IVersionedId> it = extraUnits.iterator(); it.hasNext();)
+ {
+ IVersionedId extraUnit = it.next();
+ for (IInstallableUnit extraIU : P2Util.asIterable(queryable.query(QueryUtil.createIUQuery(extraUnit), null)))
+ {
+ ius.add(extraIU);
+ break;
+ }
+ }
+
first = false;
}
}
}
else
{
- // Use keySet() to preserve iteration order!
- for (String url : queryables.keySet())
- {
- IMetadataRepository metadataRepository = queryables.get(url);
- Set<IInstallableUnit> ius = CollectionUtil.getSet(result, metadataRepository);
-
- for (Iterator<IVersionedId> it = extraUnits.iterator(); it.hasNext();)
- {
- IVersionedId extraUnit = it.next();
- for (IInstallableUnit extraIU : P2Util.asIterable(metadataRepository.query(QueryUtil.createIUQuery(extraUnit), null)))
- {
- ius.add(extraIU);
- it.remove(); // TODO Why is it removed? Should we log left-overs?
- break;
- }
- }
- }
-
for (IInstallableUnit iu : resolvedIUs)
{
for (IMetadataRepository metadataRepository : queryables.values())
@@ -804,6 +786,24 @@ public class TargetDefinitionGenerator extends WorkspaceUpdateListener
{
RootAnalyzer.removeImplicitUnits(result, monitor, true);
}
+
+ // Use keySet() to preserve iteration order!
+ for (String url : queryables.keySet())
+ {
+ IMetadataRepository metadataRepository = queryables.get(url);
+ Set<IInstallableUnit> ius = CollectionUtil.getSet(result, metadataRepository);
+
+ for (Iterator<IVersionedId> it = extraUnits.iterator(); it.hasNext();)
+ {
+ IVersionedId extraUnit = it.next();
+ for (IInstallableUnit extraIU : P2Util.asIterable(metadataRepository.query(QueryUtil.createIUQuery(extraUnit), null)))
+ {
+ ius.add(extraIU);
+ it.remove(); // TODO Why is it removed? Should we log left-overs?
+ break;
+ }
+ }
+ }
}
return result;
diff --git a/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
index 107c49e3e..1a93000bd 100644
--- a/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.edit/META-INF/MANIFEST.MF
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.oomph.targlets.provider;version="1.5.0";x-internal:=
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
index bbbe2f1fe..40709ac46 100644
--- a/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.editor/META-INF/MANIFEST.MF
@@ -18,9 +18,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.oomph.targlets.core;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
index f994e69ec..ff1567c16 100644
--- a/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.targlets.ui/META-INF/MANIFEST.MF
@@ -32,7 +32,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.targlets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.targlets.editor;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.oomph.p2.ui;bundle-version="[1.9.0,2.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)",
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.oomph.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.ui/META-INF/MANIFEST.MF
index 9398a130e..bf6a2e5b9 100644
--- a/plugins/org.eclipse.oomph.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.ui/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.ui;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -15,10 +15,10 @@ Require-Bundle: org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
org.eclipse.core.filebuffers;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)",
org.eclipse.ui.workbench.texteditor;bundle-version="[3.5.0,4.0.0)";resolution:=optional
-Export-Package: org.eclipse.oomph.internal.ui;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.ui;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.internal.ui;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.ui;version="1.9.0";x-internal:=true
Eclipse-BuddyPolicy: dependent
diff --git a/plugins/org.eclipse.oomph.ui/pom.xml b/plugins/org.eclipse.oomph.ui/pom.xml
index 2fae3afe5..00b72ffc4 100644
--- a/plugins/org.eclipse.oomph.ui/pom.xml
+++ b/plugins/org.eclipse.oomph.ui/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.ui</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.util.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.util.doc/META-INF/MANIFEST.MF
index 1fd56653f..449015867 100644
--- a/plugins/org.eclipse.oomph.util.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.util.doc/META-INF/MANIFEST.MF
@@ -10,9 +10,9 @@ Bundle-ClassPath: .
Require-Bundle: org.eclipse.help;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.util.pde;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport,
org.eclipse.oomph.resources.edit;bundle-version="[1.9.0,2.0.0)";resolution:=optional;visibility:=reexport
Export-Package: org.eclipse.oomph.util.doc;version="1.9.0",
diff --git a/plugins/org.eclipse.oomph.version.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.version.tests/META-INF/MANIFEST.MF
index 5903ee892..d51316c8a 100644
--- a/plugins/org.eclipse.oomph.version.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.version.tests/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.equinox.ds;bundle-version="[1.0.0,2.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
org.eclipse.oomph.version;bundle-version="[1.8.0,2.0.0)",
org.eclipse.oomph.version.digest;bundle-version="[1.7.0,2.0.0)",
- org.eclipse.oomph.version.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.version.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.resources;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.tests;bundle-version="[1.8.0,2.0.0)"
Export-Package: org.eclipse.oomph.version.tests;version="1.9.0"
diff --git a/plugins/org.eclipse.oomph.version.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.version.ui/META-INF/MANIFEST.MF
index 3daac36ff..e027e0aa2 100644
--- a/plugins/org.eclipse.oomph.version.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.version.ui/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.version.ui;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -15,14 +15,14 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)",
org.eclipse.oomph.version;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
org.eclipse.pde.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.pde.api.tools;bundle-version="[1.0.0,2.0.0)";resolution:=optional
-Export-Package: org.eclipse.oomph.version.ui;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.version.ui.actions;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.version.ui.dialogs;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.version.ui.preferences;version="1.8.0";x-internal:=true,
- org.eclipse.oomph.version.ui.quickfixes;version="1.8.0";x-friends:="org.eclipse.oomph.version.tests",
- org.eclipse.oomph.version.ui.views;version="1.8.0";x-internal:=true
+Export-Package: org.eclipse.oomph.version.ui;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.version.ui.actions;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.version.ui.dialogs;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.version.ui.preferences;version="1.9.0";x-internal:=true,
+ org.eclipse.oomph.version.ui.quickfixes;version="1.9.0";x-friends:="org.eclipse.oomph.version.tests",
+ org.eclipse.oomph.version.ui.views;version="1.9.0";x-internal:=true
Eclipse-BuddyPolicy: dependent
diff --git a/plugins/org.eclipse.oomph.version.ui/pom.xml b/plugins/org.eclipse.oomph.version.ui/pom.xml
index 5c9381e84..2d2b8f614 100644
--- a/plugins/org.eclipse.oomph.version.ui/pom.xml
+++ b/plugins/org.eclipse.oomph.version.ui/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.version.ui</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.workingsets.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.workingsets.edit/META-INF/MANIFEST.MF
index c1f38d45b..e0c013048 100644
--- a/plugins/org.eclipse.oomph.workingsets.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.workingsets.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.oomph.workingsets.edit;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.oomph.workingsets.provider.WorkingSetsEditPlugin$Implementation
Bundle-Vendor: %providerName
@@ -10,8 +10,8 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.oomph.workingsets.provider;version="1.5.0"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.oomph.workingsets;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.workingsets;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.edit;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.workingsets.edit/pom.xml b/plugins/org.eclipse.oomph.workingsets.edit/pom.xml
index 647df28d7..cda636bc4 100644
--- a/plugins/org.eclipse.oomph.workingsets.edit/pom.xml
+++ b/plugins/org.eclipse.oomph.workingsets.edit/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.workingsets.edit</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
index 83bcca128..c45a4daa6 100644
--- a/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.workingsets.editor/META-INF/MANIFEST.MF
@@ -12,11 +12,11 @@ Export-Package: org.eclipse.oomph.workingsets.presentation;version="1.5.0";
x-friends:="org.eclipse.oomph.setup.editor"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.workingsets.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.workingsets.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
org.eclipse.emf.ecore.xmi;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.edit.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.base.edit;bundle-version="[1.8.0,2.0.0)";visibility:=reexport,
- org.eclipse.oomph.ui;bundle-version="[1.8.0,2.0.0)"
+ org.eclipse.oomph.predicates.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.base.edit;bundle-version="[1.9.0,2.0.0)";visibility:=reexport,
+ org.eclipse.oomph.ui;bundle-version="[1.9.0,2.0.0)"
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.oomph.workingsets/META-INF/MANIFEST.MF b/plugins/org.eclipse.oomph.workingsets/META-INF/MANIFEST.MF
index 386666c53..6bd28a596 100644
--- a/plugins/org.eclipse.oomph.workingsets/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.oomph.workingsets/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.oomph.workingsets;singleton:=true
-Bundle-Version: 1.8.0.qualifier
+Bundle-Version: 1.9.0.qualifier
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
@@ -9,9 +9,9 @@ Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.oomph.predicates;bundle-version="[1.8.0,2.0.0)";visibility:=reexport
+ org.eclipse.oomph.predicates;bundle-version="[1.9.0,2.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.oomph.workingsets;version="1.8.0",
- org.eclipse.oomph.workingsets.impl;version="1.8.0",
- org.eclipse.oomph.workingsets.util;version="1.8.0"
+Export-Package: org.eclipse.oomph.workingsets;version="1.9.0",
+ org.eclipse.oomph.workingsets.impl;version="1.9.0",
+ org.eclipse.oomph.workingsets.util;version="1.9.0"
diff --git a/plugins/org.eclipse.oomph.workingsets/pom.xml b/plugins/org.eclipse.oomph.workingsets/pom.xml
index bb45c5546..190c1008f 100644
--- a/plugins/org.eclipse.oomph.workingsets/pom.xml
+++ b/plugins/org.eclipse.oomph.workingsets/pom.xml
@@ -20,7 +20,7 @@
</parent>
<groupId>org.eclipse.oomph</groupId>
<artifactId>org.eclipse.oomph.workingsets</artifactId>
- <version>1.8.0-SNAPSHOT</version>
+ <version>1.9.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/releng/org.eclipse.oomph.releng/Build Clean.launch b/releng/org.eclipse.oomph.releng/Build Clean.launch
index b9750b1ac..1013d107f 100644
--- a/releng/org.eclipse.oomph.releng/Build Clean.launch
+++ b/releng/org.eclipse.oomph.releng/Build Clean.launch
@@ -3,6 +3,7 @@
<listAttribute key="org.eclipse.debug.ui.favoriteGroups">
<listEntry value="org.eclipse.ui.externaltools.launchGroup"/>
</listAttribute>
+<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LAUNCH_CONFIGURATION_BUILD_SCOPE" value="${none}"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${maven.root}\bin\mvn.bat"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="clean&#13;&#10;-Dtycho.mode=maven"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${git.clone.oomph}"/>
diff --git a/releng/org.eclipse.oomph.releng/Build Windows 32bit.launch b/releng/org.eclipse.oomph.releng/Build Windows 32bit.launch
index b6c28344b..3ddd4fdd2 100644
--- a/releng/org.eclipse.oomph.releng/Build Windows 32bit.launch
+++ b/releng/org.eclipse.oomph.releng/Build Windows 32bit.launch
@@ -3,6 +3,7 @@
<listAttribute key="org.eclipse.debug.ui.favoriteGroups">
<listEntry value="org.eclipse.ui.externaltools.launchGroup"/>
</listAttribute>
+<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LAUNCH_CONFIGURATION_BUILD_SCOPE" value="${none}"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${maven.root}\bin\mvn.bat"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="-Dbuild.id=Local&#13;&#10;-Dgit.commit=Unknown&#13;&#10;-DskipTests=true&#13;&#10;-DGENERATE_SOURCE=true&#13;&#10;-Denv=win32&#13;&#10;clean&#13;&#10;verify"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${git.clone.oomph}"/>
diff --git a/releng/org.eclipse.oomph.releng/Build Windows 64bit (debug).launch b/releng/org.eclipse.oomph.releng/Build Windows 64bit (debug).launch
index f0946fc64..613d4d536 100644
--- a/releng/org.eclipse.oomph.releng/Build Windows 64bit (debug).launch
+++ b/releng/org.eclipse.oomph.releng/Build Windows 64bit (debug).launch
@@ -3,6 +3,7 @@
<listAttribute key="org.eclipse.debug.ui.favoriteGroups">
<listEntry value="org.eclipse.ui.externaltools.launchGroup"/>
</listAttribute>
+<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LAUNCH_CONFIGURATION_BUILD_SCOPE" value="${none}"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${maven.root}\bin\mvnDebug.bat"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="-Dbuild.id=Local&#13;&#10;-Dgit.commit=Unknown&#13;&#10;-DskipTests=true&#13;&#10;-Denv=win64&#13;&#10;-DDtycho.debug.resolver=true&#13;&#10;-DGENERATE_SOURCE=true&#13;&#10;-DX&#13;&#10;clean&#13;&#10;verify"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${git.clone.oomph}"/>
diff --git a/releng/org.eclipse.oomph.releng/Build Windows 64bit.launch b/releng/org.eclipse.oomph.releng/Build Windows 64bit.launch
index ae1e3136b..56f5a976c 100644
--- a/releng/org.eclipse.oomph.releng/Build Windows 64bit.launch
+++ b/releng/org.eclipse.oomph.releng/Build Windows 64bit.launch
@@ -3,6 +3,7 @@
<listAttribute key="org.eclipse.debug.ui.favoriteGroups">
<listEntry value="org.eclipse.ui.externaltools.launchGroup"/>
</listAttribute>
+<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LAUNCH_CONFIGURATION_BUILD_SCOPE" value="${none}"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_LOCATION" value="${maven.root}\bin\mvn.bat"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_TOOL_ARGUMENTS" value="-Dbuild.id=Local&#13;&#10;-Dgit.commit=Unknown&#13;&#10;-DskipTests=true&#13;&#10;-Denv=win64&#13;&#10;-DDtycho.debug.resolver=true&#13;&#10;-DGENERATE_SOURCE=true&#13;&#10;-DX&#13;&#10;clean&#13;&#10;verify"/>
<stringAttribute key="org.eclipse.ui.externaltools.ATTR_WORKING_DIRECTORY" value="${git.clone.oomph}"/>

Back to the top