Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Pingel2013-07-17 14:24:31 -0400
committerSteffen Pingel2013-07-17 14:53:27 -0400
commit7e7e8c64f4e7ea0292097c6d9e0f920dc0491939 (patch)
tree830ebd0b652cb2c25b4add442fa851e51124800e
parentb918bab52122f9b2fbd9f12c3edacf10de5e12ea (diff)
downloadorg.eclipse.mylyn.incubator-7e7e8c64f4e7ea0292097c6d9e0f920dc0491939.tar.gz
org.eclipse.mylyn.incubator-7e7e8c64f4e7ea0292097c6d9e0f920dc0491939.tar.xz
org.eclipse.mylyn.incubator-7e7e8c64f4e7ea0292097c6d9e0f920dc0491939.zip
412890: update build to publish snapshot builds to I... location again
Change-Id: If2036bf8d9da8cbcdea93da833adda6fed311301 Task-Url: https://bugs.eclipse.org/bugs/show_bug.cgi?id=412890
-rw-r--r--org.eclipse.mylyn.incubator-site/pom.xml10
-rw-r--r--org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF30
2 files changed, 24 insertions, 16 deletions
diff --git a/org.eclipse.mylyn.incubator-site/pom.xml b/org.eclipse.mylyn.incubator-site/pom.xml
index 92944913..370d220f 100644
--- a/org.eclipse.mylyn.incubator-site/pom.xml
+++ b/org.eclipse.mylyn.incubator-site/pom.xml
@@ -43,6 +43,14 @@ http://www.eclipse.org/legal/epl-v10.html
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
+ <artifactId>tycho-packaging-plugin</artifactId>
+ <version>${tycho-version}</version>
+ <configuration>
+ <timestampProvider>default</timestampProvider>
+ </configuration>
+ </plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho</groupId>
<artifactId>target-platform-configuration</artifactId>
<version>${tycho-version}</version>
<configuration>
@@ -111,7 +119,7 @@ http://www.eclipse.org/legal/epl-v10.html
<property name="skipPromote" value="${promote.skip}"/>
<property name="version" value="${unqualifiedVersion}"/>
- <property name="qualifier" value="${buildQualifier}"/>
+ <property name="qualifier" value="${promote.prefix}${buildQualifier}"/>
</ant>
<echo file="${project.build.directory}/version.properties">
<![CDATA[
diff --git a/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
index c7c2e2b2..0128ef5a 100644
--- a/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
@@ -18,21 +18,21 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.jdt.debug.ui,
org.eclipse.jdt.ui,
org.eclipse.search,
- org.eclipse.mylyn.context.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.context.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.tasks.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.bugzilla.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.bugzilla.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.tasks.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.monitor.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.java.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.commons.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.commons.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.commons.workbench;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.monitor.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.resources.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.ide.ant;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.pde.ui;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.mylyn.context.core;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.context.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.tasks.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.bugzilla.core;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.bugzilla.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.monitor.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.java.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.commons.core;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.commons.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.commons.workbench;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.monitor.core;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.resources.ui;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.ide.ant;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.mylyn.pde.ui;bundle-version="[3.10.0,4.0.0)",
org.eclipse.core.expressions,
org.eclipse.pde.core
Bundle-ActivationPolicy: lazy

Back to the top