Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexei.trebounskikh2018-12-18 19:23:40 -0500
committeralexei.trebounskikh2019-01-21 20:26:49 -0500
commiteb4f9f023164953f404ae1ca6797b6778394fc6b (patch)
tree57837fec98806b83ad83357d1b4f4e961d3c5ddb
parenta10e61f7e9ecad45c3a475a2895e05ce05b413fb (diff)
downloadorg.eclipse.mylyn-e_4_8_m_3_24_x.tar.gz
org.eclipse.mylyn-e_4_8_m_3_24_x.tar.xz
org.eclipse.mylyn-e_4_8_m_3_24_x.zip
542870: Mylyn is not compatible with Java 11e_4_8_m_3_24_x
* added javax.xml.bind to target files * added javax.activation that JAXB depends on * added com.sun.xml.bind (JAXB implementation) required by JAXB * added javax.xml.stream Task-Url: https://bugs.eclipse.org/bugs/show_bug.cgi?id=542870 Change-Id: I4701eb3661ed91792acff45325b28e996a5ad65c Signed-off-by: alexei.trebounskikh <alexei.trebounskikh@tasktop.com>
-rw-r--r--org.eclipse.mylyn-target/mylyn-e4.5.target4
-rw-r--r--org.eclipse.mylyn-target/mylyn-e4.6.target4
-rw-r--r--org.eclipse.mylyn-target/mylyn-e4.7.target4
-rw-r--r--org.eclipse.mylyn-target/mylyn-e4.8.target4
-rw-r--r--org.eclipse.mylyn-target/mylyn-emaintenance.target190
-rw-r--r--org.eclipse.mylyn-target/mylyn-estaging.target4
6 files changed, 117 insertions, 93 deletions
diff --git a/org.eclipse.mylyn-target/mylyn-e4.5.target b/org.eclipse.mylyn-target/mylyn-e4.5.target
index cf55b75..0c8f7a1 100644
--- a/org.eclipse.mylyn-target/mylyn-e4.5.target
+++ b/org.eclipse.mylyn-target/mylyn-e4.5.target
@@ -39,6 +39,10 @@
<unit id="org.apache.xml.serializer" version="2.7.1.v201005080400"/>
<unit id="org.apache.xerces" version="2.9.0.v201101211617"/>
<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170516192513/repository"/>
</location>
<location includeAllPlatforms="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
diff --git a/org.eclipse.mylyn-target/mylyn-e4.6.target b/org.eclipse.mylyn-target/mylyn-e4.6.target
index 81c7d7b..79dcb50 100644
--- a/org.eclipse.mylyn-target/mylyn-e4.6.target
+++ b/org.eclipse.mylyn-target/mylyn-e4.6.target
@@ -5,6 +5,10 @@
<unit id="com.google.gwt.servlet" version="2.0.4.v20100709-0658"/>
<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
diff --git a/org.eclipse.mylyn-target/mylyn-e4.7.target b/org.eclipse.mylyn-target/mylyn-e4.7.target
index 1a5d2a9..36739f2 100644
--- a/org.eclipse.mylyn-target/mylyn-e4.7.target
+++ b/org.eclipse.mylyn-target/mylyn-e4.7.target
@@ -5,6 +5,10 @@
<unit id="com.google.gwt.servlet" version="2.0.4.v20100709-0658"/>
<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
diff --git a/org.eclipse.mylyn-target/mylyn-e4.8.target b/org.eclipse.mylyn-target/mylyn-e4.8.target
index fe60c3d..99be4fe 100644
--- a/org.eclipse.mylyn-target/mylyn-e4.8.target
+++ b/org.eclipse.mylyn-target/mylyn-e4.8.target
@@ -5,6 +5,10 @@
<unit id="com.google.gwt.servlet" version="2.0.4.v20100709-0658"/>
<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
diff --git a/org.eclipse.mylyn-target/mylyn-emaintenance.target b/org.eclipse.mylyn-target/mylyn-emaintenance.target
index 54d85e1..2ed0003 100644
--- a/org.eclipse.mylyn-target/mylyn-emaintenance.target
+++ b/org.eclipse.mylyn-target/mylyn-emaintenance.target
@@ -1,93 +1,97 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<?pde version="3.8"?><target name="mylyn-emaintenance" sequenceNumber="13">
-<locations>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="com.google.gwt.servlet" version="2.0.4.v20100709-0658"/>
-<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
-<unit id="org.apache.lucene.core" version="2.9.1.v201101211721"/>
-<unit id="javax.servlet" version="3.0.0.v201112011016"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="com.google.gerrit.prettify" version="2.1.5.v201112241444"/>
-<unit id="com.google.gerrit.reviewdb" version="2.1.5.v201112241444"/>
-<unit id="com.google.gerrit.common" version="2.1.5.v201112241444"/>
-<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
-<unit id="com.google.gwtjsonrpc" version="1.2.5.v201112241444"/>
-<unit id="com.google.gwtorm" version="1.1.4.v201112241444"/>
-<unit id="javax.el" version="2.2.0.v201303151357"/>
-<unit id="org.apache.commons.codec" version="1.9.0.v20170208-1614"/>
-<unit id="org.apache.commons.httpclient" version="3.1.0.v201012070820"/>
-<unit id="org.apache.commons.io" version="2.0.1.v201105210651"/>
-<unit id="org.apache.commons.lang" version="2.6.0.v201404270220"/>
-<unit id="org.apache.commons.logging" version="1.1.1.v201101211721"/>
-<unit id="org.apache.xmlrpc" version="3.0.0.v20100427-1100"/>
-<unit id="org.apache.ws.commons.util" version="1.0.1.v20100518-1140"/>
-<unit id="org.hamcrest" version="1.1.0.v20090501071000"/>
-<unit id="org.hamcrest.core" version="1.1.0.v20090501071000"/>
-<unit id="org.hamcrest.generator" version="1.1.0.v20090501071000"/>
-<unit id="org.hamcrest.integration" version="1.1.0.v201303031500"/>
-<unit id="org.hamcrest.library" version="1.1.0.v20090501071000"/>
-<unit id="org.hamcrest.text" version="1.1.0.v20090501071000"/>
-<unit id="com.thoughtworks.qdox" version="1.6.3.v20081201-1400"/>
-<unit id="org.mockito" version="1.9.5.v201605172210"/>
-<unit id="org.objenesis" version="1.0.0.v201505121915"/>
-<unit id="org.apache.httpcomponents.httpclient" version="4.5.2.v20170210-0925"/>
-<unit id="org.apache.httpcomponents.httpcore" version="4.4.6.v20170210-0925"/>
-<unit id="org.jsoup" version="1.7.2.v201411291515"/>
-<unit id="org.apache.tika.core" version="1.3.0.v201505121915"/>
-<unit id="org.apache.tika.parsers" version="1.3.0.v201605180015"/>
-<unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
-<unit id="javax.xml" version="1.3.4.v201005080400"/>
-<unit id="org.apache.xml.resolver" version="1.2.0.v201005080400"/>
-<unit id="org.apache.xml.serializer" version="2.7.1.v201005080400"/>
-<unit id="org.apache.xerces" version="2.9.0.v201101211617"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170516192513/repository"/>
-</location>
-<location includeAllPlatforms="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="org.junit" version="4.8.2.v4_8_2_v20130308-0413"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20130517111416/repository/"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="org.eclipse.cdt.platform.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.cdt.debug.core" version="0.0.0"/>
-<unit id="org.eclipse.tools.templates.ui" version="0.0.0" />
-<unit id="org.eclipse.tools.templates.core" version="0.0.0" />
-<unit id="org.eclipse.ecf.core.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.ecf.discovery.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.ecf.discovery.jmdns.feature.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.equinox.concurrent" version="0.0.0"/>
-<unit id="org.eclipse.emf.ecore.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.ecore.source.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.common.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.common.source.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.common.ui.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.databinding.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.edit.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.emf.edit.ui.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.launchbar.feature.group" version="0.0.0"/>
-<unit id="org.eclipse.sdk.ide" version="0.0.0"/>
-<repository location="http://download.eclipse.org/staging/neon/"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="org.tigris.subversion.subclipse.feature.group" version="1.8.10"/>
-<unit id="org.tigris.subversion.clientadapter.feature.feature.group" version="1.8.2"/>
-<repository location="http://subclipse.tigris.org/archive/subclipse_1.8.10"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="org.eclipse.osgi" version="3.8.2.v20130124-134944"/>
-<unit id="org.eclipse.core.runtime.compatibility.auth" version="3.2.300.v20120523-2004"/>
-<unit id="org.eclipse.jdt.annotation" version="1.0.1.v20130111-135246"/>
-<repository location="http://download.eclipse.org/eclipse/updates/3.8/R-3.8.2-201301310800"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
-<unit id="org.eclipse.license.feature.group" version="1.0.1.v20140414-1359"/>
-<repository location="http://download.eclipse.org/cbi/updates/license"/>
-</location>
-</locations>
-</target>
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde version="3.8"?><target name="mylyn-emaintenance" sequenceNumber="13">
+<locations>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="com.google.gwt.servlet" version="2.0.4.v20100709-0658"/>
+<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
+<unit id="org.apache.lucene.core" version="2.9.1.v201101211721"/>
+<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="com.google.gerrit.prettify" version="2.1.5.v201112241444"/>
+<unit id="com.google.gerrit.reviewdb" version="2.1.5.v201112241444"/>
+<unit id="com.google.gerrit.common" version="2.1.5.v201112241444"/>
+<unit id="com.google.gson" version="2.7.0.v20170129-0911"/>
+<unit id="com.google.gwtjsonrpc" version="1.2.5.v201112241444"/>
+<unit id="com.google.gwtorm" version="1.1.4.v201112241444"/>
+<unit id="javax.el" version="2.2.0.v201303151357"/>
+<unit id="org.apache.commons.codec" version="1.9.0.v20170208-1614"/>
+<unit id="org.apache.commons.httpclient" version="3.1.0.v201012070820"/>
+<unit id="org.apache.commons.io" version="2.0.1.v201105210651"/>
+<unit id="org.apache.commons.lang" version="2.6.0.v201404270220"/>
+<unit id="org.apache.commons.logging" version="1.1.1.v201101211721"/>
+<unit id="org.apache.xmlrpc" version="3.0.0.v20100427-1100"/>
+<unit id="org.apache.ws.commons.util" version="1.0.1.v20100518-1140"/>
+<unit id="org.hamcrest" version="1.1.0.v20090501071000"/>
+<unit id="org.hamcrest.core" version="1.1.0.v20090501071000"/>
+<unit id="org.hamcrest.generator" version="1.1.0.v20090501071000"/>
+<unit id="org.hamcrest.integration" version="1.1.0.v201303031500"/>
+<unit id="org.hamcrest.library" version="1.1.0.v20090501071000"/>
+<unit id="org.hamcrest.text" version="1.1.0.v20090501071000"/>
+<unit id="com.thoughtworks.qdox" version="1.6.3.v20081201-1400"/>
+<unit id="org.mockito" version="1.9.5.v201605172210"/>
+<unit id="org.objenesis" version="1.0.0.v201505121915"/>
+<unit id="org.apache.httpcomponents.httpclient" version="4.5.2.v20170210-0925"/>
+<unit id="org.apache.httpcomponents.httpcore" version="4.4.6.v20170210-0925"/>
+<unit id="org.jsoup" version="1.7.2.v201411291515"/>
+<unit id="org.apache.tika.core" version="1.3.0.v201505121915"/>
+<unit id="org.apache.tika.parsers" version="1.3.0.v201605180015"/>
+<unit id="com.google.guava" version="21.0.0.v20170206-1425"/>
+<unit id="javax.xml" version="1.3.4.v201005080400"/>
+<unit id="org.apache.xml.resolver" version="1.2.0.v201005080400"/>
+<unit id="org.apache.xml.serializer" version="2.7.1.v201005080400"/>
+<unit id="org.apache.xerces" version="2.9.0.v201101211617"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20170516192513/repository"/>
+</location>
+<location includeAllPlatforms="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.junit" version="4.8.2.v4_8_2_v20130308-0413"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20130517111416/repository/"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.cdt.platform.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.cdt.debug.core" version="0.0.0"/>
+<unit id="org.eclipse.tools.templates.ui" version="0.0.0" />
+<unit id="org.eclipse.tools.templates.core" version="0.0.0" />
+<unit id="org.eclipse.ecf.core.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.ecf.core.source.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.ecf.core.ssl.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.ecf.core.ssl.source.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.ecf.discovery.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.ecf.discovery.jmdns.feature.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.equinox.concurrent" version="0.0.0"/>
+<unit id="org.eclipse.emf.ecore.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.ecore.source.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.common.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.common.source.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.common.ui.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.databinding.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.edit.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.emf.edit.ui.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.egit.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.jgit.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.launchbar.feature.group" version="0.0.0"/>
+<unit id="org.eclipse.sdk.ide" version="0.0.0"/>
+<repository location="http://download.eclipse.org/staging/neon/"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.tigris.subversion.subclipse.feature.group" version="1.8.10"/>
+<unit id="org.tigris.subversion.clientadapter.feature.feature.group" version="1.8.2"/>
+<repository location="http://subclipse.tigris.org/archive/subclipse_1.8.10"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.osgi" version="3.8.2.v20130124-134944"/>
+<unit id="org.eclipse.core.runtime.compatibility.auth" version="3.2.300.v20120523-2004"/>
+<unit id="org.eclipse.jdt.annotation" version="1.0.1.v20130111-135246"/>
+<repository location="http://download.eclipse.org/eclipse/updates/3.8/R-3.8.2-201301310800"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.license.feature.group" version="1.0.1.v20140414-1359"/>
+<repository location="http://download.eclipse.org/cbi/updates/license"/>
+</location>
+</locations>
+</target>
diff --git a/org.eclipse.mylyn-target/mylyn-estaging.target b/org.eclipse.mylyn-target/mylyn-estaging.target
index 3fba4cd..bb409e2 100644
--- a/org.eclipse.mylyn-target/mylyn-estaging.target
+++ b/org.eclipse.mylyn-target/mylyn-estaging.target
@@ -6,6 +6,10 @@
<unit id="org.antlr.runtime" version="3.0.0.v200803061811"/>
<unit id="org.apache.lucene.core" version="2.9.1.v201101211721"/>
<unit id="javax.servlet" version="3.0.0.v201112011016"/>
+<unit id="javax.activation" version="1.1.0.v201211130549"/>
+<unit id="javax.xml.bind" version="2.2.0.v201105210648"/>
+<unit id="com.sun.xml.bind" version="2.2.0.v201505121915"/>
+<unit id="javax.xml.stream" version="1.0.1.v201004272200"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">

Back to the top