Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaxsun McCarthy Huggan2016-05-04 14:56:24 -0400
committerJaxsun McCarthy Huggan2016-05-06 16:52:52 -0400
commitce9b43c0b5beef244ab0a69dfd5b573aa9c0f672 (patch)
tree14fbf480a3f1bf6b9c161b8b28de1592b79172cc
parentab71b0a39ecd32482103309827818069a965b5a9 (diff)
downloadorg.eclipse.mylyn-ce9b43c0b5beef244ab0a69dfd5b573aa9c0f672.tar.gz
org.eclipse.mylyn-ce9b43c0b5beef244ab0a69dfd5b573aa9c0f672.tar.xz
org.eclipse.mylyn-ce9b43c0b5beef244ab0a69dfd5b573aa9c0f672.zip
Change dependencies in tycho surefire builds to target dependencies
This is necessary to run the Mylyn integration builds after upgrading to Tycho 0.21. Change-Id: Ia4295d84293cc880ecb69f8254df7257bd8bd239 Signed-off-by: Jaxsun McCarthy Huggan <jaxsun.mccarthy@tasktop.com>
-rw-r--r--org.eclipse.mylyn-parent/pom.xml16
-rw-r--r--org.eclipse.mylyn.maven-parent/pom.xml16
-rw-r--r--org.eclipse.mylyn.tests/pom.xml76
3 files changed, 57 insertions, 51 deletions
diff --git a/org.eclipse.mylyn-parent/pom.xml b/org.eclipse.mylyn-parent/pom.xml
index 4e6f781..e15fa7d 100644
--- a/org.eclipse.mylyn-parent/pom.xml
+++ b/org.eclipse.mylyn-parent/pom.xml
@@ -764,13 +764,15 @@
</environmentVariables>
-->
<application>org.eclipse.ui.ide.workbench</application>
- <dependencies>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.sdk.feature.group</artifactId>
- <version>${platform-version}</version>
- </dependency>
- </dependencies>
+ <dependency-resolution>
+ <extraRequirements>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.sdk.feature.group</id>
+ <versionRange>${platform-version}</versionRange>
+ </requirement>
+ </extraRequirements>
+ </dependency-resolution>
</configuration>
</plugin>
</plugins>
diff --git a/org.eclipse.mylyn.maven-parent/pom.xml b/org.eclipse.mylyn.maven-parent/pom.xml
index d31b89e..0428146 100644
--- a/org.eclipse.mylyn.maven-parent/pom.xml
+++ b/org.eclipse.mylyn.maven-parent/pom.xml
@@ -261,13 +261,15 @@
<appArgLine>${test.args}</appArgLine>
<application>org.eclipse.ui.ide.workbench</application>
<!-- <product>org.eclipse.sdk.ide</product> -->
- <dependencies>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.sdk.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- </dependencies>
+ <dependency-resolution>
+ <extraRequirements>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.sdk.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ </extraRequirements>
+ </dependency-resolution>
</configuration>
</plugin>
</plugins>
diff --git a/org.eclipse.mylyn.tests/pom.xml b/org.eclipse.mylyn.tests/pom.xml
index e2acda3..658b31d 100644
--- a/org.eclipse.mylyn.tests/pom.xml
+++ b/org.eclipse.mylyn.tests/pom.xml
@@ -43,43 +43,45 @@
<explodedBundles>
<explodedBundle>org.eclipse.mylyn.bugzilla.tests</explodedBundle>
</explodedBundles>
- <dependencies>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.sdk.feature.group</artifactId>
- <version>${platform-version}</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.mylyn.sdk_feature.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.mylyn.context.sdk.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.mylyn.docs.sdk.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.cdt.mylyn.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.mylyn.gerrit.feature.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- <dependency>
- <type>p2-installable-unit</type>
- <artifactId>org.eclipse.mylyn.hudson.feature.group</artifactId>
- <version>0.0.0</version>
- </dependency>
- </dependencies>
+ <dependency-resolution>
+ <extraRequirements>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.sdk.feature.group</id>
+ <versionRange>${platform-version}</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.mylyn.sdk_feature.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.mylyn.context.sdk.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.mylyn.docs.sdk.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.cdt.mylyn.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.mylyn.gerrit.feature.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ <requirement>
+ <type>p2-installable-unit</type>
+ <id>org.eclipse.mylyn.hudson.feature.group</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ </extraRequirements>
+ </dependency-resolution>
</configuration>
</plugin>
<plugin>

Back to the top