Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpelder2006-08-24 09:04:19 -0400
committerpelder2006-08-24 09:04:19 -0400
commit4c52a7917a63b1d3240067f02e15a6595e3576fc (patch)
tree2551251cc57c9ccdccaf79c50ce29f788ecf24d4 /examples
parent217fbb61f6a05c0890239fe78b3b2b56d0e3b2d4 (diff)
downloadorg.eclipse.jet-4c52a7917a63b1d3240067f02e15a6595e3576fc.tar.gz
org.eclipse.jet-4c52a7917a63b1d3240067f02e15a6595e3576fc.tar.xz
org.eclipse.jet-4c52a7917a63b1d3240067f02e15a6595e3576fc.zip
[154957] Ensure plug-in dependencies all express a range in MANIFEST.MF and express a minimum version + Compatible in feature.xml
Diffstat (limited to 'examples')
-rw-r--r--examples/org.eclipse.jet.examples-feature/feature.xml2
-rw-r--r--examples/org.eclipse.jet.examples/META-INF/MANIFEST.MF2
2 files changed, 2 insertions, 2 deletions
diff --git a/examples/org.eclipse.jet.examples-feature/feature.xml b/examples/org.eclipse.jet.examples-feature/feature.xml
index 814b2c7..6559ba8 100644
--- a/examples/org.eclipse.jet.examples-feature/feature.xml
+++ b/examples/org.eclipse.jet.examples-feature/feature.xml
@@ -38,7 +38,7 @@
</url>
<requires>
- <import plugin="org.eclipse.jet"/>
+ <import plugin="org.eclipse.jet" version="0.7.0" match="compatible"/>
</requires>
<plugin
diff --git a/examples/org.eclipse.jet.examples/META-INF/MANIFEST.MF b/examples/org.eclipse.jet.examples/META-INF/MANIFEST.MF
index 424f142..f325c2a 100644
--- a/examples/org.eclipse.jet.examples/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.jet.examples/META-INF/MANIFEST.MF
@@ -6,5 +6,5 @@ Bundle-Version: 0.7.0.qualifier
Bundle-ClassPath: examples.jar
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.jet
+Require-Bundle: org.eclipse.jet;bundle-version="[0.7.0,1.0.0)"
Eclipse-LazyStart: true

Back to the top