Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpelder2008-02-06 11:06:34 -0500
committerpelder2008-02-06 11:06:34 -0500
commit5d767e7019bb66e3a7b24d661683e4fe066b2d55 (patch)
tree1005862f29bfb99819ead7421f44ec0b0f0447fb
parente48889ffa6c583b9d4b470c426ec61bf8cf769b5 (diff)
downloadorg.eclipse.jet-5d767e7019bb66e3a7b24d661683e4fe066b2d55.tar.gz
org.eclipse.jet-5d767e7019bb66e3a7b24d661683e4fe066b2d55.tar.xz
org.eclipse.jet-5d767e7019bb66e3a7b24d661683e4fe066b2d55.zip
[207151] JET editor feature name and provider show 'featureName' and 'providerName'
https://bugs.eclipse.org/bugs/show_bug.cgi?id=207151
-rw-r--r--plugins/org.eclipse.jet.editor-feature/build.properties5
-rw-r--r--plugins/org.eclipse.jet.editor-feature/feature.xml20
2 files changed, 23 insertions, 2 deletions
diff --git a/plugins/org.eclipse.jet.editor-feature/build.properties b/plugins/org.eclipse.jet.editor-feature/build.properties
index 64f93a9..39b0777 100644
--- a/plugins/org.eclipse.jet.editor-feature/build.properties
+++ b/plugins/org.eclipse.jet.editor-feature/build.properties
@@ -1 +1,4 @@
-bin.includes = feature.xml
+bin.includes = feature.xml,\
+ epl-v10.html,\
+ feature.properties,\
+ license.html
diff --git a/plugins/org.eclipse.jet.editor-feature/feature.xml b/plugins/org.eclipse.jet.editor-feature/feature.xml
index 3921843..8dd0b33 100644
--- a/plugins/org.eclipse.jet.editor-feature/feature.xml
+++ b/plugins/org.eclipse.jet.editor-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jet.editor"
label="%featureName"
- version="0.8.0.qualifier"
+ version="0.9.0.qualifier"
provider-name="%providerName">
<description>
@@ -17,6 +17,24 @@
%license
</license>
+ <requires>
+ <import plugin="org.eclipse.core.runtime" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.core.resources" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.jface.text" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.ui" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.ide" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.editors" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.workbench.texteditor" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.views" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.views.properties.tabbed" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.jdt.core" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.jdt.ui" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jet" version="0.8.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen.ecore" version="2.2.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore" version="2.2.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen.ecore.ui" version="2.2.0" match="compatible"/>
+ </requires>
+
<plugin
id="org.eclipse.jet.editor"
download-size="0"

Back to the top