Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--m2e-maven-runtime/org.eclipse.m2e.maven.runtime/pom.xml5
-rw-r--r--org.eclipse.m2e.core.ui/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.core/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.m2e.discovery/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.editor.xml/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.m2e.editor/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.m2e.importer/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.jdt.ui/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.m2e.jdt/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.launching/META-INF/MANIFEST.MF3
-rw-r--r--org.eclipse.m2e.logback.configuration/META-INF/MANIFEST.MF5
-rw-r--r--org.eclipse.m2e.profiles.ui/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.refactoring/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.m2e.scm/META-INF/MANIFEST.MF4
14 files changed, 25 insertions, 24 deletions
diff --git a/m2e-maven-runtime/org.eclipse.m2e.maven.runtime/pom.xml b/m2e-maven-runtime/org.eclipse.m2e.maven.runtime/pom.xml
index 22127384..0ab2d03b 100644
--- a/m2e-maven-runtime/org.eclipse.m2e.maven.runtime/pom.xml
+++ b/m2e-maven-runtime/org.eclipse.m2e.maven.runtime/pom.xml
@@ -134,10 +134,11 @@
</_exportcontents>
<Import-Package>
- !*
+ org.slf4j;version="1.6.2",
+ org.slf4j.spi;version="1.6.2",
+ org.slf4j.helpers;version="1.6.2",
</Import-Package>
<Require-Bundle>
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.m2e.maven.runtime.slf4j.simple;bundle-version="[1.8.0,1.9.0)",
javax.inject;bundle-version="1.0.0";visibility:=reexport
</Require-Bundle>
diff --git a/org.eclipse.m2e.core.ui/META-INF/MANIFEST.MF b/org.eclipse.m2e.core.ui/META-INF/MANIFEST.MF
index 67abe4dc..9b78a669 100644
--- a/org.eclipse.m2e.core.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.core.ui/META-INF/MANIFEST.MF
@@ -35,8 +35,8 @@ Require-Bundle: org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
org.eclipse.core.filesystem;bundle-version="1.2.1",
org.eclipse.core.expressions;bundle-version="3.4.101",
org.eclipse.ui.forms;bundle-version="3.4.1",
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.jface.text,
org.eclipse.ui
Import-Package: org.eclipse.compare.rangedifferencer,
- org.eclipse.ltk.core.refactoring
+ org.eclipse.ltk.core.refactoring,
+ org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.core/META-INF/MANIFEST.MF b/org.eclipse.m2e.core/META-INF/MANIFEST.MF
index c8f4b2b2..30d2df30 100644
--- a/org.eclipse.m2e.core/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.core/META-INF/MANIFEST.MF
@@ -13,7 +13,6 @@ Require-Bundle: org.eclipse.osgi;bundle-version="3.10.0",
org.eclipse.m2e.workspace.cli;bundle-version="0.1.0",
org.eclipse.core.runtime;bundle-version="3.7.0",
org.eclipse.core.resources;bundle-version="3.9.0",
- org.slf4j.api;bundle-version="1.6.2",
com.google.guava;bundle-version="[14.0.1,16.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
@@ -50,3 +49,4 @@ Export-Package: org.eclipse.m2e.core,
org.eclipse.m2e.core.repository
MavenArtifact-GroupId: org.eclipse.m2e
MavenArtifact-ArtifactId: org.eclipse.m2e.core
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.discovery/META-INF/MANIFEST.MF b/org.eclipse.m2e.discovery/META-INF/MANIFEST.MF
index b30aaff8..bfdb4211 100644
--- a/org.eclipse.m2e.discovery/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.discovery/META-INF/MANIFEST.MF
@@ -19,7 +19,6 @@ Require-Bundle: org.eclipse.equinox.p2.ui.discovery,
org.eclipse.equinox.p2.operations,
org.eclipse.equinox.p2.core,
org.eclipse.equinox.p2.metadata,
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.m2e.maven.runtime;bundle-version="[1.8.0,1.9.0)",
org.eclipse.equinox.p2.repository,
org.eclipse.equinox.p2.ui,
@@ -40,7 +39,8 @@ Import-Package: org.apache.maven.plugin;provider=m2e,
org.eclipse.equinox.p2.engine,
org.eclipse.equinox.p2.metadata,
org.eclipse.equinox.p2.repository.metadata,
- org.eclipse.equinox.p2.ui
+ org.eclipse.equinox.p2.ui,
+ org.slf4j;version="1.6.2"
Bundle-Activator: org.eclipse.m2e.internal.discovery.DiscoveryActivator
Bundle-ActivationPolicy: lazy
Service-Component: OSGI-INF/component.xml
diff --git a/org.eclipse.m2e.editor.xml/META-INF/MANIFEST.MF b/org.eclipse.m2e.editor.xml/META-INF/MANIFEST.MF
index 4f13d88d..ae941137 100644
--- a/org.eclipse.m2e.editor.xml/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.editor.xml/META-INF/MANIFEST.MF
@@ -22,7 +22,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ui.ide,
org.eclipse.core.filesystem,
org.eclipse.ui.forms,
- org.slf4j.api;bundle-version="1.6.2",
com.google.guava;bundle-version="[14.0.1,16.0.0)"
Export-Package: org.eclipse.m2e.editor.xml;x-internal:=true,
org.eclipse.m2e.editor.xml.internal;x-internal:=true,
@@ -35,3 +34,4 @@ Bundle-ClassPath: .
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Service-Component: OSGI-INF/component.xml
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.editor/META-INF/MANIFEST.MF b/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
index 5570ea69..1145b7a8 100644
--- a/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
@@ -18,7 +18,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.m2e.maven.runtime;bundle-version="[1.8.0,1.9.0)",
org.eclipse.m2e.editor.xml;bundle-version="[1.8.0,1.9.0)",
org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.wst.common.emf,
org.eclipse.swt,
org.eclipse.jface,
@@ -32,3 +31,4 @@ Export-Package: org.eclipse.m2e.editor;x-internal:=true,
org.eclipse.m2e.editor.composites;x-internal:=true,
org.eclipse.m2e.editor.dialogs;x-internal:=true,
org.eclipse.m2e.editor.pom;x-internal:=true
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.importer/META-INF/MANIFEST.MF b/org.eclipse.m2e.importer/META-INF/MANIFEST.MF
index 60b1bd8a..7165b592 100644
--- a/org.eclipse.m2e.importer/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.importer/META-INF/MANIFEST.MF
@@ -10,9 +10,9 @@ Require-Bundle: org.eclipse.ui.ide,
org.eclipse.core.runtime,
org.eclipse.core.resources,
org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
- org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2"
+ org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.m2e.importer.internal.Activator
Export-Package: org.eclipse.m2e.importer.internal
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.jdt.ui/META-INF/MANIFEST.MF b/org.eclipse.m2e.jdt.ui/META-INF/MANIFEST.MF
index 2df24531..9c68e88a 100644
--- a/org.eclipse.m2e.jdt.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.jdt.ui/META-INF/MANIFEST.MF
@@ -18,7 +18,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources,
org.eclipse.m2e.maven.runtime;bundle-version="[1.8.0,1.9.0)",
org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %Bundle-Vendor
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.jdt/META-INF/MANIFEST.MF b/org.eclipse.m2e.jdt/META-INF/MANIFEST.MF
index 458c1f3f..cacc0c50 100644
--- a/org.eclipse.m2e.jdt/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.jdt/META-INF/MANIFEST.MF
@@ -13,9 +13,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.jdt.launching,
org.eclipse.core.resources,
org.eclipse.m2e.maven.runtime;bundle-version="[1.8.0,1.9.0)",
- org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2"
+ org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.m2e.jdt.MavenJdtPlugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %Bundle-Vendor
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.launching/META-INF/MANIFEST.MF b/org.eclipse.m2e.launching/META-INF/MANIFEST.MF
index 5ff6e712..eecdd6c7 100644
--- a/org.eclipse.m2e.launching/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.launching/META-INF/MANIFEST.MF
@@ -21,7 +21,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
com.ibm.icu;bundle-version="4.0.1",
org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2",
org.eclipse.jdt.debug,
org.eclipse.core.resources,
org.eclipse.debug.core,
@@ -34,4 +33,4 @@ Export-Package: org.eclipse.m2e.actions;x-internal:=true,
org.eclipse.m2e.internal.launch;x-internal:=true,
org.eclipse.m2e.ui.internal.launch;x-internal:=true
Bundle-Activator: org.eclipse.m2e.internal.launch.MavenLaunchPlugin
-Import-Package: org.slf4j
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.logback.configuration/META-INF/MANIFEST.MF b/org.eclipse.m2e.logback.configuration/META-INF/MANIFEST.MF
index 682791b7..0e522a36 100644
--- a/org.eclipse.m2e.logback.configuration/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.logback.configuration/META-INF/MANIFEST.MF
@@ -7,8 +7,9 @@ Bundle-Version: 1.8.0.qualifier
Bundle-Activator: org.eclipse.m2e.logback.configuration.LogPlugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
ch.qos.logback.classic;bundle-version="0.9.24",
- ch.qos.logback.core;bundle-version="0.9.24",
- org.slf4j.api;bundle-version="1.6.2"
+ ch.qos.logback.core;bundle-version="0.9.24"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.m2e.logback.configuration;x-internal:=true
+Import-Package: org.slf4j;version="1.6.2",
+ org.slf4j.helpers;version="1.6.2"
diff --git a/org.eclipse.m2e.profiles.ui/META-INF/MANIFEST.MF b/org.eclipse.m2e.profiles.ui/META-INF/MANIFEST.MF
index e25e5b8e..704fe651 100644
--- a/org.eclipse.m2e.profiles.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.profiles.ui/META-INF/MANIFEST.MF
@@ -12,11 +12,11 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
org.eclipse.ui.ide,
org.eclipse.jface.text,
- org.eclipse.m2e.profiles.core;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2"
+ org.eclipse.m2e.profiles.core;bundle-version="[1.8.0,1.9.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %Bundle-Vendor
Export-Package: org.eclipse.m2e.profiles.ui.internal;x-internal:=true,
org.eclipse.m2e.profiles.ui.internal.actions;x-internal:=true,
org.eclipse.m2e.profiles.ui.internal.dialog;x-internal:=true
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.refactoring/META-INF/MANIFEST.MF b/org.eclipse.m2e.refactoring/META-INF/MANIFEST.MF
index c9329894..093f105d 100644
--- a/org.eclipse.m2e.refactoring/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.refactoring/META-INF/MANIFEST.MF
@@ -20,8 +20,8 @@ Require-Bundle: org.eclipse.m2e.core;bundle-version="[1.8.0,1.9.0)",
org.eclipse.ui.ide,
org.eclipse.ltk.core.refactoring,
org.eclipse.ltk.ui.refactoring;visibility:=reexport,
- org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
- org.slf4j.api;bundle-version="1.6.2"
+ org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.m2e.refactoring.exclude;x-internal:=true
+Import-Package: org.slf4j;version="1.6.2"
diff --git a/org.eclipse.m2e.scm/META-INF/MANIFEST.MF b/org.eclipse.m2e.scm/META-INF/MANIFEST.MF
index 8864dbda..63d35a5d 100644
--- a/org.eclipse.m2e.scm/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.scm/META-INF/MANIFEST.MF
@@ -24,5 +24,5 @@ Require-Bundle: org.eclipse.core.resources;bundle-version="3.5.2",
org.eclipse.m2e.core.ui;bundle-version="[1.8.0,1.9.0)",
org.eclipse.ui.workbench;bundle-version="3.5.2",
org.eclipse.ui.ide;bundle-version="3.5.1",
- org.eclipse.jdt.core;bundle-version="3.5.2";resolution:=optional,
- org.slf4j.api;bundle-version="1.6.2"
+ org.eclipse.jdt.core;bundle-version="3.5.2";resolution:=optional
+Import-Package: org.slf4j;version="1.6.2"

Back to the top