Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickael Istria2018-12-08 03:26:12 -0500
committerMickael Istria2018-12-13 13:32:03 -0500
commit37b4934bdfd8f999dc2d7241ae2ecad2ded35e20 (patch)
treeb9917cf4c812c3c401f59d87cfc56dfade38e6c1 /pom.xml
parentf13f3346eb19e1a98c0271d4b08faa6ac5c5c9b3 (diff)
downloadm2e-core-37b4934bdfd8f999dc2d7241ae2ecad2ded35e20.tar.gz
m2e-core-37b4934bdfd8f999dc2d7241ae2ecad2ded35e20.tar.xz
m2e-core-37b4934bdfd8f999dc2d7241ae2ecad2ded35e20.zip
Bug 542462 - Enforce specific version of SonarQube plugin
to work with sonar.eclipse.org Change-Id: Iedf10950c5193259f5b225b8e495a062f4002ec2 Signed-off-by: Mickael Istria <mistria@redhat.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml9
1 files changed, 9 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
index ef393d8f..280d46aa 100644
--- a/pom.xml
+++ b/pom.xml
@@ -47,6 +47,10 @@
<tycho.test.jvmArgs>-Xmx800m</tycho.test.jvmArgs>
<tycho.surefire.timeout>7200</tycho.surefire.timeout>
+
+ <!-- this specific version is required to work with sonar.eclipse.org, and there is no
+ other way to enforce it over latest one -->
+ <sonar-maven-plugin.version>3.3.0.603</sonar-maven-plugin.version>
</properties>
<organization>
@@ -222,6 +226,11 @@
<artifactId>tycho-p2-plugin</artifactId>
<version>${tycho-version}</version>
</plugin>
+ <plugin>
+ <groupId>org.sonarsource.scanner.maven</groupId>
+ <artifactId>sonar-maven-plugin</artifactId>
+ <version>${sonar-maven-plugin.version}</version>
+ </plugin>
</plugins>
</pluginManagement>
</build>

Back to the top