Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Fedorenko2011-09-06 11:36:51 -0400
committerIgor Fedorenko2011-09-06 11:36:51 -0400
commitc3f8c57e8f4a80634c43ae97012e8ce7fe2fc046 (patch)
tree031837d45f5a29bd675966b61db17f79a9518b51
parentf8e5e0f3b032965c4d6dc1b3d7d21b776f74e3d5 (diff)
downloadm2e-core-c3f8c57e8f4a80634c43ae97012e8ce7fe2fc046.tar.gz
m2e-core-c3f8c57e8f4a80634c43ae97012e8ce7fe2fc046.tar.xz
m2e-core-c3f8c57e8f4a80634c43ae97012e8ce7fe2fc046.zip
356820: CNFE: org.eclipse.ui.plugin.AbstractUIPlugin openning pom editor
after further investigation removed org.eclipse.emf.edit.ui dependency and introduced more specific emf and platform dependencies instead. Signed-off-by: Igor Fedorenko <igor@ifedorenko.com>
-rw-r--r--org.eclipse.m2e.editor/META-INF/MANIFEST.MF7
1 files changed, 5 insertions, 2 deletions
diff --git a/org.eclipse.m2e.editor/META-INF/MANIFEST.MF b/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
index 65ec097e..00ae48b5 100644
--- a/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
+++ b/org.eclipse.m2e.editor/META-INF/MANIFEST.MF
@@ -14,13 +14,16 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.wst.sse.ui,
org.eclipse.wst.xml.core,
org.eclipse.ui.workbench,
- org.eclipse.emf.edit.ui;resolution:=optional,
org.eclipse.m2e.core;bundle-version="[1.0.0,1.1.0)",
org.eclipse.m2e.maven.runtime;bundle-version="[1.0.0,1.1.0)",
org.eclipse.m2e.editor.xml;bundle-version="[1.0.0,1.1.0)",
org.eclipse.m2e.core.ui;bundle-version="[1.0.0,1.1.0)",
org.slf4j.api;bundle-version="1.6.1",
- org.eclipse.wst.common.emf
+ org.eclipse.wst.common.emf,
+ org.eclipse.swt,
+ org.eclipse.jface,
+ org.eclipse.emf.common,
+ org.eclipse.emf.ecore
Eclipse-LazyStart: true
Bundle-RequiredExecutionEnvironment: J2SE-1.5,
JavaSE-1.6

Back to the top