Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Montplaisir2013-08-16 13:30:51 -0400
committerAlexandre Montplaisir2013-08-16 15:14:13 -0400
commit26595e5ced3af74051513822158484e57315aa16 (patch)
tree7d8c9404c7901c729cdbb8f794604d5a09844fed /lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests
parent1e9f1d5c5f02a9efd35600b6d1f93939de869de8 (diff)
downloadorg.eclipse.linuxtools-26595e5ced3af74051513822158484e57315aa16.tar.gz
org.eclipse.linuxtools-26595e5ced3af74051513822158484e57315aa16.tar.xz
org.eclipse.linuxtools-26595e5ced3af74051513822158484e57315aa16.zip
lttng: Disable API checking in the luna branch
Instead of always faking @since annotations to 3.0 in the luna branch, it was deemed much more simple to simply ignore all API problems in the Luna branch. That way all @since 2.x annotation will remain as-is, without throwing errors when one checkouts that branch. Instead of having to revert dozens and dozens of temporary commits when we utlimately merge this branch back into master, only this one will have to be reverted. Change-Id: Ic37543462b677357b2051326d273d8504086db54 Signed-off-by: Alexandre Montplaisir <alexmonthy@voxpopuli.im> Reviewed-on: https://git.eclipse.org/r/15553 Reviewed-by: Bernd Hufmann <bernd.hufmann@ericsson.com> IP-Clean: Bernd Hufmann <bernd.hufmann@ericsson.com>
Diffstat (limited to 'lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests')
-rw-r--r--lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests/.settings/org.eclipse.pde.api.tools.prefs4
1 files changed, 2 insertions, 2 deletions
diff --git a/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests/.settings/org.eclipse.pde.api.tools.prefs b/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests/.settings/org.eclipse.pde.api.tools.prefs
index acc3abd47c..8c5e9081aa 100644
--- a/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests/.settings/org.eclipse.pde.api.tools.prefs
+++ b/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.tests/.settings/org.eclipse.pde.api.tools.prefs
@@ -90,8 +90,8 @@ eclipse.preferences.version=1
incompatible_api_component_version=Error
incompatible_api_component_version_include_major_without_breaking_change=Disabled
incompatible_api_component_version_include_minor_without_api_change=Disabled
-invalid_since_tag_version=Error
+invalid_since_tag_version=Ignore
malformed_since_tag=Error
-missing_since_tag=Error
+missing_since_tag=Ignore
report_api_breakage_when_major_version_incremented=Disabled
report_resolution_errors_api_component=Warning

Back to the top