Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Andre Laperle2014-05-23 13:43:42 -0400
committerMarc-Andre Laperle2014-05-23 15:36:32 -0400
commit3e1a73831e1772f81b381294980943dfb2b6e1aa (patch)
tree33561ad2269b6bed5f06ca378a57a2925071d1bf
parentb6f2330768c2bc2c00a05aa16b172aa43a09c831 (diff)
downloadorg.eclipse.linuxtools-3e1a73831e1772f81b381294980943dfb2b6e1aa.tar.gz
org.eclipse.linuxtools-3e1a73831e1772f81b381294980943dfb2b6e1aa.tar.xz
org.eclipse.linuxtools-3e1a73831e1772f81b381294980943dfb2b6e1aa.zip
Downgrade to Tycho 0.20.0 to fix build
Tycho 0.21.0-SNAPSHOT seems to fragile right now for us to use for the Luna release. We needed 0.21 to work around a bug in IcedTea but we can work around this issue by setting the SWT_GTK3=0 environment variable when executing the build instead of having it in the pom.xml. This is less convenient but more prudent in order to stabilize the build. Change-Id: I33fc64552c73a0cd8f2eac12fa27afab6af92557 Signed-off-by: Marc-Andre Laperle <marc-andre.laperle@ericsson.com> Reviewed-on: https://git.eclipse.org/r/27213 Tested-by: Hudson CI Reviewed-by: Bernd Hufmann <bernd.hufmann@ericsson.com>
-rw-r--r--lttng/org.eclipse.linuxtools.lttng2.kernel.ui.swtbot.tests/pom.xml4
-rw-r--r--lttng/org.eclipse.linuxtools.tmf.ctf.ui.swtbot.tests/pom.xml4
-rw-r--r--lttng/org.eclipse.linuxtools.tmf.ui.swtbot.tests/pom.xml4
-rw-r--r--pom.xml4
4 files changed, 11 insertions, 5 deletions
diff --git a/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.swtbot.tests/pom.xml b/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.swtbot.tests/pom.xml
index b4c4172339..f77e2ab073 100644
--- a/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.swtbot.tests/pom.xml
+++ b/lttng/org.eclipse.linuxtools.lttng2.kernel.ui.swtbot.tests/pom.xml
@@ -38,10 +38,12 @@
<useUIThread>false</useUIThread>
<argLine>${tycho.testArgLine} ${base.ui.test.vmargs}</argLine>
<product>org.eclipse.platform.ide</product>
+<!-- Disable GTK3 with Luna because it makes the test hang (bug in IcedTea http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1736) -->
+<!-- Disable the disablement because of bug in Tycho 0.20.0 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793)
<environmentVariables>
- <!-- Disable GTK3 with Luna because it makes the test hang (bug in SWT?) -->
<SWT_GTK3>0</SWT_GTK3>
</environmentVariables>
+-->
</configuration>
</plugin>
</plugins>
diff --git a/lttng/org.eclipse.linuxtools.tmf.ctf.ui.swtbot.tests/pom.xml b/lttng/org.eclipse.linuxtools.tmf.ctf.ui.swtbot.tests/pom.xml
index 3b6938f4a5..a4451d11d9 100644
--- a/lttng/org.eclipse.linuxtools.tmf.ctf.ui.swtbot.tests/pom.xml
+++ b/lttng/org.eclipse.linuxtools.tmf.ctf.ui.swtbot.tests/pom.xml
@@ -38,10 +38,12 @@
<useUIThread>false</useUIThread>
<argLine>${tycho.testArgLine} ${base.ui.test.vmargs}</argLine>
<product>org.eclipse.platform.ide</product>
+<!-- Disable GTK3 with Luna because it makes the test hang (bug in IcedTea http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1736) -->
+<!-- Disable the disablement because of bug in Tycho 0.20.0 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793)
<environmentVariables>
- <!-- Disable GTK3 with Luna because it makes the test hang (bug in SWT?) -->
<SWT_GTK3>0</SWT_GTK3>
</environmentVariables>
+-->
</configuration>
</plugin>
</plugins>
diff --git a/lttng/org.eclipse.linuxtools.tmf.ui.swtbot.tests/pom.xml b/lttng/org.eclipse.linuxtools.tmf.ui.swtbot.tests/pom.xml
index 1070df8107..9ad819eed6 100644
--- a/lttng/org.eclipse.linuxtools.tmf.ui.swtbot.tests/pom.xml
+++ b/lttng/org.eclipse.linuxtools.tmf.ui.swtbot.tests/pom.xml
@@ -38,10 +38,12 @@
<useUIThread>false</useUIThread>
<argLine>${tycho.testArgLine} ${base.ui.test.vmargs}</argLine>
<product>org.eclipse.platform.ide</product>
+<!-- Disable GTK3 with Luna because it makes the test hang (bug in IcedTea http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1736) -->
+<!-- Disable the disablement because of bug in Tycho 0.20.0 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=431793)
<environmentVariables>
- <!-- Disable GTK3 with Luna because it makes the test hang (bug in SWT?) -->
<SWT_GTK3>0</SWT_GTK3>
</environmentVariables>
+-->
</configuration>
</plugin>
</plugins>
diff --git a/pom.xml b/pom.xml
index abe38e2b97..f9f876c585 100644
--- a/pom.xml
+++ b/pom.xml
@@ -50,8 +50,8 @@
<properties>
<mirror-repo-name>updates-nightly</mirror-repo-name>
- <tycho-version>0.21.0-SNAPSHOT</tycho-version>
- <tycho-extras-version>0.21.0-SNAPSHOT</tycho-extras-version>
+ <tycho-version>0.20.0</tycho-version>
+ <tycho-extras-version>0.20.0</tycho-extras-version>
<platform-version-name>luna</platform-version-name>
<eclipse-site>http://download.eclipse.org/releases/${platform-version-name}</eclipse-site>
<swtbot-site>http://download.eclipse.org/technology/swtbot/snapshots</swtbot-site>

Back to the top