summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaloyan Raev2011-07-07 14:12:06 (EDT)
committer Kaloyan Raev2011-07-07 14:12:06 (EDT)
commit2cf60e461ab916dc35aa950e5133011a32bd6a27 (patch)
tree3f6b9e1d61d51cd7d3dd9c0b8a2a42642998a9dd
parent8c0ee3537a8f1d57403c486189e8039ddae33c14 (diff)
downloadorg.eclipse.libra-2cf60e461ab916dc35aa950e5133011a32bd6a27.zip
org.eclipse.libra-2cf60e461ab916dc35aa950e5133011a32bd6a27.tar.gz
org.eclipse.libra-2cf60e461ab916dc35aa950e5133011a32bd6a27.tar.bz2
Add dependency to jpa.core plugin, so osgi facet tests can execute
-rw-r--r--development/org.eclipse.libra.releng/pom.xml6
-rw-r--r--tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF3
2 files changed, 8 insertions, 1 deletions
diff --git a/development/org.eclipse.libra.releng/pom.xml b/development/org.eclipse.libra.releng/pom.xml
index 97a9d7c..5ae8b01 100644
--- a/development/org.eclipse.libra.releng/pom.xml
+++ b/development/org.eclipse.libra.releng/pom.xml
@@ -12,6 +12,7 @@
<tycho-version>0.12.0</tycho-version>
<eclipse-site>http://download.eclipse.org/eclipse/updates/3.7milestones/</eclipse-site>
<emf-site>http://download.eclipse.org/modeling/emf/emf/updates/2.7milestones/</emf-site>
+ <dtp-site>http://download.eclipse.org/datatools/updates/</dtp-site>
<wtp-site>http://download.eclipse.org/webtools/repository/indigo/</wtp-site>
</properties>
@@ -134,6 +135,11 @@
<layout>p2</layout>
</repository>
<repository>
+ <id>dtp-sdk</id>
+ <url>${dtp-site}</url>
+ <layout>p2</layout>
+ </repository>
+ <repository>
<id>wtp-sdk</id>
<url>${wtp-site}</url>
<layout>p2</layout>
diff --git a/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF b/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
index 27d8cce..e1b35b6 100644
--- a/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
@@ -11,7 +11,8 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.pde.core;bundle-version="3.6.1",
org.eclipse.wst.common.project.facet.core;bundle-version="1.4.102",
org.eclipse.core.databinding.observable;bundle-version="1.3.0",
- org.eclipse.ui.ide;bundle-version="3.6.0"
+ org.eclipse.ui.ide;bundle-version="3.6.0",
+ org.eclipse.jpt.jpa.core;bundle-version="3.0.0"
Bundle-Vendor: %Bundle-Vendor
Import-Package: org.junit;version="4.5.0"
Bundle-RequiredExecutionEnvironment: J2SE-1.5