Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Erven2016-11-08 18:33:13 -0500
committerHannes Erven2016-11-08 18:33:13 -0500
commitee6400126bb2887189ebdf6a452b7b2d6fb3ca70 (patch)
treec180625c619fe6304e8fba03ef195e38e45c446b
parent5ee8f8429f799c1334af120ec320899503b11c90 (diff)
downloadorg.eclipse.libra-ee6400126bb2887189ebdf6a452b7b2d6fb3ca70.tar.gz
org.eclipse.libra-ee6400126bb2887189ebdf6a452b7b2d6fb3ca70.tar.xz
org.eclipse.libra-ee6400126bb2887189ebdf6a452b7b2d6fb3ca70.zip
[506530][506534] 'master' branch is now dedicated to Oxygen development
Upgrade Execution-Environment to JavaSE-1.8 Bump Version to 0.3.3 Honor deprecation/removal of SubProgressMonitor
-rw-r--r--development/org.eclipse.libra.releng/pom.xml12
-rw-r--r--development/org.eclipse.libra.repository/dependencies.target24
-rw-r--r--development/org.eclipse.libra.repository/pom.xml2
-rw-r--r--features/org.eclipse.libra.facet.feature.source/feature.xml2
-rw-r--r--features/org.eclipse.libra.facet.feature.source/pom.xml2
-rw-r--r--features/org.eclipse.libra.facet.feature/feature.xml2
-rw-r--r--features/org.eclipse.libra.facet.feature/pom.xml2
-rw-r--r--features/org.eclipse.libra.framework.editor.feature.source/feature.xml2
-rw-r--r--features/org.eclipse.libra.framework.editor.feature.source/pom.xml2
-rw-r--r--features/org.eclipse.libra.framework.editor.feature/feature.xml2
-rw-r--r--features/org.eclipse.libra.framework.editor.feature/pom.xml2
-rw-r--r--features/org.eclipse.libra.framework.feature.source/feature.xml2
-rw-r--r--features/org.eclipse.libra.framework.feature.source/pom.xml2
-rw-r--r--features/org.eclipse.libra.framework.feature/feature.xml2
-rw-r--r--features/org.eclipse.libra.framework.feature/pom.xml2
-rw-r--r--features/org.eclipse.libra.warproducts.feature.source/feature.xml2
-rw-r--r--features/org.eclipse.libra.warproducts.feature.source/pom.xml2
-rw-r--r--features/org.eclipse.libra.warproducts.feature/feature.xml2
-rw-r--r--features/org.eclipse.libra.warproducts.feature/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.facet.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.facet.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.facet.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.facet.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.facet/.classpath2
-rw-r--r--plugins/org.eclipse.libra.facet/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.facet/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.libra.facet/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.core/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.core/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.core/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.core/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.core/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.core/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.editor.core/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.editor.core/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.integration/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.integration/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.editor.integration/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.editor.integration/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.editor.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.editor.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.editor.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.equinox.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.equinox.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.equinox.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.equinox.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.equinox/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.equinox/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.equinox/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.equinox/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.felix.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.felix.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.felix.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.felix.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.felix/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.felix/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.felix/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.felix/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.jonas.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.jonas.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.jonas.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.jonas.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.jonas/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.jonas/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.jonas/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.jonas/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.knopflerfish/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.framework.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.framework.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.libra.framework.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.framework.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.warproducts.core/.classpath2
-rw-r--r--plugins/org.eclipse.libra.warproducts.core/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.libra.warproducts.core/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.warproducts.core/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.warproducts.core/src/org/eclipse/libra/warproducts/core/WARProductExportOperation.java8
-rw-r--r--plugins/org.eclipse.libra.warproducts.help/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.warproducts.help/pom.xml2
-rw-r--r--plugins/org.eclipse.libra.warproducts.ui/.classpath2
-rw-r--r--plugins/org.eclipse.libra.warproducts.ui/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.libra.warproducts.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.libra.warproducts.ui/pom.xml2
-rw-r--r--tests/org.eclipse.libra.facet.test/.classpath2
-rw-r--r--tests/org.eclipse.libra.facet.test/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF4
-rw-r--r--tests/org.eclipse.libra.facet.test/pom.xml2
-rw-r--r--tests/org.eclipse.libra.warproducts.core.test/.classpath2
-rw-r--r--tests/org.eclipse.libra.warproducts.core.test/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--tests/org.eclipse.libra.warproducts.core.test/META-INF/MANIFEST.MF4
-rw-r--r--tests/org.eclipse.libra.warproducts.core.test/pom.xml2
98 files changed, 183 insertions, 193 deletions
diff --git a/development/org.eclipse.libra.releng/pom.xml b/development/org.eclipse.libra.releng/pom.xml
index 8f9907f..59d794b 100644
--- a/development/org.eclipse.libra.releng/pom.xml
+++ b/development/org.eclipse.libra.releng/pom.xml
@@ -4,18 +4,18 @@
<groupId>org.eclipse.libra</groupId>
<artifactId>org.eclipse.libra_parent</artifactId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<packaging>pom</packaging>
<name>Libra Parent POM</name>
<properties>
<tycho-version>0.26.0</tycho-version>
- <eclipse-site>http://download.eclipse.org/eclipse/updates/4.6/</eclipse-site>
+ <eclipse-site>http://download.eclipse.org/eclipse/updates/4.7milestones/</eclipse-site>
<emf-site>http://download.eclipse.org/modeling/emf/emf/updates/2.12/</emf-site>
- <dtp-site>http://download.eclipse.org/datatools/downloads/drops/M_updates_1.12.0/</dtp-site>
+ <dtp-site>http://download.eclipse.org/datatools/downloads/drops/N_updates_1.12.0/v20140606-1324/</dtp-site>
<gef-site>http://download.eclipse.org/tools/gef/updates/releases</gef-site>
- <wtp-site>http://download.eclipse.org/webtools/downloads/drops/R3.8.0/R-3.8.0-20160608130753/repository/</wtp-site>
- <wtp-tests-site>http://download.eclipse.org/webtools/downloads/drops/R3.8.0/R-3.8.0-20160608130753/repositoryunittests/</wtp-tests-site>
+ <wtp-site>http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M3-20161031000121/repository/</wtp-site>
+ <wtp-tests-site>http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M3-20161031000121/repositoryunittests/</wtp-tests-site>
<orbit-site>http://download.eclipse.org/tools/orbit/downloads/drops/R20160520211859/repository/</orbit-site>
<license-site>http://download.eclipse.org/cbi/updates/license</license-site>
<debug-options></debug-options> <!-- empty by default -->
@@ -145,7 +145,7 @@
<configuration>
<sourceEncoding>utf-8</sourceEncoding>
<minimumTokens>100</minimumTokens>
- <targetJdk>1.5</targetJdk>
+ <targetJdk>1.8</targetJdk>
<format>xml</format>
<failOnViolation>false</failOnViolation>
</configuration>
diff --git a/development/org.eclipse.libra.repository/dependencies.target b/development/org.eclipse.libra.repository/dependencies.target
index ba1c06f..d7fa153 100644
--- a/development/org.eclipse.libra.repository/dependencies.target
+++ b/development/org.eclipse.libra.repository/dependencies.target
@@ -1,18 +1,18 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<?pde version="3.8"?><target name="Libra" sequenceNumber="31">
+<?pde version="3.8"?><target name="Libra" sequenceNumber="33">
<locations>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
-<unit id="osgi.enterprise" version="4.2.0.v201108120515"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20130118183705/repository/"/>
+<unit id="osgi.enterprise" version="0.0.0"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160520211859/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.emf.sdk.feature.group" version="0.0.0"/>
-<repository location="http://download.eclipse.org/modeling/emf/emf/updates/2.10milestones/"/>
+<repository location="http://download.eclipse.org/modeling/emf/emf/updates/2.12/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.gef.sdk.feature.group" version="0.0.0"/>
<unit id="org.eclipse.zest.sdk.feature.group" version="0.0.0"/>
-<repository location="http://download.eclipse.org/tools/gef/updates/milestones"/>
+<repository location="http://download.eclipse.org/tools/gef/updates/releases"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.jpt.jpa_sdk.feature.feature.group" version="0.0.0"/>
@@ -24,23 +24,27 @@
<unit id="org.eclipse.jst.server_sdk.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.wst.server_adapters.sdk.feature.feature.group" version="0.0.0"/>
<unit id="org.eclipse.wst.web_sdk.feature.feature.group" version="0.0.0"/>
-<repository location="http://download.eclipse.org/webtools/downloads/drops/R3.6.0/S-3.6.0M7-20140505163128/repository/"/>
+<repository location="http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M3-20161031000121/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.wst.common_tests.feature.feature.group" version="0.0.0"/>
-<repository location="http://download.eclipse.org/webtools/downloads/drops/R3.6.0/S-3.6.0M7-20140505163128/repositoryunittests/"/>
+<repository location="http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M3-20161031000121/repositoryunittests/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.datatools.enablement.sdk.feature.feature.group" version="0.0.0"/>
-<repository location="http://download.eclipse.org/datatools/downloads/drops/M_updates_1.12.0/"/>
+<repository location="http://download.eclipse.org/datatools/downloads/drops/N_updates_1.12.0/v20140606-1324/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.license.feature.group" version="0.0.0"/>
<repository location="http://download.eclipse.org/cbi/updates/license"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
-<unit id="org.eclipse.sdk.ide" version="4.4.0.I20140501-0200"/>
-<repository location="http://download.eclipse.org/eclipse/updates/4.4milestones"/>
+<unit id="org.eclipse.sdk.ide" version="0.0.0"/>
+<repository location="http://download.eclipse.org/eclipse/updates/4.7milestones"/>
+</location>
+<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
+<unit id="org.eclipse.jpt.jpa.feature.feature.group" version="3.5.0.v201610131832"/>
+<repository location="http://download.eclipse.org/releases/oxygen"/>
</location>
</locations>
</target>
diff --git a/development/org.eclipse.libra.repository/pom.xml b/development/org.eclipse.libra.repository/pom.xml
index c79f582..1dbffae 100644
--- a/development/org.eclipse.libra.repository/pom.xml
+++ b/development/org.eclipse.libra.repository/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.facet.feature.source/feature.xml b/features/org.eclipse.libra.facet.feature.source/feature.xml
index 7bf7196..46c10bc 100644
--- a/features/org.eclipse.libra.facet.feature.source/feature.xml
+++ b/features/org.eclipse.libra.facet.feature.source/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.facet.feature.source"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.facet.feature.source/pom.xml b/features/org.eclipse.libra.facet.feature.source/pom.xml
index 1aadea0..6d47253 100644
--- a/features/org.eclipse.libra.facet.feature.source/pom.xml
+++ b/features/org.eclipse.libra.facet.feature.source/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.facet.feature/feature.xml b/features/org.eclipse.libra.facet.feature/feature.xml
index 636cc54..e14d5fc 100644
--- a/features/org.eclipse.libra.facet.feature/feature.xml
+++ b/features/org.eclipse.libra.facet.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.facet.feature"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.facet.feature/pom.xml b/features/org.eclipse.libra.facet.feature/pom.xml
index f5e8d3b..30adfec 100644
--- a/features/org.eclipse.libra.facet.feature/pom.xml
+++ b/features/org.eclipse.libra.facet.feature/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.framework.editor.feature.source/feature.xml b/features/org.eclipse.libra.framework.editor.feature.source/feature.xml
index 9b2d174..c107252 100644
--- a/features/org.eclipse.libra.framework.editor.feature.source/feature.xml
+++ b/features/org.eclipse.libra.framework.editor.feature.source/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.framework.editor.feature.source"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.framework.editor.feature.source/pom.xml b/features/org.eclipse.libra.framework.editor.feature.source/pom.xml
index c0c869a..f1b4a17 100644
--- a/features/org.eclipse.libra.framework.editor.feature.source/pom.xml
+++ b/features/org.eclipse.libra.framework.editor.feature.source/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.framework.editor.feature/feature.xml b/features/org.eclipse.libra.framework.editor.feature/feature.xml
index 94bd631..bd574f0 100644
--- a/features/org.eclipse.libra.framework.editor.feature/feature.xml
+++ b/features/org.eclipse.libra.framework.editor.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.framework.editor.feature"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.framework.editor.feature/pom.xml b/features/org.eclipse.libra.framework.editor.feature/pom.xml
index 74b2eb7..9c5162a 100644
--- a/features/org.eclipse.libra.framework.editor.feature/pom.xml
+++ b/features/org.eclipse.libra.framework.editor.feature/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.framework.feature.source/feature.xml b/features/org.eclipse.libra.framework.feature.source/feature.xml
index 5ee3da4..3ad702b 100644
--- a/features/org.eclipse.libra.framework.feature.source/feature.xml
+++ b/features/org.eclipse.libra.framework.feature.source/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.framework.feature.source"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.framework.feature.source/pom.xml b/features/org.eclipse.libra.framework.feature.source/pom.xml
index f2647d7..ed6f9e2 100644
--- a/features/org.eclipse.libra.framework.feature.source/pom.xml
+++ b/features/org.eclipse.libra.framework.feature.source/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.framework.feature/feature.xml b/features/org.eclipse.libra.framework.feature/feature.xml
index 4ddcc8c..34829c2 100644
--- a/features/org.eclipse.libra.framework.feature/feature.xml
+++ b/features/org.eclipse.libra.framework.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.framework.feature"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.framework.feature/pom.xml b/features/org.eclipse.libra.framework.feature/pom.xml
index b2a3a5d..dd36df8 100644
--- a/features/org.eclipse.libra.framework.feature/pom.xml
+++ b/features/org.eclipse.libra.framework.feature/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.warproducts.feature.source/feature.xml b/features/org.eclipse.libra.warproducts.feature.source/feature.xml
index 18a8ff7..3f3ab39 100644
--- a/features/org.eclipse.libra.warproducts.feature.source/feature.xml
+++ b/features/org.eclipse.libra.warproducts.feature.source/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.warproducts.feature.source"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.warproducts.feature.source/pom.xml b/features/org.eclipse.libra.warproducts.feature.source/pom.xml
index 86f625b..038af1e 100644
--- a/features/org.eclipse.libra.warproducts.feature.source/pom.xml
+++ b/features/org.eclipse.libra.warproducts.feature.source/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/features/org.eclipse.libra.warproducts.feature/feature.xml b/features/org.eclipse.libra.warproducts.feature/feature.xml
index cb70cf6..a612a6d 100644
--- a/features/org.eclipse.libra.warproducts.feature/feature.xml
+++ b/features/org.eclipse.libra.warproducts.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.libra.warproducts.feature"
label="%featureName"
- version="0.3.2.qualifier"
+ version="0.3.3.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.libra.warproducts.feature/pom.xml b/features/org.eclipse.libra.warproducts.feature/pom.xml
index cc154b8..269e47e 100644
--- a/features/org.eclipse.libra.warproducts.feature/pom.xml
+++ b/features/org.eclipse.libra.warproducts.feature/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.facet.ui/.classpath b/plugins/org.eclipse.libra.facet.ui/.classpath
index 2d1a430..b862a29 100644
--- a/plugins/org.eclipse.libra.facet.ui/.classpath
+++ b/plugins/org.eclipse.libra.facet.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.facet.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.facet.ui/.settings/org.eclipse.jdt.core.prefs
index d99b4d0..295926d 100644
--- a/plugins/org.eclipse.libra.facet.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.facet.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Jan 11 18:34:56 EET 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.facet.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.facet.ui/META-INF/MANIFEST.MF
index 2cf9485..a1aff50 100644
--- a/plugins/org.eclipse.libra.facet.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.facet.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.facet.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Require-Bundle: org.eclipse.core.resources;bundle-version="3.5.0",
org.eclipse.core.runtime;bundle-version="3.5.0",
org.eclipse.core.databinding;bundle-version="1.2.0",
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.core.resources;bundle-version="3.5.0",
org.eclipse.pde.core;bundle-version="3.6.0",
org.eclipse.jface.databinding;bundle-version="1.3.0",
org.eclipse.libra.facet;bundle-version="0.1.0"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.libra.facet.ui.operations
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.libra.facet.ui/pom.xml b/plugins/org.eclipse.libra.facet.ui/pom.xml
index c0bde10..fb7d250 100644
--- a/plugins/org.eclipse.libra.facet.ui/pom.xml
+++ b/plugins/org.eclipse.libra.facet.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.facet/.classpath b/plugins/org.eclipse.libra.facet/.classpath
index 2d1a430..b862a29 100644
--- a/plugins/org.eclipse.libra.facet/.classpath
+++ b/plugins/org.eclipse.libra.facet/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.facet/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.facet/.settings/org.eclipse.jdt.core.prefs
index 8a87b68..bb35fa0 100644
--- a/plugins/org.eclipse.libra.facet/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.facet/.settings/org.eclipse.jdt.core.prefs
@@ -1,12 +1,11 @@
-#Mon Jul 25 11:43:09 EEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.facet/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.facet/META-INF/MANIFEST.MF
index 3fe5ef6..04400d8 100644
--- a/plugins/org.eclipse.libra.facet/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.facet/META-INF/MANIFEST.MF
@@ -3,18 +3,18 @@ Eclipse-ExtensibleAPI: true
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.facet;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.facet.internal.LibraFacetPlugin
Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.core.resources;bundle-version="3.5.0",
- org.eclipse.core.runtime;bundle-version="3.5.0",
- org.eclipse.jdt.core;bundle-version="3.5.0",
- org.eclipse.pde.core;bundle-version="3.7.0",
+Require-Bundle: org.eclipse.core.databinding;bundle-version="1.6.0",
+ org.eclipse.core.resources;bundle-version="3.12.0",
+ org.eclipse.core.runtime;bundle-version="3.12.0",
+ org.eclipse.jdt.core;bundle-version="3.12.0",
+ org.eclipse.pde.core;bundle-version="3.11.0",
org.eclipse.wst.common.modulecore;bundle-version="1.2.0",
org.eclipse.wst.common.project.facet.core;bundle-version="1.4.0",
- org.eclipse.core.databinding;bundle-version="1.2.0",
org.eclipse.jst.common.project.facet.core;bundle-version="1.4.0"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.libra.facet
diff --git a/plugins/org.eclipse.libra.facet/pom.xml b/plugins/org.eclipse.libra.facet/pom.xml
index 54f71d5..0dc8b7c 100644
--- a/plugins/org.eclipse.libra.facet/pom.xml
+++ b/plugins/org.eclipse.libra.facet/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.core/.classpath b/plugins/org.eclipse.libra.framework.core/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.core/.classpath
+++ b/plugins/org.eclipse.libra.framework.core/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.core/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.core/.settings/org.eclipse.jdt.core.prefs
index 64203b9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.core/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.core/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 22 10:43:27 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.core/META-INF/MANIFEST.MF
index 628f580..dc07b49 100644
--- a/plugins/org.eclipse.libra.framework.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.core/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.core;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.core.FrameworkCorePlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -22,7 +22,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.wst.web;bundle-version="1.1.401",
org.eclipse.wst.common.project.facet.core;bundle-version="1.4.102",
org.eclipse.libra.framework.editor.core;bundle-version="[0.1.0,2.0.0)";visibility:=reexport
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.core.resources,
org.eclipse.debug.core,
diff --git a/plugins/org.eclipse.libra.framework.core/pom.xml b/plugins/org.eclipse.libra.framework.core/pom.xml
index a5a2100..eb7e047 100644
--- a/plugins/org.eclipse.libra.framework.core/pom.xml
+++ b/plugins/org.eclipse.libra.framework.core/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.editor.core/.classpath b/plugins/org.eclipse.libra.framework.editor.core/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.editor.core/.classpath
+++ b/plugins/org.eclipse.libra.framework.editor.core/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.editor.core/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.editor.core/.settings/org.eclipse.jdt.core.prefs
index fae65f9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.editor.core/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.editor.core/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Wed Oct 05 20:16:09 EEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.editor.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.editor.core/META-INF/MANIFEST.MF
index 2409319..4ae1769 100644
--- a/plugins/org.eclipse.libra.framework.editor.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.editor.core/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.framework.editor.core
-Bundle-Version: 0.3.2.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-Version: 0.3.3.qualifier
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.libra.framework.editor.core;version="0.1.0
",org.eclipse.libra.framework.editor.core.model;version="0.1.0"
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)"
diff --git a/plugins/org.eclipse.libra.framework.editor.core/pom.xml b/plugins/org.eclipse.libra.framework.editor.core/pom.xml
index e49c745..0effc93 100644
--- a/plugins/org.eclipse.libra.framework.editor.core/pom.xml
+++ b/plugins/org.eclipse.libra.framework.editor.core/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.editor.integration/.classpath b/plugins/org.eclipse.libra.framework.editor.integration/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.editor.integration/.classpath
+++ b/plugins/org.eclipse.libra.framework.editor.integration/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.editor.integration/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.editor.integration/.settings/org.eclipse.jdt.core.prefs
index 6237a6a..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.editor.integration/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.editor.integration/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Wed Oct 05 20:14:59 EEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.editor.integration/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.editor.integration/META-INF/MANIFEST.MF
index 78beab6..6b084e4 100644
--- a/plugins/org.eclipse.libra.framework.editor.integration/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.editor.integration/META-INF/MANIFEST.MF
@@ -2,10 +2,10 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.framework.editor.integration;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.debug.core
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.libra.framework.editor.core;version="0.1.0",
org.eclipse.libra.framework.editor.core.model;version="0.1.0",
org.osgi.jmx.framework;version="[1.0.0,2.0.0)"
diff --git a/plugins/org.eclipse.libra.framework.editor.integration/pom.xml b/plugins/org.eclipse.libra.framework.editor.integration/pom.xml
index e201c80..3fd98f9 100644
--- a/plugins/org.eclipse.libra.framework.editor.integration/pom.xml
+++ b/plugins/org.eclipse.libra.framework.editor.integration/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.editor.ui/.classpath b/plugins/org.eclipse.libra.framework.editor.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.editor.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.editor.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.editor.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.editor.ui/.settings/org.eclipse.jdt.core.prefs
index 5ef1156..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.editor.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.editor.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Wed Oct 05 20:16:27 EEST 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.editor.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.editor.ui/META-INF/MANIFEST.MF
index 092c4d1..d42ce2e 100644
--- a/plugins/org.eclipse.libra.framework.editor.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.editor.ui/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.framework.editor.ui
-Bundle-Version: 0.3.2.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-Version: 0.3.3.qualifier
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.libra.framework.editor.ui.console;version=
"0.1.0"; uses:="org.eclipse.libra.framework.editor.ui.internal.overvi
ew, org.eclipse.libra.framework.editor.ui.internal, org.eclipse.swt
diff --git a/plugins/org.eclipse.libra.framework.editor.ui/pom.xml b/plugins/org.eclipse.libra.framework.editor.ui/pom.xml
index 9062352..ae3c1f3 100644
--- a/plugins/org.eclipse.libra.framework.editor.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.editor.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.equinox.ui/.classpath b/plugins/org.eclipse.libra.framework.equinox.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.equinox.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.equinox.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.equinox.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.equinox.ui/.settings/org.eclipse.jdt.core.prefs
index 87e641f..d000edc 100644
--- a/plugins/org.eclipse.libra.framework.equinox.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.equinox.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,3 @@
-#Sat Oct 16 21:03:45 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=error
@@ -9,9 +8,9 @@ org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=disabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -69,6 +68,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.incompatibleJDKLevel=warning
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/plugins/org.eclipse.libra.framework.equinox.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.equinox.ui/META-INF/MANIFEST.MF
index 7145e3d..b0bb797 100644
--- a/plugins/org.eclipse.libra.framework.equinox.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.equinox.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.equinox.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.equinox.ui.EquinoxUIPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -26,4 +26,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.libra.framework.ui,
org.eclipse.libra.framework.equinox
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.libra.framework.equinox.ui/pom.xml b/plugins/org.eclipse.libra.framework.equinox.ui/pom.xml
index 68586d3..eed0429 100644
--- a/plugins/org.eclipse.libra.framework.equinox.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.equinox.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.equinox/.classpath b/plugins/org.eclipse.libra.framework.equinox/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.equinox/.classpath
+++ b/plugins/org.eclipse.libra.framework.equinox/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.equinox/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.equinox/.settings/org.eclipse.jdt.core.prefs
index 64203b9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.equinox/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.equinox/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 22 10:43:27 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.equinox/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.equinox/META-INF/MANIFEST.MF
index 955187b..5e7e08d 100644
--- a/plugins/org.eclipse.libra.framework.equinox/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.equinox/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.equinox;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.equinox.EquinoxPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.wst.common.modulecore,
org.eclipse.equinox.frameworkadmin,
org.eclipse.libra.framework.core
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.core.resources,
org.eclipse.debug.core,
diff --git a/plugins/org.eclipse.libra.framework.equinox/pom.xml b/plugins/org.eclipse.libra.framework.equinox/pom.xml
index bf9b3cb..fc17a5c 100644
--- a/plugins/org.eclipse.libra.framework.equinox/pom.xml
+++ b/plugins/org.eclipse.libra.framework.equinox/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.felix.ui/.classpath b/plugins/org.eclipse.libra.framework.felix.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.felix.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.felix.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.felix.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.felix.ui/.settings/org.eclipse.jdt.core.prefs
index 87e641f..d000edc 100644
--- a/plugins/org.eclipse.libra.framework.felix.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.felix.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,3 @@
-#Sat Oct 16 21:03:45 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=error
@@ -9,9 +8,9 @@ org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=disabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -69,6 +68,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.incompatibleJDKLevel=warning
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/plugins/org.eclipse.libra.framework.felix.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.felix.ui/META-INF/MANIFEST.MF
index eec3da8..92284bc 100644
--- a/plugins/org.eclipse.libra.framework.felix.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.felix.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.felix.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.felix.ui.FelixUIPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -26,4 +26,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.libra.framework.core,
org.eclipse.libra.framework.ui
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.libra.framework.felix.ui/pom.xml b/plugins/org.eclipse.libra.framework.felix.ui/pom.xml
index 2562749..77db4a5 100644
--- a/plugins/org.eclipse.libra.framework.felix.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.felix.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.felix/.classpath b/plugins/org.eclipse.libra.framework.felix/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.felix/.classpath
+++ b/plugins/org.eclipse.libra.framework.felix/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.felix/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.felix/.settings/org.eclipse.jdt.core.prefs
index 64203b9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.felix/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.felix/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 22 10:43:27 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.felix/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.felix/META-INF/MANIFEST.MF
index c48cb5c..006f23c 100644
--- a/plugins/org.eclipse.libra.framework.felix/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.felix/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.felix;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.felix.FelixPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.wst.common.modulecore,
org.eclipse.equinox.frameworkadmin,
org.eclipse.libra.framework.core
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.core.resources,
org.eclipse.debug.core,
diff --git a/plugins/org.eclipse.libra.framework.felix/pom.xml b/plugins/org.eclipse.libra.framework.felix/pom.xml
index e97c869..e4c5219 100644
--- a/plugins/org.eclipse.libra.framework.felix/pom.xml
+++ b/plugins/org.eclipse.libra.framework.felix/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.jonas.ui/.classpath b/plugins/org.eclipse.libra.framework.jonas.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.jonas.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.jonas.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.jonas.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.jonas.ui/.settings/org.eclipse.jdt.core.prefs
index 87e641f..d000edc 100644
--- a/plugins/org.eclipse.libra.framework.jonas.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.jonas.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,3 @@
-#Sat Oct 16 21:03:45 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=error
@@ -9,9 +8,9 @@ org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=disabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -69,6 +68,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.incompatibleJDKLevel=warning
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/plugins/org.eclipse.libra.framework.jonas.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.jonas.ui/META-INF/MANIFEST.MF
index d4d5d9e..efd302a 100644
--- a/plugins/org.eclipse.libra.framework.jonas.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.jonas.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.jonas.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.jonas.ui.JonasUIPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -26,4 +26,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.libra.framework.core,
org.eclipse.libra.framework.ui
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.libra.framework.jonas.ui/pom.xml b/plugins/org.eclipse.libra.framework.jonas.ui/pom.xml
index 91477a9..623af2d 100644
--- a/plugins/org.eclipse.libra.framework.jonas.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.jonas.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.jonas/.classpath b/plugins/org.eclipse.libra.framework.jonas/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.jonas/.classpath
+++ b/plugins/org.eclipse.libra.framework.jonas/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.jonas/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.jonas/.settings/org.eclipse.jdt.core.prefs
index 64203b9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.jonas/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.jonas/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 22 10:43:27 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.jonas/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.jonas/META-INF/MANIFEST.MF
index 4f1bf18..db6c27b 100644
--- a/plugins/org.eclipse.libra.framework.jonas/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.jonas/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.jonas;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.jonas.JonasPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -23,7 +23,7 @@ Require-Bundle: org.eclipse.ui,
org.apache.ant,
org.eclipse.ant.core,
org.eclipse.ant.launching
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.core.resources,
org.eclipse.debug.core,
diff --git a/plugins/org.eclipse.libra.framework.jonas/pom.xml b/plugins/org.eclipse.libra.framework.jonas/pom.xml
index 3ca67c4..4380ca6 100644
--- a/plugins/org.eclipse.libra.framework.jonas/pom.xml
+++ b/plugins/org.eclipse.libra.framework.jonas/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish.ui/.classpath b/plugins/org.eclipse.libra.framework.knopflerfish.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.knopflerfish.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.knopflerfish.ui/.settings/org.eclipse.jdt.core.prefs
index 87e641f..d000edc 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.knopflerfish.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,3 @@
-#Sat Oct 16 21:03:45 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=error
@@ -9,9 +8,9 @@ org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=disabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -69,6 +68,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.incompatibleJDKLevel=warning
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.knopflerfish.ui/META-INF/MANIFEST.MF
index 7540e80..67fbf60 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.knopflerfish.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.knopflerfish.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.knopflerfish.ui.KnopflerfishUIPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -25,4 +25,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.libra.framework.ui,
org.eclipse.libra.framework.knopflerfish
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish.ui/pom.xml b/plugins/org.eclipse.libra.framework.knopflerfish.ui/pom.xml
index b2005b6..9e69e27 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.knopflerfish.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish/.classpath b/plugins/org.eclipse.libra.framework.knopflerfish/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish/.classpath
+++ b/plugins/org.eclipse.libra.framework.knopflerfish/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.knopflerfish/.settings/org.eclipse.jdt.core.prefs
index 64203b9..0c68a61 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.knopflerfish/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Fri Oct 22 10:43:27 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.knopflerfish/META-INF/MANIFEST.MF
index 17089ad..64001bb 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.knopflerfish/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.knopflerfish;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.knopflerfish.KnopflerfishPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.wst.common.modulecore,
org.eclipse.equinox.frameworkadmin,
org.eclipse.libra.framework.core
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.core.resources,
org.eclipse.debug.core,
diff --git a/plugins/org.eclipse.libra.framework.knopflerfish/pom.xml b/plugins/org.eclipse.libra.framework.knopflerfish/pom.xml
index 098ff88..0e28c44 100644
--- a/plugins/org.eclipse.libra.framework.knopflerfish/pom.xml
+++ b/plugins/org.eclipse.libra.framework.knopflerfish/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.framework.ui/.classpath b/plugins/org.eclipse.libra.framework.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.framework.ui/.classpath
+++ b/plugins/org.eclipse.libra.framework.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.framework.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.framework.ui/.settings/org.eclipse.jdt.core.prefs
index 87e641f..d000edc 100644
--- a/plugins/org.eclipse.libra.framework.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.framework.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,4 +1,3 @@
-#Sat Oct 16 21:03:45 EEST 2010
eclipse.preferences.version=1
org.eclipse.jdt.core.builder.cleanOutputFolder=clean
org.eclipse.jdt.core.builder.duplicateResourceTask=error
@@ -9,9 +8,9 @@ org.eclipse.jdt.core.circularClasspath=error
org.eclipse.jdt.core.classpath.exclusionPatterns=disabled
org.eclipse.jdt.core.classpath.multipleOutputLocations=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -69,6 +68,6 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenImplementingAbstract=di
org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disabled
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=error
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.incompatibleJDKLevel=warning
org.eclipse.jdt.core.incompleteClasspath=error
diff --git a/plugins/org.eclipse.libra.framework.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.framework.ui/META-INF/MANIFEST.MF
index 17fcda1..d0c2b5f 100644
--- a/plugins/org.eclipse.libra.framework.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.framework.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.libra.framework.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Bundle-Activator: org.eclipse.libra.framework.ui.FrameworkUIPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -28,7 +28,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.libra.framework.core,
org.eclipse.gef
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.libra.framework.editor.ui.console;version="[0.1.0,2.0.0)",
org.eclipse.libra.framework.editor.ui.dependencies;version="[0.1.0,2.0.0)",
org.eclipse.libra.framework.editor.ui.overview;version="[0.1.0,2.0.0)"
diff --git a/plugins/org.eclipse.libra.framework.ui/pom.xml b/plugins/org.eclipse.libra.framework.ui/pom.xml
index cb96dae..e0d18ac 100644
--- a/plugins/org.eclipse.libra.framework.ui/pom.xml
+++ b/plugins/org.eclipse.libra.framework.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.warproducts.core/.classpath b/plugins/org.eclipse.libra.warproducts.core/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.warproducts.core/.classpath
+++ b/plugins/org.eclipse.libra.warproducts.core/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.warproducts.core/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.warproducts.core/.settings/org.eclipse.jdt.core.prefs
index 0c298fa..9d249f4 100644
--- a/plugins/org.eclipse.libra.warproducts.core/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.warproducts.core/.settings/org.eclipse.jdt.core.prefs
@@ -9,9 +9,9 @@ org.eclipse.jdt.core.compiler.annotation.nullable=org.eclipse.jdt.annotation.Nul
org.eclipse.jdt.core.compiler.annotation.nullable.secondary=
org.eclipse.jdt.core.compiler.annotation.nullanalysis=disabled
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -102,7 +102,7 @@ org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedTypeParameter=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/plugins/org.eclipse.libra.warproducts.core/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.warproducts.core/META-INF/MANIFEST.MF
index dbbf276..2cd37c7 100644
--- a/plugins/org.eclipse.libra.warproducts.core/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.warproducts.core/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.warproducts.core
-Bundle-Version: 0.3.2.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-Version: 0.3.3.qualifier
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Export-Package: org.eclipse.libra.warproducts.core;x-friends:="org.ecl
ipse.libra.warproducts.core.test,org.eclipse.libra.warproducts.ui",or
diff --git a/plugins/org.eclipse.libra.warproducts.core/pom.xml b/plugins/org.eclipse.libra.warproducts.core/pom.xml
index 7014881..c908805 100644
--- a/plugins/org.eclipse.libra.warproducts.core/pom.xml
+++ b/plugins/org.eclipse.libra.warproducts.core/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.warproducts.core/src/org/eclipse/libra/warproducts/core/WARProductExportOperation.java b/plugins/org.eclipse.libra.warproducts.core/src/org/eclipse/libra/warproducts/core/WARProductExportOperation.java
index ab2be78..c6ce81b 100644
--- a/plugins/org.eclipse.libra.warproducts.core/src/org/eclipse/libra/warproducts/core/WARProductExportOperation.java
+++ b/plugins/org.eclipse.libra.warproducts.core/src/org/eclipse/libra/warproducts/core/WARProductExportOperation.java
@@ -99,7 +99,9 @@ public class WARProductExportOperation extends FeatureExportOperation {
this.root = root;
}
- protected IStatus run( final IProgressMonitor monitor ) {
+ protected IStatus run( final IProgressMonitor monitor0 ) {
+ final SubMonitor monitor = SubMonitor.convert( monitor0 );
+
IStatus result = null;
String[][] configurations = fInfo.targets;
if( configurations == null ) {
@@ -129,7 +131,7 @@ public class WARProductExportOperation extends FeatureExportOperation {
null,
featureLocation,
configurations,
- new SubProgressMonitor( monitor, 8 ) );
+ monitor.split( 8 ) );
} catch( final IOException e ) {
PDECore.log( e );
} catch( final InvocationTargetException e ) {
@@ -154,7 +156,7 @@ public class WARProductExportOperation extends FeatureExportOperation {
PDECore.log( e );
}
}
- cleanup( null, new SubProgressMonitor( monitor, 1 ) );
+ cleanup( monitor.split ( 1 ) );
}
if( hasAntErrors() ) {
String compilationErrors
diff --git a/plugins/org.eclipse.libra.warproducts.help/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.warproducts.help/META-INF/MANIFEST.MF
index d9331aa..fccee9e 100644
--- a/plugins/org.eclipse.libra.warproducts.help/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.warproducts.help/META-INF/MANIFEST.MF
@@ -3,6 +3,6 @@ Bundle-ManifestVersion: 2
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.warproducts.help;singleton:=true
-Bundle-Version: 0.3.2.qualifier
-Require-Bundle: org.eclipse.help;bundle-version="3.5.0"
+Bundle-Version: 0.3.3.qualifier
+Require-Bundle: org.eclipse.help;bundle-version="3.8.0"
Bundle-Vendor: %Bundle-Vendor
diff --git a/plugins/org.eclipse.libra.warproducts.help/pom.xml b/plugins/org.eclipse.libra.warproducts.help/pom.xml
index 546cc7c..96a8842 100644
--- a/plugins/org.eclipse.libra.warproducts.help/pom.xml
+++ b/plugins/org.eclipse.libra.warproducts.help/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/plugins/org.eclipse.libra.warproducts.ui/.classpath b/plugins/org.eclipse.libra.warproducts.ui/.classpath
index 64c5e31..eca7bdb 100644
--- a/plugins/org.eclipse.libra.warproducts.ui/.classpath
+++ b/plugins/org.eclipse.libra.warproducts.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.libra.warproducts.ui/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.libra.warproducts.ui/.settings/org.eclipse.jdt.core.prefs
index 981bf0d..9c9ca70 100644
--- a/plugins/org.eclipse.libra.warproducts.ui/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.libra.warproducts.ui/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -73,7 +73,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/plugins/org.eclipse.libra.warproducts.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.libra.warproducts.ui/META-INF/MANIFEST.MF
index cfa531f..76739a7 100644
--- a/plugins/org.eclipse.libra.warproducts.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.libra.warproducts.ui/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.warproducts.ui;singleton:=true
-Bundle-Version: 0.3.2.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-Version: 0.3.3.qualifier
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui;bundle-version="3.7.0",
org.eclipse.pde.ui;bundle-version="3.6.0",
diff --git a/plugins/org.eclipse.libra.warproducts.ui/pom.xml b/plugins/org.eclipse.libra.warproducts.ui/pom.xml
index 08e5b63..8e77443 100644
--- a/plugins/org.eclipse.libra.warproducts.ui/pom.xml
+++ b/plugins/org.eclipse.libra.warproducts.ui/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/tests/org.eclipse.libra.facet.test/.classpath b/tests/org.eclipse.libra.facet.test/.classpath
index 288a780..43b9862 100644
--- a/tests/org.eclipse.libra.facet.test/.classpath
+++ b/tests/org.eclipse.libra.facet.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="target/classes"/>
diff --git a/tests/org.eclipse.libra.facet.test/.settings/org.eclipse.jdt.core.prefs b/tests/org.eclipse.libra.facet.test/.settings/org.eclipse.jdt.core.prefs
index b0788c3..295926d 100644
--- a/tests/org.eclipse.libra.facet.test/.settings/org.eclipse.jdt.core.prefs
+++ b/tests/org.eclipse.libra.facet.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,7 @@
-#Tue Jan 11 18:35:44 EET 2011
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
diff --git a/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF b/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
index e9e7446..b6998fe 100644
--- a/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.libra.facet.test/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.facet.test
-Bundle-Version: 0.3.2.qualifier
+Bundle-Version: 0.3.3.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.jdt.core,
org.eclipse.debug.core,
@@ -24,6 +24,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.wst.xsd.core
Bundle-Vendor: %Bundle-Vendor
Import-Package: org.junit;version="4.5.0"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
diff --git a/tests/org.eclipse.libra.facet.test/pom.xml b/tests/org.eclipse.libra.facet.test/pom.xml
index 7e23775..685f3c7 100644
--- a/tests/org.eclipse.libra.facet.test/pom.xml
+++ b/tests/org.eclipse.libra.facet.test/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>
diff --git a/tests/org.eclipse.libra.warproducts.core.test/.classpath b/tests/org.eclipse.libra.warproducts.core.test/.classpath
index 64c5e31..eca7bdb 100644
--- a/tests/org.eclipse.libra.warproducts.core.test/.classpath
+++ b/tests/org.eclipse.libra.warproducts.core.test/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.8"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/tests/org.eclipse.libra.warproducts.core.test/.settings/org.eclipse.jdt.core.prefs b/tests/org.eclipse.libra.warproducts.core.test/.settings/org.eclipse.jdt.core.prefs
index 981bf0d..9c9ca70 100644
--- a/tests/org.eclipse.libra.warproducts.core.test/.settings/org.eclipse.jdt.core.prefs
+++ b/tests/org.eclipse.libra.warproducts.core.test/.settings/org.eclipse.jdt.core.prefs
@@ -1,8 +1,8 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -73,7 +73,7 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.8
org.eclipse.jdt.core.formatter.align_type_members_on_columns=false
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_allocation_expression=82
org.eclipse.jdt.core.formatter.alignment_for_arguments_in_annotation=0
diff --git a/tests/org.eclipse.libra.warproducts.core.test/META-INF/MANIFEST.MF b/tests/org.eclipse.libra.warproducts.core.test/META-INF/MANIFEST.MF
index 7a137bf..642ffd6 100644
--- a/tests/org.eclipse.libra.warproducts.core.test/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.libra.warproducts.core.test/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.libra.warproducts.core.test
-Bundle-Version: 0.3.2.qualifier
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-Version: 0.3.3.qualifier
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Require-Bundle: org.junit;bundle-version="3.8.2",
org.eclipse.libra.warproducts.core;bundle-version="0.1.0",
diff --git a/tests/org.eclipse.libra.warproducts.core.test/pom.xml b/tests/org.eclipse.libra.warproducts.core.test/pom.xml
index 2404817..d2804cc 100644
--- a/tests/org.eclipse.libra.warproducts.core.test/pom.xml
+++ b/tests/org.eclipse.libra.warproducts.core.test/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>org.eclipse.libra_parent</artifactId>
<groupId>org.eclipse.libra</groupId>
- <version>0.3.2-SNAPSHOT</version>
+ <version>0.3.3-SNAPSHOT</version>
<relativePath>../../development/org.eclipse.libra.releng/pom.xml</relativePath>
</parent>

Back to the top