Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchsaad2016-05-25 08:26:47 -0400
committerchsaad2016-05-25 08:26:47 -0400
commita6a4dec9b11cb7403a4851d590577e5f8c2979ea (patch)
tree37303166d2c33771d23b72692e7ea5c9dd1f6ba7
parent12ef4da5129ecc4ca6ca2243145dc7ee64f900f6 (diff)
downloadorg.eclipse.soa.jwt-a6a4dec9b11cb7403a4851d590577e5f8c2979ea.tar.gz
org.eclipse.soa.jwt-a6a4dec9b11cb7403a4851d590577e5f8c2979ea.tar.xz
org.eclipse.soa.jwt-a6a4dec9b11cb7403a4851d590577e5f8c2979ea.zip
new test for dependencies
-rw-r--r--releng/mvn-jwt-builder/pom.xml11
-rw-r--r--releng/org.eclipse.jwt.test.feature/feature.xml12
2 files changed, 15 insertions, 8 deletions
diff --git a/releng/mvn-jwt-builder/pom.xml b/releng/mvn-jwt-builder/pom.xml
index c24df77b..ab82ec8c 100644
--- a/releng/mvn-jwt-builder/pom.xml
+++ b/releng/mvn-jwt-builder/pom.xml
@@ -126,6 +126,17 @@
<configuration>
<includePackedArtifacts>false</includePackedArtifacts>
+
+ <dependency-resolution>
+ <extraRequirements>
+ <requirement>
+ <type>eclipse-feature</type>
+ <id>org.eclipse.jwt.test.feature</id>
+ <versionRange>0.0.0</versionRange>
+ </requirement>
+ </extraRequirements>
+ </dependency-resolution>
+
</configuration>
</plugin>
diff --git a/releng/org.eclipse.jwt.test.feature/feature.xml b/releng/org.eclipse.jwt.test.feature/feature.xml
index c1aee96e..23835a07 100644
--- a/releng/org.eclipse.jwt.test.feature/feature.xml
+++ b/releng/org.eclipse.jwt.test.feature/feature.xml
@@ -17,6 +17,10 @@
[Enter License Description here.]
</license>
+ <includes
+ id="org.eclipse.jwt.feature"
+ version="0.0.0"/>
+
<requires>
<import plugin="org.junit"/>
<import plugin="org.eclipse.core.runtime" version="3.5.0" match="greaterOrEqual"/>
@@ -27,14 +31,6 @@
<import plugin="org.eclipse.emf.common" version="2.4.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.emf.edit" version="2.4.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.gef" version="3.4.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.jwt.feature" version="1.6.0.qualifier"/>
</requires>
- <plugin
- id="org.eclipse.jwt.tests"
- download-size="0"
- install-size="0"
- version="1.6.0.qualifier"
- unpack="false"/>
-
</feature>

Back to the top