Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: d4226925bdd92a2f687bf5a26e02269ab23bbfd2 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Automatic-Module-Name: org.eclipse.jgit
Bundle-SymbolicName: org.eclipse.jgit
Bundle-Version: 5.3.3.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.jgit.annotations;version="5.3.3",
 org.eclipse.jgit.api;version="5.3.3";
  uses:="org.eclipse.jgit.revwalk,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.diff,
   org.eclipse.jgit.util,
   org.eclipse.jgit.notes,
   org.eclipse.jgit.dircache,
   org.eclipse.jgit.api.errors,
   org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.blame,
   org.eclipse.jgit.submodule,
   org.eclipse.jgit.transport,
   org.eclipse.jgit.merge",
 org.eclipse.jgit.api.errors;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.errors",
 org.eclipse.jgit.attributes;version="5.3.3",
 org.eclipse.jgit.blame;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.diff",
 org.eclipse.jgit.diff;version="5.3.3";
  uses:="org.eclipse.jgit.patch,
   org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.util",
 org.eclipse.jgit.dircache;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.util,
   org.eclipse.jgit.events,
   org.eclipse.jgit.attributes",
 org.eclipse.jgit.errors;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.internal.storage.pack,
   org.eclipse.jgit.transport,
   org.eclipse.jgit.dircache",
 org.eclipse.jgit.events;version="5.3.3";uses:="org.eclipse.jgit.lib",
 org.eclipse.jgit.fnmatch;version="5.3.3",
 org.eclipse.jgit.gitrepo;version="5.3.3";
  uses:="org.eclipse.jgit.api,
   org.eclipse.jgit.lib,
   org.eclipse.jgit.revwalk,
   org.xml.sax.helpers,
   org.xml.sax",
 org.eclipse.jgit.gitrepo.internal;version="5.3.3";x-internal:=true,
 org.eclipse.jgit.hooks;version="5.3.3";uses:="org.eclipse.jgit.lib",
 org.eclipse.jgit.ignore;version="5.3.3",
 org.eclipse.jgit.ignore.internal;version="5.3.3";x-friends:="org.eclipse.jgit.test",
 org.eclipse.jgit.internal;version="5.3.3";x-friends:="org.eclipse.jgit.test,org.eclipse.jgit.http.test",
 org.eclipse.jgit.internal.fsck;version="5.3.3";x-friends:="org.eclipse.jgit.test",
 org.eclipse.jgit.internal.ketch;version="5.3.3";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
 org.eclipse.jgit.internal.revwalk;version="5.3.3";x-internal:=true,
 org.eclipse.jgit.internal.storage.dfs;version="5.3.3";
  x-friends:="org.eclipse.jgit.test,
   org.eclipse.jgit.http.server,
   org.eclipse.jgit.http.test,
   org.eclipse.jgit.lfs.test",
 org.eclipse.jgit.internal.storage.file;version="5.3.3";
  x-friends:="org.eclipse.jgit.test,
   org.eclipse.jgit.junit,
   org.eclipse.jgit.junit.http,
   org.eclipse.jgit.http.server,
   org.eclipse.jgit.lfs,
   org.eclipse.jgit.pgm,
   org.eclipse.jgit.pgm.test,
   org.eclipse.jgit.ssh.apache",
 org.eclipse.jgit.internal.storage.io;version="5.3.3";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
 org.eclipse.jgit.internal.storage.pack;version="5.3.3";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
 org.eclipse.jgit.internal.storage.reftable;version="5.3.3";
  x-friends:="org.eclipse.jgit.http.test,
   org.eclipse.jgit.junit,
   org.eclipse.jgit.test,
   org.eclipse.jgit.pgm",
 org.eclipse.jgit.internal.storage.reftree;version="5.3.3";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
 org.eclipse.jgit.internal.submodule;version="5.3.3";x-internal:=true,
 org.eclipse.jgit.internal.transport.parser;version="5.3.3";x-friends:="org.eclipse.jgit.http.server,org.eclipse.jgit.test",
 org.eclipse.jgit.internal.transport.ssh;version="5.3.3";x-friends:="org.eclipse.jgit.ssh.apache",
 org.eclipse.jgit.lib;version="5.3.3";
  uses:="org.eclipse.jgit.revwalk,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.util,
   org.eclipse.jgit.events,
   org.eclipse.jgit.dircache,
   org.eclipse.jgit.internal.storage.file,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.transport,
   org.eclipse.jgit.submodule",
 org.eclipse.jgit.lib.internal;version="5.3.3";x-internal:=true,
 org.eclipse.jgit.merge;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.diff,
   org.eclipse.jgit.dircache,
   org.eclipse.jgit.api",
 org.eclipse.jgit.nls;version="5.3.3",
 org.eclipse.jgit.notes;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.merge",
 org.eclipse.jgit.patch;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.diff",
 org.eclipse.jgit.revplot;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.revwalk",
 org.eclipse.jgit.revwalk;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.treewalk,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.diff,
   org.eclipse.jgit.revwalk.filter",
 org.eclipse.jgit.revwalk.filter;version="5.3.3";uses:="org.eclipse.jgit.revwalk,org.eclipse.jgit.lib,org.eclipse.jgit.util",
 org.eclipse.jgit.storage.file;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.util",
 org.eclipse.jgit.storage.pack;version="5.3.3";uses:="org.eclipse.jgit.lib",
 org.eclipse.jgit.submodule;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.treewalk.filter,org.eclipse.jgit.treewalk",
 org.eclipse.jgit.transport;version="5.3.3";
  uses:="org.eclipse.jgit.transport.resolver,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.internal.storage.pack,
   com.jcraft.jsch,
   org.eclipse.jgit.util,
   org.eclipse.jgit.util.io,
   org.eclipse.jgit.internal.storage.file,
   org.eclipse.jgit.internal.transport.parser,
   org.eclipse.jgit.lib,
   org.eclipse.jgit.transport.http,
   org.eclipse.jgit.errors,
   org.eclipse.jgit.storage.pack",
 org.eclipse.jgit.transport.http;version="5.3.3";uses:="javax.net.ssl",
 org.eclipse.jgit.transport.resolver;version="5.3.3";uses:="org.eclipse.jgit.lib,org.eclipse.jgit.transport",
 org.eclipse.jgit.treewalk;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.revwalk,
   org.eclipse.jgit.attributes,
   org.eclipse.jgit.treewalk.filter,
   org.eclipse.jgit.util,
   org.eclipse.jgit.dircache",
 org.eclipse.jgit.treewalk.filter;version="5.3.3";uses:="org.eclipse.jgit.treewalk",
 org.eclipse.jgit.util;version="5.3.3";
  uses:="org.eclipse.jgit.lib,
   org.eclipse.jgit.transport.http,
   org.eclipse.jgit.storage.file,
   org.ietf.jgss",
 org.eclipse.jgit.util.io;version="5.3.3",
 org.eclipse.jgit.util.sha1;version="5.3.3",
 org.eclipse.jgit.util.time;version="5.3.3"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: com.googlecode.javaewah;version="[1.1.6,2.0.0)",
 com.jcraft.jsch;version="[0.1.37,0.2.0)",
 javax.crypto,
 javax.net.ssl,
 org.bouncycastle;version="[1.60.0,2.0.0)",
 org.bouncycastle.bcpg;version="[1.60.0,2.0.0)",
 org.bouncycastle.gpg;version="[1.60.0,2.0.0)",
 org.bouncycastle.gpg.keybox;version="[1.60.0,2.0.0)",
 org.bouncycastle.jce.provider;version="[1.60.0,2.0.0)",
 org.bouncycastle.openpgp;version="[1.60.0,2.0.0)",
 org.bouncycastle.openpgp.jcajce;version="[1.60.0,2.0.0)",
 org.bouncycastle.openpgp.operator;version="[1.60.0,2.0.0)",
 org.bouncycastle.openpgp.operator.jcajce;version="[1.60.0,2.0.0)",
 org.bouncycastle.util.encoders;version="[1.60.0,2.0.0)",
 org.slf4j;version="[1.7.0,2.0.0)",
 org.xml.sax,
 org.xml.sax.helpers

Back to the top