Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugues Malphettes2011-05-20 23:56:11 -0400
committerHugues Malphettes2011-05-20 23:56:11 -0400
commitcd21c56d4b80fd0d0bf81ba92aa99e704482218d (patch)
tree871a56b7e0d9df5a80985d0c787591eb73f3762d
parent6574fc33cb450e4a93d8a4b19c9c4faa079df3af (diff)
downloadorg.eclipse.jetty.project-cd21c56d4b80fd0d0bf81ba92aa99e704482218d.tar.gz
org.eclipse.jetty.project-cd21c56d4b80fd0d0bf81ba92aa99e704482218d.tar.xz
org.eclipse.jetty.project-cd21c56d4b80fd0d0bf81ba92aa99e704482218d.zip
bug 34605 Export the package as x-internal for other bundles to be able tp extend those eventually.
git-svn-id: svn+ssh://dev.eclipse.org/svnroot/rt/org.eclipse.jetty/jetty/trunk@3228 7e9141cc-0065-0410-87d8-b60c137991c4
-rw-r--r--jetty-distribution/pom.xml2
-rw-r--r--jetty-osgi/jetty-osgi-equinoxtools/META-INF/MANIFEST.MF4
2 files changed, 4 insertions, 2 deletions
diff --git a/jetty-distribution/pom.xml b/jetty-distribution/pom.xml
index 48844e3ffe..d928155486 100644
--- a/jetty-distribution/pom.xml
+++ b/jetty-distribution/pom.xml
@@ -9,7 +9,7 @@
<name>Jetty :: Distribution Assemblies</name>
<packaging>pom</packaging>
<properties>
- <jetty-orbit-url>http://download.eclipse.org/jetty/orbit/</jetty-orbit-url>
+ <jetty-orbit-url>http://download.eclipse.org/jetty/orbit/jetty-7</jetty-orbit-url>
<assembly-directory>target/distribution</assembly-directory>
<eclipse-ecj-version>3.6</eclipse-ecj-version>
<orbit-javax-activation-version>${javax-activation-version}.0.v201005080500</orbit-javax-activation-version>
diff --git a/jetty-osgi/jetty-osgi-equinoxtools/META-INF/MANIFEST.MF b/jetty-osgi/jetty-osgi-equinoxtools/META-INF/MANIFEST.MF
index 6a67257a6a..0d122db435 100644
--- a/jetty-osgi/jetty-osgi-equinoxtools/META-INF/MANIFEST.MF
+++ b/jetty-osgi/jetty-osgi-equinoxtools/META-INF/MANIFEST.MF
@@ -16,5 +16,7 @@ Import-Package: javax.servlet;version="2.5.0",
org.osgi.framework;version="1.3.0",
org.osgi.service.http;version="1.2.0",
org.osgi.util.tracker;version="1.3.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
+Export-Package: org.eclipse.jetty.osgi.equinoxtools;x-internal:=true;version="7.4.2.qualifier",
+ org.eclipse.jetty.osgi.equinoxtools.console;x-internal:=true;version="7.4.2.qualifier"
+Bundle-RequiredExecutionEnvironment: J2SE-1.5

Back to the top