Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskovalsky2014-03-05 09:38:54 -0500
committerskovalsky2014-03-05 09:38:54 -0500
commit9f1d6ed167acc675869f4aaad662fd78faee56e5 (patch)
treee998b3326b545c22493c015704bf179e7c95b672
parentd6fbdce74d056a995d16128f1c9521f3d1aa1418 (diff)
downloadorg.eclipse.gmf-tooling-9f1d6ed167acc675869f4aaad662fd78faee56e5.tar.gz
org.eclipse.gmf-tooling-9f1d6ed167acc675869f4aaad662fd78faee56e5.tar.xz
org.eclipse.gmf-tooling-9f1d6ed167acc675869f4aaad662fd78faee56e5.zip
[429666] - Upgrade Bundle-RequiredExecutionEnvironment to JavaSE-1.6
-rw-r--r--plugins/org.eclipse.gmf.bridge.trace/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.bridge.trace/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.bridge.ui.dashboard/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.bridge.ui.dashboard/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.bridge.ui/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.bridge.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.bridge/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.bridge/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.codegen.edit/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.codegen.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.codegen.lite.ui/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.codegen.lite.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.codegen.ui/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.codegen.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.codegen/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.codegen/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.common/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.graphdef.codegen.ui/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.graphdef.codegen.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.graphdef.codegen/.classpath3
-rw-r--r--plugins/org.eclipse.gmf.graphdef.codegen/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.graphdef.codegen/src/org/eclipse/gmf/graphdef/codegen/StandaloneEmitters.java8
-rw-r--r--plugins/org.eclipse.gmf.graphdef.edit/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.graphdef.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.graphdef.editor/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.graphdef.editor/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--plugins/org.eclipse.gmf.graphdef.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.graphdef/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.graphdef/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.map.edit/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.map.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.map.editor/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.map.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.map/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.map/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.runtime.lite.svg/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.runtime.lite.svg/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.runtime.lite/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.runtime.lite/.settings/org.eclipse.jdt.core.prefs8
-rw-r--r--plugins/org.eclipse.gmf.runtime.lite/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.tooldef.edit/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.tooldef.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.tooldef/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.tooldef/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime.ide/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime.ide/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime/.settings/org.eclipse.jdt.core.prefs6
-rw-r--r--plugins/org.eclipse.gmf.tooling.runtime/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.tooling/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.validate/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.validate/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.xpand.ant/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.xpand.ant/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.xpand.editor/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.xpand.editor/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.xpand.qvtlibrary/.classpath2
-rw-r--r--plugins/org.eclipse.gmf.xpand.qvtlibrary/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.gmf.xpand/.classpath4
-rw-r--r--plugins/org.eclipse.gmf.xpand/META-INF/MANIFEST.MF2
-rw-r--r--tests/org.eclipse.gmf.tests.lite/.classpath4
-rw-r--r--tests/org.eclipse.gmf.tests.lite/META-INF/MANIFEST.MF2
-rw-r--r--tests/org.eclipse.gmf.tests/.classpath2
65 files changed, 89 insertions, 89 deletions
diff --git a/plugins/org.eclipse.gmf.bridge.trace/.classpath b/plugins/org.eclipse.gmf.bridge.trace/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.bridge.trace/.classpath
+++ b/plugins/org.eclipse.gmf.bridge.trace/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.bridge.trace/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.bridge.trace/META-INF/MANIFEST.MF
index a123f65f1..697539f3a 100644
--- a/plugins/org.eclipse.gmf.bridge.trace/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.bridge.trace/META-INF/MANIFEST.MF
@@ -13,4 +13,4 @@ Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.3.0,3.0.0)",
org.eclipse.ocl.ecore;bundle-version="[3.0.0,4.0.0)"
Bundle-Activator: org.eclipse.gmf.internal.bridge.trace.GmfTracePlugin
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.bridge.ui.dashboard/.classpath b/plugins/org.eclipse.gmf.bridge.ui.dashboard/.classpath
index 304e86186..121e527a9 100644
--- a/plugins/org.eclipse.gmf.bridge.ui.dashboard/.classpath
+++ b/plugins/org.eclipse.gmf.bridge.ui.dashboard/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.bridge.ui.dashboard/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.bridge.ui.dashboard/META-INF/MANIFEST.MF
index a5e6aab97..1be1d4130 100644
--- a/plugins/org.eclipse.gmf.bridge.ui.dashboard/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.bridge.ui.dashboard/META-INF/MANIFEST.MF
@@ -21,4 +21,4 @@ Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.gmf.bridge.ui.dashboard,
org.eclipse.gmf.internal.bridge.ui.dashboard;x-internal:=true,
org.eclipse.gmf.internal.bridge.ui.dashboard.actions;x-friends:="org.eclipse.gmf.codegen.lite.ui"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.bridge.ui/.classpath b/plugins/org.eclipse.gmf.bridge.ui/.classpath
index 304e86186..121e527a9 100644
--- a/plugins/org.eclipse.gmf.bridge.ui/.classpath
+++ b/plugins/org.eclipse.gmf.bridge.ui/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.bridge.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.bridge.ui/META-INF/MANIFEST.MF
index 3401eaa22..7233be436 100644
--- a/plugins/org.eclipse.gmf.bridge.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.bridge.ui/META-INF/MANIFEST.MF
@@ -35,4 +35,4 @@ Export-Package: org.eclipse.gmf.internal.bridge.resolver;x-internal:=true,
org.eclipse.gmf.internal.bridge.wizards.pages;x-friends:="org.eclipse.gmf.doc.ui",
org.eclipse.gmf.internal.bridge.wizards.pages.simple;x-internal:=true,
org.eclipse.gmf.internal.bridge.wizards.strategy;x-internal:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.bridge/.classpath b/plugins/org.eclipse.gmf.bridge/.classpath
index 304e86186..121e527a9 100644
--- a/plugins/org.eclipse.gmf.bridge/.classpath
+++ b/plugins/org.eclipse.gmf.bridge/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.bridge/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.bridge/META-INF/MANIFEST.MF
index dcda37dd4..ed7a8e97a 100644
--- a/plugins/org.eclipse.gmf.bridge/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.bridge/META-INF/MANIFEST.MF
@@ -19,4 +19,4 @@ Export-Package: org.eclipse.gmf.internal.bridge;x-friends:="org.eclipse.gmf.test
org.eclipse.gmf.internal.bridge.naming;x-friends:="org.eclipse.gmf.tests",
org.eclipse.gmf.internal.bridge.naming.gen;x-friends:="org.eclipse.gmf.tests,org.eclipse.gmf.codegen.ui,org.eclipse.gmf.bridge.ui"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.codegen.edit/.classpath b/plugins/org.eclipse.gmf.codegen.edit/.classpath
index 304e86186..121e527a9 100644
--- a/plugins/org.eclipse.gmf.codegen.edit/.classpath
+++ b/plugins/org.eclipse.gmf.codegen.edit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.codegen.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.codegen.edit/META-INF/MANIFEST.MF
index 6411c0ed3..db469753c 100644
--- a/plugins/org.eclipse.gmf.codegen.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.codegen.edit/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.3.0,4.0.0)";visibility:=reexport,
org.eclipse.emf.codegen.ecore.ui;bundle-version="[2.3.0,3.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.codegen.lite.ui/.classpath b/plugins/org.eclipse.gmf.codegen.lite.ui/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.codegen.lite.ui/.classpath
+++ b/plugins/org.eclipse.gmf.codegen.lite.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.codegen.lite.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.codegen.lite.ui/META-INF/MANIFEST.MF
index db009c388..1fc14112b 100644
--- a/plugins/org.eclipse.gmf.codegen.lite.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.codegen.lite.ui/META-INF/MANIFEST.MF
@@ -13,4 +13,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.gmf.codegen.ui;bundle-version="[1.1.0,2.0.0)",
org.eclipse.gmf.bridge.ui.dashboard;bundle-version="[2.0.0,3.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.codegen.ui/.classpath b/plugins/org.eclipse.gmf.codegen.ui/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.codegen.ui/.classpath
+++ b/plugins/org.eclipse.gmf.codegen.ui/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.codegen.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.codegen.ui/META-INF/MANIFEST.MF
index f6dd569fd..ee6c4aac1 100644
--- a/plugins/org.eclipse.gmf.codegen.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.codegen.ui/META-INF/MANIFEST.MF
@@ -22,4 +22,4 @@ Bundle-ActivationPolicy: lazy
Bundle-Vendor: %providerName
Export-Package: org.eclipse.gmf.internal.codegen;x-friends:="org.eclipse.gmf.tests",
org.eclipse.gmf.internal.codegen.popup.actions;x-friends:="org.eclipse.gmf.bridge.ui.dashboard,org.eclipse.gmf.codegen.lite.ui,org.eclipse.gmf.codegen.xtend.ui"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.codegen/.classpath b/plugins/org.eclipse.gmf.codegen/.classpath
index d32b70f21..3887a6374 100644
--- a/plugins/org.eclipse.gmf.codegen/.classpath
+++ b/plugins/org.eclipse.gmf.codegen/.classpath
@@ -2,7 +2,7 @@
<classpath>
<classpathentry kind="src" path="src"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="src" path="templates.qvtlib"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.codegen/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.codegen/META-INF/MANIFEST.MF
index a48758028..82137010b 100644
--- a/plugins/org.eclipse.gmf.codegen/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.codegen/META-INF/MANIFEST.MF
@@ -22,5 +22,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
org.eclipse.gmf.xpand;bundle-version="[2.1.0,3.0.0)",
org.eclipse.m2m.qvt.oml;bundle-version="[3.4.0,4.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Eclipse-BuddyPolicy: registered
diff --git a/plugins/org.eclipse.gmf.common/.classpath b/plugins/org.eclipse.gmf.common/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.common/.classpath
+++ b/plugins/org.eclipse.gmf.common/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.common/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.common/META-INF/MANIFEST.MF
index bcd9bcbd1..12b72f138 100644
--- a/plugins/org.eclipse.gmf.common/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.common/META-INF/MANIFEST.MF
@@ -26,7 +26,7 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.jface;bundle-version="[3.3.0,4.0.0)",
org.eclipse.jdt.ui;bundle-version="[3.3.0,4.0.0)",
org.eclipse.gmf.xpand;bundle-version="[2.1.0,3.0.0)"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Activator: org.eclipse.gmf.internal.common.Activator
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.gmf.graphdef.codegen.ui/.classpath b/plugins/org.eclipse.gmf.graphdef.codegen.ui/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.graphdef.codegen.ui/.classpath
+++ b/plugins/org.eclipse.gmf.graphdef.codegen.ui/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.graphdef.codegen.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.graphdef.codegen.ui/META-INF/MANIFEST.MF
index 32aa5febe..2b410cbe2 100644
--- a/plugins/org.eclipse.gmf.graphdef.codegen.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.graphdef.codegen.ui/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Require-Bundle: org.eclipse.pde.ui;bundle-version="[3.3.0,4.0.0)",
org.eclipse.jdt.core;bundle-version="[3.3.0,4.0.0)",
org.eclipse.ui.forms;bundle-version="[3.3.0,4.0.0)"
Export-Package: org.eclipse.gmf.internal.graphdef.codegen.ui;x-friends:="org.eclipse.gmf.codegen.ui"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.graphdef.codegen/.classpath b/plugins/org.eclipse.gmf.graphdef.codegen/.classpath
index 155fe578b..6e3c23d5d 100644
--- a/plugins/org.eclipse.gmf.graphdef.codegen/.classpath
+++ b/plugins/org.eclipse.gmf.graphdef.codegen/.classpath
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="templates.qvtlib"/>
+ <classpathentry kind="src" path="templates"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.graphdef.codegen/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.graphdef.codegen/META-INF/MANIFEST.MF
index e552b26df..91c671030 100644
--- a/plugins/org.eclipse.gmf.graphdef.codegen/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.graphdef.codegen/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Export-Package: org.eclipse.gmf.graphdef.codegen,
org.eclipse.gmf.internal.graphdef.codegen;x-friends:="org.eclipse.gmf.graphdef.codegen.ui,org.eclipse.gmf.tests"
Bundle-Activator: org.eclipse.gmf.internal.graphdef.codegen.Activator
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.graphdef.codegen/src/org/eclipse/gmf/graphdef/codegen/StandaloneEmitters.java b/plugins/org.eclipse.gmf.graphdef.codegen/src/org/eclipse/gmf/graphdef/codegen/StandaloneEmitters.java
index 9e3fadf75..992039e0c 100644
--- a/plugins/org.eclipse.gmf.graphdef.codegen/src/org/eclipse/gmf/graphdef/codegen/StandaloneEmitters.java
+++ b/plugins/org.eclipse.gmf.graphdef.codegen/src/org/eclipse/gmf/graphdef/codegen/StandaloneEmitters.java
@@ -33,11 +33,11 @@ class StandaloneEmitters {
}
public TextEmitter getBuildPropertiesEmitter() throws UnexpectedBehaviourException {
- return new XpandTextEmitter(myResourceManager, "plugin::BuildProperties::Init");
+ return new XpandTextEmitter(myResourceManager, "plugin::BuildProperties", "Init");
}
public TextEmitter getPluginPropertiesEmitter() throws UnexpectedBehaviourException {
- return new XpandTextEmitter(myResourceManager, "plugin::PluginProperties::Init") {
+ return new XpandTextEmitter(myResourceManager, "plugin::PluginProperties", "Init") {
@Override
protected Object[] extractArguments(Object[] arguments) {
assert arguments != null && arguments.length > 0 && arguments[0] instanceof Config;
@@ -51,7 +51,7 @@ class StandaloneEmitters {
}
public TextEmitter getManifestMFEmitter() throws UnexpectedBehaviourException {
- return new XpandTextEmitter(myResourceManager, "plugin::Manifest::Init") {
+ return new XpandTextEmitter(myResourceManager, "plugin::Manifest", "Init") {
@Override
protected Object[] extractArguments(Object[] arguments) {
assert arguments != null && arguments.length > 1 && arguments[0] instanceof Config && arguments[1] instanceof String[];
@@ -69,7 +69,7 @@ class StandaloneEmitters {
}
public TextEmitter getPluginActivatorEmitter() throws UnexpectedBehaviourException {
- return new XpandTextEmitter(myResourceManager, "plugin::Activator::Init") {
+ return new XpandTextEmitter(myResourceManager, "plugin::Activator", "Init") {
@Override
protected Object extractTarget(Object[] arguments) {
assert arguments != null && arguments.length >= 2;
diff --git a/plugins/org.eclipse.gmf.graphdef.edit/.classpath b/plugins/org.eclipse.gmf.graphdef.edit/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.graphdef.edit/.classpath
+++ b/plugins/org.eclipse.gmf.graphdef.edit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.graphdef.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.graphdef.edit/META-INF/MANIFEST.MF
index a5e073ec3..00668a742 100644
--- a/plugins/org.eclipse.gmf.graphdef.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.graphdef.edit/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.emf.edit.ui;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.3.0,4.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.graphdef.editor/.classpath b/plugins/org.eclipse.gmf.graphdef.editor/.classpath
index 32822ce24..ebbd73f71 100644
--- a/plugins/org.eclipse.gmf.graphdef.editor/.classpath
+++ b/plugins/org.eclipse.gmf.graphdef.editor/.classpath
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
+ <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" path="src-extra"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
- <classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.graphdef.editor/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.gmf.graphdef.editor/.settings/org.eclipse.jdt.core.prefs
index ee83133e3..6067a5b17 100644
--- a/plugins/org.eclipse.gmf.graphdef.editor/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.gmf.graphdef.editor/.settings/org.eclipse.jdt.core.prefs
@@ -1,9 +1,8 @@
-#Mon May 12 19:37:54 CEST 2008
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
org.eclipse.jdt.core.compiler.debug.localVariable=generate
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
@@ -67,4 +66,4 @@ org.eclipse.jdt.core.compiler.problem.unusedParameterWhenOverridingConcrete=disa
org.eclipse.jdt.core.compiler.problem.unusedPrivateMember=warning
org.eclipse.jdt.core.compiler.problem.unusedWarningToken=warning
org.eclipse.jdt.core.compiler.problem.varargsArgumentNeedCast=warning
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/plugins/org.eclipse.gmf.graphdef.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.graphdef.editor/META-INF/MANIFEST.MF
index 918914baf..8c869c0fd 100644
--- a/plugins/org.eclipse.gmf.graphdef.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.graphdef.editor/META-INF/MANIFEST.MF
@@ -39,5 +39,5 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ui.navigator.resources,
org.eclipse.ocl.ecore;visibility:=reexport
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Eclipse-LazyStart: true
diff --git a/plugins/org.eclipse.gmf.graphdef/.classpath b/plugins/org.eclipse.gmf.graphdef/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.graphdef/.classpath
+++ b/plugins/org.eclipse.gmf.graphdef/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.graphdef/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.graphdef/META-INF/MANIFEST.MF
index 715e578a9..1852a2f35 100644
--- a/plugins/org.eclipse.gmf.graphdef/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.graphdef/META-INF/MANIFEST.MF
@@ -12,4 +12,4 @@ Export-Package: org.eclipse.gmf.gmfgraph,
org.eclipse.gmf.gmfgraph.impl;x-friends:="org.eclipse.gmf.map",
org.eclipse.gmf.gmfgraph.util,
org.eclipse.gmf.internal.graphdef.util;x-internal:=true
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.map.edit/.classpath b/plugins/org.eclipse.gmf.map.edit/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.map.edit/.classpath
+++ b/plugins/org.eclipse.gmf.map.edit/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.map.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.map.edit/META-INF/MANIFEST.MF
index 446faefbc..e81041e4d 100644
--- a/plugins/org.eclipse.gmf.map.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.map.edit/META-INF/MANIFEST.MF
@@ -20,4 +20,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.gmf.tooldef.edit;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.ecore.edit;bundle-version="[2.4.0,3.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.map.editor/.classpath b/plugins/org.eclipse.gmf.map.editor/.classpath
index 751c8f2e5..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.map.editor/.classpath
+++ b/plugins/org.eclipse.gmf.map.editor/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.map.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.map.editor/META-INF/MANIFEST.MF
index be18ffad6..185f8019f 100644
--- a/plugins/org.eclipse.gmf.map.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.map.editor/META-INF/MANIFEST.MF
@@ -43,4 +43,4 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.gmf.runtime.draw2d.ui;visibility:=reexport,
org.eclipse.draw2d;visibility:=reexport
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.map/.classpath b/plugins/org.eclipse.gmf.map/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.map/.classpath
+++ b/plugins/org.eclipse.gmf.map/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.map/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.map/META-INF/MANIFEST.MF
index 4f87cd6ec..2d298a524 100644
--- a/plugins/org.eclipse.gmf.map/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.map/META-INF/MANIFEST.MF
@@ -16,4 +16,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.gmf.tooldef;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
org.eclipse.gmf.validate;bundle-version="[1.1.0,2.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.runtime.lite.svg/.classpath b/plugins/org.eclipse.gmf.runtime.lite.svg/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.runtime.lite.svg/.classpath
+++ b/plugins/org.eclipse.gmf.runtime.lite.svg/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.runtime.lite.svg/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.runtime.lite.svg/META-INF/MANIFEST.MF
index b182ddc30..ddcb247c0 100644
--- a/plugins/org.eclipse.gmf.runtime.lite.svg/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.runtime.lite.svg/META-INF/MANIFEST.MF
@@ -17,7 +17,7 @@ Require-Bundle: org.eclipse.ui,
org.apache.batik.transcoder;bundle-version="[1.6.0,1.7.0)",
org.apache.batik.util;bundle-version="[1.6.0,1.7.0)",
org.w3c.dom.svg;bundle-version="[1.1.0,2.0.0)"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.gmf.internal.runtime.lite.svg;x-internal:=true,
org.eclipse.gmf.runtime.lite.svg
diff --git a/plugins/org.eclipse.gmf.runtime.lite/.classpath b/plugins/org.eclipse.gmf.runtime.lite/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.runtime.lite/.classpath
+++ b/plugins/org.eclipse.gmf.runtime.lite/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.runtime.lite/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.gmf.runtime.lite/.settings/org.eclipse.jdt.core.prefs
index 6f2a05c6b..c537b6306 100644
--- a/plugins/org.eclipse.gmf.runtime.lite/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.gmf.runtime.lite/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
-#Fri Feb 23 18:20:05 CET 2007
eclipse.preferences.version=1
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/plugins/org.eclipse.gmf.runtime.lite/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.runtime.lite/META-INF/MANIFEST.MF
index 7121fc6c6..43a897aa9 100644
--- a/plugins/org.eclipse.gmf.runtime.lite/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.runtime.lite/META-INF/MANIFEST.MF
@@ -37,5 +37,5 @@ Export-Package: org.eclipse.gmf.runtime.lite.commands,
org.eclipse.gmf.runtime.lite.shortcuts,
org.eclipse.gmf.runtime.lite.ui.actions,
org.eclipse.gmf.runtime.lite.validation
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.tooldef.edit/.classpath b/plugins/org.eclipse.gmf.tooldef.edit/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.tooldef.edit/.classpath
+++ b/plugins/org.eclipse.gmf.tooldef.edit/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.tooldef.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.tooldef.edit/META-INF/MANIFEST.MF
index 4980fdf08..ed06f2180 100644
--- a/plugins/org.eclipse.gmf.tooldef.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.tooldef.edit/META-INF/MANIFEST.MF
@@ -17,4 +17,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.emf.edit.ui;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
org.eclipse.ui.ide;bundle-version="[3.3.0,4.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.tooldef/.classpath b/plugins/org.eclipse.gmf.tooldef/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.tooldef/.classpath
+++ b/plugins/org.eclipse.gmf.tooldef/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.tooldef/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.tooldef/META-INF/MANIFEST.MF
index f4915ad14..58b85be37 100644
--- a/plugins/org.eclipse.gmf.tooldef/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.tooldef/META-INF/MANIFEST.MF
@@ -12,4 +12,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.emf.ecore;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
org.eclipse.gmf.common;bundle-version="[1.1.0,2.0.0)"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.tooling.runtime.ide/.classpath b/plugins/org.eclipse.gmf.tooling.runtime.ide/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime.ide/.classpath
+++ b/plugins/org.eclipse.gmf.tooling.runtime.ide/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.tooling.runtime.ide/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.gmf.tooling.runtime.ide/.settings/org.eclipse.jdt.core.prefs
index af0f20f97..c537b6306 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime.ide/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.gmf.tooling.runtime.ide/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/plugins/org.eclipse.gmf.tooling.runtime.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.tooling.runtime.ide/META-INF/MANIFEST.MF
index b5fda4eaa..927d6ca3a 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.tooling.runtime.ide/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.gmf.tooling.runtime.ide
Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ui.ide,
org.eclipse.core.expressions,
diff --git a/plugins/org.eclipse.gmf.tooling.runtime/.classpath b/plugins/org.eclipse.gmf.tooling.runtime/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime/.classpath
+++ b/plugins/org.eclipse.gmf.tooling.runtime/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.tooling.runtime/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.gmf.tooling.runtime/.settings/org.eclipse.jdt.core.prefs
index af0f20f97..c537b6306 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.gmf.tooling.runtime/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/plugins/org.eclipse.gmf.tooling.runtime/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.tooling.runtime/META-INF/MANIFEST.MF
index 6e7bae416..5a575d2a2 100644
--- a/plugins/org.eclipse.gmf.tooling.runtime/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.tooling.runtime/META-INF/MANIFEST.MF
@@ -21,7 +21,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ocl.ecore,
org.eclipse.gmf.runtime.notation
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Activator: org.eclipse.gmf.tooling.runtime.GMFToolingRuntimePlugin
Export-Package: org.eclipse.gmf.tooling.runtime,
org.eclipse.gmf.tooling.runtime.actions,
diff --git a/plugins/org.eclipse.gmf.tooling/.classpath b/plugins/org.eclipse.gmf.tooling/.classpath
index c83506765..bc74aabe3 100644
--- a/plugins/org.eclipse.gmf.tooling/.classpath
+++ b/plugins/org.eclipse.gmf.tooling/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.validate/.classpath b/plugins/org.eclipse.gmf.validate/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.validate/.classpath
+++ b/plugins/org.eclipse.gmf.validate/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.validate/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.validate/META-INF/MANIFEST.MF
index cee88c6f3..9d9065533 100644
--- a/plugins/org.eclipse.gmf.validate/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.validate/META-INF/MANIFEST.MF
@@ -15,4 +15,4 @@ Export-Package: org.eclipse.gmf.internal.validate;x-friends:="org.eclipse.gmf.te
org.eclipse.gmf.validate
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.xpand.ant/.classpath b/plugins/org.eclipse.gmf.xpand.ant/.classpath
index 55ac8ef60..7f25349c7 100644
--- a/plugins/org.eclipse.gmf.xpand.ant/.classpath
+++ b/plugins/org.eclipse.gmf.xpand.ant/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="src" output="bin-ant" path="src-ant"/>
diff --git a/plugins/org.eclipse.gmf.xpand.ant/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.xpand.ant/META-INF/MANIFEST.MF
index a61fa7130..c12ca7a4a 100644
--- a/plugins/org.eclipse.gmf.xpand.ant/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.xpand.ant/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-SymbolicName: org.eclipse.gmf.xpand.ant;singleton:=true
Bundle-Version: 0.10.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: .
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.gmf.xpand;bundle-version="[2.1.0,3.0.0)",
diff --git a/plugins/org.eclipse.gmf.xpand.editor/.classpath b/plugins/org.eclipse.gmf.xpand.editor/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.xpand.editor/.classpath
+++ b/plugins/org.eclipse.gmf.xpand.editor/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.xpand.editor/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.xpand.editor/META-INF/MANIFEST.MF
index f96f8f74b..2e047da9e 100644
--- a/plugins/org.eclipse.gmf.xpand.editor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.xpand.editor/META-INF/MANIFEST.MF
@@ -22,4 +22,4 @@ Export-Package: org.eclipse.gmf.internal.xpand.codeassist;x-friends:="org.eclips
org.eclipse.gmf.internal.xpand.editor;x-friends:="org.eclipse.gmf.tests.xpand",
org.eclipse.gmf.internal.xpand.expression.codeassist;x-friends:="org.eclipse.gmf.tests.xpand"
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/plugins/org.eclipse.gmf.xpand.qvtlibrary/.classpath b/plugins/org.eclipse.gmf.xpand.qvtlibrary/.classpath
index 64c5e31b7..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.xpand.qvtlibrary/.classpath
+++ b/plugins/org.eclipse.gmf.xpand.qvtlibrary/.classpath
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
diff --git a/plugins/org.eclipse.gmf.xpand.qvtlibrary/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.xpand.qvtlibrary/META-INF/MANIFEST.MF
index 40ffcc292..9d7041a5c 100644
--- a/plugins/org.eclipse.gmf.xpand.qvtlibrary/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.xpand.qvtlibrary/META-INF/MANIFEST.MF
@@ -9,5 +9,5 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.m2m.qvt.oml;bundle-version="[3.4.0,4.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.eclipse.gmf.internal.xpand.qvtlibraries;x-friends:="org.eclipse.gmf.xpand"
diff --git a/plugins/org.eclipse.gmf.xpand/.classpath b/plugins/org.eclipse.gmf.xpand/.classpath
index 304e86186..ad32c83a7 100644
--- a/plugins/org.eclipse.gmf.xpand/.classpath
+++ b/plugins/org.eclipse.gmf.xpand/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/plugins/org.eclipse.gmf.xpand/META-INF/MANIFEST.MF b/plugins/org.eclipse.gmf.xpand/META-INF/MANIFEST.MF
index 4d241d374..37338cd74 100644
--- a/plugins/org.eclipse.gmf.xpand/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.gmf.xpand/META-INF/MANIFEST.MF
@@ -57,5 +57,5 @@ Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy; exclude:="org.eclipse.gmf.internal.xpand.inactive"
Bundle-ClassPath: .
Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Eclipse-ExtensibleAPI: true
diff --git a/tests/org.eclipse.gmf.tests.lite/.classpath b/tests/org.eclipse.gmf.tests.lite/.classpath
index 304e86186..ad32c83a7 100644
--- a/tests/org.eclipse.gmf.tests.lite/.classpath
+++ b/tests/org.eclipse.gmf.tests.lite/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/tests/org.eclipse.gmf.tests.lite/META-INF/MANIFEST.MF b/tests/org.eclipse.gmf.tests.lite/META-INF/MANIFEST.MF
index 23c9468f8..f92965154 100644
--- a/tests/org.eclipse.gmf.tests.lite/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.gmf.tests.lite/META-INF/MANIFEST.MF
@@ -28,4 +28,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.eclipse.emf.common.ui;bundle-version="[2.3.0,3.0.0)",
org.eclipse.gmf.runtime.lite.svg;bundle-version="1.0.0"
Bundle-ActivationPolicy: lazy
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/tests/org.eclipse.gmf.tests/.classpath b/tests/org.eclipse.gmf.tests/.classpath
index 304e86186..121e527a9 100644
--- a/tests/org.eclipse.gmf.tests/.classpath
+++ b/tests/org.eclipse.gmf.tests/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>

Back to the top