Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Belle2019-10-10 08:45:45 -0400
committerJan Belle2019-10-11 09:40:53 -0400
commitaac958396bc0a687d2fac361f2b3bcb073e16d1f (patch)
treedc077eae11fd8151a59d8352f2cfa9e0bf4ce5bc
parent105760a8e143d474638d3d1b3ee443a9ed666fc8 (diff)
downloadorg.eclipse.etrice-aac958396bc0a687d2fac361f2b3bcb073e16d1f.tar.gz
org.eclipse.etrice-aac958396bc0a687d2fac361f2b3bcb073e16d1f.tar.xz
org.eclipse.etrice-aac958396bc0a687d2fac361f2b3bcb073e16d1f.zip
[releng] Ensure consistent versioning of eclipse plugins
* Set all plugin and feature versions to 0.0.0 * Remove all version constraints of plugin dependencies * Implement build logic to update version strings * Integrate maven tycho build in gradle build Plugin and feature versions are updated by the build process. Version is computed from last git tag. Bug 541499 Change-Id: Ic9453508a27488239718074c318182977a21c214
-rw-r--r--build.gradle7
-rw-r--r--examples/my.etrice.generator.launch/META-INF/MANIFEST.MF24
-rw-r--r--examples/my.etrice.generator/META-INF/MANIFEST.MF14
-rw-r--r--features/org.eclipse.etrice.cdt-integration.feature/feature.xml11
-rw-r--r--features/org.eclipse.etrice.feature/feature.xml5
-rw-r--r--features/org.eclipse.etrice.fsm.feature/feature.xml2
-rw-r--r--features/org.eclipse.etrice.tests.feature/feature.xml40
-rw-r--r--features/pom.xml3
-rw-r--r--gradle/scmVersion.gradle6
-rw-r--r--plugins/org.eclipse.etrice.abstractexec.behavior/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.etrice.core.common.ui/META-INF/MANIFEST.MF18
-rw-r--r--plugins/org.eclipse.etrice.core.common/META-INF/MANIFEST.MF16
-rw-r--r--plugins/org.eclipse.etrice.core.config.ui/META-INF/MANIFEST.MF26
-rw-r--r--plugins/org.eclipse.etrice.core.config/META-INF/MANIFEST.MF26
-rw-r--r--plugins/org.eclipse.etrice.core.etmap.ui/META-INF/MANIFEST.MF24
-rw-r--r--plugins/org.eclipse.etrice.core.etmap/META-INF/MANIFEST.MF26
-rw-r--r--plugins/org.eclipse.etrice.core.etphys.ui/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.core.etphys/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.etrice.core.fsm.ui/META-INF/MANIFEST.MF18
-rw-r--r--plugins/org.eclipse.etrice.core.fsm/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.core.genmodel.fsm/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.etrice.core.genmodel/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.etrice.core.room.ui/META-INF/MANIFEST.MF34
-rw-r--r--plugins/org.eclipse.etrice.core.room/META-INF/MANIFEST.MF24
-rw-r--r--plugins/org.eclipse.etrice.dctools.fsm/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.etrice.dctools/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.etrice.doc/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.etrice.etunit.converter/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.etrice.expressions.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.etrice.generator.base/META-INF/MANIFEST.MF7
-rw-r--r--plugins/org.eclipse.etrice.generator.c/META-INF/MANIFEST.MF22
-rw-r--r--plugins/org.eclipse.etrice.generator.config/META-INF/MANIFEST.MF22
-rw-r--r--plugins/org.eclipse.etrice.generator.contractmonitor/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.etrice.generator.cpp/META-INF/MANIFEST.MF22
-rw-r--r--plugins/org.eclipse.etrice.generator.doc/META-INF/MANIFEST.MF32
-rw-r--r--plugins/org.eclipse.etrice.generator.fsm/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.etrice.generator.fsmtest.ui/META-INF/MANIFEST.MF16
-rw-r--r--plugins/org.eclipse.etrice.generator.fsmtest/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.etrice.generator.java/META-INF/MANIFEST.MF22
-rw-r--r--plugins/org.eclipse.etrice.generator.launch.c/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.generator.launch.contractmonitor/META-INF/MANIFEST.MF3
-rw-r--r--plugins/org.eclipse.etrice.generator.launch.cpp/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.generator.launch.doc/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.etrice.generator.launch.java/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.generator.launch/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.generator.ui.cdt/META-INF/MANIFEST.MF20
-rw-r--r--plugins/org.eclipse.etrice.generator.ui/META-INF/MANIFEST.MF40
-rw-r--r--plugins/org.eclipse.etrice.generator/META-INF/MANIFEST.MF26
-rw-r--r--plugins/org.eclipse.etrice.logging/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.etrice.ui.behavior.actioneditor/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.etrice.ui.behavior.fsm/META-INF/MANIFEST.MF32
-rw-r--r--plugins/org.eclipse.etrice.ui.behavior/META-INF/MANIFEST.MF38
-rw-r--r--plugins/org.eclipse.etrice.ui.commands/META-INF/MANIFEST.MF26
-rw-r--r--plugins/org.eclipse.etrice.ui.common.base/META-INF/MANIFEST.MF30
-rw-r--r--plugins/org.eclipse.etrice.ui.common/META-INF/MANIFEST.MF30
-rw-r--r--plugins/org.eclipse.etrice.ui.runtime/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.etrice.ui.runtime/pom.xml3
-rw-r--r--plugins/org.eclipse.etrice.ui.structure/META-INF/MANIFEST.MF28
-rw-r--r--plugins/pom.xml3
-rw-r--r--pom.xml11
-rw-r--r--releng/org.eclipse.etrice.parent/pom.xml9
-rw-r--r--releng/org.eclipse.etrice.releng/build.gradle12
-rw-r--r--releng/org.eclipse.etrice.site/build.gradle60
-rw-r--r--releng/org.eclipse.etrice.site/category.xml4
-rw-r--r--releng/org.eclipse.etrice.site/pom.xml3
-rw-r--r--runtime/org.eclipse.etrice.modellib.java/META-INF/MANIFEST.MF2
-rw-r--r--runtime/org.eclipse.etrice.runtime.java/META-INF/MANIFEST.MF2
-rw-r--r--tests/org.eclipse.etrice.abstractexec.behavior.tests/META-INF/MANIFEST.MF12
-rw-r--r--tests/org.eclipse.etrice.core.common.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/org.eclipse.etrice.core.config.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/org.eclipse.etrice.core.etmap.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/org.eclipse.etrice.core.etphys.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/org.eclipse.etrice.core.fsm.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/org.eclipse.etrice.core.genmodel.fsm.tests/META-INF/MANIFEST.MF16
-rw-r--r--tests/org.eclipse.etrice.core.genmodel.tests/META-INF/MANIFEST.MF14
-rw-r--r--tests/org.eclipse.etrice.core.room.tests/META-INF/MANIFEST.MF18
-rw-r--r--tests/org.eclipse.etrice.dctools.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/org.eclipse.etrice.etunit.converter.tests/META-INF/MANIFEST.MF6
-rw-r--r--tests/org.eclipse.etrice.generator.fsmtest.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/org.eclipse.etrice.generator.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/org.eclipse.etrice.ui.base.tests/META-INF/MANIFEST.MF12
-rw-r--r--tests/org.eclipse.etrice.ui.behavior.tests/META-INF/MANIFEST.MF30
-rw-r--r--tests/org.eclipse.etrice.ui.structure.tests/META-INF/MANIFEST.MF20
-rw-r--r--tests/pom.xml3
84 files changed, 694 insertions, 664 deletions
diff --git a/build.gradle b/build.gradle
index ab8a48f10..0deaf5a02 100644
--- a/build.gradle
+++ b/build.gradle
@@ -1,5 +1,7 @@
plugins {
- id 'org.xtext.xtend' version '2.0.7'
+ id 'org.xtext.xtend' version '2.0.7' apply false
+ id 'com.github.dkorotych.gradle-maven-exec' version '2.2.1'
+ id 'org.hidetake.ssh' version '2.10.1'
}
apply from: "$rootDir/gradle/scmVersion.gradle"
@@ -34,5 +36,4 @@ allprojects {
url 'https://repo.eclipse.org/content/repositories/maven_central/'
}
}
-}
-
+} \ No newline at end of file
diff --git a/examples/my.etrice.generator.launch/META-INF/MANIFEST.MF b/examples/my.etrice.generator.launch/META-INF/MANIFEST.MF
index 25c644b8f..45ad453ef 100644
--- a/examples/my.etrice.generator.launch/META-INF/MANIFEST.MF
+++ b/examples/my.etrice.generator.launch/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Derived Generator Launcher
Bundle-SymbolicName: my.etrice.generator.launch;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: my.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch.java;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.java;bundle-version="2.0.0",
- org.eclipse.debug.ui;bundle-version="3.8.1",
- org.eclipse.swt;bundle-version="3.100.1",
- org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.jdt.launching;bundle-version="3.6.100",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+Require-Bundle: my.etrice.generator,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.launch,
+ org.eclipse.etrice.generator.launch.java,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator.java,
+ org.eclipse.debug.ui,
+ org.eclipse.swt,
+ org.eclipse.core.runtime,
+ org.eclipse.jdt.launching,
+ org.eclipse.etrice.generator.base
Automatic-Module-Name: my.etrice.generator.launch
diff --git a/examples/my.etrice.generator/META-INF/MANIFEST.MF b/examples/my.etrice.generator/META-INF/MANIFEST.MF
index 45de050c3..36e51363e 100644
--- a/examples/my.etrice.generator/META-INF/MANIFEST.MF
+++ b/examples/my.etrice.generator/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Derived Generator
Bundle-SymbolicName: my.etrice.generator
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.java;bundle-version="2.0.0",
- com.google.inject;bundle-version="3.0.0"
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.java,
+ com.google.inject
Export-Package: my.etrice.generator
Automatic-Module-Name: my.etrice.generator
diff --git a/features/org.eclipse.etrice.cdt-integration.feature/feature.xml b/features/org.eclipse.etrice.cdt-integration.feature/feature.xml
index 48a18b66e..d572c7774 100644
--- a/features/org.eclipse.etrice.cdt-integration.feature/feature.xml
+++ b/features/org.eclipse.etrice.cdt-integration.feature/feature.xml
@@ -17,7 +17,7 @@
<feature
id="org.eclipse.etrice.cdt_integration.feature"
label="%featureName"
- version="2.0.0.qualifier"
+ version="0.0.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.etrice.core.room.ui"
license-feature="org.eclipse.license"
@@ -40,16 +40,7 @@ http://www.eclipse.org/legal/epl-v20.html
</license>
<requires>
- <import plugin="org.eclipse.etrice.generator.ui" version="0.4.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.cdt.core" version="5.5.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.cdt.managedbuilder.core" version="8.2.1" match="greaterOrEqual"/>
- <import plugin="org.eclipse.equinox.common" version="3.6.200" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.resources"/>
- <import plugin="org.eclipse.ant.launching"/>
<import feature="org.eclipse.cdt" version="8.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ant.core"/>
- <import plugin="org.eclipse.ant.ui"/>
- <import plugin="org.eclipse.core.externaltools"/>
</requires>
<plugin
diff --git a/features/org.eclipse.etrice.feature/feature.xml b/features/org.eclipse.etrice.feature/feature.xml
index 8f1f90a1a..1d1a504de 100644
--- a/features/org.eclipse.etrice.feature/feature.xml
+++ b/features/org.eclipse.etrice.feature/feature.xml
@@ -17,7 +17,7 @@
<feature
id="org.eclipse.etrice.feature"
label="%featureName"
- version="2.0.0.qualifier"
+ version="0.0.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.etrice.core.room.ui"
license-feature="org.eclipse.license"
@@ -44,9 +44,8 @@ http://www.eclipse.org/legal/epl-v20.html
</url>
<requires>
- <import plugin="org.apache.commons.io" version="2.0.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.graphiti" version="0.8.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.xtext.redist" version="2.12.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.xtext.runtime" version="2.15.0" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/features/org.eclipse.etrice.fsm.feature/feature.xml b/features/org.eclipse.etrice.fsm.feature/feature.xml
index 24c738e31..b21dabf16 100644
--- a/features/org.eclipse.etrice.fsm.feature/feature.xml
+++ b/features/org.eclipse.etrice.fsm.feature/feature.xml
@@ -17,7 +17,7 @@
<feature
id="org.eclipse.etrice.fsm.feature"
label="eTrice.FSM Feature"
- version="2.0.0.qualifier"
+ version="0.0.0.qualifier"
provider-name="eTrice"
license-feature="org.eclipse.license"
license-feature-version="2.0.2.v20181016-2210">
diff --git a/features/org.eclipse.etrice.tests.feature/feature.xml b/features/org.eclipse.etrice.tests.feature/feature.xml
index acbd64514..f9734e2b0 100644
--- a/features/org.eclipse.etrice.tests.feature/feature.xml
+++ b/features/org.eclipse.etrice.tests.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.etrice.tests.feature"
label="%featureName"
- version="2.0.0.qualifier"
+ version="0.0.0.qualifier"
provider-name="%providerName">
<description>
@@ -22,40 +22,40 @@ http://www.eclipse.org/legal/epl-v20.html
</license>
<requires>
- <import plugin="org.eclipse.etrice.core.room" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.common" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.fsm" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.core.room"/>
+ <import plugin="org.eclipse.etrice.core.common"/>
+ <import plugin="org.eclipse.etrice.core.fsm"/>
<import plugin="org.junit" version="4.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.xtext.junit4" version="2.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.osgi" version="3.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.xtext" version="2.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.runtime" version="3.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.emf.ecore"/>
- <import plugin="org.eclipse.etrice.generator" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.generator.fsm" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.ui.behavior" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.ui.behavior.fsm" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.ui.common" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.ui.common.base" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.generator"/>
+ <import plugin="org.eclipse.etrice.generator.fsm"/>
+ <import plugin="org.eclipse.etrice.ui.behavior"/>
+ <import plugin="org.eclipse.etrice.ui.behavior.fsm"/>
+ <import plugin="org.eclipse.etrice.ui.common"/>
+ <import plugin="org.eclipse.etrice.ui.common.base"/>
<import plugin="org.eclipse.ui" version="3.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.graphiti" version="0.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.ui.structure" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.etunit.converter" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.ui.structure"/>
+ <import plugin="org.eclipse.etrice.etunit.converter"/>
<import plugin="org.junit" version="4.8.2" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.genmodel" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.core.genmodel"/>
<import plugin="org.eclipse.core.runtime" version="3.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.config" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.config.ui" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.core.config"/>
+ <import plugin="org.eclipse.etrice.core.config.ui"/>
<import plugin="org.apache.log4j" version="1.2.15" match="greaterOrEqual"/>
<import plugin="org.apache.commons.logging" version="1.0.4" match="greaterOrEqual"/>
<import plugin="org.hamcrest.core"/>
- <import plugin="org.eclipse.etrice.abstractexec.behavior" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.abstractexec.behavior"/>
<import plugin="org.eclipse.emf.ecore" version="2.7.0" match="greaterOrEqual"/>
<import plugin="com.google.inject" version="3.0.0" match="greaterOrEqual"/>
<import plugin="org.junit" version="4.10.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.etmap" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.etmap.ui" version="2.0.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.etrice.core.etphys" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.core.etmap"/>
+ <import plugin="org.eclipse.etrice.core.etmap.ui"/>
+ <import plugin="org.eclipse.etrice.core.etphys"/>
<import plugin="org.eclipse.etrice.core.etphys.ui"/>
<import plugin="org.eclipse.core.runtime" version="3.5.0" match="compatible"/>
<import plugin="org.eclipse.core.variables" version="3.0.0" match="compatible"/>
@@ -63,7 +63,7 @@ http://www.eclipse.org/legal/epl-v20.html
<import plugin="org.eclipse.pde.core" version="3.5.0" match="compatible"/>
<import plugin="org.eclipse.equinox.frameworkadmin" version="2.0.0" match="compatible"/>
<import plugin="org.eclipse.xtext.xbase.junit"/>
- <import plugin="org.eclipse.etrice.ui.base.tests" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.etrice.ui.base.tests"/>
<import plugin="org.eclipse.xtext.xbase.lib"/>
<import plugin="org.eclipse.etrice.core.common.ui"/>
<import plugin="org.eclipse.oomph.util" version="1.7.0" match="compatible"/>
diff --git a/features/pom.xml b/features/pom.xml
index dca419ad3..761668b1c 100644
--- a/features/pom.xml
+++ b/features/pom.xml
@@ -17,10 +17,9 @@
<parent>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.etrice.parent</relativePath>
</parent>
- <groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.features</artifactId>
<packaging>pom</packaging>
</project> \ No newline at end of file
diff --git a/gradle/scmVersion.gradle b/gradle/scmVersion.gradle
index b416d4e7f..2686f78a1 100644
--- a/gradle/scmVersion.gradle
+++ b/gradle/scmVersion.gradle
@@ -9,17 +9,11 @@ buildscript {
apply plugin: pl.allegro.tech.build.axion.release.ReleasePlugin
-if(properties.get('build.type') == 'N') {
- ext.set('release.forceSnapshot', true)
-}
-
scmVersion {
tag {
prefix = 'v'
versionSeparator = '_'
}
- versionIncrementer 'incrementPrerelease'
- versionCreator 'versionWithBranch'
// localOnly = false
checks {
uncommittedChanges = false
diff --git a/plugins/org.eclipse.etrice.abstractexec.behavior/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.abstractexec.behavior/META-INF/MANIFEST.MF
index b95e7c236..da385143c 100644
--- a/plugins/org.eclipse.etrice.abstractexec.behavior/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.abstractexec.behavior/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Abstract Execution for State Machines
Bundle-SymbolicName: org.eclipse.etrice.abstractexec.behavior;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.generator.fsm,
org.eclipse.emf.ecore,
- org.eclipse.xtext;bundle-version="2.6.0",
+ org.eclipse.xtext,
org.eclipse.core.runtime,
org.eclipse.xtext.xbase.lib,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.generator.base
Bundle-Activator: org.eclipse.etrice.abstractexec.behavior.Activator
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.etrice.abstractexec.behavior
diff --git a/plugins/org.eclipse.etrice.core.common.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.common.ui/META-INF/MANIFEST.MF
index 533dee979..c434bd944 100644
--- a/plugins/org.eclipse.etrice.core.common.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.common.ui/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Common eTrice DSL UI classes
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.common.ui; singleton:=true
Require-Bundle: org.eclipse.etrice.core.common;visibility:=reexport,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.common.types.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.common.types.ui,
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare,
- org.eclipse.core.filesystem;bundle-version="1.3.0",
+ org.eclipse.core.filesystem,
org.eclipse.help,
org.eclipse.xtext.xbase.lib,
org.eclipse.etrice.generator.base
diff --git a/plugins/org.eclipse.etrice.core.common/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.common/META-INF/MANIFEST.MF
index bcf63a905..b9e932727 100644
--- a/plugins/org.eclipse.etrice.core.common/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.common/META-INF/MANIFEST.MF
@@ -2,19 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Common eTrice Grammar Fragment and Utility Classes
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.common; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.xbase;bundle-version="2.6.0";resolution:=optional;visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.xtext.common.types;bundle-version="2.6.0",
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+Require-Bundle: org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.xbase;resolution:=optional;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
+ org.eclipse.xtext.util,
+ org.eclipse.xtext.common.types,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- org.objectweb.asm;bundle-version="[5.0.0,7.0.0)";resolution:=optional,
+ org.objectweb.asm;resolution:=optional,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
diff --git a/plugins/org.eclipse.etrice.core.config.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.config.ui/META-INF/MANIFEST.MF
index 41d149281..8e157edf1 100644
--- a/plugins/org.eclipse.etrice.core.config.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.config.ui/META-INF/MANIFEST.MF
@@ -2,23 +2,23 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Config DSL UI
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.config.ui; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.config;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+Require-Bundle: org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.config;visibility:=reexport,
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.common.types.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.common.types.ui,
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare
Import-Package: org.apache.commons.logging,
org.apache.log4j,
diff --git a/plugins/org.eclipse.etrice.core.config/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.config/META-INF/MANIFEST.MF
index 50858949a..a0ee34012 100644
--- a/plugins/org.eclipse.etrice.core.config/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.config/META-INF/MANIFEST.MF
@@ -2,29 +2,29 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Config DSL
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.config; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.xbase;bundle-version="2.6.0";resolution:=optional;visibility:=reexport,
- org.apache.log4j;bundle-version="1.2.15";visibility:=reexport,
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional;visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.xbase;resolution:=optional;visibility:=reexport,
+ org.apache.log4j;visibility:=reexport,
+ org.apache.commons.logging;resolution:=optional;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.6.0",
+ org.eclipse.xtext.util,
+ org.eclipse.xtext.xbase.lib,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
- org.eclipse.xtext.common.types;bundle-version="2.6.0"
+ org.eclipse.xtext.common.types
Import-Package: org.apache.commons.logging,
org.apache.log4j,
- org.eclipse.xtend.lib;bundle-version="2.6.0",
+ org.eclipse.xtend.lib,
org.eclipse.xtext.xbase.lib
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core,
diff --git a/plugins/org.eclipse.etrice.core.etmap.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.etmap.ui/META-INF/MANIFEST.MF
index 6b2c0aa8e..501ee06e0 100644
--- a/plugins/org.eclipse.etrice.core.etmap.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.etmap.ui/META-INF/MANIFEST.MF
@@ -2,23 +2,23 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etmap.ui
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etmap.ui; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+Require-Bundle: org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.etmap;visibility:=reexport,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare,
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0"
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.core.room
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.etmap.ui,
diff --git a/plugins/org.eclipse.etrice.core.etmap/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.etmap/META-INF/MANIFEST.MF
index 79a524e7a..d0ab17c29 100644
--- a/plugins/org.eclipse.etrice.core.etmap/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.etmap/META-INF/MANIFEST.MF
@@ -2,28 +2,28 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etmap
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etmap; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.xbase;bundle-version="2.6.0";resolution:=optional;visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.xbase;resolution:=optional;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
+ org.eclipse.xtext.util,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
org.eclipse.xtext.xbase.lib,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.generator.base
Import-Package: org.apache.log4j,
org.eclipse.xtext.xbase.lib
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.core.etphys.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.etphys.ui/META-INF/MANIFEST.MF
index cb6e6ffa7..8423ff3c8 100644
--- a/plugins/org.eclipse.etrice.core.etphys.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.etphys.ui/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etphys.ui
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etphys.ui; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+Require-Bundle: org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.etphys;visibility:=reexport,
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare,
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0"
+ org.eclipse.etrice.core.common.ui
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.etphys.ui.contentassist,
diff --git a/plugins/org.eclipse.etrice.core.etphys/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.etphys/META-INF/MANIFEST.MF
index 867c16429..53d512cbe 100644
--- a/plugins/org.eclipse.etrice.core.etphys/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.etphys/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etphys
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etphys; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
+Require-Bundle: org.eclipse.etrice.core.room,
+ org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
org.antlr.runtime,
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
+ org.eclipse.xtext.util,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
- org.eclipse.etrice.core.common;bundle-version="2.0.0",
+ org.eclipse.etrice.core.common,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
org.eclipse.xtext.xbase.lib
diff --git a/plugins/org.eclipse.etrice.core.fsm.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.fsm.ui/META-INF/MANIFEST.MF
index d43f3fac0..231e17f09 100644
--- a/plugins/org.eclipse.etrice.core.fsm.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.fsm.ui/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: FSM DSL UI
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.fsm.ui; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.common.ui,
org.eclipse.etrice.core.fsm;visibility:=reexport,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.common.types.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.common.types.ui,
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
diff --git a/plugins/org.eclipse.etrice.core.fsm/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.fsm/META-INF/MANIFEST.MF
index fb03894c1..3a1418f43 100644
--- a/plugins/org.eclipse.etrice.core.fsm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.fsm/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: FSM DSL
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.fsm; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.xbase;bundle-version="2.6.0";resolution:=optional;visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.xtext.common.types;bundle-version="2.6.0",
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.xbase;resolution:=optional;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
+ org.eclipse.xtext.util,
+ org.eclipse.xtext.common.types,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
- org.objectweb.asm;bundle-version="[5.0.1,7.0.0)";resolution:=optional,
- com.google.guava;bundle-version="8.0.0",
+ org.objectweb.asm;resolution:=optional,
+ com.google.guava,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
org.eclipse.xtext.xbase.lib
diff --git a/plugins/org.eclipse.etrice.core.genmodel.fsm/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.genmodel.fsm/META-INF/MANIFEST.MF
index 2d2899146..3558b5540 100644
--- a/plugins/org.eclipse.etrice.core.genmodel.fsm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.genmodel.fsm/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.etrice.core.genmodel.fsm;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.genmodel.fsm,
@@ -10,12 +10,12 @@ Export-Package: org.eclipse.etrice.core.genmodel.fsm,
org.eclipse.etrice.core.genmodel.fsm.fsmgen.impl,
org.eclipse.etrice.core.genmodel.fsm.fsmgen.util
Require-Bundle: org.eclipse.etrice.core.common;visibility:=reexport,
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0";visibility:=reexport,
+ org.eclipse.etrice.core.fsm;visibility:=reexport,
org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.xtext.xbase.lib,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.etrice.core.genmodel/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.genmodel/META-INF/MANIFEST.MF
index e6d555467..44dd15ea2 100644
--- a/plugins/org.eclipse.etrice.core.genmodel/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.genmodel/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.etrice.core.genmodel;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: Eclipse eTrice
Bundle-Localization: plugin
@@ -13,13 +13,13 @@ Export-Package: org.eclipse.etrice.core.genmodel,
org.eclipse.etrice.core.genmodel.etricegen.impl,
org.eclipse.etrice.core.genmodel.etricegen.util,
org.eclipse.etrice.core.genmodel.util
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.etrice.core.room;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0";visibility:=reexport,
+Require-Bundle: org.eclipse.etrice.core.common;visibility:=reexport,
+ org.eclipse.etrice.core.fsm;visibility:=reexport,
+ org.eclipse.etrice.core.room;visibility:=reexport,
+ org.eclipse.etrice.core.genmodel.fsm;visibility:=reexport,
org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.etrice.core.genmodel
diff --git a/plugins/org.eclipse.etrice.core.room.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.room.ui/META-INF/MANIFEST.MF
index 0babd26b1..e17635656 100644
--- a/plugins/org.eclipse.etrice.core.room.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.room.ui/META-INF/MANIFEST.MF
@@ -2,30 +2,30 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: ROOM DSL UI
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.room.ui;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.fsm.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0";visibility:=reexport,
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.doc;bundle-version="2.0.0",
- org.eclipse.ui;bundle-version="3.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
- org.eclipse.xtext.builder;bundle-version="2.6.0",
- org.antlr.runtime;bundle-version="3.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm.ui,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.core.room;visibility:=reexport,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.doc,
+ org.eclipse.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui,
+ org.eclipse.xtext.ui.shared,
+ org.eclipse.xtext.builder,
+ org.antlr.runtime,
org.eclipse.emf.codegen,
org.eclipse.compare,
- org.eclipse.core.filesystem;bundle-version="1.3.0",
+ org.eclipse.core.filesystem,
org.eclipse.help,
com.google.inject,
org.eclipse.etrice.expressions.ui,
- org.eclipse.etrice.ui.behavior.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.ui.behavior.fsm,
+ org.eclipse.etrice.generator.base
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.ui,
diff --git a/plugins/org.eclipse.etrice.core.room/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.core.room/META-INF/MANIFEST.MF
index 0fc9fa2b7..d521e2a93 100644
--- a/plugins/org.eclipse.etrice.core.room/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.core.room/META-INF/MANIFEST.MF
@@ -2,26 +2,26 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: ROOM DSL
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.room;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.xtext,
+ org.eclipse.xtext.generator;resolution:=optional,
+ org.eclipse.xtext.util,
org.eclipse.xtext.xbase.lib,
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- com.ibm.icu;bundle-version="4.2.1";resolution:=optional,
+ com.ibm.icu;resolution:=optional,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
- org.antlr.runtime;bundle-version="3.0.0",
- org.eclipse.core.resources;bundle-version="3.7.100",
- org.eclipse.core.runtime;bundle-version="3.7.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
+ org.antlr.runtime,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.etrice.core.genmodel.fsm,
org.eclipse.etrice.generator.base
Import-Package: org.apache.log4j,
org.eclipse.etrice.core.room
diff --git a/plugins/org.eclipse.etrice.dctools.fsm/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.dctools.fsm/META-INF/MANIFEST.MF
index 1507f1262..8a50b2ee3 100644
--- a/plugins/org.eclipse.etrice.dctools.fsm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.dctools.fsm/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Detail Code Tools for FSM
Bundle-SymbolicName: org.eclipse.etrice.dctools.fsm
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Automatic-Module-Name: org.eclipse.etrice.dctools.fsm
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
Require-Bundle: org.eclipse.jface.text,
- org.eclipse.xtext.xbase.lib;bundle-version="2.6.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.6.0",
+ org.eclipse.xtext.xbase.lib,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtend.lib.macro,
org.eclipse.xtext.ui,
org.eclipse.etrice.core.fsm,
org.eclipse.etrice.generator
diff --git a/plugins/org.eclipse.etrice.dctools/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.dctools/META-INF/MANIFEST.MF
index 141958859..f2442efd4 100644
--- a/plugins/org.eclipse.etrice.dctools/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.dctools/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Detail Code Tools
Bundle-SymbolicName: org.eclipse.etrice.dctools
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Automatic-Module-Name: org.eclipse.etrice.dctools
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.doc/META-INF/MANIFEST.MF
index 68fc1dd2c..dd47836e3 100644
--- a/plugins/org.eclipse.etrice.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.doc/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Documentation
Bundle-SymbolicName: org.eclipse.etrice.doc;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.etrice.etunit.converter/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.etunit.converter/META-INF/MANIFEST.MF
index bbee7339d..fc007d36a 100644
--- a/plugins/org.eclipse.etrice.etunit.converter/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.etunit.converter/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: etUnit File Converter
Bundle-SymbolicName: org.eclipse.etrice.etunit.converter;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: Eclipse eTrice
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.etrice.expressions.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.expressions.ui/META-INF/MANIFEST.MF
index 39e95a4c1..5dc11cc55 100644
--- a/plugins/org.eclipse.etrice.expressions.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.expressions.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Expressions UI
Bundle-SymbolicName: org.eclipse.etrice.expressions.ui;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jface.text,
org.eclipse.xtext.xbase.lib,
diff --git a/plugins/org.eclipse.etrice.generator.base/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.base/META-INF/MANIFEST.MF
index ab1a0dabd..dbbd29203 100644
--- a/plugins/org.eclipse.etrice.generator.base/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.base/META-INF/MANIFEST.MF
@@ -1,16 +1,15 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.etrice.generator.base
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.emf.ecore,
- com.google.inject;bundle-version="3.0.0",
+ com.google.inject,
org.eclipse.xtext.generator,
org.eclipse.xtext.util,
org.eclipse.xtext,
org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.apache.commons.io
+ org.eclipse.core.runtime
Export-Package: org.eclipse.etrice.generator.base,
org.eclipse.etrice.generator.base.args,
org.eclipse.etrice.generator.base.cli,
diff --git a/plugins/org.eclipse.etrice.generator.c/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.c/META-INF/MANIFEST.MF
index b5346d4b1..700e45fdf 100644
--- a/plugins/org.eclipse.etrice.generator.c/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.c/META-INF/MANIFEST.MF
@@ -2,19 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice C Generator
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.c;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.config;bundle-version="2.0.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.xtext.generator;bundle-version="2.6.0",
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.config,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtext.generator,
+ org.eclipse.xtext.util,
+ org.eclipse.etrice.generator.base,
org.eclipse.etrice.generator.config
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.generator.config/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.config/META-INF/MANIFEST.MF
index e62e4d45a..25d6705a2 100644
--- a/plugins/org.eclipse.etrice.generator.config/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.config/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Generator Config
Bundle-SymbolicName: org.eclipse.etrice.generator.config;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.config;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- com.google.guava;bundle-version="8.0.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.6.0"
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.config,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.base,
+ org.eclipse.xtend.lib,
+ com.google.guava,
+ org.eclipse.xtext.xbase.lib
Export-Package: org.eclipse.etrice.generator.config
Automatic-Module-Name: org.eclipse.etrice.generator.config
diff --git a/plugins/org.eclipse.etrice.generator.contractmonitor/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.contractmonitor/META-INF/MANIFEST.MF
index 7d3a96534..3905b25ee 100644
--- a/plugins/org.eclipse.etrice.generator.contractmonitor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.contractmonitor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Contract Monitor Generator
Bundle-SymbolicName: org.eclipse.etrice.generator.contractmonitor;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Export-Package: org.eclipse.etrice.generator.contractmonitor,
org.eclipse.etrice.generator.contractmonitor.setup
Bundle-Vendor: Eclipse eTrice
@@ -15,3 +15,5 @@ Require-Bundle: org.eclipse.etrice.core.genmodel,
org.eclipse.xtend.lib,
org.eclipse.xtend.lib.macro,
org.eclipse.xtext
+Automatic-Module-Name: org.eclipse.etrice.generator.contractmonitor
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.generator.cpp/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.cpp/META-INF/MANIFEST.MF
index f25a85762..7ed017297 100644
--- a/plugins/org.eclipse.etrice.generator.cpp/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.cpp/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice C++ Generator
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.cpp;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.config;bundle-version="2.0.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.xtext.generator;bundle-version="2.6.0",
- org.eclipse.xtext.util;bundle-version="2.6.0",
+Require-Bundle: org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.config,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtext.generator,
+ org.eclipse.xtext.util,
org.eclipse.etrice.core.genmodel.fsm,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.generator.base
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator.cpp,
diff --git a/plugins/org.eclipse.etrice.generator.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.doc/META-INF/MANIFEST.MF
index 3437cb2e7..e82991666 100644
--- a/plugins/org.eclipse.etrice.generator.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.doc/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Document Generator
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.doc;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.core.resources;bundle-version="3.6.0",
- org.eclipse.core.runtime;bundle-version="3.6.0",
- org.eclipse.ui;bundle-version="3.7.0",
- org.eclipse.ui.ide;bundle-version="3.7.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.xtext.generator;bundle-version="2.6.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
- org.eclipse.etrice.abstractexec.behavior;bundle-version="2.0.0"
+Require-Bundle: org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.core.resources,
+ org.eclipse.core.runtime,
+ org.eclipse.ui,
+ org.eclipse.ui.ide,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtext.util,
+ org.eclipse.xtext.generator,
+ org.eclipse.etrice.generator.base,
+ org.eclipse.etrice.abstractexec.behavior
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator.doc;uses:="org.eclipse.etrice.generator.base",
diff --git a/plugins/org.eclipse.etrice.generator.fsm/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.fsm/META-INF/MANIFEST.MF
index 9dff0de57..70f20d3a5 100644
--- a/plugins/org.eclipse.etrice.generator.fsm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.fsm/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Generator for Finite State Machines
Bundle-SymbolicName: org.eclipse.etrice.generator.fsm
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator.fsm.base,
org.eclipse.etrice.generator.fsm.generic
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.genmodel.fsm,
org.eclipse.core.resources,
org.eclipse.core.runtime,
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.xtend.lib,
+ org.eclipse.etrice.generator.base
Import-Package: org.eclipse.core.runtime
Automatic-Module-Name: org.eclipse.etrice.generator.fsm
diff --git a/plugins/org.eclipse.etrice.generator.fsmtest.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.fsmtest.ui/META-INF/MANIFEST.MF
index f8380642b..42baa156b 100644
--- a/plugins/org.eclipse.etrice.generator.fsmtest.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.fsmtest.ui/META-INF/MANIFEST.MF
@@ -2,19 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.generator.fsmtest.ui
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.fsmtest.ui; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.etrice.generator.fsmtest;visibility:=reexport,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version="3.5.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+ org.eclipse.xtext.ui,
+ org.eclipse.ui.editors,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.ui.shared,
org.eclipse.ui,
- org.eclipse.xtext.builder;bundle-version="2.6.0",
+ org.eclipse.xtext.builder,
org.antlr.runtime,
- org.eclipse.xtext.common.types.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.codetemplates.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.common.types.ui,
+ org.eclipse.xtext.ui.codetemplates.ui,
org.eclipse.compare
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.generator.fsmtest/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.fsmtest/META-INF/MANIFEST.MF
index 6e5be66e4..06f8d1cc2 100644
--- a/plugins/org.eclipse.etrice.generator.fsmtest/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.fsmtest/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.generator.fsmtest
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.fsmtest; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.xtext;bundle-version="2.6.0";visibility:=reexport,
- org.eclipse.xtext.xbase;bundle-version="2.6.0";resolution:=optional;visibility:=reexport,
- org.eclipse.xtext.generator;bundle-version="2.6.0";resolution:=optional,
- org.apache.commons.logging;bundle-version="1.0.4";resolution:=optional,
+Require-Bundle: org.eclipse.xtext;visibility:=reexport,
+ org.eclipse.xtext.xbase;resolution:=optional;visibility:=reexport,
+ org.eclipse.xtext.generator;resolution:=optional,
+ org.apache.commons.logging;resolution:=optional,
org.eclipse.emf.codegen.ecore;resolution:=optional,
org.eclipse.emf.mwe.utils;resolution:=optional,
org.eclipse.emf.mwe2.launch;resolution:=optional,
- org.eclipse.xtext.util;bundle-version="2.6.0",
+ org.eclipse.xtext.util,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
- org.eclipse.xtext.common.types;bundle-version="2.6.0"
+ org.eclipse.xtext.common.types
Import-Package: org.apache.log4j,
org.eclipse.xtext.xbase.lib
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.etrice.generator.java/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.java/META-INF/MANIFEST.MF
index ab798710d..7bf6f43be 100644
--- a/plugins/org.eclipse.etrice.generator.java/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.java/META-INF/MANIFEST.MF
@@ -2,19 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Java Generator
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.java;singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.config;bundle-version="2.0.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
- org.eclipse.xtext.generator;bundle-version="2.6.0",
- org.eclipse.xtext.util;bundle-version="2.6.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+Require-Bundle: org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.config,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtext.generator,
+ org.eclipse.xtext.util,
+ org.eclipse.etrice.generator.base
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator.java,
diff --git a/plugins/org.eclipse.etrice.generator.launch.c/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch.c/META-INF/MANIFEST.MF
index 822ebd82b..c9c5458e5 100644
--- a/plugins/org.eclipse.etrice.generator.launch.c/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch.c/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice C Generator Launcher
Bundle-SymbolicName: org.eclipse.etrice.generator.launch.c;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.generator.launch.c.Activator
-Require-Bundle: org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.c;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator.c,
+ org.eclipse.etrice.generator.launch,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.debug.core,
org.eclipse.debug.ui,
- org.eclipse.jdt.ui;bundle-version="3.7.0",
- org.eclipse.jdt.core;bundle-version="3.7.0",
- org.eclipse.core.variables;bundle-version="3.2.500",
- org.eclipse.etrice.generator.ui;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.jdt.ui,
+ org.eclipse.jdt.core,
+ org.eclipse.core.variables,
+ org.eclipse.etrice.generator.ui,
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.jdt.launching,
diff --git a/plugins/org.eclipse.etrice.generator.launch.contractmonitor/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch.contractmonitor/META-INF/MANIFEST.MF
index 26a70fa89..39e6cb715 100644
--- a/plugins/org.eclipse.etrice.generator.launch.contractmonitor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch.contractmonitor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Contract Monitor Generator Launcher
Bundle-SymbolicName: org.eclipse.etrice.generator.launch.contractmonitor;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Vendor: Eclipse eTrice
@@ -19,3 +19,4 @@ Require-Bundle: org.eclipse.etrice.generator.contractmonitor,
Import-Package: org.eclipse.jdt.launching,
org.eclipse.ui.dialogs
Export-Package: org.eclipse.etrice.generator.launch.contractmonitor
+Automatic-Module-Name: org.eclipse.etrice.generator.launch.contractmonitor
diff --git a/plugins/org.eclipse.etrice.generator.launch.cpp/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch.cpp/META-INF/MANIFEST.MF
index 83d4fc1ae..776abbd95 100644
--- a/plugins/org.eclipse.etrice.generator.launch.cpp/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch.cpp/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Cpp Generator Launcher
Bundle-SymbolicName: org.eclipse.etrice.generator.launch.cpp;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.generator.launch.cpp.Activator
-Require-Bundle: org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.cpp;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator.cpp,
+ org.eclipse.etrice.generator.launch,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.debug.core,
org.eclipse.debug.ui,
- org.eclipse.jdt.ui;bundle-version="3.7.0",
- org.eclipse.jdt.core;bundle-version="3.7.0",
- org.eclipse.core.variables;bundle-version="3.2.500",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.jdt.ui,
+ org.eclipse.jdt.core,
+ org.eclipse.core.variables,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.jdt.launching,
diff --git a/plugins/org.eclipse.etrice.generator.launch.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch.doc/META-INF/MANIFEST.MF
index bc57860c9..7aa8e58e5 100644
--- a/plugins/org.eclipse.etrice.generator.launch.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch.doc/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Doc Generator Launcher
Bundle-SymbolicName: org.eclipse.etrice.generator.launch.doc;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.generator.launch.doc.Activator
-Require-Bundle: org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.doc;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.doc,
+ org.eclipse.etrice.generator.base,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.etrice.generator.launch,
diff --git a/plugins/org.eclipse.etrice.generator.launch.java/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch.java/META-INF/MANIFEST.MF
index 18ca42191..94769d0ef 100644
--- a/plugins/org.eclipse.etrice.generator.launch.java/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch.java/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Java Generator Launcher
Bundle-SymbolicName: org.eclipse.etrice.generator.launch.java;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.generator.launch.java.Activator
-Require-Bundle: org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.java;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator.java,
+ org.eclipse.etrice.generator.launch,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.debug.core,
org.eclipse.debug.ui,
- org.eclipse.jdt.ui;bundle-version="3.7.0",
- org.eclipse.jdt.core;bundle-version="3.7.0",
- org.eclipse.core.variables;bundle-version="3.2.500",
- org.eclipse.etrice.generator.ui;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.jdt.ui,
+ org.eclipse.jdt.core,
+ org.eclipse.core.variables,
+ org.eclipse.etrice.generator.ui,
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.jdt.launching,
diff --git a/plugins/org.eclipse.etrice.generator.launch/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.launch/META-INF/MANIFEST.MF
index 2c496aafc..597b8546a 100644
--- a/plugins/org.eclipse.etrice.generator.launch/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.launch/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Generator Launch Base Classes
Bundle-SymbolicName: org.eclipse.etrice.generator.launch;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.generator.launch.Activator
-Require-Bundle: org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.etrice.generator.ui,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.room.ui,
org.eclipse.ui,
org.eclipse.ui.console,
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
+ org.eclipse.xtext.ui.shared,
+ org.eclipse.xtext.ui,
org.eclipse.debug.core,
org.eclipse.debug.ui,
org.eclipse.core.variables,
org.eclipse.jdt.launching,
org.eclipse.ui.ide,
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
+ org.eclipse.etrice.generator.base,
org.eclipse.etrice.core.common.ui
Import-Package: org.eclipse.xtext.xbase.lib
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.etrice.generator.ui.cdt/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.ui.cdt/META-INF/MANIFEST.MF
index 7fe5f5328..5d88e9303 100644
--- a/plugins/org.eclipse.etrice.generator.ui.cdt/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.ui.cdt/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: CDT integration of eTrice
Bundle-SymbolicName: org.eclipse.etrice.generator.ui.cdt;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.etrice.generator.ui;bundle-version="2.0.0",
- org.eclipse.cdt.core;bundle-version="5.5.0",
- org.eclipse.cdt.managedbuilder.core;bundle-version="8.2.0",
- org.eclipse.equinox.common;bundle-version="3.6.200",
- org.eclipse.ui.workbench;bundle-version="3.106.0",
- org.eclipse.equinox.preferences;bundle-version="3.5.200",
- org.eclipse.core.commands;bundle-version="3.6.100",
- org.eclipse.ui.ide;bundle-version="3.10.0",
+Require-Bundle: org.eclipse.etrice.generator.ui,
+ org.eclipse.cdt.core,
+ org.eclipse.cdt.managedbuilder.core,
+ org.eclipse.equinox.common,
+ org.eclipse.ui.workbench,
+ org.eclipse.equinox.preferences,
+ org.eclipse.core.commands,
+ org.eclipse.ui.ide,
org.eclipse.emf.common,
org.eclipse.emf.common.ui,
- org.eclipse.core.runtime;bundle-version="3.10.0"
+ org.eclipse.core.runtime
Import-Package: org.eclipse.core.resources,
org.eclipse.core.runtime.jobs
Bundle-Activator: org.eclipse.etrice.generator.ui.cdt.Activator
diff --git a/plugins/org.eclipse.etrice.generator.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator.ui/META-INF/MANIFEST.MF
index 0cbf26b3c..77882682e 100644
--- a/plugins/org.eclipse.etrice.generator.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator.ui/META-INF/MANIFEST.MF
@@ -2,31 +2,31 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Generator UI
Bundle-SymbolicName: org.eclipse.etrice.generator.ui;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.etrice.ui.runtime;bundle-version="2.0.0",
- org.eclipse.etrice.core.common;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.core.etmap.ui,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.core.etphys.ui,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.etrice.ui.runtime,
+ org.eclipse.etrice.core.common,
org.eclipse.core.runtime,
org.eclipse.ui,
- org.apache.log4j;bundle-version="1.2.15",
- org.eclipse.core.resources;bundle-version="3.8.100",
+ org.apache.log4j,
+ org.eclipse.core.resources,
org.eclipse.emf.ecore,
- org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.jdt.core;bundle-version="3.9.0",
- org.eclipse.jdt.launching;bundle-version="3.7.0",
- org.eclipse.ui.ide;bundle-version="3.9.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.6.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+ org.eclipse.etrice.core.room.ui,
+ org.eclipse.jdt.core,
+ org.eclipse.jdt.launching,
+ org.eclipse.ui.ide,
+ org.eclipse.xtext.xbase.lib,
+ org.eclipse.xtext,
+ org.eclipse.xtext.ui,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.base
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.etrice.generator.ui.Activator
Export-Package: org.eclipse.etrice.generator.ui.configurator,
diff --git a/plugins/org.eclipse.etrice.generator/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.generator/META-INF/MANIFEST.MF
index 5ce2f99d9..a26a6ab2d 100644
--- a/plugins/org.eclipse.etrice.generator/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.generator/META-INF/MANIFEST.MF
@@ -2,27 +2,25 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Generator Model
Bundle-SymbolicName: org.eclipse.etrice.generator;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator.base,
org.eclipse.etrice.generator.generic
-Require-Bundle: org.eclipse.etrice.generator.base;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.eclipse.core.runtime;bundle-version="3.6.0",
+Require-Bundle: org.eclipse.etrice.generator.base,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.core.etphys,
+ org.eclipse.etrice.generator.fsm,
+ org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi,
- org.eclipse.core.resources;bundle-version="3.7.100",
- org.eclipse.xtext.generator;bundle-version="2.6.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.xtend.lib;bundle-version="2.3.0",
- org.apache.commons.io;bundle-version="2.0.1",
+ org.eclipse.core.resources,
+ org.eclipse.xtext.generator,
+ org.eclipse.xtext,
+ org.eclipse.xtend.lib,
org.eclipse.etrice.core.config
Bundle-ActivationPolicy: lazy
-Import-Package: org.eclipse.etrice.generator.generic
Automatic-Module-Name: org.eclipse.etrice.generator
diff --git a/plugins/org.eclipse.etrice.logging/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.logging/META-INF/MANIFEST.MF
index efc993c10..c5bd24e2b 100644
--- a/plugins/org.eclipse.etrice.logging/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.logging/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Logging Fragment
Bundle-SymbolicName: org.eclipse.etrice.logging
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
-Fragment-Host: org.apache.log4j;bundle-version="1.2.15"
+Fragment-Host: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.etrice.logging
diff --git a/plugins/org.eclipse.etrice.ui.behavior.actioneditor/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.behavior.actioneditor/META-INF/MANIFEST.MF
index 789b6cd20..bfad6fb18 100644
--- a/plugins/org.eclipse.etrice.ui.behavior.actioneditor/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.behavior.actioneditor/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: ROOM Action Code Editor
Bundle-SymbolicName: org.eclipse.etrice.ui.behavior.actioneditor;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.behavior.actioneditor.Activator
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior.fsm;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.ui.behavior,
+ org.eclipse.etrice.ui.behavior.fsm,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.common,
@@ -17,11 +17,11 @@ Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
org.eclipse.xtext.util,
org.eclipse.xtend.lib,
org.eclipse.xtend.lib.macro,
- com.google.guava;bundle-version="8.0.0",
+ com.google.guava,
org.eclipse.xtext.xbase.lib,
org.eclipse.ui.workbench.texteditor,
org.eclipse.etrice.core.room.ui,
- org.eclipse.etrice.expressions.ui;bundle-version="2.0.0",
+ org.eclipse.etrice.expressions.ui,
org.eclipse.ui.editors
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.etrice.ui.behavior.fsm/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.behavior.fsm/META-INF/MANIFEST.MF
index 6ea109d29..b93a72334 100644
--- a/plugins/org.eclipse.etrice.ui.behavior.fsm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.behavior.fsm/META-INF/MANIFEST.MF
@@ -2,25 +2,25 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Abstract FSM Diagram Editor
Bundle-SymbolicName: org.eclipse.etrice.ui.behavior.fsm;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.behavior.fsm.Activator
Bundle-Vendor: eTrice
-Require-Bundle: org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm.ui;bundle-version="2.0.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.graphiti.ui;bundle-version="0.8.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.core.databinding;bundle-version="1.3.100",
- org.eclipse.gef;bundle-version="3.6.1",
+Require-Bundle: org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.core.fsm.ui,
+ org.eclipse.graphiti,
+ org.eclipse.graphiti.ui,
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.core.databinding,
+ org.eclipse.gef,
org.eclipse.emf.transaction,
- org.eclipse.xtext.ui;bundle-version="2.7.0",
- org.eclipse.xtend.lib;bundle-version="2.7.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.7.0",
- org.eclipse.etrice.expressions.ui;bundle-version="2.0.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.7.0"
+ org.eclipse.xtext.ui,
+ org.eclipse.xtend.lib,
+ org.eclipse.xtext.ui.shared,
+ org.eclipse.etrice.expressions.ui,
+ org.eclipse.xtext.ui.shared
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.etrice.ui.behavior.fsm,
diff --git a/plugins/org.eclipse.etrice.ui.behavior/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.behavior/META-INF/MANIFEST.MF
index adb25f3e4..ade3a037f 100644
--- a/plugins/org.eclipse.etrice.ui.behavior/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.behavior/META-INF/MANIFEST.MF
@@ -2,27 +2,27 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Actor Behavior Diagram Editor
Bundle-SymbolicName: org.eclipse.etrice.ui.behavior;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.behavior.Activator
-Require-Bundle: org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm.ui;bundle-version="2.0.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.graphiti.ui;bundle-version="0.8.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.core.databinding;bundle-version="1.3.100",
- org.eclipse.gef;bundle-version="3.6.1",
+Require-Bundle: org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.etrice.ui.behavior.fsm,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.fsm.ui,
+ org.eclipse.graphiti,
+ org.eclipse.graphiti.ui,
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.core.databinding,
+ org.eclipse.gef,
org.eclipse.emf.transaction,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
- org.eclipse.etrice.abstractexec.behavior;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.eclipse.etrice.expressions.ui;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0"
+ org.eclipse.xtext.ui,
+ org.eclipse.xtext.ui.shared,
+ org.eclipse.etrice.abstractexec.behavior,
+ org.eclipse.etrice.core.genmodel,
+ org.eclipse.etrice.expressions.ui,
+ org.eclipse.etrice.generator
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
diff --git a/plugins/org.eclipse.etrice.ui.commands/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.commands/META-INF/MANIFEST.MF
index e0adbf383..d571f3d1b 100644
--- a/plugins/org.eclipse.etrice.ui.commands/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.commands/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Commands
Bundle-SymbolicName: org.eclipse.etrice.ui.commands; singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.commands.Activator
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior.fsm;bundle-version="2.0.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.graphiti.ui;bundle-version="0.8.0",
- org.eclipse.gef;bundle-version="3.7.0",
- org.eclipse.ui.ide;bundle-version="3.7.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.ui.behavior.fsm,
+ org.eclipse.graphiti,
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.xtext.ui,
+ org.eclipse.graphiti.ui,
+ org.eclipse.gef,
+ org.eclipse.ui.ide,
org.eclipse.xtext.ui.shared
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.etrice.ui.common.base/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.common.base/META-INF/MANIFEST.MF
index 1caac8f92..9a2a39b06 100644
--- a/plugins/org.eclipse.etrice.ui.common.base/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.common.base/META-INF/MANIFEST.MF
@@ -2,29 +2,29 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Common Base for UI
Bundle-SymbolicName: org.eclipse.etrice.ui.common.base;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.common.base.UIBaseActivator
Bundle-Vendor: eTrice
-Require-Bundle: org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm.ui;bundle-version="2.0.0",
- org.eclipse.etrice.doc;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.core.fsm.ui,
+ org.eclipse.etrice.doc,
org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.transaction,
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
- org.eclipse.xtend.lib;bundle-version="2.6.0",
+ org.eclipse.graphiti,
+ org.eclipse.xtext.ui,
+ org.eclipse.xtext.ui.shared,
+ org.eclipse.xtend.lib,
org.eclipse.emf.databinding,
org.eclipse.jface.databinding,
- org.eclipse.core.databinding.property;bundle-version="1.4.200",
- org.eclipse.jdt.core;bundle-version="3.9.0",
- org.eclipse.graphiti.ui;bundle-version="0.7.0",
- org.eclipse.gef;bundle-version="3.6.1",
- org.eclipse.ui.forms;bundle-version="3.6.1",
+ org.eclipse.core.databinding.property,
+ org.eclipse.jdt.core,
+ org.eclipse.graphiti.ui,
+ org.eclipse.gef,
+ org.eclipse.ui.forms,
org.eclipse.emf.workspace,
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.ui.ide;bundle-version="3.9.2",
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.ui.ide,
org.eclipse.help
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.etrice.ui.common/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.common/META-INF/MANIFEST.MF
index d6c45298c..c4a193e32 100644
--- a/plugins/org.eclipse.etrice.ui.common/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.common/META-INF/MANIFEST.MF
@@ -2,26 +2,26 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: UI Common
Bundle-SymbolicName: org.eclipse.etrice.ui.common;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.ui.common.base,
org.eclipse.emf.transaction,
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.ui.ide;bundle-version="3.6.0",
- org.eclipse.graphiti.ui;bundle-version="0.7.0",
- org.eclipse.gef;bundle-version="3.6.1",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+ org.eclipse.graphiti,
+ org.eclipse.ui.ide,
+ org.eclipse.graphiti.ui,
+ org.eclipse.gef,
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.xtext.ui,
+ org.eclipse.xtext.ui.shared,
org.eclipse.emf.databinding,
org.eclipse.jface.databinding,
- org.eclipse.core.databinding.property;bundle-version="1.4.200",
- org.eclipse.jdt.core;bundle-version="3.9.0",
+ org.eclipse.core.databinding.property,
+ org.eclipse.jdt.core,
org.eclipse.emf.workspace
Export-Package: org.eclipse.etrice.ui.common,
org.eclipse.etrice.ui.common.commands,
diff --git a/plugins/org.eclipse.etrice.ui.runtime/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.runtime/META-INF/MANIFEST.MF
index 2fa41eee1..f3c3797a5 100644
--- a/plugins/org.eclipse.etrice.ui.runtime/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.runtime/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: New Wizards for Runtime
Bundle-SymbolicName: org.eclipse.etrice.ui.runtime;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.etrice.ui.runtime/pom.xml b/plugins/org.eclipse.etrice.ui.runtime/pom.xml
index 977a27b06..170f9dc0a 100644
--- a/plugins/org.eclipse.etrice.ui.runtime/pom.xml
+++ b/plugins/org.eclipse.etrice.ui.runtime/pom.xml
@@ -16,10 +16,9 @@
<parent>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<relativePath>../../releng/org.eclipse.etrice.parent</relativePath>
</parent>
- <groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.ui.runtime</artifactId>
<packaging>eclipse-plugin</packaging>
diff --git a/plugins/org.eclipse.etrice.ui.structure/META-INF/MANIFEST.MF b/plugins/org.eclipse.etrice.ui.structure/META-INF/MANIFEST.MF
index aa2753bc1..8a1d1a347 100644
--- a/plugins/org.eclipse.etrice.ui.structure/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.etrice.ui.structure/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Actor Structure Diagram Editor
Bundle-SymbolicName: org.eclipse.etrice.ui.structure;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.structure.Activator
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room.ui;bundle-version="2.0.0",
- org.eclipse.etrice.core.common.ui;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.graphiti.ui;bundle-version="0.8.0",
- org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.100",
- org.eclipse.core.databinding;bundle-version="1.3.100",
- org.eclipse.gef;bundle-version="3.6.1",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room.ui,
+ org.eclipse.etrice.core.common.ui,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.graphiti,
+ org.eclipse.graphiti.ui,
+ org.eclipse.ui.views.properties.tabbed,
+ org.eclipse.core.databinding,
+ org.eclipse.gef,
org.eclipse.emf.transaction,
- org.eclipse.xtext.ui;bundle-version="2.6.0",
- org.eclipse.xtext.ui.shared;bundle-version="2.6.0",
+ org.eclipse.xtext.ui,
+ org.eclipse.xtext.ui.shared,
org.eclipse.jface.databinding,
- org.eclipse.core.databinding.beans;bundle-version="1.2.200"
+ org.eclipse.core.databinding.beans
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.etrice.ui.structure,
diff --git a/plugins/pom.xml b/plugins/pom.xml
index a80b9ee44..0546ea531 100644
--- a/plugins/pom.xml
+++ b/plugins/pom.xml
@@ -17,10 +17,9 @@
<parent>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.etrice.parent</relativePath>
</parent>
- <groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.plugins</artifactId>
<packaging>pom</packaging>
</project> \ No newline at end of file
diff --git a/pom.xml b/pom.xml
index 9dd0e0bca..c23c4ebac 100644
--- a/pom.xml
+++ b/pom.xml
@@ -15,13 +15,18 @@
xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<modelVersion>4.0.0</modelVersion>
- <groupId>org.eclipse.etrice</groupId>
+ <parent>
+ <groupId>org.eclipse.etrice</groupId>
+ <artifactId>org.eclipse.etrice.parent</artifactId>
+ <version>0.0.0-SNAPSHOT</version>
+ <relativePath>releng/org.eclipse.etrice.parent</relativePath>
+ </parent>
+
<artifactId>org.eclipse.etrice</artifactId>
- <version>2.0.0-SNAPSHOT</version>
<packaging>pom</packaging>
<modules>
-
+
<!-- Plugins -->
<module>plugins/org.eclipse.etrice.abstractexec.behavior</module>
<module>plugins/org.eclipse.etrice.core.common</module>
diff --git a/releng/org.eclipse.etrice.parent/pom.xml b/releng/org.eclipse.etrice.parent/pom.xml
index 91dbb1d3e..2e5b5c12d 100644
--- a/releng/org.eclipse.etrice.parent/pom.xml
+++ b/releng/org.eclipse.etrice.parent/pom.xml
@@ -17,7 +17,7 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<packaging>pom</packaging>
<properties>
@@ -29,7 +29,6 @@
<eclipse.url>http://download.eclipse.org/releases/oxygen</eclipse.url>
<xtext.url>http://download.eclipse.org/modeling/tmf/xtext/updates/releases/${xtext.version}</xtext.url>
<license.url>http://download.eclipse.org/cbi/updates/license</license.url>
- <orbit.url>http://download.eclipse.org/tools/orbit/R-builds/R20170516192513/repository</orbit.url>
<cbi.url>https://repo.eclipse.org/content/repositories/cbi-releases</cbi.url>
<etrice.url>http://download.eclipse.org/etrice/updates/nightly</etrice.url>
@@ -52,11 +51,6 @@
<url>${license.url}</url>
<layout>p2</layout>
</repository>
- <repository>
- <id>orbit</id>
- <url>${orbit.url}</url>
- <layout>p2</layout>
- </repository>
</repositories>
<pluginRepositories>
@@ -104,6 +98,7 @@
<version>${tycho.version}</version>
<configuration>
<format>'${build.type}'yyyyMMddHHmm</format>
+ <strictVersions>false</strictVersions>
</configuration>
</plugin>
<plugin>
diff --git a/releng/org.eclipse.etrice.releng/build.gradle b/releng/org.eclipse.etrice.releng/build.gradle
index c3ad58b49..4b2a969e9 100644
--- a/releng/org.eclipse.etrice.releng/build.gradle
+++ b/releng/org.eclipse.etrice.releng/build.gradle
@@ -1,7 +1,3 @@
-plugins {
- id 'org.hidetake.ssh' version '2.10.1'
-}
-
configurations {
archives
updates
@@ -16,11 +12,7 @@ dependencies {
updates project(path: ':releng:org.eclipse.etrice.site', configuration: 'archive')
}
-def isSnapshot = version.endsWith('SNAPSHOT')
-def versionDir = version
-if(isSnapshot) {
- versionDir = 'nightly'
-}
+def versionDir = scmVersion.version.endsWith('SNAPSHOT') ? 'nightly' : scmVersion.version
def downloadDir = '/home/data/httpd/download.eclipse.org/etrice'
def promoteDir = "$downloadDir/$versionDir"
def assembleDir = "$buildDir/$versionDir"
@@ -53,6 +45,8 @@ task assembleArtifacts(type: Sync) {
into assembleDir
}
+assemble.dependsOn assembleArtifacts
+
task promote {
dependsOn assembleArtifacts
doLast {
diff --git a/releng/org.eclipse.etrice.site/build.gradle b/releng/org.eclipse.etrice.site/build.gradle
index 991070c1c..0867a1a06 100644
--- a/releng/org.eclipse.etrice.site/build.gradle
+++ b/releng/org.eclipse.etrice.site/build.gradle
@@ -2,7 +2,63 @@ configurations {
archive
}
-artifacts {
- archive fileTree(dir: 'target', include: 'org.eclipse.etrice.site-*.zip').files
+task updateVersionStrings {
+ doLast {
+ def manifestVersion = "${scmVersion.undecoratedVersion}.qualifier"
+ // Replace plugin versions
+ ant.replaceregexp(
+ match: "Bundle-Version:\\s*[\\w.-]*",
+ replace: "Bundle-Version: $manifestVersion") {
+ fileset(dir: rootDir, includes: '**/MANIFEST.MF')
+ }
+ // Replace feature versions
+ ant.replaceregexp(
+ match: "(?s)<feature(.*?)version\\s*=\\s*\"[\\w.-]*\"(.*)>",
+ replace: "<feature\\1version=\"$manifestVersion\"\\2>") {
+ fileset(dir: rootDir, includes: '**/feature.xml')
+ }
+ // Replace first occurence of version tag in poms
+ ant.replaceregexp(
+ match: "(?s)(.*?)<version>[\\w.-]*</version>(.*)",
+ replace: "\\1<version>$version</version>\\2") {
+ fileset(dir: rootDir, includes: '**/pom.xml')
+ }
+ }
+}
+
+task runMaven(type: MavenExec, dependsOn: updateVersionStrings) {
+ workingDir rootDir
+ goals 'clean', 'verify'
+ options {
+ define = ['build.type' : version.endsWith('SNAPSHOT') ? 'N' : 'R']
+ if(findProperty('sign') != null) {
+ activateProfiles = ['sign']
+ }
+ }
+}
+
+def maven = findProperty('maven')
+if(maven != null) {
+ if(!maven.empty) {
+ runMaven.mavenDir = rootProject.file(maven)
+ }
}
+else {
+ updateVersionStrings.enabled = false
+ runMaven.enabled = false
+}
+
+def siteZipName = "${project.name}-${version}.zip"
+task copySiteZip(type: Copy, dependsOn: runMaven) {
+ from 'target'
+ include "${project.name}-*.zip"
+ into buildDir
+ rename { siteZipName }
+}
+
+artifacts {
+ archive(layout.buildDirectory.file(siteZipName)) {
+ builtBy copySiteZip
+ }
+} \ No newline at end of file
diff --git a/releng/org.eclipse.etrice.site/category.xml b/releng/org.eclipse.etrice.site/category.xml
index 8819870d5..2d92b5178 100644
--- a/releng/org.eclipse.etrice.site/category.xml
+++ b/releng/org.eclipse.etrice.site/category.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<site>
- <feature id="org.eclipse.etrice.feature" version="2.0.0.qualifier">
+ <feature id="org.eclipse.etrice.feature">
<category name="org.eclipse.etrice"/>
</feature>
- <feature id="org.eclipse.etrice.cdt_integration.feature" version="2.0.0.qualifier">
+ <feature id="org.eclipse.etrice.cdt_integration.feature">
<category name="org.eclipse.etrice"/>
</feature>
<category-def name="org.eclipse.etrice" label="eTrice">
diff --git a/releng/org.eclipse.etrice.site/pom.xml b/releng/org.eclipse.etrice.site/pom.xml
index 93b32e8c8..c39a49336 100644
--- a/releng/org.eclipse.etrice.site/pom.xml
+++ b/releng/org.eclipse.etrice.site/pom.xml
@@ -17,11 +17,10 @@
<parent>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<relativePath>../../releng/org.eclipse.etrice.parent</relativePath>
</parent>
- <groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.site</artifactId>
<packaging>eclipse-repository</packaging>
diff --git a/runtime/org.eclipse.etrice.modellib.java/META-INF/MANIFEST.MF b/runtime/org.eclipse.etrice.modellib.java/META-INF/MANIFEST.MF
index 325a9e533..ae1ef7c29 100644
--- a/runtime/org.eclipse.etrice.modellib.java/META-INF/MANIFEST.MF
+++ b/runtime/org.eclipse.etrice.modellib.java/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Java ModelLib
Bundle-SymbolicName: org.eclipse.etrice.modellib.java
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.etrice.modellib.java
diff --git a/runtime/org.eclipse.etrice.runtime.java/META-INF/MANIFEST.MF b/runtime/org.eclipse.etrice.runtime.java/META-INF/MANIFEST.MF
index 31276323c..19a5575e4 100644
--- a/runtime/org.eclipse.etrice.runtime.java/META-INF/MANIFEST.MF
+++ b/runtime/org.eclipse.etrice.runtime.java/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Java Runtime
Bundle-SymbolicName: org.eclipse.etrice.runtime.java
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Export-Package: org.eclipse.etrice.runtime.java.config,
org.eclipse.etrice.runtime.java.debugging,
org.eclipse.etrice.runtime.java.etunit,
diff --git a/tests/org.eclipse.etrice.abstractexec.behavior.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.abstractexec.behavior.tests/META-INF/MANIFEST.MF
index 8de00ed9a..0ef934276 100644
--- a/tests/org.eclipse.etrice.abstractexec.behavior.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.abstractexec.behavior.tests/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Abstract Execution for Behavior Tests
Bundle-SymbolicName: org.eclipse.etrice.abstractexec.behavior.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.abstractexec.behavior.tests.Activator
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.abstractexec.behavior;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.abstractexec.behavior,
org.eclipse.core.runtime,
org.eclipse.emf.ecore,
- com.google.inject;bundle-version="3.0.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.junit;bundle-version="4.10.0",
+ com.google.inject,
+ org.eclipse.xtext,
+ org.junit,
org.eclipse.etrice.core.room
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/tests/org.eclipse.etrice.core.common.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.common.tests/META-INF/MANIFEST.MF
index 32790e715..2c3759ffc 100644
--- a/tests/org.eclipse.etrice.core.common.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.common.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests for common eTrice grammar fragments and classes
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.common.tests; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.etrice.core.common,
@@ -10,15 +10,15 @@ Require-Bundle: org.eclipse.etrice.core.common,
org.eclipse.xtext.xbase.lib,
org.eclipse.etrice.core.common.ui,
org.eclipse.ui.workbench;resolution:=optional,
- org.eclipse.xtext.testing;bundle-version="2.12.0",
- org.eclipse.xtext.junit4;bundle-version="2.12.0"
+ org.eclipse.xtext.testing,
+ org.eclipse.xtext.junit4
Import-Package: org.apache.log4j,
- org.junit;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit,
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.common.tests,
diff --git a/tests/org.eclipse.etrice.core.config.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.config.tests/META-INF/MANIFEST.MF
index 5c0588bb5..4e427abdb 100644
--- a/tests/org.eclipse.etrice.core.config.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.config.tests/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Config DSL Tests
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.config.tests; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.config;bundle-version="2.0.0",
- org.eclipse.etrice.core.config.ui;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.config,
+ org.eclipse.etrice.core.config.ui,
org.eclipse.core.runtime,
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.xtext.junit4;bundle-version="2.6.0",
+ org.eclipse.xtext,
+ org.eclipse.xtext.junit4,
org.junit,
org.eclipse.ui.workbench;resolution:=optional,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
org.apache.commons.logging,
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core
diff --git a/tests/org.eclipse.etrice.core.etmap.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.etmap.tests/META-INF/MANIFEST.MF
index f11c38e68..ceb6cacb2 100644
--- a/tests/org.eclipse.etrice.core.etmap.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.etmap.tests/META-INF/MANIFEST.MF
@@ -2,22 +2,22 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etmap.tests
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etmap.tests; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.etmap;bundle-version="2.0.0",
- org.eclipse.etrice.core.etmap.ui;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.etmap,
+ org.eclipse.etrice.core.etmap.ui,
org.eclipse.core.runtime,
- org.eclipse.xtext.junit4;bundle-version="2.6.0",
+ org.eclipse.xtext.junit4,
org.eclipse.ui.workbench;resolution:=optional,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
- org.junit;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit,
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.etmap
diff --git a/tests/org.eclipse.etrice.core.etphys.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.etphys.tests/META-INF/MANIFEST.MF
index fb4f8704f..c0c4b21d5 100644
--- a/tests/org.eclipse.etrice.core.etphys.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.etphys.tests/META-INF/MANIFEST.MF
@@ -2,22 +2,22 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.core.etphys.tests
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.etphys.tests; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.core.etphys;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.etphys,
org.eclipse.etrice.core.etphys.ui,
org.eclipse.core.runtime,
- org.eclipse.xtext.junit4;bundle-version="2.6.0",
+ org.eclipse.xtext.junit4,
org.eclipse.ui.workbench;resolution:=optional,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
- org.junit;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit,
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.etphys
diff --git a/tests/org.eclipse.etrice.core.fsm.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.fsm.tests/META-INF/MANIFEST.MF
index 7ad31023b..bd58b3443 100644
--- a/tests/org.eclipse.etrice.core.fsm.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.fsm.tests/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: FSM DSL Tests
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.core.fsm.tests; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.etrice.core.common,
org.eclipse.etrice.core.fsm,
org.eclipse.etrice.core.fsm.ui,
org.eclipse.core.runtime,
- org.eclipse.xtext.junit4;bundle-version="2.6.0",
+ org.eclipse.xtext.junit4,
org.eclipse.ui.workbench;resolution:=optional,
- org.objectweb.asm;bundle-version="[5.0.1,7.0.0)";resolution:=optional,
+ org.objectweb.asm;resolution:=optional,
org.eclipse.xtext.xbase.lib
Import-Package: org.apache.log4j,
- org.junit;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit,
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.core.fsm
diff --git a/tests/org.eclipse.etrice.core.genmodel.fsm.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.genmodel.fsm.tests/META-INF/MANIFEST.MF
index e50e94337..75ee57418 100644
--- a/tests/org.eclipse.etrice.core.genmodel.fsm.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.genmodel.fsm.tests/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: FSM GenModel Tests
Bundle-SymbolicName: org.eclipse.etrice.core.genmodel.fsm.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.osgi;bundle-version="3.11.2",
- org.eclipse.core.runtime;bundle-version="3.12.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.room.tests;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+Require-Bundle: org.junit,
+ org.eclipse.osgi,
+ org.eclipse.core.runtime,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.room.tests,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.generator.base
Bundle-Activator: org.eclipse.etrice.core.genmodel.fsm.tests.FSMGenModelTestsActivator
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.etrice.core.genmodel.fsm.tests
diff --git a/tests/org.eclipse.etrice.core.genmodel.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.genmodel.tests/META-INF/MANIFEST.MF
index 2d3c9c7f5..681d686f7 100644
--- a/tests/org.eclipse.etrice.core.genmodel.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.genmodel.tests/META-INF/MANIFEST.MF
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.eclipse.etrice.core.genmodel.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Vendor: Eclipse eTrice
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel;bundle-version="2.0.0",
- org.junit;bundle-version="4.8.1",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.core.runtime;bundle-version="3.7.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0"
+Require-Bundle: org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.genmodel,
+ org.junit,
+ org.eclipse.xtext,
+ org.eclipse.core.runtime,
+ org.eclipse.etrice.generator.base
Bundle-Activator: org.eclipse.etrice.core.genmodel.GenmodelTestsActivator
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.etrice.core.genmodel.tests
diff --git a/tests/org.eclipse.etrice.core.room.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.core.room.tests/META-INF/MANIFEST.MF
index 72721653b..995284838 100644
--- a/tests/org.eclipse.etrice.core.room.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.core.room.tests/META-INF/MANIFEST.MF
@@ -2,20 +2,20 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Room Core Tests
Bundle-SymbolicName: org.eclipse.etrice.core.room.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.junit;bundle-version="4.8.1",
+Require-Bundle: org.eclipse.etrice.core.room,
+ org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.junit,
org.eclipse.xtext.junit4,
org.eclipse.xtext.xbase.junit,
- org.eclipse.osgi;bundle-version="3.6.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.core.runtime;bundle-version="3.6.0",
+ org.eclipse.osgi,
+ org.eclipse.xtext,
+ org.eclipse.core.runtime,
org.eclipse.emf.ecore,
- org.eclipse.xtext.testing;bundle-version="2.12.0"
+ org.eclipse.xtext.testing
Bundle-Activator: org.eclipse.etrice.core.CoreTestsActivator
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.etrice.core
diff --git a/tests/org.eclipse.etrice.dctools.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.dctools.tests/META-INF/MANIFEST.MF
index 2b72d1713..a599bf750 100644
--- a/tests/org.eclipse.etrice.dctools.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.dctools.tests/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Expressions UI Tests
Bundle-SymbolicName: org.eclipse.etrice.dctools.tests;singleton:=true
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Automatic-Module-Name: org.eclipse.etrice.expressions.ui.tests
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.junit;bundle-version="4.12.0",
- org.eclipse.jface.text;bundle-version="3.12.2",
- org.eclipse.core.runtime;bundle-version="3.13.0",
+Require-Bundle: org.junit,
+ org.eclipse.jface.text,
+ org.eclipse.core.runtime,
org.eclipse.emf.ecore,
com.google.guava,
org.eclipse.etrice.dctools,
diff --git a/tests/org.eclipse.etrice.etunit.converter.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.etunit.converter.tests/META-INF/MANIFEST.MF
index 2d87b0ba7..746f1727a 100644
--- a/tests/org.eclipse.etrice.etunit.converter.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.etunit.converter.tests/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: etUnit Converter Tests
Bundle-SymbolicName: org.eclipse.etrice.etunit.converter.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.etunit.converter.tests.Activator
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.etunit.converter;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.etunit.converter,
org.eclipse.core.runtime,
- org.junit;bundle-version="4.8.2",
+ org.junit,
com.google.guava
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
diff --git a/tests/org.eclipse.etrice.generator.fsmtest.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.generator.fsmtest.tests/META-INF/MANIFEST.MF
index 68fa8e95a..e0b2fb0f4 100644
--- a/tests/org.eclipse.etrice.generator.fsmtest.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.generator.fsmtest.tests/META-INF/MANIFEST.MF
@@ -2,21 +2,21 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.etrice.generator.fsmtest.tests
Bundle-Vendor: Eclipse eTrice
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-SymbolicName: org.eclipse.etrice.generator.fsmtest.tests; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.etrice.generator.fsmtest;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsmtest.ui;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.generator.fsmtest,
+ org.eclipse.etrice.generator.fsmtest.ui,
org.eclipse.core.runtime,
- org.eclipse.xtext.junit4;bundle-version="2.6.0",
+ org.eclipse.xtext.junit4,
org.eclipse.ui.workbench;resolution:=optional
Import-Package: org.apache.log4j,
- org.junit;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
+ org.junit,
+ org.junit.runner,
+ org.junit.runner.manipulation,
+ org.junit.runner.notification,
+ org.junit.runners,
+ org.junit.runners.model,
org.hamcrest.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.etrice.generator
diff --git a/tests/org.eclipse.etrice.generator.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.generator.tests/META-INF/MANIFEST.MF
index 2e098df0d..95259bb24 100644
--- a/tests/org.eclipse.etrice.generator.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.generator.tests/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Generator Model Tests
Bundle-SymbolicName: org.eclipse.etrice.generator.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.common;bundle-version="2.0.0",
- org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.generator;bundle-version="2.0.0",
- org.eclipse.etrice.generator.fsm;bundle-version="2.0.0",
- org.junit;bundle-version="4.8.1",
- org.eclipse.osgi;bundle-version="3.6.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.core.runtime;bundle-version="3.6.0"
+Require-Bundle: org.eclipse.etrice.core.common,
+ org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.generator,
+ org.eclipse.etrice.generator.fsm,
+ org.junit,
+ org.eclipse.osgi,
+ org.eclipse.xtext,
+ org.eclipse.core.runtime
Bundle-Activator: org.eclipse.etrice.generator.InstanceTestsActivator
Bundle-ActivationPolicy: lazy
Automatic-Module-Name: org.eclipse.etrice.generator.tests
diff --git a/tests/org.eclipse.etrice.ui.base.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.ui.base.tests/META-INF/MANIFEST.MF
index 02a5bb890..3131d1e01 100644
--- a/tests/org.eclipse.etrice.ui.base.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.ui.base.tests/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Diagram Test Base Classes
Bundle-SymbolicName: org.eclipse.etrice.ui.base.tests
-Bundle-Version: 2.0.0.qualifier
-Require-Bundle: org.junit;bundle-version="4.8.1",
+Bundle-Version: 0.0.0.qualifier
+Require-Bundle: org.junit,
org.eclipse.core.runtime,
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.ui.structure;bundle-version="2.0.0",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.ui.structure,
+ org.eclipse.xtext,
+ org.eclipse.graphiti,
org.eclipse.etrice.ui.common.base,
com.google.guava,
org.eclipse.xtext.xbase.lib,
diff --git a/tests/org.eclipse.etrice.ui.behavior.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.ui.behavior.tests/META-INF/MANIFEST.MF
index a54e8e156..ca84aa4ea 100644
--- a/tests/org.eclipse.etrice.ui.behavior.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.ui.behavior.tests/META-INF/MANIFEST.MF
@@ -2,25 +2,25 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Behavior Diagram Tests
Bundle-SymbolicName: org.eclipse.etrice.ui.behavior.tests
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.etrice.ui.behavior.BehaviorTestActivator
Bundle-Vendor: Eclipse eTrice
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior;bundle-version="2.0.0",
- org.eclipse.etrice.ui.behavior.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.ui.base.tests;bundle-version="2.0.0",
- org.eclipse.etrice.generator.launch;bundle-version="2.0.0",
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.ui.behavior,
+ org.eclipse.etrice.ui.behavior.fsm,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.ui.base.tests,
+ org.eclipse.etrice.generator.launch,
org.eclipse.ui,
org.eclipse.core.runtime,
- org.junit;bundle-version="4.8.1",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.graphiti;bundle-version="0.8.0",
- org.eclipse.etrice.core.room.tests;bundle-version="2.0.0",
- org.eclipse.etrice.core.genmodel.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.generator.base;bundle-version="2.0.0",
+ org.junit,
+ org.eclipse.xtext,
+ org.eclipse.graphiti,
+ org.eclipse.etrice.core.room.tests,
+ org.eclipse.etrice.core.genmodel.fsm,
+ org.eclipse.etrice.generator.base,
org.eclipse.core.resources
Import-Package: org.eclipse.xtext.xbase.lib
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/tests/org.eclipse.etrice.ui.structure.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.etrice.ui.structure.tests/META-INF/MANIFEST.MF
index 484601ad2..a8c8f4589 100644
--- a/tests/org.eclipse.etrice.ui.structure.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.etrice.ui.structure.tests/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: eTrice Structure Diagram Tests
Bundle-SymbolicName: org.eclipse.etrice.ui.structure.tests
-Bundle-Version: 2.0.0.qualifier
-Require-Bundle: org.eclipse.etrice.core.fsm;bundle-version="2.0.0",
- org.eclipse.etrice.core.room;bundle-version="2.0.0",
- org.eclipse.etrice.ui.structure;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common;bundle-version="2.0.0",
- org.eclipse.etrice.ui.common.base;bundle-version="2.0.0",
- org.eclipse.etrice.ui.base.tests;bundle-version="2.0.0",
+Bundle-Version: 0.0.0.qualifier
+Require-Bundle: org.eclipse.etrice.core.fsm,
+ org.eclipse.etrice.core.room,
+ org.eclipse.etrice.ui.structure,
+ org.eclipse.etrice.ui.common,
+ org.eclipse.etrice.ui.common.base,
+ org.eclipse.etrice.ui.base.tests,
org.eclipse.ui,
org.eclipse.core.runtime,
- org.junit;bundle-version="4.8.1",
- org.eclipse.xtext;bundle-version="2.6.0",
- org.eclipse.graphiti;bundle-version="0.8.0"
+ org.junit,
+ org.eclipse.xtext,
+ org.eclipse.graphiti
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse eTrice
Bundle-ActivationPolicy: lazy
diff --git a/tests/pom.xml b/tests/pom.xml
index d6c30be48..8ae4ab856 100644
--- a/tests/pom.xml
+++ b/tests/pom.xml
@@ -17,10 +17,9 @@
<parent>
<groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.parent</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>0.0.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.etrice.parent</relativePath>
</parent>
- <groupId>org.eclipse.etrice</groupId>
<artifactId>org.eclipse.etrice.tests</artifactId>
<packaging>pom</packaging>

Back to the top