Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Oberlies2012-10-01 06:27:01 -0400
committerTobias Oberlies2012-10-01 07:55:25 -0400
commitaa6e786cd25e59f8f36e22099f3239a553b0bc2f (patch)
treebbaa5da159a94e9c82aa49bc826c07fbd32c6ab8 /bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile
parentfee334517cb619dc480b8122ea2bb789b3cf5c20 (diff)
downloadrt.equinox.p2-aa6e786cd25e59f8f36e22099f3239a553b0bc2f.tar.gz
rt.equinox.p2-aa6e786cd25e59f8f36e22099f3239a553b0bc2f.tar.xz
rt.equinox.p2-aa6e786cd25e59f8f36e22099f3239a553b0bc2f.zip
388566 Copy EE profile files from org.eclipse.osgi
- Reset profile files included in o.e.e.p2.publisher to current state in org.eclipse.osge bundle. (Last change to these files was rt.equinox.framework commit d2f8703.) This adds the org.osgi.framework.system.capabilities property to all profiles, and fixes bug 386013. - Adapted tests that check for the total number of provided capabilities. Bug: 388566 JREAction: Publish osgi.ee capabilities in 'a.jre' IUs Bug: 386013 EE profile JavaSE-1.7 declares system packages that don't exist
Diffstat (limited to 'bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile')
-rw-r--r--bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile2
1 files changed, 2 insertions, 0 deletions
diff --git a/bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile b/bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile
index 601b37379..95a689631 100644
--- a/bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile
+++ b/bundles/org.eclipse.equinox.p2.publisher/profiles/OSGi_Minimum-1.2.profile
@@ -16,6 +16,8 @@ org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.0,\
OSGi/Minimum-1.1,\
OSGi/Minimum-1.2
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2"
osgi.java.profile.name = OSGi/Minimum-1.2
org.eclipse.jdt.core.compiler.compliance=1.4
org.eclipse.jdt.core.compiler.source=1.3

Back to the top