Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurtakov2017-11-28 13:58:25 -0500
committerAlexander Kurtakov2017-11-28 13:58:25 -0500
commitbca37abc53dfd293c1b750c5c9844f7cd905ddf8 (patch)
treed3cfae7f49ffe24560bd590e814148ec7182c2cb
parenta85029f8ce86497b570c955d84fb60f6324bdd20 (diff)
downloadrt.equinox.p2-I20171205-2000.tar.gz
rt.equinox.p2-I20171205-2000.tar.xz
rt.equinox.p2-I20171205-2000.zip
Could not install bundle... Restore update.configurator reconciler disabling in ConfigCUsAction. It was removed with commit a85029f8ce86497b570c955d84fb60f6324bdd20. Change-Id: I8a64dd6ed8c34208372721c05f0dd63ee3097495 Signed-off-by: Alexander Kurtakov <akurtako@redhat.com>
-rw-r--r--bundles/org.eclipse.equinox.p2.publisher.eclipse/src/org/eclipse/equinox/p2/publisher/eclipse/ConfigCUsAction.java8
1 files changed, 7 insertions, 1 deletions
diff --git a/bundles/org.eclipse.equinox.p2.publisher.eclipse/src/org/eclipse/equinox/p2/publisher/eclipse/ConfigCUsAction.java b/bundles/org.eclipse.equinox.p2.publisher.eclipse/src/org/eclipse/equinox/p2/publisher/eclipse/ConfigCUsAction.java
index 2ed0ff2ed..8d1f0dce8 100644
--- a/bundles/org.eclipse.equinox.p2.publisher.eclipse/src/org/eclipse/equinox/p2/publisher/eclipse/ConfigCUsAction.java
+++ b/bundles/org.eclipse.equinox.p2.publisher.eclipse/src/org/eclipse/equinox/p2/publisher/eclipse/ConfigCUsAction.java
@@ -36,6 +36,7 @@ import org.osgi.framework.Constants;
*/
public class ConfigCUsAction extends AbstractPublisherAction {
+ protected static final String ORG_ECLIPSE_UPDATE_CONFIGURATOR = "org.eclipse.update.configurator"; //$NON-NLS-1$
protected static final String DEFAULT_START_LEVEL = "osgi.bundles.defaultStartLevel"; //$NON-NLS-1$
private static Collection<String> PROPERTIES_TO_SKIP;
private static HashSet<String> PROGRAM_ARGS_TO_SKIP;
@@ -347,7 +348,12 @@ public class ConfigCUsAction extends AbstractPublisherAction {
continue;
// TODO need to factor this out into its own action
- if (bundle.getStartLevel() == BundleInfo.NO_LEVEL && !bundle.isMarkedAsStarted()) {
+ if (bundle.getSymbolicName().equals(ORG_ECLIPSE_UPDATE_CONFIGURATOR)) {
+ bundle.setStartLevel(BundleInfo.NO_LEVEL);
+ bundle.setMarkedAsStarted(false);
+ bundle.setSpecialConfigCommands("setProgramProperty(propName:org.eclipse.update.reconcile, propValue:false);"); //$NON-NLS-1$
+ bundle.setSpecialUnconfigCommands("setProgramProperty(propName:org.eclipse.update.reconcile, propValue:);"); //$NON-NLS-1$
+ } else if (bundle.getStartLevel() == BundleInfo.NO_LEVEL && !bundle.isMarkedAsStarted()) {
// this bundle does not require any particular configuration, the plug-in default IU will handle installing it
continue;
}

Back to the top