Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurtakov2016-09-27 17:09:02 -0400
committerArun Thondapu2016-09-30 06:41:06 -0400
commit685d39d3b2f27797e28c74ed1e24cc918fc51b7d (patch)
treeafd42d3c0d5cd54939df62dc42f4988bc73faa37 /features
parentc6e7babcafcd6809fb78f61fb32b0d6ef95362da (diff)
downloadrt.equinox.framework-685d39d3b2f27797e28c74ed1e24cc918fc51b7d.tar.gz
rt.equinox.framework-685d39d3b2f27797e28c74ed1e24cc918fc51b7d.tar.xz
rt.equinox.framework-685d39d3b2f27797e28c74ed1e24cc918fc51b7d.zip
Bug 501986 - [GTK+] Make GTK+ 2.24 the minimum supported version
Change-Id: I027be9384110042aa7eb202c11e9f890dc44c54e Signed-off-by: Alexander Kurtakov <akurtako@redhat.com>
Diffstat (limited to 'features')
-rw-r--r--features/org.eclipse.equinox.executable.feature/library/gtk/eclipseGtkInit.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/features/org.eclipse.equinox.executable.feature/library/gtk/eclipseGtkInit.c b/features/org.eclipse.equinox.executable.feature/library/gtk/eclipseGtkInit.c
index 66c1a3b62..200a05848 100644
--- a/features/org.eclipse.equinox.executable.feature/library/gtk/eclipseGtkInit.c
+++ b/features/org.eclipse.equinox.executable.feature/library/gtk/eclipseGtkInit.c
@@ -1,5 +1,5 @@
/*******************************************************************************
- * Copyright (c) 2007, 2015 IBM Corporation and others.
+ * Copyright (c) 2007, 2016 IBM Corporation and others.
* All rights reserved. This program and the accompanying materials
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
@@ -17,14 +17,14 @@
struct GTK_PTRS gtk = { 1 }; /* initialize the first field "not_initialized" so we can tell when we've loaded the pointers */
-static _TCHAR* minVerMsg1 = _T_ECLIPSE("Starting from the Eclipse 4.5 (Mars) release, \nGTK+ versions below");
+static _TCHAR* minVerMsg1 = _T_ECLIPSE("Starting from the Eclipse 4.7 (Oxygen) release, \nGTK+ versions below");
static _TCHAR* minVerMsg2 = _T_ECLIPSE("are not supported.\nGTK+ version found is");
static _TCHAR* minVerTitle = _T_ECLIPSE("Unsupported GTK+ version");
static _TCHAR* gtkInitFail = _T_ECLIPSE("Unable to initialize GTK+\n");
static _TCHAR* upgradeWarning1 = _T_ECLIPSE("\nPlease upgrade GTK+ to minimum version");
static _TCHAR* upgradeWarning2 = _T_ECLIPSE("\nor use an older version of Eclipse.\nClick OK to Exit.");
static int minGtkMajorVersion = 2;
-static int minGtkMinorVersion = 18;
+static int minGtkMinorVersion = 24;
static int minGtkMicroVersion = 0;
/* tables to help initialize the function pointers */

Back to the top