Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Watson2010-09-10 10:11:54 -0400
committerThomas Watson2010-09-10 10:11:54 -0400
commit3970c45e2cf13db77bf65732ed8e069f5a221406 (patch)
tree35c590b8aefde60c657b43747a59a160130f8f26
parentdcf1b66aeb82d98b61861626de61963ded9d109e (diff)
downloadrt.equinox.framework-3970c45e2cf13db77bf65732ed8e069f5a221406.tar.gz
rt.equinox.framework-3970c45e2cf13db77bf65732ed8e069f5a221406.tar.xz
rt.equinox.framework-3970c45e2cf13db77bf65732ed8e069f5a221406.zip
Bug 323964 - Support osgi.ee capabilities for execution environments
-rw-r--r--bundles/org.eclipse.osgi/CDC-1.0_Foundation-1.0.profile3
-rw-r--r--bundles/org.eclipse.osgi/CDC-1.1_Foundation-1.1.profile3
-rw-r--r--bundles/org.eclipse.osgi/J2SE-1.2.profile3
-rw-r--r--bundles/org.eclipse.osgi/J2SE-1.3.profile3
-rw-r--r--bundles/org.eclipse.osgi/J2SE-1.4.profile3
-rw-r--r--bundles/org.eclipse.osgi/J2SE-1.5.profile3
-rw-r--r--bundles/org.eclipse.osgi/JavaSE-1.6.profile4
-rw-r--r--bundles/org.eclipse.osgi/JavaSE-1.7.profile4
-rw-r--r--bundles/org.eclipse.osgi/OSGi_Minimum-1.0.profile2
-rw-r--r--bundles/org.eclipse.osgi/OSGi_Minimum-1.1.profile2
-rw-r--r--bundles/org.eclipse.osgi/OSGi_Minimum-1.2.profile2
11 files changed, 18 insertions, 14 deletions
diff --git a/bundles/org.eclipse.osgi/CDC-1.0_Foundation-1.0.profile b/bundles/org.eclipse.osgi/CDC-1.0_Foundation-1.0.profile
index dde120a4d..3cbbc60f6 100644
--- a/bundles/org.eclipse.osgi/CDC-1.0_Foundation-1.0.profile
+++ b/bundles/org.eclipse.osgi/CDC-1.0_Foundation-1.0.profile
@@ -16,6 +16,9 @@ org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.0,\
OSGi/Minimum-1.1,\
CDC-1.0/Foundation-1.0
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1",\
+ osgi.ee; osgi.ee="CDC/Foundation"; version:Version="1.0"
osgi.java.profile.name = CDC-1.0/Foundation-1.0
org.eclipse.jdt.core.compiler.compliance=1.3
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/CDC-1.1_Foundation-1.1.profile b/bundles/org.eclipse.osgi/CDC-1.1_Foundation-1.1.profile
index 67b20c7ef..efa83eb80 100644
--- a/bundles/org.eclipse.osgi/CDC-1.1_Foundation-1.1.profile
+++ b/bundles/org.eclipse.osgi/CDC-1.1_Foundation-1.1.profile
@@ -22,6 +22,9 @@ org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.2,\
CDC-1.0/Foundation-1.0,\
CDC-1.1/Foundation-1.1
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",\
+ osgi.ee; osgi.ee="CDC/Foundation"; version:List<Version>="1.0, 1.1"
osgi.java.profile.name = CDC-1.1/Foundation-1.1
org.eclipse.jdt.core.compiler.compliance=1.4
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/J2SE-1.2.profile b/bundles/org.eclipse.osgi/J2SE-1.2.profile
index 2d4d348f0..81ce7bc07 100644
--- a/bundles/org.eclipse.osgi/J2SE-1.2.profile
+++ b/bundles/org.eclipse.osgi/J2SE-1.2.profile
@@ -40,8 +40,7 @@ org.osgi.framework.executionenvironment = \
JRE-1.1,\
J2SE-1.2
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
- osgi.ee; osgi.ee="J2SE"; version:Version="1.2"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2"
osgi.java.profile.name = J2SE-1.2
org.eclipse.jdt.core.compiler.compliance=1.3
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/J2SE-1.3.profile b/bundles/org.eclipse.osgi/J2SE-1.3.profile
index 27e44e65c..53b95e8c6 100644
--- a/bundles/org.eclipse.osgi/J2SE-1.3.profile
+++ b/bundles/org.eclipse.osgi/J2SE-1.3.profile
@@ -61,9 +61,8 @@ org.osgi.framework.executionenvironment = \
J2SE-1.2,\
J2SE-1.3
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1",\
- osgi.ee; osgi.ee="J2SE"; version:List<Version>="1.2, 1.3"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3"
osgi.java.profile.name = J2SE-1.3
org.eclipse.jdt.core.compiler.compliance=1.3
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/J2SE-1.4.profile b/bundles/org.eclipse.osgi/J2SE-1.4.profile
index 28325778b..925e2bc6b 100644
--- a/bundles/org.eclipse.osgi/J2SE-1.4.profile
+++ b/bundles/org.eclipse.osgi/J2SE-1.4.profile
@@ -122,9 +122,8 @@ org.osgi.framework.executionenvironment = \
J2SE-1.3,\
J2SE-1.4
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",\
- osgi.ee; osgi.ee="J2SE"; version:List<Version>="1.2, 1.3, 1.4"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4"
osgi.java.profile.name = J2SE-1.4
org.eclipse.jdt.core.compiler.compliance=1.4
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/J2SE-1.5.profile b/bundles/org.eclipse.osgi/J2SE-1.5.profile
index 6d1e4058f..e0f680818 100644
--- a/bundles/org.eclipse.osgi/J2SE-1.5.profile
+++ b/bundles/org.eclipse.osgi/J2SE-1.5.profile
@@ -149,9 +149,8 @@ org.osgi.framework.executionenvironment = \
J2SE-1.4,\
J2SE-1.5
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",\
- osgi.ee; osgi.ee="J2SE"; version:List<Version>="1.2, 1.3, 1.4, 1.5"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4, 1.5"
osgi.java.profile.name = J2SE-1.5
org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.source=1.5
diff --git a/bundles/org.eclipse.osgi/JavaSE-1.6.profile b/bundles/org.eclipse.osgi/JavaSE-1.6.profile
index b8e7509f0..8b466ff23 100644
--- a/bundles/org.eclipse.osgi/JavaSE-1.6.profile
+++ b/bundles/org.eclipse.osgi/JavaSE-1.6.profile
@@ -186,10 +186,8 @@ org.osgi.framework.executionenvironment = \
J2SE-1.5,\
JavaSE-1.6
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",\
- osgi.ee; osgi.ee="J2SE"; version:List<Version>="1.2, 1.3, 1.4, 1.5",\
- osgi.ee; osgi.ee="JavaSE"; version:Version="1.6"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6"
osgi.java.profile.name = JavaSE-1.6
org.eclipse.jdt.core.compiler.compliance=1.6
org.eclipse.jdt.core.compiler.source=1.6
diff --git a/bundles/org.eclipse.osgi/JavaSE-1.7.profile b/bundles/org.eclipse.osgi/JavaSE-1.7.profile
index 166f715e7..c07fc02af 100644
--- a/bundles/org.eclipse.osgi/JavaSE-1.7.profile
+++ b/bundles/org.eclipse.osgi/JavaSE-1.7.profile
@@ -190,10 +190,8 @@ org.osgi.framework.executionenvironment = \
JavaSE-1.6,\
JavaSE-1.7
org.osgi.framework.system.capabilities = \
- osgi.ee; osgi.ee="JRE"; version:Version="1.1",\
osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",\
- osgi.ee; osgi.ee="J2SE"; version:List<Version>="1.2, 1.3, 1.4, 1.5",\
- osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.6, 1.7"
+ osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7"
osgi.java.profile.name = JavaSE-1.7
org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.source=1.7
diff --git a/bundles/org.eclipse.osgi/OSGi_Minimum-1.0.profile b/bundles/org.eclipse.osgi/OSGi_Minimum-1.0.profile
index 773501a52..40da61f85 100644
--- a/bundles/org.eclipse.osgi/OSGi_Minimum-1.0.profile
+++ b/bundles/org.eclipse.osgi/OSGi_Minimum-1.0.profile
@@ -14,6 +14,8 @@ org.osgi.framework.bootdelegation = \
com.sun.*
org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.0
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:Version="1.0"
osgi.java.profile.name = OSGi/Minimum-1.0
org.eclipse.jdt.core.compiler.compliance=1.3
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/OSGi_Minimum-1.1.profile b/bundles/org.eclipse.osgi/OSGi_Minimum-1.1.profile
index 5031392b7..818bf10c2 100644
--- a/bundles/org.eclipse.osgi/OSGi_Minimum-1.1.profile
+++ b/bundles/org.eclipse.osgi/OSGi_Minimum-1.1.profile
@@ -15,6 +15,8 @@ org.osgi.framework.bootdelegation = \
org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.0,\
OSGi/Minimum-1.1
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1"
osgi.java.profile.name = OSGi/Minimum-1.1
org.eclipse.jdt.core.compiler.compliance=1.3
org.eclipse.jdt.core.compiler.source=1.3
diff --git a/bundles/org.eclipse.osgi/OSGi_Minimum-1.2.profile b/bundles/org.eclipse.osgi/OSGi_Minimum-1.2.profile
index 601b37379..95a689631 100644
--- a/bundles/org.eclipse.osgi/OSGi_Minimum-1.2.profile
+++ b/bundles/org.eclipse.osgi/OSGi_Minimum-1.2.profile
@@ -16,6 +16,8 @@ org.osgi.framework.executionenvironment = \
OSGi/Minimum-1.0,\
OSGi/Minimum-1.1,\
OSGi/Minimum-1.2
+org.osgi.framework.system.capabilities = \
+ osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2"
osgi.java.profile.name = OSGi/Minimum-1.2
org.eclipse.jdt.core.compiler.compliance=1.4
org.eclipse.jdt.core.compiler.source=1.3

Back to the top