Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Knauer2014-05-07 16:14:03 -0400
committerMarkus Knauer2014-05-23 14:41:57 -0400
commit671cb4bf24bb1e7748b035832e9281eec3f115e2 (patch)
tree842cf2889ce5f4e0cde0ea3d9338d5f4b71a03a0
parent88b0fdab81800d6b03782892de64bf6879298f91 (diff)
downloadorg.eclipse.epp.packages-671cb4bf24bb1e7748b035832e9281eec3f115e2.tar.gz
org.eclipse.epp.packages-671cb4bf24bb1e7748b035832e9281eec3f115e2.tar.xz
org.eclipse.epp.packages-671cb4bf24bb1e7748b035832e9281eec3f115e2.zip
Require Java 7 in order to start the standard package
Set the property osgi.requiredJavaVersion to 1.7 and require at least a JRE 1.7 to start the package. Otherwise an error is reported to the user. Bug 423734 - Require Java Version 1.7 or higher in all EPP packages https://bugs.eclipse.org/bugs/show_bug.cgi?id=423734 [epp-dev] Requiring Java 7 for specific EPP packages http://dev.eclipse.org/mhonarc/lists/epp-dev/msg02836.html Change-Id: I5c475547d99254afb3a03b205e171b3af7729c75 Signed-off-by: Markus Knauer <mknauer@eclipsesource.com>
-rw-r--r--packages/org.eclipse.epp.package.standard.feature/.forceQualifierUpdate2
-rw-r--r--packages/org.eclipse.epp.package.standard.product/.forceQualifierUpdate2
-rw-r--r--packages/org.eclipse.epp.package.standard.product/epp.product10
3 files changed, 7 insertions, 7 deletions
diff --git a/packages/org.eclipse.epp.package.standard.feature/.forceQualifierUpdate b/packages/org.eclipse.epp.package.standard.feature/.forceQualifierUpdate
index ac72f0a4..9ab900dc 100644
--- a/packages/org.eclipse.epp.package.standard.feature/.forceQualifierUpdate
+++ b/packages/org.eclipse.epp.package.standard.feature/.forceQualifierUpdate
@@ -1 +1 @@
-4.4.0.20140518-0900
+4.4.0.20140523-1800
diff --git a/packages/org.eclipse.epp.package.standard.product/.forceQualifierUpdate b/packages/org.eclipse.epp.package.standard.product/.forceQualifierUpdate
index ac72f0a4..9ab900dc 100644
--- a/packages/org.eclipse.epp.package.standard.product/.forceQualifierUpdate
+++ b/packages/org.eclipse.epp.package.standard.product/.forceQualifierUpdate
@@ -1 +1 @@
-4.4.0.20140518-0900
+4.4.0.20140523-1800
diff --git a/packages/org.eclipse.epp.package.standard.product/epp.product b/packages/org.eclipse.epp.package.standard.product/epp.product
index 23ed2353..d71b270e 100644
--- a/packages/org.eclipse.epp.package.standard.product/epp.product
+++ b/packages/org.eclipse.epp.package.standard.product/epp.product
@@ -18,7 +18,7 @@
--launcher.defaultAction openFile</programArgs>
<programArgsWin>--launcher.XXMaxPermSize
256M</programArgsWin>
- <vmArgs>-Dosgi.requiredJavaVersion=1.6
+ <vmArgs>-Dosgi.requiredJavaVersion=1.7
-Xms40m
-Xmx512m</vmArgs>
<vmArgsLin>-XX:MaxPermSize=256m</vmArgsLin>
@@ -42,10 +42,10 @@
<intro introId="org.eclipse.ui.intro.universal"/>
<vm>
- <linux include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6</linux>
- <macos include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6</macos>
- <solaris include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6</solaris>
- <windows include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6</windows>
+ <linux include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7</linux>
+ <macos include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7</macos>
+ <solaris include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7</solaris>
+ <windows include="false">org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.7</windows>
</vm>
<license>

Back to the top