Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Knauer2012-06-14 04:11:52 -0400
committerMarkus Knauer2012-06-14 04:11:52 -0400
commitbfa89f5a70b2aad3d067f9bde420838b7a278c99 (patch)
tree72a73baab194aa95233b59105aff5ddf04b2f211
parent24280bc7385d1a15c193a1e4cbc8e399a3c7d7ac (diff)
downloadorg.eclipse.epp.packages-bfa89f5a70b2aad3d067f9bde420838b7a278c99.tar.gz
org.eclipse.epp.packages-bfa89f5a70b2aad3d067f9bde420838b7a278c99.tar.xz
org.eclipse.epp.packages-bfa89f5a70b2aad3d067f9bde420838b7a278c99.zip
Add additional Java compiler preferences to Mobile package
Source and target platform settings have been adjusted to Java 1.6, see bug 376258 comment #31.
-rw-r--r--packages/org.eclipse.epp.package.mobile/plugin_customization.ini4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/org.eclipse.epp.package.mobile/plugin_customization.ini b/packages/org.eclipse.epp.package.mobile/plugin_customization.ini
index 9192674f..892a99a3 100644
--- a/packages/org.eclipse.epp.package.mobile/plugin_customization.ini
+++ b/packages/org.eclipse.epp.package.mobile/plugin_customization.ini
@@ -38,3 +38,7 @@ org.eclipse.help/HELP_DATA = helpData.xml
# Java compiler compliance level should be 1.6 or higher (Mobile package)
org.eclipse.jdt.core/org.eclipse.jdt.core.compiler.compliance=1.6
+org.eclipse.jdt.core/org.eclipse.jdt.core.compiler.source=1.6
+org.eclipse.jdt.core/org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core/org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
+org.eclipse.jdt.core/org.eclipse.jdt.core.compiler.problem.enumIdentifier=error

Back to the top