Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlgoubet2012-05-02 09:40:25 -0400
committerlgoubet2012-05-03 05:56:25 -0400
commitd1535e7d4e71cb6c0e8dae79b71d3ffad3785a16 (patch)
treeffd61acd4600b2221d34560264ecab64fa75ef66 /plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
parent5a55fa8d5b72ce4ca6938e5d247501c8d9e36ffb (diff)
downloadorg.eclipse.emf.compare-d1535e7d4e71cb6c0e8dae79b71d3ffad3785a16.tar.gz
org.eclipse.emf.compare-d1535e7d4e71cb6c0e8dae79b71d3ffad3785a16.tar.xz
org.eclipse.emf.compare-d1535e7d4e71cb6c0e8dae79b71d3ffad3785a16.zip
Contributing test metamodel wit the necessary "specific" features (multiple containment features, single-valued containment, multi-valued attribute...) and its generated code.
Diffstat (limited to 'plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF')
-rw-r--r--plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF9
1 files changed, 7 insertions, 2 deletions
diff --git a/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
index 5cd439e03..50f50a1ec 100644
--- a/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
@@ -1,9 +1,10 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
-Bundle-SymbolicName: org.eclipse.emf.compare.tests
+Bundle-SymbolicName: org.eclipse.emf.compare.tests;singleton:=true
Bundle-Version: 2.0.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.tests.EMFCompareTestsPlugin
+Bundle-ClassPath: .
Bundle-Vendor: %providerName
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.common,
@@ -12,7 +13,11 @@ Require-Bundle: org.eclipse.core.runtime,
org.junit;bundle-version="4.8.2",
org.eclipse.emf.ecore.xmi;bundle-version="2.5.0",
org.eclipse.compare
+Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Bundle-ActivationPolicy: lazy
+Export-Package: org.eclipse.emf.compare.tests.nodes,
+ org.eclipse.emf.compare.tests.nodes.impl,
+ org.eclipse.emf.compare.tests.nodes.util
Import-Package: com.google.common.base;version="2.0.0",
com.google.common.collect;version="2.0.0"
+Bundle-ActivationPolicy: lazy

Back to the top