Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Goubet2016-09-12 04:00:22 -0400
committerLaurent Delaigue2016-09-14 10:00:30 -0400
commit14123b883ed31ca999c92a153cd9ba4a01672212 (patch)
tree3f5ebdb3ac48734a263b84fc2d1a723d60a52475
parentc01f56d36d84172ff43aaa5ca6a22c9bcfde660a (diff)
downloadorg.eclipse.emf.compare-14123b883ed31ca999c92a153cd9ba4a01672212.tar.gz
org.eclipse.emf.compare-14123b883ed31ca999c92a153cd9ba4a01672212.tar.xz
org.eclipse.emf.compare-14123b883ed31ca999c92a153cd9ba4a01672212.zip
Bump versions for EMF Compare 3.3.0
Change-Id: If58253d9e062b447173cb5a6ed26afe953a364f9 Signed-off-by: Laurent Delaigue <laurent.delaigue@obeo.fr> Signed-off-by: Laurent Goubet <laurent.goubet@obeo.fr>
-rw-r--r--org.eclipse.emf.compare-parent/bundle-parent/pom.xml2
-rw-r--r--org.eclipse.emf.compare-parent/feature-parent/pom.xml2
-rw-r--r--org.eclipse.emf.compare-parent/pom.xml4
-rw-r--r--org.eclipse.emf.compare-parent/test-parent/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.gmf-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.gmf-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.papyrus-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.papyrus-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.sirius-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.diagram.sirius-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.egit-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.egit-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.gendoc/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.ide.ui-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.ide.ui-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.rcp.ui-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.rcp.ui-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.uml2-feature/feature.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.uml2-feature/pom.xml2
-rw-r--r--packaging/org.eclipse.emf.compare.update/pom.xml4
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.edit/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.ide.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.papyrus/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.sirius/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram.sirius/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.diagram/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.doc/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.doc/pom.xml8
-rw-r--r--plugins/org.eclipse.emf.compare.doc/publisher.properties8
-rw-r--r--plugins/org.eclipse.emf.compare.edit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.edit/pom.xml2
-rwxr-xr-xplugins/org.eclipse.emf.compare.egit.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.egit.ui/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.egit/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.egit/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.e4/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.e4/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.tests.git/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.tests.git/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.ide.ui.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.ide/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.log4j.fragment/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp.ui.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.rcp/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.specifications/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.specifications/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.specifications/src/3.3.0-release.mediawiki103
-rw-r--r--plugins/org.eclipse.emf.compare.specifications/src/index.mediawiki10
-rw-r--r--plugins/org.eclipse.emf.compare.subversive/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.subversive/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.tests.fuzzy/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.tests.fuzzy/pom.xml4
-rw-r--r--plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.ide/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/pom.xml2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.rcp/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.compare.uml2.rcp/pom.xml2
94 files changed, 213 insertions, 102 deletions
diff --git a/org.eclipse.emf.compare-parent/bundle-parent/pom.xml b/org.eclipse.emf.compare-parent/bundle-parent/pom.xml
index 3244dbd43..1b75375a2 100644
--- a/org.eclipse.emf.compare-parent/bundle-parent/pom.xml
+++ b/org.eclipse.emf.compare-parent/bundle-parent/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>..</relativePath>
</parent>
<groupId>org.eclipse.emf.compare</groupId>
diff --git a/org.eclipse.emf.compare-parent/feature-parent/pom.xml b/org.eclipse.emf.compare-parent/feature-parent/pom.xml
index 82aabd6e3..13d6c4023 100644
--- a/org.eclipse.emf.compare-parent/feature-parent/pom.xml
+++ b/org.eclipse.emf.compare-parent/feature-parent/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>..</relativePath>
</parent>
diff --git a/org.eclipse.emf.compare-parent/pom.xml b/org.eclipse.emf.compare-parent/pom.xml
index 95213746a..5c615acb9 100644
--- a/org.eclipse.emf.compare-parent/pom.xml
+++ b/org.eclipse.emf.compare-parent/pom.xml
@@ -14,7 +14,7 @@
</prerequisites>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>emf.compare-parent</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>pom</packaging>
<licenses>
<license>
@@ -31,7 +31,7 @@
</licenses>
<properties>
<!-- Properties -->
- <parent-version>3.2.0-SNAPSHOT</parent-version>
+ <parent-version>3.3.0-SNAPSHOT</parent-version>
<source-java-version>1.5</source-java-version>
<target-java-version>${source-java-version}</target-java-version>
<java-source-encoding>UTF-8</java-source-encoding>
diff --git a/org.eclipse.emf.compare-parent/test-parent/pom.xml b/org.eclipse.emf.compare-parent/test-parent/pom.xml
index 83a9710bc..bee7e1f99 100644
--- a/org.eclipse.emf.compare-parent/test-parent/pom.xml
+++ b/org.eclipse.emf.compare-parent/test-parent/pom.xml
@@ -5,7 +5,7 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>..</relativePath>
</parent>
<groupId>org.eclipse.emf.compare</groupId>
diff --git a/packaging/org.eclipse.emf.compare-feature/feature.xml b/packaging/org.eclipse.emf.compare-feature/feature.xml
index c2c4db02c..b9bd8eaa8 100644
--- a/packaging/org.eclipse.emf.compare-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare-feature/pom.xml b/packaging/org.eclipse.emf.compare-feature/pom.xml
index dea589082..44f950086 100644
--- a/packaging/org.eclipse.emf.compare-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/feature.xml b/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/feature.xml
index 6b8e26e1a..46060c612 100644
--- a/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.diagram.ecoretools"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.diagram.ide.ui.ecoretools"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/pom.xml b/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/pom.xml
index 57eb92726..2e4c78cf2 100644
--- a/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.ecoretools-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ecoretools</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.diagram.gmf-feature/feature.xml b/packaging/org.eclipse.emf.compare.diagram.gmf-feature/feature.xml
index 7632e3ded..09b1964fc 100644
--- a/packaging/org.eclipse.emf.compare.diagram.gmf-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.gmf-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.diagram.gmf"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.diagram"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.diagram.gmf-feature/pom.xml b/packaging/org.eclipse.emf.compare.diagram.gmf-feature/pom.xml
index 952601344..41678970d 100644
--- a/packaging/org.eclipse.emf.compare.diagram.gmf-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.gmf-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.diagram.gmf</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/feature.xml b/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/feature.xml
index 83a686879..8723ba215 100644
--- a/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.diagram.papyrus"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.diagram.ide.ui.papyrus"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/pom.xml b/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/pom.xml
index 0b329945b..4b91e72d5 100644
--- a/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.papyrus-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.diagram.papyrus</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.diagram.sirius-feature/feature.xml b/packaging/org.eclipse.emf.compare.diagram.sirius-feature/feature.xml
index a84625816..396966a3d 100644
--- a/packaging/org.eclipse.emf.compare.diagram.sirius-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.sirius-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.diagram.sirius"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="1.0.1">
diff --git a/packaging/org.eclipse.emf.compare.diagram.sirius-feature/pom.xml b/packaging/org.eclipse.emf.compare.diagram.sirius-feature/pom.xml
index 3f0822fbe..5faf6d711 100644
--- a/packaging/org.eclipse.emf.compare.diagram.sirius-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.diagram.sirius-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.diagram.sirius</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.egit-feature/feature.xml b/packaging/org.eclipse.emf.compare.egit-feature/feature.xml
index ebb1fc7c0..e66820971 100644
--- a/packaging/org.eclipse.emf.compare.egit-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.egit-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.egit"
label="%featureName"
- version="1.1.0.qualifier"
+ version="1.2.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="1.0.1">
diff --git a/packaging/org.eclipse.emf.compare.egit-feature/pom.xml b/packaging/org.eclipse.emf.compare.egit-feature/pom.xml
index 462f34a96..de856a765 100644
--- a/packaging/org.eclipse.emf.compare.egit-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.egit-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.egit</artifactId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.gendoc/pom.xml b/packaging/org.eclipse.emf.compare.gendoc/pom.xml
index accae9bec..2d4904fde 100644
--- a/packaging/org.eclipse.emf.compare.gendoc/pom.xml
+++ b/packaging/org.eclipse.emf.compare.gendoc/pom.xml
@@ -6,7 +6,7 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>../../org.eclipse.emf.compare-parent</relativePath>
</parent>
<groupId>org.eclipse.emf.compare</groupId>
diff --git a/packaging/org.eclipse.emf.compare.ide.ui-feature/feature.xml b/packaging/org.eclipse.emf.compare.ide.ui-feature/feature.xml
index 72dc9e4a6..641485070 100644
--- a/packaging/org.eclipse.emf.compare.ide.ui-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.ide.ui-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.ide.ui"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.ide.ui"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.ide.ui-feature/pom.xml b/packaging/org.eclipse.emf.compare.ide.ui-feature/pom.xml
index 4567a6f75..92402d683 100644
--- a/packaging/org.eclipse.emf.compare.ide.ui-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.ide.ui-feature/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.ide.ui</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
<build>
diff --git a/packaging/org.eclipse.emf.compare.rcp.ui-feature/feature.xml b/packaging/org.eclipse.emf.compare.rcp.ui-feature/feature.xml
index cf8783604..8c76aebaa 100644
--- a/packaging/org.eclipse.emf.compare.rcp.ui-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.rcp.ui-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.rcp.ui"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.rcp.ui"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.rcp.ui-feature/pom.xml b/packaging/org.eclipse.emf.compare.rcp.ui-feature/pom.xml
index 8d5c27d2f..5e6ccb03d 100644
--- a/packaging/org.eclipse.emf.compare.rcp.ui-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.rcp.ui-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.rcp.ui</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.uml2-feature/feature.xml b/packaging/org.eclipse.emf.compare.uml2-feature/feature.xml
index 15be9ef0f..b1aba6929 100644
--- a/packaging/org.eclipse.emf.compare.uml2-feature/feature.xml
+++ b/packaging/org.eclipse.emf.compare.uml2-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.emf.compare.uml2"
label="%featureName"
- version="3.2.0.qualifier"
+ version="3.3.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.emf.compare.uml2"
license-feature="org.eclipse.license"
diff --git a/packaging/org.eclipse.emf.compare.uml2-feature/pom.xml b/packaging/org.eclipse.emf.compare.uml2-feature/pom.xml
index 56cdf84ef..abdc6a397 100644
--- a/packaging/org.eclipse.emf.compare.uml2-feature/pom.xml
+++ b/packaging/org.eclipse.emf.compare.uml2-feature/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare.features</groupId>
<artifactId>org.eclipse.emf.compare.uml2</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
</project>
diff --git a/packaging/org.eclipse.emf.compare.update/pom.xml b/packaging/org.eclipse.emf.compare.update/pom.xml
index 8bc345e64..d192d02c0 100644
--- a/packaging/org.eclipse.emf.compare.update/pom.xml
+++ b/packaging/org.eclipse.emf.compare.update/pom.xml
@@ -4,12 +4,12 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>../../org.eclipse.emf.compare-parent</relativePath>
</parent>
<artifactId>org.eclipse.emf.compare.update</artifactId>
<packaging>eclipse-repository</packaging>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<build>
<resources>
<resource>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/META-INF/MANIFEST.MF
index f01df3d35..0ae30369e 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ecoretools.tests
-Bundle-Version: 2.3.0.qualifier
+Bundle-Version: 2.4.0.qualifier
Export-Package: org.eclipse.emf.compare.diagram.ecoretools.tests,
org.eclipse.emf.compare.diagram.ecoretools.tests.hide
Require-Bundle: org.eclipse.emf.ecore;bundle-version="2.5.0",
diff --git a/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/pom.xml
index 66deb2faf..b7112e71b 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ecoretools.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ecoretools.tests</artifactId>
- <version>2.3.0-SNAPSHOT</version>
+ <version>2.4.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.diagram.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.edit/META-INF/MANIFEST.MF
index ef48f4554..f47a425a2 100644
--- a/plugins/org.eclipse.emf.compare.diagram.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.edit;singleton:=true
-Bundle-Version: 2.4.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.emf.compare.diagram.internal.extensions.provider.ExtensionsEditPlugin$Implementation
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.emf.compare.diagram.edit/pom.xml b/plugins/org.eclipse.emf.compare.diagram.edit/pom.xml
index 7081a3ea7..9e09a001e 100644
--- a/plugins/org.eclipse.emf.compare.diagram.edit/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.edit/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.edit</artifactId>
- <version>2.4.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/META-INF/MANIFEST.MF
index a7aa2f7a5..65791154e 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ide.ecoretools.tests
-Bundle-Version: 2.3.0.qualifier
+Bundle-Version: 2.4.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.emf.ecore;bundle-version="2.6.0",
org.junit,
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/pom.xml
index b29240d2f..ef8a643f8 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ecoretools.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ide.ecoretools.tests</artifactId>
- <version>2.3.0-SNAPSHOT</version>
+ <version>2.4.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/META-INF/MANIFEST.MF
index e2c4f5394..d7c8f0928 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ide.ui.ecoretools;singleton:=true
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
-Bundle-Version: 2.3.0.qualifier
+Bundle-Version: 2.4.0.qualifier
Bundle-Localization: plugin
Require-Bundle: org.eclipse.emf.compare.diagram.ide.ui;bundle-version="3.0.0",
org.eclipse.emf.ecoretools;bundle-version="[1.0.0,3.0.0)"
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/pom.xml
index 57e929516..5ba69a23d 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.ecoretools/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ide.ui.ecoretools</artifactId>
- <version>2.3.0-SNAPSHOT</version>
+ <version>2.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/META-INF/MANIFEST.MF
index 11e5e46fb..272593911 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ide.ui.papyrus;singleton:=true
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
-Bundle-Version: 2.5.0.qualifier
+Bundle-Version: 2.6.0.qualifier
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.emf.compare.diagram.ide.ui.papyrus.internal.CompareDiagramIDEUIPapyrusPlugin
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/pom.xml
index aeca7f38d..68cd5dd90 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.papyrus/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ide.ui.papyrus</artifactId>
- <version>2.5.0-SNAPSHOT</version>
+ <version>2.6.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
<plugins>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/META-INF/MANIFEST.MF
index e70247c5e..b92882873 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ide.ui.sirius;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/pom.xml
index 3fc48195b..19a3e9fa8 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui.sirius/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ide.ui.sirius</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.ide.ui/META-INF/MANIFEST.MF
index f1965d317..a18998b6d 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.ide.ui;singleton:=true
-Bundle-Version: 3.3.0.qualifier
+Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.diagram.ide.ui.internal.CompareDiagramIDEUIPlugin
Require-Bundle: org.eclipse.emf.compare,
org.eclipse.gmf.runtime.diagram.ui,
diff --git a/plugins/org.eclipse.emf.compare.diagram.ide.ui/pom.xml b/plugins/org.eclipse.emf.compare.diagram.ide.ui/pom.xml
index fedd1b2fb..5a1926ef3 100644
--- a/plugins/org.eclipse.emf.compare.diagram.ide.ui/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.ide.ui/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.ide.ui</artifactId>
- <version>3.3.0-SNAPSHOT</version>
+ <version>3.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/META-INF/MANIFEST.MF
index 214bdebb0..7b3328d52 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.papyrus.tests.git;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.6.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Fragment-Host: org.eclipse.emf.compare.diagram.papyrus.tests
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/pom.xml b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/pom.xml
index 50c86bb16..0f64072ba 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests.git/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.papyrus.tests.git</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>2.6.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/META-INF/MANIFEST.MF
index af78c6818..b314d223f 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.papyrus.tests;singleton:=true
-Bundle-Version: 2.5.1.qualifier
+Bundle-Version: 2.6.0.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.junit,
org.eclipse.osgi,
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/pom.xml b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/pom.xml
index 1803a3983..7e9daed39 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.papyrus.tests</artifactId>
- <version>2.5.1-SNAPSHOT</version>
+ <version>2.6.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.papyrus/META-INF/MANIFEST.MF
index b64912c4e..633156842 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.papyrus;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.eclipse.emf.compare.rcp;bundle-version="2.3.0",
diff --git a/plugins/org.eclipse.emf.compare.diagram.papyrus/pom.xml b/plugins/org.eclipse.emf.compare.diagram.papyrus/pom.xml
index 0312a4a5f..c0e5be6fc 100644
--- a/plugins/org.eclipse.emf.compare.diagram.papyrus/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.papyrus/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.papyrus</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram.sirius/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram.sirius/META-INF/MANIFEST.MF
index 47f20269e..29304db84 100644
--- a/plugins/org.eclipse.emf.compare.diagram.sirius/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram.sirius/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram.sirius;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.emf.compare.diagram.sirius/pom.xml b/plugins/org.eclipse.emf.compare.diagram.sirius/pom.xml
index f76ada7e5..c1be0cc7c 100644
--- a/plugins/org.eclipse.emf.compare.diagram.sirius/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram.sirius/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram.sirius</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.diagram/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.diagram/META-INF/MANIFEST.MF
index c5711bebc..3c3d3c94d 100644
--- a/plugins/org.eclipse.emf.compare.diagram/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.diagram/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.diagram;singleton:=true
-Bundle-Version: 2.4.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.emf.compare.diagram/pom.xml b/plugins/org.eclipse.emf.compare.diagram/pom.xml
index bf80ddc6f..48eb4fb75 100644
--- a/plugins/org.eclipse.emf.compare.diagram/pom.xml
+++ b/plugins/org.eclipse.emf.compare.diagram/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.diagram</artifactId>
- <version>2.4.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.doc/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.doc/META-INF/MANIFEST.MF
index b39da122d..7f1b70c3e 100644
--- a/plugins/org.eclipse.emf.compare.doc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.doc/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.doc; singleton:=true
-Bundle-Version: 3.2.0.qualifier
+Bundle-Version: 3.3.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.compare.doc/pom.xml b/plugins/org.eclipse.emf.compare.doc/pom.xml
index 2ab201a83..c9a9985e4 100644
--- a/plugins/org.eclipse.emf.compare.doc/pom.xml
+++ b/plugins/org.eclipse.emf.compare.doc/pom.xml
@@ -16,12 +16,12 @@
<parent>
<artifactId>emf.compare-parent</artifactId>
<groupId>org.eclipse.emf.compare</groupId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<relativePath>../../org.eclipse.emf.compare-parent</relativePath>
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.doc</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<properties>
@@ -121,7 +121,7 @@
<argument>${project.build.directory}/website</argument>
<argument>-version</argument>
<!-- Please update qualified version for each release. Please also update the publisher.properties.-->
- <argument>3.2.0.${buildQualifier}</argument>
+ <argument>3.3.0.${buildQualifier}</argument>
</arguments>
</configuration>
</execution>
@@ -140,7 +140,7 @@
</executions>
<configuration>
<!-- Please update qualified version for each release. Please also update the publisher.properties.-->
- <finalName>${project.artifactId}-website-3.2.0.${buildQualifier}</finalName>
+ <finalName>${project.artifactId}-website-3.3.0.${buildQualifier}</finalName>
<appendAssemblyId>false</appendAssemblyId>
<descriptors>
<descriptor>assembly.xml</descriptor>
diff --git a/plugins/org.eclipse.emf.compare.doc/publisher.properties b/plugins/org.eclipse.emf.compare.doc/publisher.properties
index 814cb2f37..7b3ec579c 100644
--- a/plugins/org.eclipse.emf.compare.doc/publisher.properties
+++ b/plugins/org.eclipse.emf.compare.doc/publisher.properties
@@ -1,6 +1,6 @@
# EMFCompare publisher properties
# TODO update qualified version for each release. Please also update the pom.xml.
-DOCUMENTATION_WEBSITE__UNQUALIFIED_VERSION=3.2.0
-DOCUMENTATION_WEBSITE__QUALIFIED_VERSION=3.2.0.${buildQualifier}
-DOCUMENTATION_WEBSITE__ARTIFACT_NAME=${project.groupId}-website-3.2.0.${buildQualifier}.zip
-DOCUMENTATION_WEBSITE__ARTIFACT_URL=${env.JOB_URL}${env.BUILD_NUMBER}/artifact/plugins/org.eclipse.emf.compare.doc/target/${project.artifactId}-website-3.2.0.${buildQualifier}.zip
+DOCUMENTATION_WEBSITE__UNQUALIFIED_VERSION=3.3.0
+DOCUMENTATION_WEBSITE__QUALIFIED_VERSION=3.3.0.${buildQualifier}
+DOCUMENTATION_WEBSITE__ARTIFACT_NAME=${project.groupId}-website-3.3.0.${buildQualifier}.zip
+DOCUMENTATION_WEBSITE__ARTIFACT_URL=${env.JOB_URL}${env.BUILD_NUMBER}/artifact/plugins/org.eclipse.emf.compare.doc/target/${project.artifactId}-website-3.3.0.${buildQualifier}.zip
diff --git a/plugins/org.eclipse.emf.compare.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.edit/META-INF/MANIFEST.MF
index f60921003..cea9572b6 100644
--- a/plugins/org.eclipse.emf.compare.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.edit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.edit;singleton:=true
-Bundle-Version: 4.2.0.qualifier
+Bundle-Version: 4.3.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.emf.compare.provider.EMFCompareEditPlugin$Implementation
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.emf.compare.edit/pom.xml b/plugins/org.eclipse.emf.compare.edit/pom.xml
index 6c65a3313..d3773bea5 100644
--- a/plugins/org.eclipse.emf.compare.edit/pom.xml
+++ b/plugins/org.eclipse.emf.compare.edit/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.edit</artifactId>
- <version>4.2.0-SNAPSHOT</version>
+ <version>4.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.egit.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.egit.ui/META-INF/MANIFEST.MF
index e793f12f9..5cf304419 100755
--- a/plugins/org.eclipse.emf.compare.egit.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.egit.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.egit.ui;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.emf.compare.egit,
diff --git a/plugins/org.eclipse.emf.compare.egit.ui/pom.xml b/plugins/org.eclipse.emf.compare.egit.ui/pom.xml
index 4abba223c..fee7f82f8 100644
--- a/plugins/org.eclipse.emf.compare.egit.ui/pom.xml
+++ b/plugins/org.eclipse.emf.compare.egit.ui/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.egit.ui</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.egit/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.egit/META-INF/MANIFEST.MF
index 0a300dd19..e37eef03b 100644
--- a/plugins/org.eclipse.emf.compare.egit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.egit/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.egit;singleton:=true
-Bundle-Version: 1.1.0.qualifier
+Bundle-Version: 1.2.0.qualifier
Require-Bundle: org.eclipse.core.resources,
org.eclipse.core.runtime,
org.eclipse.jgit;bundle-version="4.1.0",
diff --git a/plugins/org.eclipse.emf.compare.egit/pom.xml b/plugins/org.eclipse.emf.compare.egit/pom.xml
index ff135969a..63470dae0 100644
--- a/plugins/org.eclipse.emf.compare.egit/pom.xml
+++ b/plugins/org.eclipse.emf.compare.egit/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.egit</artifactId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.ide.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.ide.tests/META-INF/MANIFEST.MF
index 92f48962e..ae586db6c 100644
--- a/plugins/org.eclipse.emf.compare.ide.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.ide.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.ide.tests
-Bundle-Version: 3.3.0.qualifier
+Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.ide.tests.Activator
Require-Bundle: org.eclipse.core.runtime,
org.junit;bundle-version="4.8.1",
diff --git a/plugins/org.eclipse.emf.compare.ide.tests/pom.xml b/plugins/org.eclipse.emf.compare.ide.tests/pom.xml
index 79e15aa90..e3c68adcf 100644
--- a/plugins/org.eclipse.emf.compare.ide.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.ide.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.ide.tests</artifactId>
- <version>3.3.0-SNAPSHOT</version>
+ <version>3.4.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.e4/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.ide.ui.e4/META-INF/MANIFEST.MF
index 8db5517e7..f656338c1 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.e4/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.ide.ui.e4/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.ide.ui.e4
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Require-Bundle: org.eclipse.emf.compare.ide.ui;bundle-version="4.1.0",
org.eclipse.ui,
org.eclipse.core.runtime
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.e4/pom.xml b/plugins/org.eclipse.emf.compare.ide.ui.e4/pom.xml
index 377985507..15676ac23 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.e4/pom.xml
+++ b/plugins/org.eclipse.emf.compare.ide.ui.e4/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.ide.ui.e4</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.tests.git/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.ide.ui.tests.git/META-INF/MANIFEST.MF
index 7afad52c9..31864feef 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.tests.git/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.ide.ui.tests.git/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.ide.ui.tests.git;singleton:=true
-Bundle-Version: 4.2.0.qualifier
+Bundle-Version: 4.3.0.qualifier
Bundle-Vendor: %providerName
Fragment-Host: org.eclipse.emf.compare.ide.ui.tests
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.tests.git/pom.xml b/plugins/org.eclipse.emf.compare.ide.ui.tests.git/pom.xml
index 5eb25783d..90531a2bd 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.tests.git/pom.xml
+++ b/plugins/org.eclipse.emf.compare.ide.ui.tests.git/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.ide.ui.tests.git</artifactId>
- <version>4.2.0-SNAPSHOT</version>
+ <version>4.3.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.ide.ui.tests/META-INF/MANIFEST.MF
index 523cb53e3..04cc06a67 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.ide.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.ide.ui.tests;singleton:=true
-Bundle-Version: 4.2.0.qualifier
+Bundle-Version: 4.3.0.qualifier
Bundle-Vendor: %providerName
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.emf.compare.ide.ui.tests/pom.xml b/plugins/org.eclipse.emf.compare.ide.ui.tests/pom.xml
index be860a611..baa3d70b3 100644
--- a/plugins/org.eclipse.emf.compare.ide.ui.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.ide.ui.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.ide.ui.tests</artifactId>
- <version>4.2.0-SNAPSHOT</version>
+ <version>4.3.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.ide/META-INF/MANIFEST.MF
index 03eac79f5..b3410817a 100644
--- a/plugins/org.eclipse.emf.compare.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.ide/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.ide;singleton:=true
-Bundle-Version: 3.3.0.qualifier
+Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.ide.EMFCompareIDEPlugin
Bundle-Vendor: %providerName
Require-Bundle: org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.emf.compare.ide/pom.xml b/plugins/org.eclipse.emf.compare.ide/pom.xml
index 5d32ad2de..dad9bf970 100644
--- a/plugins/org.eclipse.emf.compare.ide/pom.xml
+++ b/plugins/org.eclipse.emf.compare.ide/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.ide</artifactId>
- <version>3.3.0-SNAPSHOT</version>
+ <version>3.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.log4j.fragment/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.log4j.fragment/META-INF/MANIFEST.MF
index ecdb3d620..f5345c532 100644
--- a/plugins/org.eclipse.emf.compare.log4j.fragment/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.log4j.fragment/META-INF/MANIFEST.MF
@@ -2,6 +2,6 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Logging
Bundle-SymbolicName: org.eclipse.emf.compare.log4j.fragment
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Fragment-Host: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.emf.compare.rcp.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.rcp.tests/META-INF/MANIFEST.MF
index 75505288b..9416dae07 100644
--- a/plugins/org.eclipse.emf.compare.rcp.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.rcp.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.eclipse.emf.compare.rcp.tests
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.junit;bundle-version="4.8.2",
org.eclipse.emf.compare;bundle-version="3.3.0",
diff --git a/plugins/org.eclipse.emf.compare.rcp.tests/pom.xml b/plugins/org.eclipse.emf.compare.rcp.tests/pom.xml
index e4de7fea5..42c63e232 100644
--- a/plugins/org.eclipse.emf.compare.rcp.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.rcp.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.rcp.tests</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.rcp.ui.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.rcp.ui.tests/META-INF/MANIFEST.MF
index 5479433af..1d85c0799 100644
--- a/plugins/org.eclipse.emf.compare.rcp.ui.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.rcp.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.rcp.ui.tests;singleton:=true
-Bundle-Version: 4.2.0.qualifier
+Bundle-Version: 4.3.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.rcp.ui.tests.Activator
Require-Bundle: org.eclipse.core.runtime,
org.junit;bundle-version="4.8.0",
diff --git a/plugins/org.eclipse.emf.compare.rcp.ui.tests/pom.xml b/plugins/org.eclipse.emf.compare.rcp.ui.tests/pom.xml
index ca3d447d1..f86f4b2d3 100644
--- a/plugins/org.eclipse.emf.compare.rcp.ui.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.rcp.ui.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.rcp.ui.tests</artifactId>
- <version>4.2.0-SNAPSHOT</version>
+ <version>4.3.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.rcp/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.rcp/META-INF/MANIFEST.MF
index 7a5d72880..d2af6b463 100644
--- a/plugins/org.eclipse.emf.compare.rcp/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.rcp/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.rcp;singleton:=true
-Bundle-Version: 2.4.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.rcp.EMFCompareRCPPlugin
Bundle-Vendor: %providerName
Require-Bundle: org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.emf.compare.rcp/pom.xml b/plugins/org.eclipse.emf.compare.rcp/pom.xml
index bc46096af..2b96bdda3 100644
--- a/plugins/org.eclipse.emf.compare.rcp/pom.xml
+++ b/plugins/org.eclipse.emf.compare.rcp/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.rcp</artifactId>
- <version>2.4.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.specifications/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.specifications/META-INF/MANIFEST.MF
index c68252eff..8f4d7e124 100644
--- a/plugins/org.eclipse.emf.compare.specifications/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.specifications/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.specifications;singleton:=true
-Bundle-Version: 3.2.0.qualifier
+Bundle-Version: 3.3.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.emf.compare.specifications/pom.xml b/plugins/org.eclipse.emf.compare.specifications/pom.xml
index 3339a7020..017f4c2b8 100644
--- a/plugins/org.eclipse.emf.compare.specifications/pom.xml
+++ b/plugins/org.eclipse.emf.compare.specifications/pom.xml
@@ -21,7 +21,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.specifications</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<properties>
diff --git a/plugins/org.eclipse.emf.compare.specifications/src/3.3.0-release.mediawiki b/plugins/org.eclipse.emf.compare.specifications/src/3.3.0-release.mediawiki
new file mode 100644
index 000000000..7fbd87d43
--- /dev/null
+++ b/plugins/org.eclipse.emf.compare.specifications/src/3.3.0-release.mediawiki
@@ -0,0 +1,103 @@
+= Specifications of the EMF Compare 3.3.0 release (Simultaneous with Eclipse Neon.1 but not included in Neon.1) =
+
+== US_330_001 - Improve Group Providers and Filters ==
+
+=== Description ===
+
+Group Providers are responsible for computing the tress displayed in the Structure Merge Viewer.
+Previous implementations suffered some issues that led to instabilities, missing diffs in the UI, and a poor user experience when it came to understanding the comparisons displayed. Moreover, the base implementation of the groups providers was a hotspot in the code base that was very hard to maintain.
+Another problem identified was the performance of the computation of the UI tree which had severe impacts on the time it took to display the comparison.
+
+Version 3.1.0 brings a new implementation to resolve these issues and make it easier to maintain the code, faster to display the comparison and easier to understand the UI.
+
+This is accompanied by a number of 'great principles' that EMFCompare complies with:
+* Filters:
+** They should only hide differences when selected, and do nothing when they are not selected
+** Consequently, unchecking all the filters should display all the diffs of the comparison in the UI
+* Groups:
+** A node in the tree should represent either a diff or a match but not both at the same time
+** A diff is displayed as a node whose parent represents a match, or another diff if (and only if) it is a refining diff
+** A match should never be displayed as child of a diff
+** Refining diffs should be displayed as children of their refined diff(s)
+** In the group 'conflicts', a conflict should never be empty. It should display _at least_ all the diffs that are part of this conflict
+
+==== Categories ====
+[[./index.html#UI-related Specifications|UI]]
+
+=== Content ===
+
+One major difference in the display of the tree used in the Structure Merge Viewer (top part of the comparison editor) concerns added/deleted objects.
+
+Previously, and object added or deleted caused the display of a node that represented both the object's '''Match''', and the add/delete containment '''ReferenceChange'''.
+
+Now, a node is displayed for the '''Match''', and inside another node is displayed which represents the containment '''ReferenceChange''', i.e. the add or delete difference. It's important to note that in this case, the diff is not displayed as a child of it Match, but is displayed as a child of the Match of its '''value'''. Since it is a '''ReferenceChange''', this means that the Match of the displayed diff is the ''grand-parent'' node.
+
+Feedback and suggestions on this choice are very welcome!
+
+== US_330_002 - Additive Merge ==
+
+=== Description ===
+
+Support a merge mode that allows an end-user to merge two versions of a model by rejecting all deletions (and associated changes such as unsets) that are only made on one side.
+
+==== Categories ====
+[[./index.html#UI-related Specifications|core]], [[./index.html#UI-related Specifications|egit]]
+
+=== Content ===
+
+A new MergeStrategy has been implemented and can be used by setting the relevant preference in the EGit preferences.
+This merge strategy is consequently only supported when merging git branches.
+
+Review [[https://git.eclipse.org/r/55389]] proposes an improvement in EGit dialogs to make it possible to select the merge strategy to be used for the operation at hand (merge, rebase, cherry-pick, and so on).
+
+
+== US_330_003 - Automatic Profile Migration on Papyrus UML models ==
+
+=== Description ===
+Make it possible to compare versions of Papyrus models that use different versions of a profile by automatically applying the papyrus tools to migration applied profiles prior to launching the comparison.
+
+==== Categories ====
+[[./index.html#Team-related Specifications|UML]]
+
+=== Related Bugs & Reviews ===
+
+This user story is linked with these bugs & reviews:
+* https://bugs.eclipse.org/bugs/show_bug.cgi?id=495259
+
+=== Content ===
+
+== US_330_004 - User can deactivate filters ==
+
+=== Description ===
+Make it possible for users to completely deactivate filters, so that they don't appear in the EMFCompare UI (comparison editor) nor are applied.
+
+==== Categories ====
+[[./index.html#UI-related Specifications|UI]]
+
+=== Related Bugs & Reviews ===
+
+This user story is linked with these bugs & reviews:
+* https://bugs.eclipse.org/bugs/show_bug.cgi?id=493921
+
+=== Content ===
+This has been addressed by supplying in the preferences the possibility to completely deactivate filters.
+This is available in a new tab in the preference page 'Filters'.
+
+'''Note:''' It has recently been reported that is would also be useful to hide filters in the combo-box without deactivating the associated filter. This could be useful for third-parties that build their own products upon EMFCompare and don't wish their users to be able to deactivate certain filters.
+
+
+== US_330_005 - Improve EMFCompare Preference Pages ==
+
+=== Description ===
+Several minor differences in the layout and organization of the numerous preference pages of EMFCompare make these pages unsightly.
+
+==== Categories ====
+[[./index.html#UI-related Specifications|UI]]
+
+=== Related Bugs & Reviews ===
+
+This user story is linked with these bugs & reviews:
+* https://bugs.eclipse.org/bugs/show_bug.cgi?id=495753
+
+=== Content ===
+The pages have been harmonized and reorganized a bit, as described in the bug and associated reviews.
diff --git a/plugins/org.eclipse.emf.compare.specifications/src/index.mediawiki b/plugins/org.eclipse.emf.compare.specifications/src/index.mediawiki
index 8ecc82b9f..2e754d4d5 100644
--- a/plugins/org.eclipse.emf.compare.specifications/src/index.mediawiki
+++ b/plugins/org.eclipse.emf.compare.specifications/src/index.mediawiki
@@ -1,8 +1,10 @@
= Specifications =
+== [[./3.3.0-release.html|3.3.0 release (Simultaneous but not included in Eclipse Neon.1)]] ==
+
+
== [[./3.2.0-release.html|3.2.0 release (Eclipse Neon)]] ==
-* [[./3.2.0-release.html#US_320_001 - UML Dangling stereotypes|US_320_001 - UML Dangling stereotypes]]
== [[./3.1.0-release.html|3.1.0 release (Eclipse Mars)]] ==
@@ -16,11 +18,15 @@
== UI-related Specifications ==
+* [[./3.3.0-release.html#US_330_001 - Improve Group Providers and Filters|US_330_001 - Improve Group Providers and Filters]]
+* [[./3.3.0-release.html#US_330_004 - User can deactivate filters|US_330_004 - User can deactivate filters]]
+* [[./3.3.0-release.html#US_330_005 - Improve EMFCompare Preference Pages|US_330_005 - Improve EMFCompare Preference Pages]]
* [[./3.2.0-release.html#US_320_001 - UML Dangling stereotypes|US_320_001 - UML Dangling stereotypes]]
* [[./3.2.0-release.html#US_320_003 - Synchronize view integration|US_320_003 - Synchronize view integration]]
== UML-related Specifications ==
+* [[./3.3.0-release.html#US_330_003 - Automatic Profile Migration on Papyrus UML models|US_330_003 - Automatic Profile Migration on Papyrus UML models]]
* [[./3.2.0-release.html#US_320_001 - UML Dangling stereotypes|US_320_001 - UML Dangling stereotypes]]
* [[./3.2.0-release.html#US_320_008 - Ignore changes in Papyrus di-files|US_320_008 - Ignore changes in Papyrus di-files]]
* [[./3.2.0-release.html#US_320_009 - Multiplicity Element Change|US_320_009 - Multiplicity Element Change]]
@@ -33,4 +39,6 @@
== EGit-related Specifications ==
+* [[./3.3.0-release.html#US_330_002 - Additive Merge|US_330_002 - Additive Merge]]
+
== Command Line-related Specifications == \ No newline at end of file
diff --git a/plugins/org.eclipse.emf.compare.subversive/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.subversive/META-INF/MANIFEST.MF
index 7193998cf..7d1405b60 100644
--- a/plugins/org.eclipse.emf.compare.subversive/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.subversive/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.emf.compare.subversive;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Localization: plugin
Require-Bundle: org.eclipse.equinox.registry,
diff --git a/plugins/org.eclipse.emf.compare.subversive/pom.xml b/plugins/org.eclipse.emf.compare.subversive/pom.xml
index 5be92a439..7fb118a7c 100644
--- a/plugins/org.eclipse.emf.compare.subversive/pom.xml
+++ b/plugins/org.eclipse.emf.compare.subversive/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.subversive</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.tests.fuzzy/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.tests.fuzzy/META-INF/MANIFEST.MF
index b03202078..328585dad 100644
--- a/plugins/org.eclipse.emf.compare.tests.fuzzy/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.tests.fuzzy/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.tests.fuzzy
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Vendor: %providerName
Fragment-Host: org.eclipse.emf.compare.tests;bundle-version="3.1.0"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/org.eclipse.emf.compare.tests.fuzzy/pom.xml b/plugins/org.eclipse.emf.compare.tests.fuzzy/pom.xml
index 01378771e..37d216fe4 100644
--- a/plugins/org.eclipse.emf.compare.tests.fuzzy/pom.xml
+++ b/plugins/org.eclipse.emf.compare.tests.fuzzy/pom.xml
@@ -10,9 +10,9 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.tests.fuzzy</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
-
+ <build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
diff --git a/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
index 964cdc545..ff3dd2d5a 100644
--- a/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.tests;singleton:=true
-Bundle-Version: 3.3.0.qualifier
+Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.tests.EMFCompareTestsPlugin
Bundle-ClassPath: .
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.emf.compare.tests/pom.xml b/plugins/org.eclipse.emf.compare.tests/pom.xml
index 35d37fee5..49446580b 100644
--- a/plugins/org.eclipse.emf.compare.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.tests</artifactId>
- <version>3.3.0-SNAPSHOT</version>
+ <version>3.4.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.uml2.ide.tests/META-INF/MANIFEST.MF
index 037cf7558..bc00bae95 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.uml2.ide.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.emf.compare.uml2.ide.tests;singleton:=true
-Bundle-Version: 3.2.0.qualifier
+Bundle-Version: 3.3.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.uml2.ide.tests.Activator
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide.tests/pom.xml b/plugins/org.eclipse.emf.compare.uml2.ide.tests/pom.xml
index 1dd2ebb6f..e6f6bdd63 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.uml2.ide.tests/pom.xml
@@ -11,7 +11,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.uml2.ide.tests</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/META-INF/MANIFEST.MF
index 71c940e58..13630947f 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.emf.compare.uml2.ide.ui.tests
-Bundle-Version: 4.0.0.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.uml2.ide.ui.tests.Activator
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/pom.xml b/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/pom.xml
index 18c6e8cbe..3ecf7aadf 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.uml2.ide.ui.tests/pom.xml
@@ -11,7 +11,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.uml2.ide.ui.tests</artifactId>
- <version>4.0.0-SNAPSHOT</version>
+ <version>4.1.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.uml2.ide/META-INF/MANIFEST.MF
index 5c4e4555f..b6028d58b 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.uml2.ide/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.uml2.ide;singleton:=true
-Bundle-Version: 3.2.0.qualifier
+Bundle-Version: 3.3.0.qualifier
Bundle-Activator: org.eclipse.emf.compare.uml2.ide.Activator
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
diff --git a/plugins/org.eclipse.emf.compare.uml2.ide/pom.xml b/plugins/org.eclipse.emf.compare.uml2.ide/pom.xml
index 6e34e7737..402fa11c1 100644
--- a/plugins/org.eclipse.emf.compare.uml2.ide/pom.xml
+++ b/plugins/org.eclipse.emf.compare.uml2.ide/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.uml2.ide</artifactId>
- <version>3.2.0-SNAPSHOT</version>
+ <version>3.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/META-INF/MANIFEST.MF
index ecc6b80e5..48e5c73af 100644
--- a/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.uml2.rcp.ui.tests
-Bundle-Version: 2.4.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Bundle-Vendor: %providerName
Bundle-Activator: org.eclipse.emf.compare.uml2.rcp.ui.tests.Activator
Require-Bundle: org.eclipse.ui,
diff --git a/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/pom.xml b/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/pom.xml
index 954a62899..f5d792b42 100644
--- a/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/pom.xml
+++ b/plugins/org.eclipse.emf.compare.uml2.rcp.ui.tests/pom.xml
@@ -10,7 +10,7 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.uml2.rcp.ui.tests</artifactId>
- <version>2.4.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<build>
diff --git a/plugins/org.eclipse.emf.compare.uml2.rcp/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.compare.uml2.rcp/META-INF/MANIFEST.MF
index 5177cda67..da4610368 100644
--- a/plugins/org.eclipse.emf.compare.uml2.rcp/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.compare.uml2.rcp/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.emf.compare.uml2.rcp;singleton:=true
-Bundle-Version: 2.4.0.qualifier
+Bundle-Version: 2.5.0.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.compare.rcp;bundle-version="2.1.0",
org.eclipse.emf.ecore,
diff --git a/plugins/org.eclipse.emf.compare.uml2.rcp/pom.xml b/plugins/org.eclipse.emf.compare.uml2.rcp/pom.xml
index f0e07f40d..64525ec51 100644
--- a/plugins/org.eclipse.emf.compare.uml2.rcp/pom.xml
+++ b/plugins/org.eclipse.emf.compare.uml2.rcp/pom.xml
@@ -10,6 +10,6 @@
</parent>
<groupId>org.eclipse.emf.compare</groupId>
<artifactId>org.eclipse.emf.compare.uml2.rcp</artifactId>
- <version>2.4.0-SNAPSHOT</version>
+ <version>2.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>

Back to the top