Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2010-02-16 19:31:50 -0500
committerMatthias Sohn2010-02-19 09:12:18 -0500
commit8ed301ca1834de6f8a2e5bcfabfc7793a26b49ee (patch)
tree030d4f30be84a6344308540d64147fba65d9d5ba /org.eclipse.egit.core.test/META-INF
parent8e5dd91534d9ff876d380c1c77e74aa543f30e93 (diff)
downloadegit-8ed301ca1834de6f8a2e5bcfabfc7793a26b49ee.tar.gz
egit-8ed301ca1834de6f8a2e5bcfabfc7793a26b49ee.tar.xz
egit-8ed301ca1834de6f8a2e5bcfabfc7793a26b49ee.zip
Convert tests to JUnit 4 style
The maven-osgi-test-plugin doesn't find JUnit4 with package dependency to org.junit;version="[4.3.1,5.0.0)". Hence require bundle org.junit4. Filed https://issues.sonatype.org/browse/TYCHO-360 for this problem. Rename T0002_history so that it is detected as test class by maven-osgi-test-plugin default logic (see [1]). [1] http://github.com/sonatype/sonatype-tycho/blob/master/tycho-surefire/ maven-osgi-test-plugin/src/main/java/org/codehaus/tycho/osgitest/TestMojo.java Change-Id: I5466e7e3b8d018c2484bf700334cc03778c9728a Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.egit.core.test/META-INF')
-rw-r--r--org.eclipse.egit.core.test/META-INF/MANIFEST.MF6
1 files changed, 3 insertions, 3 deletions
diff --git a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
index 196c2b104..b4338c1c4 100644
--- a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
@@ -10,10 +10,10 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
org.eclipse.team.core;bundle-version="[3.4.0,4.0.0)",
org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)"
+ org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)",
+ org.junit4;bundle-version="[4.3.0,5.0.0)"
Bundle-ActivationPolicy: lazy
-Import-Package: junit.framework;version="[4.3.1,5.0.0)",
- org.eclipse.egit.core;version="[0.6.0,0.7.0)",
+Import-Package: org.eclipse.egit.core;version="[0.6.0,0.7.0)",
org.eclipse.egit.core.op;version="[0.6.0,0.7.0)",
org.eclipse.egit.core.project;version="[0.6.0,0.7.0)",
org.eclipse.jgit.junit;version="[0.6.0,0.7.0)",

Back to the top