Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn O. Pearce2010-02-11 18:57:21 -0500
committerMatthias Sohn2010-02-13 21:57:10 -0500
commit058456865a75ff36d85d63105650d3897ee21105 (patch)
treef2ae32126b33536d083dbf70532e7cea5cd153bd /org.eclipse.egit.core.test/META-INF
parentf701560d6f08edbf55a3afad2765400ecf1753ba (diff)
downloadegit-058456865a75ff36d85d63105650d3897ee21105.tar.gz
egit-058456865a75ff36d85d63105650d3897ee21105.tar.xz
egit-058456865a75ff36d85d63105650d3897ee21105.zip
Fix build and test failures
- Correcting versions. [ms: - Correcting wrong version for org.eclipse.core.filesystem to [1.1,2.0) - "Require-Bundle:" needs to use "bundle-version:" to specify version. - Manifest refered to JUnit 4 but test execution specified JUnit 3. - Fix tests which have been broken by the change 667f571b "Fix enabling team operations on project import." - Split packages between org.eclipse.egit.core and org.eclipse.egit.core.test caused ClassNotFoundException in test execution hence moving test packages. ] Change-Id: Ic76335ecb34daa76431b3d7daae566d97a7413f0 Signed-off-by: Shawn O. Pearce <spearce@spearce.org> Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.egit.core.test/META-INF')
-rw-r--r--org.eclipse.egit.core.test/META-INF/MANIFEST.MF12
1 files changed, 6 insertions, 6 deletions
diff --git a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
index 2eb331188..196c2b104 100644
--- a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
@@ -5,12 +5,12 @@ Bundle-Vendor: Eclipse.org
Bundle-SymbolicName: org.eclipse.egit.core.test
Bundle-Version: 0.6.0.qualifier
Bundle-Activator: org.eclipse.egit.core.test.Activator
-Require-Bundle: org.eclipse.core.runtime;version="[3.4.0,4.0.0)",
- org.eclipse.core.filesystem;version="[3.4.0,4.0.0)",
- org.eclipse.core.resources;version="[3.4.0,4.0.0)",
- org.eclipse.team.core;version="[3.4.0,4.0.0)",
- org.eclipse.jdt.core;version="[3.4.0,4.0.0)",
- org.eclipse.jdt.launching;version="[3.4.0,4.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.team.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)"
Bundle-ActivationPolicy: lazy
Import-Package: junit.framework;version="[4.3.1,5.0.0)",
org.eclipse.egit.core;version="[0.6.0,0.7.0)",

Back to the top