Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Wolf2018-09-19 10:30:07 -0400
committerThomas Wolf2018-09-19 11:32:56 -0400
commitdcd36536f35c6ea3046b5d8bc7fe9e209a7b59dc (patch)
tree6b4259740f5f4497abd7708706df0f830da86f4e
parente0dea42eb0995afb4b0e2bb59a711bfe5e3f7bbc (diff)
downloadegit-dcd36536f35c6ea3046b5d8bc7fe9e209a7b59dc.tar.gz
egit-dcd36536f35c6ea3046b5d8bc7fe9e209a7b59dc.tar.xz
egit-dcd36536f35c6ea3046b5d8bc7fe9e209a7b59dc.zip
[oomph] Update API baselines
As usual, drop the oldest and add the new 5.1.1. This gives baselines for working on the next and the past two releases. Developers needing even older API baselines can download the older zips from [1]. [1] http://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F Change-Id: I6f15713239cc511fead107c53570a79224e4c442 Signed-off-by: Thomas Wolf <thomas.wolf@paranor.ch>
-rw-r--r--tools/oomph/EGit.setup20
1 files changed, 10 insertions, 10 deletions
diff --git a/tools/oomph/EGit.setup b/tools/oomph/EGit.setup
index 8d1728fcd..c8fbcf5b8 100644
--- a/tools/oomph/EGit.setup
+++ b/tools/oomph/EGit.setup
@@ -105,15 +105,6 @@
xsi:type="pde:APIBaselineTask"
name="EGit"
activate="false"
- version="4.10.0"
- location="${workspace.location/../api.baseline/4.10.0}"
- remoteURI="http://download.eclipse.org/egit/updates-4.10/org.eclipse.egit.repository-4.10.0.201712302008-r.zip">
- <description>EGit 4.10.0 API baseline; to be used with branch stable-4.11</description>
- </setupTask>
- <setupTask
- xsi:type="pde:APIBaselineTask"
- name="EGit"
- activate="false"
version="4.11.0"
location="${workspace.location/../api.baseline/4.11.0}"
remoteURI="http://download.eclipse.org/egit/updates-4.11/org.eclipse.egit.repository-4.11.0.201803080745-r.zip">
@@ -122,10 +113,19 @@
<setupTask
xsi:type="pde:APIBaselineTask"
name="EGit"
+ activate="false"
version="5.0.0"
location="${workspace.location/../api.baseline/5.0.0}"
remoteURI="http://download.eclipse.org/egit/updates-5.0/org.eclipse.egit.repository-5.0.0.201806131550-r.zip">
- <description>EGit 5.0.0 API baseline; to be used with branch master</description>
+ <description>EGit 5.0.0 API baseline; to be used with branch stable-5.1</description>
+ </setupTask>
+ <setupTask
+ xsi:type="pde:APIBaselineTask"
+ name="EGit"
+ version="5.1.1"
+ location="${workspace.location/../api.baseline/5.1.1}"
+ remoteURI="http://download.eclipse.org/egit/updates-5.1.1/org.eclipse.egit.repository-5.1.1.201809181055-r.zip">
+ <description>EGit 5.1.1 API baseline; to be used with branch master</description>
</setupTask>
<stream name="master"
label="Workspace setup for branch master">

Back to the top