Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Keppler2019-03-16 11:15:42 -0400
committerMichael Keppler2019-03-17 10:00:08 -0400
commitc3a285e7f553fa6dea72ce1882e0c0e652ed3f7e (patch)
treec6faceebb0696d17c7801e2984c49893a5477430
parent810fc9850f57b8f3432e47d5020469db7451cb63 (diff)
downloadegit-c3a285e7f553fa6dea72ce1882e0c0e652ed3f7e.tar.gz
egit-c3a285e7f553fa6dea72ce1882e0c0e652ed3f7e.tar.xz
egit-c3a285e7f553fa6dea72ce1882e0c0e652ed3f7e.zip
Use UTF-8 with maven-resources-plugin
The egit parent pom contained configuration for the maven-resources-plugin, setting its encoding to ISO-8859-1. That lead to log output like "Using 'ISO-8859-1' encoding to copy filtered resources.". Since all egit code is UTF-8, this looks like an ancient mistake. Change the encoding to UTF-8 via property instead of listing the plugin in plugin management. Change-Id: I7da93eee8ab3cdc82ff16548fa7909187adbfddc Signed-off-by: Michael Keppler <Michael.Keppler@gmx.de>
-rw-r--r--pom.xml10
1 files changed, 2 insertions, 8 deletions
diff --git a/pom.xml b/pom.xml
index b58f560af..c466f99de 100644
--- a/pom.xml
+++ b/pom.xml
@@ -74,6 +74,8 @@
<test.vmparams></test.vmparams>
<coretest.vmparams></coretest.vmparams>
<uitest.vmparams>-Dorg.eclipse.swtbot.search.timeout=30000 -Dorg.eclipse.swtbot.screenshots.dir=target/screenshots -Xmx1024m</uitest.vmparams>
+ <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
+ <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
</properties>
<profiles>
@@ -473,14 +475,6 @@
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-resources-plugin</artifactId>
- <version>3.1.0</version>
- <configuration>
- <encoding>ISO-8859-1</encoding>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-antrun-plugin</artifactId>
<version>1.8</version>
</plugin>

Back to the top