Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Keppler2019-03-08 09:12:20 -0500
committerMichael Keppler2019-03-12 12:43:38 -0400
commitc0d7a36d6b725ca278d59b28f47f2bcf00d6145b (patch)
tree2ecb1a4f102be6f518e705b4503d549972c90137
parent6f4e8396309238bf3ef2ee8506891f17b5540418 (diff)
downloadegit-c0d7a36d6b725ca278d59b28f47f2bcf00d6145b.tar.gz
egit-c0d7a36d6b725ca278d59b28f47f2bcf00d6145b.tar.xz
egit-c0d7a36d6b725ca278d59b28f47f2bcf00d6145b.zip
Require Mylyn 3.21 (Neon+)
The oldest tested target platform in egit (egit-4.6.target) contains Mylyn 3.21.0. We should therefore require at least that version as dependency both in the egit/egit-github plugins and features. All changes have been done by matching the current version of each bundle from the target platform in the manifest editor. I.e. this was no search and replace. Change-Id: I48992fbc3ccc5ced03e16a38a20f585ee3494295 Signed-off-by: Michael Keppler <Michael.Keppler@gmx.de>
-rw-r--r--org.eclipse.egit.mylyn-feature/feature.xml2
-rw-r--r--org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF8
2 files changed, 5 insertions, 5 deletions
diff --git a/org.eclipse.egit.mylyn-feature/feature.xml b/org.eclipse.egit.mylyn-feature/feature.xml
index e5103acfc..e2cda3c87 100644
--- a/org.eclipse.egit.mylyn-feature/feature.xml
+++ b/org.eclipse.egit.mylyn-feature/feature.xml
@@ -27,7 +27,7 @@
<requires>
<import feature="org.eclipse.egit" version="5.4.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.mylyn.team_feature" version="3.5.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.mylyn.team_feature" version="3.21.0" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF b/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
index ef24a8e8a..2df32134b 100644
--- a/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
@@ -10,10 +10,10 @@ Require-Bundle: org.eclipse.jface,
org.eclipse.core.resources,
org.eclipse.core.runtime,
org.eclipse.ui.workbench,
- org.eclipse.mylyn.tasks.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.tasks.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.team.ui;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.mylyn.context.core;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.tasks.ui;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.team.ui;bundle-version="[3.21.0,4.0.0)",
+ org.eclipse.mylyn.context.core;bundle-version="[3.21.0,4.0.0)",
org.eclipse.jface.text,
org.eclipse.team.core
Bundle-RequiredExecutionEnvironment: JavaSE-1.8

Back to the top