Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Wolf2019-03-24 17:21:46 -0400
committerThomas Wolf2019-03-24 17:49:00 -0400
commit69a3b3126cc0b1aa9689ebf4e1fdc53985f2e947 (patch)
tree3fb6eb60dbed81b70871c2b654f1cd7a2a83acd2
parentd4ecfa96d4f693fc793fc8bba7d69ae593adcbdf (diff)
downloadegit-69a3b3126cc0b1aa9689ebf4e1fdc53985f2e947.tar.gz
egit-69a3b3126cc0b1aa9689ebf4e1fdc53985f2e947.tar.xz
egit-69a3b3126cc0b1aa9689ebf4e1fdc53985f2e947.zip
Set minimum versions to the ones from Neon.0
Increase required bundle versions to the Neon.0 baseline. Decrease the Mylyn required version from 3.21 to the 3.20 present in Neon.0. Change-Id: I5d7bdc841994838ee9d333f9206d71a110362839 Signed-off-by: Thomas Wolf <thomas.wolf@paranor.ch>
-rw-r--r--org.eclipse.egit-feature/feature.xml28
-rw-r--r--org.eclipse.egit.core.junit/META-INF/MANIFEST.MF12
-rw-r--r--org.eclipse.egit.core.test/META-INF/MANIFEST.MF12
-rw-r--r--org.eclipse.egit.core/META-INF/MANIFEST.MF20
-rw-r--r--org.eclipse.egit.gitflow.test/META-INF/MANIFEST.MF6
-rw-r--r--org.eclipse.egit.gitflow.ui/META-INF/MANIFEST.MF18
-rw-r--r--org.eclipse.egit.gitflow/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.egit.mylyn-feature/feature.xml4
-rw-r--r--org.eclipse.egit.mylyn.ui.test/META-INF/MANIFEST.MF6
-rw-r--r--org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF22
-rw-r--r--org.eclipse.egit.ui.smartimport/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.egit.ui.test/META-INF/MANIFEST.MF18
-rw-r--r--org.eclipse.egit.ui/META-INF/MANIFEST.MF41
13 files changed, 96 insertions, 97 deletions
diff --git a/org.eclipse.egit-feature/feature.xml b/org.eclipse.egit-feature/feature.xml
index ebce627e7..f06c7ff80 100644
--- a/org.eclipse.egit-feature/feature.xml
+++ b/org.eclipse.egit-feature/feature.xml
@@ -26,20 +26,20 @@
</url>
<requires>
- <import plugin="org.eclipse.core.runtime" version="3.7" match="compatible"/>
- <import plugin="org.eclipse.core.resources" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.core.filesystem" version="1.1.0" match="compatible"/>
- <import plugin="org.eclipse.ui" version="3.5.0" match="compatible"/>
- <import plugin="org.eclipse.team.ui" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.jface.text" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.ui.ide" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.ui.workbench.texteditor" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.compare" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.core.net" version="1.1.0" match="compatible"/>
- <import plugin="org.eclipse.team.core" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.jsch.ui" version="1.1.100" match="compatible"/>
- <import plugin="org.eclipse.jsch.core" version="1.1.100" match="compatible"/>
- <import plugin="com.jcraft.jsch" version="0.1.37" match="compatible"/>
+ <import plugin="org.eclipse.core.runtime" version="3.12.0" match="compatible"/>
+ <import plugin="org.eclipse.core.resources" version="3.11.0" match="compatible"/>
+ <import plugin="org.eclipse.core.filesystem" version="1.6.0" match="compatible"/>
+ <import plugin="org.eclipse.ui" version="3.108.0" match="compatible"/>
+ <import plugin="org.eclipse.team.ui" version="3.8.0" match="compatible"/>
+ <import plugin="org.eclipse.jface.text" version="3.11.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.ide" version="3.12.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.workbench.texteditor" version="3.10.0" match="compatible"/>
+ <import plugin="org.eclipse.compare" version="3.6.0" match="compatible"/>
+ <import plugin="org.eclipse.core.net" version="1.3.0" match="compatible"/>
+ <import plugin="org.eclipse.team.core" version="3.8.0" match="compatible"/>
+ <import plugin="org.eclipse.jsch.ui" version="1.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jsch.core" version="1.3.0" match="compatible"/>
+ <import plugin="com.jcraft.jsch" version="0.1.53" match="compatible"/>
<import feature="org.eclipse.jgit" version="5.4.0" match="equivalent"/>
<import feature="org.eclipse.jgit.ssh.apache" version="5.4.0" match="equivalent"/>
</requires>
diff --git a/org.eclipse.egit.core.junit/META-INF/MANIFEST.MF b/org.eclipse.egit.core.junit/META-INF/MANIFEST.MF
index 61373da78..c94c80985 100644
--- a/org.eclipse.egit.core.junit/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.core.junit/META-INF/MANIFEST.MF
@@ -5,12 +5,12 @@ Bundle-Vendor: %Bundle-Vendor
Automatic-Module-Name: org.eclipse.egit.core.junit
Bundle-SymbolicName: org.eclipse.egit.core.junit
Bundle-Version: 5.4.0.qualifier
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)",
- org.junit;bundle-version="[4.3.0,5.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.jdt.core;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.8.100,4.0.0)",
+ org.junit;bundle-version="[4.12.0,5.0.0)"
Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",
org.eclipse.egit.core.op;version="[5.4.0,5.5.0)",
org.eclipse.jgit.api;version="[5.4.0,5.5.0)",
diff --git a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
index dc24f74e0..448f619ff 100644
--- a/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.core.test/META-INF/MANIFEST.MF
@@ -6,13 +6,13 @@ Automatic-Module-Name: org.eclipse.egit.core.test
Bundle-SymbolicName: org.eclipse.egit.core.test;singleton:=true
Fragment-Host: org.eclipse.egit.core
Bundle-Version: 5.4.0.qualifier
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.team.core;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.team.core;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.jdt.core;bundle-version="[3.12.0,4.0.0)",
org.hamcrest;bundle-version="[1.1.0,2.0.0)",
- org.junit;bundle-version="[4.3.0,5.0.0)",
+ org.junit;bundle-version="[4.12.0,5.0.0)",
org.eclipse.egit.core.junit;bundle-version="[5.4.0,5.5.0)"
Import-Package: net.bytebuddy;version="[1.7.9,2.0.0)",
net.bytebuddy.agent;version="[1.7.9,2.0.0)",
diff --git a/org.eclipse.egit.core/META-INF/MANIFEST.MF b/org.eclipse.egit.core/META-INF/MANIFEST.MF
index 30979c7b6..071aa6749 100644
--- a/org.eclipse.egit.core/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.core/META-INF/MANIFEST.MF
@@ -7,13 +7,13 @@ Bundle-Version: 5.4.0.qualifier
Bundle-Activator: org.eclipse.egit.core.Activator
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.7.0,4.0.0)",
- org.eclipse.team.core;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.equinox.security;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.core.filebuffers;bundle-version="[3.5.0,4.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.team.core;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.equinox.security;bundle-version="[1.2.200,2.0.0)",
+ org.eclipse.core.variables;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.core.filebuffers;bundle-version="[3.6.0,4.0.0)"
Export-Package: org.eclipse.egit.core;version="5.4.0";
x-friends:="org.eclipse.egit.ui,
org.eclipse.egit.ui.test,
@@ -52,8 +52,8 @@ Export-Package: org.eclipse.egit.core;version="5.4.0";
org.eclipse.egit.core.synchronize.dto;version="5.4.0";x-friends:="org.eclipse.egit.ui"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.jcraft.jsch;bundle-version="[0.1.37,0.2.0)",
- org.eclipse.core.net.proxy;bundle-version="[1.1.0,2.0.0)",
+Import-Package: com.jcraft.jsch;bundle-version="[0.1.53,0.2.0)",
+ org.eclipse.core.net.proxy;bundle-version="[1.3.0,2.0.0)",
org.eclipse.jgit.annotations;version="[5.4.0,5.5.0)",
org.eclipse.jgit.api;version="[5.4.0,5.5.0)",
org.eclipse.jgit.api.errors;version="[5.4.0,5.5.0)",
@@ -76,4 +76,4 @@ Import-Package: com.jcraft.jsch;bundle-version="[0.1.37,0.2.0)",
org.eclipse.jgit.treewalk.filter;version="[5.4.0,5.5.0)",
org.eclipse.jgit.util;version="[5.4.0,5.5.0)",
org.eclipse.jgit.util.io;version="[5.4.0,5.5.0)",
- org.eclipse.jsch.core;bundle-version="[1.1.100,2.0.0)"
+ org.eclipse.jsch.core;bundle-version="[1.3.0,2.0.0)"
diff --git a/org.eclipse.egit.gitflow.test/META-INF/MANIFEST.MF b/org.eclipse.egit.gitflow.test/META-INF/MANIFEST.MF
index 5a99f6702..24cb74722 100644
--- a/org.eclipse.egit.gitflow.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.gitflow.test/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",
org.eclipse.jgit.junit;version="[5.4.0,5.5.0)",
org.hamcrest;version="[1.1.0,1.2.0)",
- org.junit.rules;version="[4.12.0,4.13.0)",
- org.junit;version="[4.3.0,5.0.0)"
-Require-Bundle: org.eclipse.core.resources,
+ org.junit.rules;version="[4.12.0,5.0.0)",
+ org.junit;version="[4.12.0,5.0.0)"
+Require-Bundle: org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
org.eclipse.egit.core.junit;bundle-version="[5.4.0,5.5.0)"
diff --git a/org.eclipse.egit.gitflow.ui/META-INF/MANIFEST.MF b/org.eclipse.egit.gitflow.ui/META-INF/MANIFEST.MF
index c45a2c7af..0cfb3258f 100644
--- a/org.eclipse.egit.gitflow.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.gitflow.ui/META-INF/MANIFEST.MF
@@ -32,15 +32,15 @@ Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",
org.eclipse.jgit.revplot;version="[5.4.0,5.5.0)",
org.eclipse.jgit.revwalk;version="[5.4.0,5.5.0)",
org.eclipse.jgit.util;version="[5.4.0,5.5.0)"
-Require-Bundle: org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.team.ui;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.expressions;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.jface.databinding;bundle-version="[1.6.0,2.0.0)",
- org.eclipse.core.databinding.property;bundle-version="[1.4.0,2.0.0)",
- org.eclipse.core.databinding.beans;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.core.databinding;bundle-version="[1.4.0,2.0.0)"
+Require-Bundle: org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.team.ui;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.core.expressions;bundle-version="[3.5.100,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.108.0,4.0.0)",
+ org.eclipse.jface.databinding;bundle-version="[1.8.0,2.0.0)",
+ org.eclipse.core.databinding.property;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.core.databinding.beans;bundle-version="[1.3.100,2.0.0)",
+ org.eclipse.core.databinding;bundle-version="[1.6.0,2.0.0)"
Export-Package: org.eclipse.egit.gitflow.ui;version="5.4.0";x-friends:="org.eclipse.egit.ui.test",
org.eclipse.egit.gitflow.ui.internal;version="5.4.0";x-friends:="org.eclipse.egit.ui.test",
org.eclipse.egit.gitflow.ui.internal.actions;version="5.4.0";x-friends:="org.eclipse.egit.ui.test",
diff --git a/org.eclipse.egit.gitflow/META-INF/MANIFEST.MF b/org.eclipse.egit.gitflow/META-INF/MANIFEST.MF
index 7aadf8ec0..099ae3743 100644
--- a/org.eclipse.egit.gitflow/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.gitflow/META-INF/MANIFEST.MF
@@ -9,8 +9,7 @@ Bundle-Activator: org.eclipse.egit.gitflow.Activator
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.jgit;bundle-version="[5.4.0,5.5.0)";resolution:=optional
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)"
Export-Package: org.eclipse.egit.gitflow;version="5.4.0";
uses:="org.osgi.framework,
org.eclipse.jgit.transport,
@@ -31,6 +30,7 @@ Import-Package: org.eclipse.egit.core.internal.job;version="[5.4.0,5.5.0)",
org.eclipse.egit.core.op;version="[5.4.0,5.5.0)",
org.eclipse.jgit.api;version="[5.4.0,5.5.0)",
org.eclipse.jgit.api.errors;version="[5.4.0,5.5.0)",
+ org.eclipse.jgit.annotations;version="[5.4.0,5.5.0)",
org.eclipse.jgit.errors;version="[5.4.0,5.5.0)",
org.eclipse.jgit.lib;version="[5.4.0,5.5.0)",
org.eclipse.jgit.revwalk;version="[5.4.0,5.5.0)",
diff --git a/org.eclipse.egit.mylyn-feature/feature.xml b/org.eclipse.egit.mylyn-feature/feature.xml
index e2cda3c87..826b5b2c1 100644
--- a/org.eclipse.egit.mylyn-feature/feature.xml
+++ b/org.eclipse.egit.mylyn-feature/feature.xml
@@ -26,8 +26,8 @@
</url>
<requires>
- <import feature="org.eclipse.egit" version="5.4.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.mylyn.team_feature" version="3.21.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.egit" version="5.4.0" match="equivalent"/>
+ <import feature="org.eclipse.mylyn.team_feature" version="3.20.0" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/org.eclipse.egit.mylyn.ui.test/META-INF/MANIFEST.MF b/org.eclipse.egit.mylyn.ui.test/META-INF/MANIFEST.MF
index 473a805c2..c2ec78579 100644
--- a/org.eclipse.egit.mylyn.ui.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.mylyn.ui.test/META-INF/MANIFEST.MF
@@ -7,6 +7,6 @@ Bundle-Version: 5.4.0.qualifier
Fragment-Host: org.eclipse.egit.mylyn.ui
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse.org
-Import-Package: org.junit;version="[4.3.1,5.0.0)",
- org.junit.runner;version="[4.3.1,5.0.0)",
- org.junit.runners;version="[4.3.1,5.0.0)"
+Import-Package: org.junit;version="[4.12.0,5.0.0)",
+ org.junit.runner;version="[4.12.0,5.0.0)",
+ org.junit.runners;version="[4.12.0,5.0.0)"
diff --git a/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF b/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
index 2df32134b..544955186 100644
--- a/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.mylyn.ui/META-INF/MANIFEST.MF
@@ -6,16 +6,16 @@ Bundle-SymbolicName: org.eclipse.egit.mylyn.ui;singleton:=true
Bundle-Version: 5.4.0.qualifier
Bundle-Activator: org.eclipse.egit.internal.mylyn.ui.EGitMylynUI
Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.jface,
- org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.ui.workbench,
- org.eclipse.mylyn.tasks.core;bundle-version="[3.21.0,4.0.0)",
- org.eclipse.mylyn.tasks.ui;bundle-version="[3.21.0,4.0.0)",
- org.eclipse.mylyn.team.ui;bundle-version="[3.21.0,4.0.0)",
- org.eclipse.mylyn.context.core;bundle-version="[3.21.0,4.0.0)",
- org.eclipse.jface.text,
- org.eclipse.team.core
+Require-Bundle: org.eclipse.jface;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.ui.workbench;bundle-version="[3.108.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.20.0,4.0.0)",
+ org.eclipse.mylyn.tasks.ui;bundle-version="[3.20.0,4.0.0)",
+ org.eclipse.mylyn.team.ui;bundle-version="[3.20.0,4.0.0)",
+ org.eclipse.mylyn.context.core;bundle-version="[3.20.0,4.0.0)",
+ org.eclipse.jface.text;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.team.core;bundle-version="[3.8.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
@@ -31,4 +31,4 @@ Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",
org.eclipse.jgit.lib;version="[5.4.0,5.5.0)",
org.eclipse.jgit.revwalk;version="[5.4.0,5.5.0)",
org.eclipse.jgit.transport;version="[5.4.0,5.5.0)",
- org.eclipse.ui.plugin
+ org.eclipse.ui.plugin;bundle-version="[3.108.0,4.0.0)"
diff --git a/org.eclipse.egit.ui.smartimport/META-INF/MANIFEST.MF b/org.eclipse.egit.ui.smartimport/META-INF/MANIFEST.MF
index 8fc205dd6..0478f3812 100644
--- a/org.eclipse.egit.ui.smartimport/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.ui.smartimport/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Fragment-Host: org.eclipse.egit.ui;bundle-version="[5.4.0,5.5.0)"
Bundle-Version: 5.4.0.qualifier
Bundle-Vendor: %provider_name
Require-Bundle: org.eclipse.ui,
- org.eclipse.ui.ide;bundle-version="3.12.0"
+ org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)"
Bundle-Localization: fragment
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.egit.ui.internal.clone;version="5.4.0";x-internal:=true;
diff --git a/org.eclipse.egit.ui.test/META-INF/MANIFEST.MF b/org.eclipse.egit.ui.test/META-INF/MANIFEST.MF
index dbbb10284..7ef8536b4 100644
--- a/org.eclipse.egit.ui.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.ui.test/META-INF/MANIFEST.MF
@@ -8,13 +8,13 @@ Fragment-Host: org.eclipse.egit.ui
Bundle-Version: 5.4.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.apache.log4j;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.search;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
- org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.search;bundle-version="[3.11.0,4.0.0)";resolution:=optional,
+ org.eclipse.ui;bundle-version="[3.108.0,4.0.0)",
org.hamcrest;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.jdt.launching;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.8.100,4.0.0)",
org.eclipse.egit.core.junit;bundle-version="[5.4.0,5.5.0)"
Import-Package: net.bytebuddy;version="[1.7.9,2.0.0)",
org.eclipse.core.net.proxy;bundle-version="[1.1.0,2.0.0)",
@@ -46,9 +46,9 @@ Import-Package: net.bytebuddy;version="[1.7.9,2.0.0)",
org.eclipse.swtbot.swt.finder.utils,
org.eclipse.swtbot.swt.finder.waits,
org.eclipse.swtbot.swt.finder.widgets,
- org.junit;version="[4.7.0,5.0.0)",
- org.junit.rules;version="[4.7.0,5.0.0)",
- org.junit.runner;version="[4.7.0,5.0.0)",
+ org.junit;version="[4.12.0,5.0.0)",
+ org.junit.rules;version="[4.12.0,5.0.0)",
+ org.junit.runner;version="[4.12.0,5.0.0)",
org.mockito;version="[2.13.0,3.0.0)",
org.mockito.junit;version="[2.13.0,3.0.0)",
org.mockito.stubbing;version="[2.13.0,3.0.0)",
diff --git a/org.eclipse.egit.ui/META-INF/MANIFEST.MF b/org.eclipse.egit.ui/META-INF/MANIFEST.MF
index 6c48291c9..61e565c15 100644
--- a/org.eclipse.egit.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.egit.ui/META-INF/MANIFEST.MF
@@ -7,27 +7,26 @@ Bundle-Version: 5.4.0.qualifier
Bundle-Activator: org.eclipse.egit.ui.Activator
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.7.0,4.0.0)",
- org.eclipse.core.filesystem;bundle-version="[1.1.0,2.0.0)",
- org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.team.core;bundle-version="[3.6.100,4.0.0)",
- org.eclipse.team.ui;bundle-version="[3.6.200,4.0.0)",
- org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui.workbench.texteditor;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.compare;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui.editors;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.ui.navigator;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui.forms;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.equinox.security;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.help;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.search;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
- org.eclipse.debug.ui;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
- org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
- org.eclipse.jdt.ui;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
- org.eclipse.ui.views;bundle-version="[3.4.0,4.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.core.filesystem;bundle-version="[1.6.0,2.0.0)",
+ org.eclipse.core.variables;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.ui;bundle-version="[3.108.0,4.0.0)",
+ org.eclipse.team.core;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.team.ui;bundle-version="[3.8.0,4.0.0)",
+ org.eclipse.jface.text;bundle-version="[3.11.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)",
+ org.eclipse.ui.workbench.texteditor;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.compare;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.10.0,4.0.0)",
+ org.eclipse.ui.navigator;bundle-version="[3.6.100,4.0.0)",
+ org.eclipse.ui.forms;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.equinox.security;bundle-version="[1.2.200,2.0.0)",
+ org.eclipse.help;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.search;bundle-version="[3.11.0,4.0.0)";resolution:=optional,
+ org.eclipse.debug.ui;bundle-version="[3.11.200,4.0.0)";resolution:=optional,
+ org.eclipse.jdt.core;bundle-version="[3.12.0,4.0.0)";resolution:=optional,
+ org.eclipse.jdt.ui;bundle-version="[3.12.0,4.0.0)";resolution:=optional,
+ org.eclipse.ui.views;bundle-version="[3.8.100,4.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.egit.core;version="[5.4.0,5.5.0)",

Back to the top