Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2015-01-12 08:26:04 -0500
committerMatthias Sohn2015-01-14 04:30:36 -0500
commit6cfb33a2494902b7e9da4b83d013fcd97f4ecaa1 (patch)
tree1f898bae45497de6593b38e328beaf4f66dd64b3 /org.eclipse.mylyn.github.ui
parentb267cccca140bae6e89d8ca560b6ae89449e1f13 (diff)
downloadegit-github-6cfb33a2494902b7e9da4b83d013fcd97f4ecaa1.tar.gz
egit-github-6cfb33a2494902b7e9da4b83d013fcd97f4ecaa1.tar.xz
egit-github-6cfb33a2494902b7e9da4b83d013fcd97f4ecaa1.zip
Relax JGit/EGit dependencies to allow versions in range [3.2,4.0)
Change version.sh to no longer flip versions of JGit and EGit dependencies. They are now set to [3.2.0,4.0.0) and have to be maintained manually from now on. Bug: 427778 Change-Id: I771e15533aa7f59bea66fd50c6e68ab967c149e0 Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.mylyn.github.ui')
-rw-r--r--org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF32
1 files changed, 16 insertions, 16 deletions
diff --git a/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
index 14ca9f5b..fa528596 100644
--- a/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.ui/META-INF/MANIFEST.MF
@@ -27,26 +27,26 @@ Export-Package: org.eclipse.mylyn.internal.github.ui;version="3.6.1";x-internal:
org.eclipse.mylyn.internal.github.ui.gist;version="3.6.1";x-internal:=true,
org.eclipse.mylyn.internal.github.ui.issue;version="3.6.1";x-internal:=true
Bundle-ActivationPolicy: lazy
-Import-Package: org.eclipse.egit.core;version="[3.6.1,3.7.0)",
- org.eclipse.egit.core.op;version="[3.6.1,3.7.0)",
+Import-Package: org.eclipse.egit.core;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.core.op;version="[3.2.0,4.0.0)",
org.eclipse.egit.github.core;version="[3.6.1,3.7.0)",
org.eclipse.egit.github.core.client;version="[3.6.1,3.7.0)",
org.eclipse.egit.github.core.service;version="[3.6.1,3.7.0)",
org.eclipse.egit.github.core.util;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.branch;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.commit;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.components;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.fetch;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.provisional.wizards;version="[3.6.1,3.7.0)",
- org.eclipse.egit.ui.internal.pull;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.errors;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.lib;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.revwalk;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.transport;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.treewalk;version="[3.6.1,3.7.0)",
- org.eclipse.jgit.treewalk.filter;version="[3.6.1,3.7.0)",
+ org.eclipse.egit.ui;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.branch;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.commit;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.components;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.fetch;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.provisional.wizards;version="[3.2.0,4.0.0)",
+ org.eclipse.egit.ui.internal.pull;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.errors;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.lib;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.revwalk;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.transport;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.treewalk;version="[3.2.0,4.0.0)",
+ org.eclipse.jgit.treewalk.filter;version="[3.2.0,4.0.0)",
org.eclipse.mylyn.internal.github.core;version="[3.6.1,3.7.0)",
org.eclipse.mylyn.internal.github.core.gist;version="[3.6.1,3.7.0)",
org.eclipse.mylyn.internal.github.core.issue;version="[3.6.1,3.7.0)",

Back to the top