Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2018-11-22 10:48:03 -0500
committerMatthias Sohn2018-11-22 11:04:23 -0500
commitfde41b3e9907290e37255dc294fc3322026c08d5 (patch)
tree47370b0e8de86843e02500ff29c0a2e1acdcf47e /org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
parent0ef9c59cbb90eede5053c749c40c9e968f72868b (diff)
downloadegit-github-fde41b3e9907290e37255dc294fc3322026c08d5.tar.gz
egit-github-fde41b3e9907290e37255dc294fc3322026c08d5.tar.xz
egit-github-fde41b3e9907290e37255dc294fc3322026c08d5.zip
Implement explicit target platform
Add a proper target platform definition and also use that in the Tycho build to ensure we use the same classpath in Eclipse and during Maven build. Run org.eclipse.mylyn.github.tests during Maven test phase. Change-Id: I6010f301f157525357b741d1d699a8a2207ac647 Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF')
-rw-r--r--org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF15
1 files changed, 4 insertions, 11 deletions
diff --git a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
index 145dfed6..03f466f8 100644
--- a/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.github.tests/META-INF/MANIFEST.MF
@@ -5,16 +5,9 @@ Automatic-Module-Name: org.eclipse.mylyn.github.tests
Bundle-SymbolicName: org.eclipse.mylyn.github.tests
Bundle-Version: 5.2.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle: org.eclipse.jface.text;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.mylyn.tasks.ui;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.mylyn.tasks.core,
- org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.junit;bundle-version="[4.8.1,5.0.0)",
- org.hamcrest;bundle-version="[1.1.0,2.0.0)",
- org.objenesis;bundle-version="[2.6.0,3.0.0)"
+Require-Bundle: org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.mylyn.tasks.core;bundle-version="[3.4.0,4.0.0)",
+ org.junit;bundle-version="[4.12.0,5.0.0)"
Bundle-Vendor: Eclipse EGit
Import-Package: org.eclipse.mylyn.internal.github.core;version="[5.2.0,5.3.0)",
- org.eclipse.mylyn.internal.github.ui.issue;version="[5.2.0,5.3.0)",
- org.mockito;version="[2.13.0,3.0.0)",
- org.mockito.runners;version="[2.13.0,3.0.0)",
- org.mockito.stubbing;version="[2.13.0,3.0.0)"
+ org.eclipse.mylyn.internal.github.ui.issue;version="[5.2.0,5.3.0)"

Back to the top